[snb mesa] GPU hang enabling MapsGL on gmaps leading to screen corruption (two thirds black, one third striped)

Bug #1011344 reported by Guilherme Salgado on 2012-06-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

A few seconds after I enabled MapsGL on google maps, using chrome, 2/3 of my screen went black and 1/3 was striped. After leaving the machine idle for a few minutes the display went into sleep mode and then when I pressed something on the keyboard to wake it up it was back to "normal". I say "normal" because although i could enter my password to unlock, the screen was flickering really badly and unity was exhibiting some really weird behavior -- menus folding back right after I'd clicked on them, dialogs (e.g. the shutdown one) disappearing before I had a chance to click on them, etc.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,regex,gnomecompat,vpswitch,compiztoolbox,move,resize,grid,animation,snap,imgpng,place,unitymtgrabhandles,session,mousepoll,workarounds,wall,expo,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Sun Jun 10 19:42:38 2012
DistUpgraded: 2012-01-16 22:21:19,701 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.12, 3.2.0-24-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d2]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 4170CTO
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=6c8b89f7-f0ef-440b-bea8-ccb5f8d5b8a3 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to precise on 2012-01-17 (145 days ago)
dmi.bios.date: 11/01/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8CET50WW (1.30 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4170CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8CET50WW(1.30):bd11/01/2011:svnLENOVO:pn4170CTO:pvrThinkPadT420s:rvnLENOVO:rn4170CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4170CTO
dmi.product.version: ThinkPad T420s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Guilherme Salgado (salgado) wrote :
Guilherme Salgado (salgado) wrote :

xserver-xorg-video-intel crash file from the time the problem happened. there are a dozen others, all between 19:15:58 and 19:16:58

Guilherme Salgado (salgado) wrote :

photo of the screen

Guilherme Salgado (salgado) wrote :

This looks very similar to bug 812638 (https://launchpadlibrarian.net/75481075/IMG_20110718_182145.jpg is what the screen looked like there)

bugbot (bugbot) on 2012-06-14
tags: added: corruption
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Chris Wilson (ickle) on 2013-02-22
summary: - Screen corruption (two thirds black, one third striped) when enabling
- MapsGL on gmaps
+ [snb mesa] GPU hang enabling MapsGL on gmaps leading to screen
+ corruption (two thirds black, one third striped)
bugbot (bugbot) on 2013-02-28
tags: added: freeze
Guilherme Salgado (salgado) wrote :

I no longer experience this on 12.10

Chris Wilson (ickle) wrote :

Thanks, assuming it remains fixed...

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers