Ubuntu

Xorg crashes randomly and resumes to the login screen

Reported by Pierre van Male on 2012-06-05
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Timo Aaltonen

Bug Description

Xorg crashes randomly and resumes to the login screen. I found some discussion linking this problem to the NVIDIA driver (http://forum.ubuntu-fr.org/viewtopic.php?id=898971), but I am using open driver and have no NVIDIA card... Other people in the same discussion have the same problem than I have and some even moved away form Ubuntu for that (losing work randomly is quite unacceptable).

I have the impression that the crash occurs more often after a resume (following a suspend) and more in Ubuntu session than Ubuntu 2D.

I am ready to provide any further information, but I do not know which one at this stage. Waiting for question.

Thanks,
Pierre

vmalep@T420-12:~$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

vmalep@T420-12:~$ apt-cache policy xorg
xorg:
  Installed: 1:7.6+12ubuntu1
  Candidate: 1:7.6+12ubuntu1
  Version table:
 *** 1:7.6+12ubuntu1 0
        500 http://es.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom]
CompositorRunning: None
Date: Tue Jun 5 21:23:39 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.12, 3.2.0-24-generic-pae, i686: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: No
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21ce]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: LENOVO 4236PN3
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic-pae root=UUID=d62b71eb-a850-4679-b60d-9b9faa8e78df ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/31/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET66WW (1.36 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4236PN3
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET66WW(1.36):bd10/31/2011:svnLENOVO:pn4236PN3:pvrThinkPadT420:rvnLENOVO:rn4236PN3:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4236PN3
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Pierre van Male (vmalep) wrote :
affects: ubuntu → xorg (Ubuntu)
Pierre van Male (vmalep) on 2012-06-08
Changed in xorg (Ubuntu):
status: New → Invalid
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2012-06-12
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
bugbot (bugbot) on 2012-06-14
tags: added: resume
Timo Aaltonen (tjaalton) wrote :

There was a new kernel update released recently, but if it hasn't fixed it please enable the -proposed repository and install the update found there and see if it helps.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Incomplete
Pierre van Male (vmalep) wrote :

Hi, the problem still occures (after I made a new install for other reasons).

dmesg:
[149328.581655] Xorg[1099]: segfault at 9 ip b7682b58 sp bf94cfd0 error 4 in Xorg[b7562000+1f3000]

What do you mean by "enable the -proposed repository"?

I see that the bug status is "incomplete". What kind of information is missing?

Timo Aaltonen (tjaalton) wrote :

open the software manager, edit the sources, check that you have precise-proposed enabled from the updates tab.

'incomplete' means I'm waiting for your test results :)

Hi Timo,

I enabled the -proposed repo, but the xorg crash persistes:
[93976.163937] Xorg[15823]: segfault at 9 ip b763ec48 sp bfa682f0 error 4
in Xorg[b751e000+1f3000]

Could you please give me a hint about the test you want me to perform?

Best regards,
Pierre

2012/6/29 Timo Aaltonen <email address hidden>

> open the software manager, edit the sources, check that you have
> precise-proposed enabled from the updates tab.
>
> 'incomplete' means I'm waiting for your test results :)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009179
>
> Title:
> Xorg crashes randomly and resumes to the login screen
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1009179/+subscriptions
>

Pierre van Male (vmalep) wrote :

Hi Timo,

I am coming back to you in regards to this bug. For the last weeks, the crash occured only once or twice a week, but lately, it happens like 3 times a day and it is really annoying.

It seems to me that it happens usually shortly after a resume of the machine.

I am still waiting for indications about the tests I am supposed to do.

Thanks in advance and best regards,
Pierre

Erwan Josset (erwan-josset) wrote :

on my system this bug only affects the nvidia proprietary drivers, It works good with the free driver.
Here is my kernel:

Linux erwan-IMEDIA-8501 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Linux Mint 13 maya Cinnamon.
Thanks,

Erwan

Pierre van Male (vmalep) wrote :

Thanks Erwan for the reply.

Indeed, a bug report already existed for the bug affecting NVIDIA card (https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/973096) and as explained in my first message, I am not using NVIDIA card (as well as many other users affected by this problem). This is why I opened this new bug report.

Pierre van Male (vmalep) wrote :

Me again. I am now using kdm and no change. Xorg keeps crashing, a few second after a resume.

Pierre van Male (vmalep) wrote :

Hi,

Lately, the bug occurred after I had switched from another user and without having suspended the computer. It may hence not be linked to the suspend mode.

I am still waiting for instructions from Timo regarding the tests he want me to perform...

BR
Pierre

hbernard (hbernard) wrote :

Hi,

on my system (EEE PC with i915 graphics), this bug occurs a few moments (between one and five minutes) after waking up from suspend mode.

Install is fresh, but user profile is not (coming back from mint 12)

Pili (pili) wrote :

Hello,
I had the same trouble and an other one ( randomely frozen screen ). I had no more resumes to logging screen scince i've opened a TTY ( TTY6 ) when i've a regular ubuntu-unity session. Sometimes my screen freeze and i'm able to switch to my TTY6 (ctrl-alt-F6) and check a top and i return to my TTY7, when i'm coming back, everything is running as usual.
I've noticed a zombie processus ( lightdm ). Doest it normal ? Does it the same for you ?
3 days without random logging screen and i keep the control on my computer ( with command line ).
Keep me in touch.
Thanks

Pierre van Male (vmalep) wrote :

The bug was put as incomplete by Timo with the following justification: "'incomplete' means I'm waiting for your test results :)".

Since beginning of August, I am waiting for instructions regarding the tests Timo wants me to perform. In my first post, I already posted the apport report and I believe this bug is serious enough to be confirmed as it affects a certified computer (the Lenovo T420) with a serious bug (sudden log off).

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Timo Aaltonen (tjaalton) wrote :

Pierre: please install the latest updates (especially xserver-xorg-input-synaptics). Do you still get those crashes? If yes, please attach /var/log/Xorg.0.log.old and output of 'dmesg > dmesg.txt' to this bug.

Pierre van Male (vmalep) wrote :

Hi Timo,

I am now abroad until mid-November and I left the concerned laptop at home.

On my return, I will follow your instructions.

Best regards,
Pierre

Chris Wilson (ickle) wrote :

Memory corruption after resume. Please update your kernel.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions