Feisty herd 3 desktop CD cannot install on D3C5105 because graphics are messed up

Bug #82958 reported by Marc Tardif on 2007-02-02
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Ubuntu)
Undecided
Unassigned

Bug Description

When installing Feisty herd 3 using the desktop CD on D3C5105, the graphics are messed up which prevents the user from seeing the installation process.

Reproduction steps:
1. Start the Herd 3 live CD
2. Select Start or Install Ubuntu
3. Watch Ubuntu logo and moving bar for a minute or two

Expected result:
Desktop should appear after the Ubuntu logo.

Actual result
Messed up image attached below.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Also note that the keyboard becomes unresponsive when the graphics become messed up so it's not possible to switch to another console.

It seems like the problem appears only when booting from desktop cd and we noticed that gfxboot does some strange things (like a small green line) when reading kernel and initramfs. I suspect there is an interaction bug here that sets registries in the card with some values that are not properly re-initizialed by the X driver.

Fabio

Kyle McMartin (kyle) wrote :

When booting the desktop cd, can you try booting with quiet and without splash? Do the kernel messages come up fine? Does the desktop come up fine in that case?

Kyle McMartin (kyle) wrote :

Er, without quiet...

Matthew Garrett (mjg59) wrote :

The "green text" from gfxboot is normal enough - isolinux dumps characters to the screen even in graphics mode. Given that usplash then messes about with the graphics registers to a much greater extent, it's far more likely to be linked to that.

dokubuntux (dokubuntux) wrote :

I also use the feisty herd 3 live-cd. After the bootsplash I don't get a messed up image, but the screen is black instead of the desktop.
There is just a little line like in a Terminal blinking in the top-left corner of the black screen.
The system reboots if I press Strg+Alt+Enter.

Form the german ubuntu-forum I got this link and read that the same bug was already in edgy:

https://wiki.ubuntu.com/EdgyKnownIssues/28925

I chose "More options" by pressing F6 and replaced "splash" by "break=bottom". Then there was a command line (initramfs) and I had to edit the "/etc/X11/xorg.conf" and chose "vesa" as the grafic-driver.
The desktop appeared, but the system didn't shutdown right. The computer ejects the cd, but instead of powering off there are still the last "messages".

BTW: I have an ATI X600.

Ampinder (ajaysingh99) wrote :

Hi,
      Well I redid a feisty herd 3 desktop with a new CD and check for bugs on the cd and there was 1 checksum failure so I burned a new one, check for errors and there was no errors and all the installation went perfectly. I did not got any screen problems. I think, in the future, we will check our CDs.

Thanks

Brian Murray (brian-murray) wrote :

Closing due to last comment regarding bad media.

Changed in xserver-xorg-video-i810:
status: Unconfirmed → Rejected
dokubuntux (dokubuntux) wrote :

hm... I just checked the same CD I had the problem with, but there were no (0) checksum failures...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers