installing 915resolution for the correct resolution shouldn't be necessary

Bug #63560 reported by Alexander van Loon
78
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-i810 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

Recently I got a notebook, a Fujitsu Siemens Amilo 1505 Pi. It has an Intel 945GM chipset and an Intel GMA 950 video chip.

Ubuntu works nicely with it, but there is one problem. The display resolution wasn't detected correctly, and installing the package 915resolution fixed this problem.

However, just like I said in bug #63551, you can't expect users to know that they have to install the package 915resolution to get Ubuntu set to the correct resolution. New users who don't have the expertise we hardcore Linux fans have do not know they have to install that, and they will be very annoyed that their laptop will not use the correct resolution.

Ubuntu should be user friendly, so maybe it would be a good idea to include the fixes in the package 915resolution in X.org by default?

Revision history for this message
Andrew Ash (ash211) wrote :

That definitely sounds reasonable to me. I had this problem on my Dell Inspiron B130. There is probably a feature specification about this. Could you please check at https://launchpad.net/distros/ubuntu/+specs

Thanks

Changed in xorg:
status: Unconfirmed → Needs Info
Revision history for this message
Andrew Ash (ash211) wrote :

I found one at https://features.launchpad.net/distros/ubuntu/+spec/wide-screen-resolution Please help me work on that and we'll try to get it included in feisty.

Changed in xorg:
status: Needs Info → Confirmed
Revision history for this message
Alexander van Loon (avanloon) wrote :

Thanks for your information, I'd be happy to help. However, how do we edit that specification and what more do we need to do in order for this problem to get the developers attention? If I visit the edit page it says I don't have permission. My Jabber ID is <email address hidden>, please add me so that we can talk.

Revision history for this message
Andrew Ash (ash211) wrote :

I couldn't edit the spec either, but I did create a wiki entry at https://wiki.ubuntu.com/BetterWidescreenDetection and asked the original creator of the wide-screen-resolution spec to link the two. I think he's the only one that can make that change.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Hello.

I have linked the feature to the wiki page. I think this is a big problem, and I would like this to be resolved in Feisty, if it's possible.

Please tell me what we can done, to start working on this!

Regards
Pochu

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

This will probably be fixed once we have the -intel driver (maybe in feisty+1?).

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

definately for feisty+1, and maybe we can replace the current -modesetting-driver with it for feisty... the problem is that the version is 1.9.91 (rc1) and I'm having problems with it. We'll see.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

uh, let me clarify that last comment: the -intel driver is still at beta, and besides that it needs tricks to build against xorg-server-1.2. And it only does 1280x800 on my tests, and the fonts in the login screen are tiny..

So, if a better version is released soon, then maybe we could replace the -modesetting driver with it. But it would still need UVF approval.

Revision history for this message
Alexis Wilke (alexis-m2osw) wrote :

This is in link with the bug I entered recently named:

  Boot of Desktop 6.10 (Edgy Eft) installer hangs on i845 -- bug #90558

I have a KVM, but I know the resolutions that my monitor support. I have had that for a while and it has been working with that computer under older Linux systems.

With Ubuntu (and most certainly Debian though I did not try, I'd bet I'd get the same issue), it HANGs. Big time. It is not directly a resolution problem for me.

The funny thing is that I have to run 915resolution to "fix" the BIOS table but I change nothing to it. The resolution I want is in there with the right everything. But if I don't overwrite it with 915resolution it hangs. Big time.

At first, I was thinking it was the auto-configuration since I could not properly boot the Desktop installer. It hanged. Big time.

But once I managed to install my system with the Server version (not a bad thing, btw) I installed X.org and all the stuff I needed to start the server. So now, I'm booted in Ubuntu consoles and I try to start X11. Paf! Again, it hangs. Big time. (btw, that means I have to turn off the computer, keyboard dead, no mouse since the screen is black, and I still did not find a reset button on this computer?!)

So I looked around and found 915resolution. I checked the resolutions and I have seen no problems. Well... I follow the instructions, I overwrite the resolution I want to use, I start X11, hooray! It worked!

Later I had to reboot for some reason, and I did not re-run 915resolution. It worked fine. Reboot again. Just fine. Turn off the computer, time to swap a hard disk or two, reboot, start X11, it hangs! Big Time. Restart, re-run 915resolution, it works. So... I have a desktop computer, a Compaq with some sort of i845 INTEL video chip. I'd bet that the auto-detection would not hang if it were to run 915resolution.

So... if you had fixed it in Edgy, I'd know, right? 8-)

Note that I'm fine now. It's just the installation process which was a bit annoying. And most certainly (as mentioned by the 1st poster) not something any beginner could understand and resolve by himself/herself.

Okay... I'll try to get the output of the stuff marked on this page:

https://help.ubuntu.com/community/DebuggingXAutoconfiguration

but I have to quit X11 first...
(and by the way, I don't like auto-booting to X nor removing the nice verbose boot process when I start OR STOP my system--just a personal comment, it took me 1h to remove all that "crap"!)

Revision history for this message
Alexis Wilke (alexis-m2osw) wrote :

Okay, I got the output requested. I think it will be somewhat useless. For one thing, the xresprobe returned exactly NOTHING. Again, I have a KVM so checking the monitor certainly does not work.

Timo Aaltonen (tjaalton)
Changed in xserver-xorg-video-i810:
importance: Undecided → Medium
Revision history for this message
Timo Aaltonen (tjaalton) wrote :
Revision history for this message
Erik Hill (thepurr) wrote : Re: [Bug 63560] Re: installing 915resolution for the correct resolution shouldn't be necessary

Okay, installed it and am using it... It does fix the 1280x800
problem, I get that resolution even if 915resolution is not installed.
 However sometimes when I log out and log on again, I get a black
screen (never got that before). I have to kill xorg (ctrl-alt-delete)
to get it back.

I had to uninstall xserver-xorg-video-i810 and xserver-xorg-video-all
to get this to install.

On 3/30/07, Timo Aaltonen <email address hidden> wrote:
> Please test 2.0rc3:
>
> http://users.tkk.fi/~tjaalton/dpkg/xserver-xorg-video-
> intel_1.9.93-1ubuntu1_i386.deb
>
> --
> installing 915resolution for the correct resolution shouldn't be necessary
> https://launchpad.net/bugs/63560
>

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

the new xorg upload should fix the dependancy-issues. Hopefully the black screen problems are gone when the final version is released. Rc2 didn't have those issues when I tested (rc3 does on my machine).

Revision history for this message
Alexis Wilke (alexis-m2osw) wrote :

Timo,

This sounds like the problem I have. The resolution is fine for me, but if
I don't first run 915resolution, I get a black screen. The screen is black
on cold boot until I run 915resolution. Then it is fine, even if I reboot.
So it looks like that table does not get changed on a reboot.

So that .deb certainly would not fix my current problem!

Thanks,
Alexis

On Fri, 30 Mar 2007, Timo Aaltonen wrote:

> the new xorg upload should fix the dependancy-issues. Hopefully the
> black screen problems are gone when the final version is released. Rc2
> didn't have those issues when I tested (rc3 does on my machine).
>
> --
> installing 915resolution for the correct resolution shouldn't be necessary
> https://launchpad.net/bugs/63560
>

------------
Alexis Wilke
President
Made to Order Software, Corporation

e-mail: <email address hidden>
cell-text: <email address hidden> (please, only small messages)

Web Pages: http://www.m2osw.com
   http://www.turnwatcher.com
Company e-mail: <email address hidden>
Phone: +(1) 916 220 6482
Fax: +(1) 916 988 1450

Address: 9275 Blue Oak Drive
   Orangevale, California 95662
   United States of America

                     CONFIDENTIAL

This document contains non-public proprietary information
that is subject to restrictions on use and/or disclosure.

If you are not the intended recipient, any dissemination,
distribution or copying is strictly prohibited. If you
think that you have received this e-mail message in error,
please e-mail the sender and delete all copies. Thank you.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

AFAIK the new driver ignores 915resolution completely.. so it's a bit strange that you have a different behaviour when running it.

Revision history for this message
Tomi (tomi-digiflex) wrote :

I (by mistake) uploaded quite the same issue, you can see it with log files here: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/102147
Have you got some kind of connection with the intel driver coders? I think they also want to contribute with the releases of large distributions.

Revision history for this message
Cay Horstmann (cay) wrote :

The 2.0rc3 driver (http://users.tkk.fi/~tjaalton/dpkg/xserver-xorg-video-intel_1.9.93-1ubuntu1_i386.deb) works fine on my Thinkpad X60 tablet, and it is able to drive an external monitor at 1680 x 1050. However, it does not rotate. When I run xrandr, the screen flashes and is back at the same orientation. (The Wacom driver thinks the rotation happened, and the pen is off.)

On a tablet, this is a bit of a problem.

Revision history for this message
Marco (mfj) wrote :

I can confirm that 1.9.93-1ubuntu1 release works fine without the 915resolution patch, on the laptop Fujitsu-Siemens Amilo Pro V3205.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Yes, I'll mark this as fixed, since 1.9.94 is now in Feisty universe. Gutsy will have it by default! (replacing -i810)

Changed in xserver-xorg-video-i810:
status: Confirmed → Fix Released
Revision history for this message
Alex Muntada (alex.muntada) wrote :

Just installed xserver-xorg-video-intel on Feisty, changed my xorg.conf "i810" with "intel", disabled 915resolution and rebooted.

The resolution was fine but I got some trouble login into gnome session, as if there was something broken that brought me back to the login screen after some video probes.

However, I decided to try "dpkg-reconfigure xserver-xorg" (again with the new "intel" driver) and it happened to fix the issue. Weird.

Hope that helps anyone.

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote :

I still have to install 915resolution to get the correct resolution with Gutsy Tribe 5. Isn't this meant to be Fix Released?

Am I meant to be changing conf files?

Revision history for this message
Brian Murray (brian-murray) wrote :

Aaron - please submit a new bug report with information regarding your system and Xorg setup before you installed 915resolution. Files needed are - /etc/X11/xorg.conf , /var/log/Xorg.0.log and the full output of 'sudo lspci -vvnn'. Thanks in advance.

Revision history for this message
Alexander van Loon (avanloon) wrote :

I can confirm that the fix works in my case. When I installed Gutsy Tribe 4 on the same notebook as I mentioned in my initial bugreport here, Ubuntu chose the correct resolution - 1280 by 800 pixels - by default.

However, when I install Tribe 4 on my desktop PC, which has a Dell 2007WFP 20 inch widescreen monitor (which has a resolution of 1680 by 1050 pixels) connected to a NVIDIA GeForce 7800 GT, it still chooses the wrong resolution of 1280 by 1024 pixels. I shall file a separate bugreport for that according to your instructions, Brian Murray.

Revision history for this message
Alex Muntada (alex.muntada) wrote :

@Sander: this bug relates to Intel chips only, so it does not apply to the issue you are experiencing on your desktop PC.

Therefore, filing a new bug is the right thing to do (unless it is been already reported, indeed).

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote :

@Brian:
Thanks for the quick replies. Is is sufficient for me to uninstall
915resolution and give you those files, or do I need to reinstall
Tribe 5 from scratch?

Revision history for this message
Brian Murray (brian-murray) wrote :

Uninstalling and having dpkg reconfigure your xserver should be sufficient.

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote :

Please see Bug #135181

Revision history for this message
François Grieu (fgrieu) wrote :

Tested Gutsy Tribe 5 from gutsy-desktop-i386.iso on a Dell Inspiron 500m portable with optional 1400*1050 LCD; has Intel 855GM Integrated Graphics, Pentium M 1.5GHz.

CD boot (default) selects 1280*1024, poor display. Native resolution not proposed in "Screen Resolution"; 1024x768 is usable but suboptimal.
CD boot (safe graphics) fails to lauch X, reports misconfiguration.
Installation on HD, update, selection of approriate display in "Screen and Graphics" did not help.

I volunteer to test a fix on a fresh install.

Revision history for this message
Alex Muntada (alex.muntada) wrote :

François, there's some kind of deadlock right now about the right way to find the right resolution on intel graphics:

 * i810 is the default, older driver but needs 915resolution (not installed by default) in order to get the right resolution
 * new intel driver gets the right values without 915resolution, but it's not installed by default yet (there are other issues related with speed, dpi and fonts)

Therefore, I guess that testing a fix on a fresh install wouldn't probably help on this case. Thanks anyway :-)

Revision history for this message
François Grieu (fgrieu) wrote :

Excellent news: ubuntu-7.10-rc-desktop-i386 uses the native 1400*1050 LCD resolution on my Dell Inspiron 500m (Intel 855GM Integrated Graphics, Pentium M 1.5GHz), where gutsy-desktop-i386 Tribe 5 would use 1280*1024. Good job!

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote :

Yes. The RC uses the new intel driver, which doesn't need
915resolution. The i810 driver does still require it.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

There is no -i810 driver anymore in Intrepid, and -intel should replace it in every respect in 8.04. Closing the bug.

Changed in xorg:
status: New → Invalid
Revision history for this message
François Grieu (fgrieu) wrote :

I confirm Intrepid uses the native 1400*1050 LCD resolution on my Dell Inspiron 500m portable with Intel 855GM Integrated Graphics, Pentium M 1.5GHz.That one is fixed as far as this machine is concerned.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers