640x480 with i855gm in edgy, OK in dapper

Bug #61234 reported by Maris Nartiss
12
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-i810

In Dapper my i855gm card where working out of box (no DRI, but correct resolution, xv, output to VGA out port). After upgrade to Edgy, I manage to get only 640x480 + garbage in upper 2cm of screen. Disabling AIGLX, DRI, GLX doesn't help (only changes distortion look).

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Revision history for this message
Maris Nartiss (maris-nartiss) wrote :

sudo 915resolution -l
Intel 800/900 Series VBIOS Hack : version 0.5.2

Chipset: 855GM
BIOS: TYPE 1
Mode Table Offset: $C0000 + $29f
Mode Table Entries: 39

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel

Revision history for this message
Maris Nartiss (maris-nartiss) wrote :

uname -a
Linux GRASS 2.6.17-7-generic #2 SMP Wed Sep 6 17:56:40 UTC 2006 i686 GNU/Linux

Revision history for this message
William Grant (wgrant) wrote :

What is the correct resolution? Did you need 915resolution to get it in Dapper?

Changed in xserver-xorg-video-i810:
status: Unconfirmed → Needs Info
Revision history for this message
Maris Nartiss (maris-nartiss) wrote :

Sorry, correct resolution is 1024x768 and I get it out of box in Dapper - without any 915resolution tricks.

William Grant (wgrant)
Changed in xserver-xorg-video-i810:
status: Needs Info → Unconfirmed
Revision history for this message
Maris Nartiss (maris-nartiss) wrote :

At attached image is seen screen when DRI is disabled (edgy's X.org with i810 driver).

Revision history for this message
Maris Nartiss (maris-nartiss) wrote :

This is equivalent with Bug #61471. Is possible to merge those bugs?

Revision history for this message
Maris Nartiss (maris-nartiss) wrote :

I switched from i810 driver to intel (xserver-xorg-video-intel 1.6.0-0ubuntu1) driver and got my 1024x768 back with xv, DRI and AIGLX.

Altrough intel driver has some issues:
DRI is slooow (max 600fps in glxgears, max 500fps w/o DRI = +100fps only);
I can not switch to console (consoles content is in upper grabbled 2 cm of screen);
fn key to switch between LFP and VGA out doesn't work;
TV-out also doesn't work (have not tested with i810);
some hard-lockups on high load.

But still is better than VESA :)

Revision history for this message
robT (rob-terhaar) wrote :

I can confirm that running a10, green vertical lines run across the top of the screen on the d505. When i downgrade to a09, the green lines are gone!

I tested simply by booting the edgy final live CD

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Can you try with Feisty Herd5 if it works any better?

Changed in xserver-xorg-video-i810:
status: Unconfirmed → Needs Info
Revision history for this message
J Fernyhough (j-fernyhough+launchpad) wrote :

All Feistys have had the same problem on my Dell D505 with BIOS A11, including Herd 5.

xserver-xorg-video-intel is not included in the Feisty repo, so this workaround is lost.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

it's called -i810-modesetting for now. Upstream has merged the modesetting branch to master, so the upcoming version will be -intel again. Unfortunately that's not going to happen for Feisty since it requires a new xorg-server as well...

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-i810 (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.