Unable to adjust refresh rate..

Bug #50048 reported by yop
10
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xserver-xorg-driver-i810

If using I810 and a ie: Philips 17" (1280x1024@60Hz)TFT/LCD that support up to 75Hz but it's recommended to use 60 Hz. the i810 don't let me set it to 60. It only let me use 75.

If using VESA then I can use 60 like it should.
Or if using "modeline" to force it to use 60, but then the GDM is using a virtual size of 1600x1200. To fix that I need to use the 915resolution, and set it to use the 1600x1200 as 1280x1024. Have tried to use HorizSync, VertRefresh but it's ignored.

If I dont do any of this and just use 75Hz the GDM and desktop shows fine except that it's running at 75Hz.
Would like to see that the i810 can handle 60hz aswell

Grafic intel 9ser builtin HP DX6100 and a Philips 170B

Revision history for this message
Eduard Wulff (mail-eduard-wulff) wrote :

I have the same problem here.

HP nc6400 (Notebook)

switched off DDC

xrandr lists only 60Hz (as I have force-configured it in xorg.conf)

1280x1024 gives 85Hz which my LCD (borked DDC-Infos from there) reports being capable but causes it to flicker that I am in fear the monitor wears out ...

800x600, 1024x768, 1600x1200 all give 60Hz and the image is stable.

My settings in xorg.conf are ignored.

Revision history for this message
Rich Johnson (nixternal) wrote :

confirming due to response to this report

Changed in xserver-xorg-video-i810:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Revision history for this message
yop (yop) wrote :

Ok here some news.
If using the modeline from GTF in ubuntu, then I get this odd problem that i need the 915 resolution as well to get GDM and desktop to have the right resolution and Hz.

But if using KDE and let it set the reso and Hz it work fine. Or if using a online generator like:
http://www.bohne-lang.de/spec/linux/modeline/
then I don't need to use the 915reso to fix the GDM issue

So it seems that the GTF in ubuntu don't generate the correct value.

Anyhow, it still would be nice to not have to use modeline and only be able to select the correct Hz from the display setting

Revision history for this message
Vedran Rodic (vrodic) wrote :

The new Xorg server should be able to query monitor by itself for DDC edid info about it's capatibilities. This functionality works for me if I leave out monitor specific information from my Xorg.conf like this:
Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
EndSection

In the edid info there should be data for the recommended resolution and refresh rate. The problem is however that some monitors have this data wrong (so you don't get the right resolution or refresh rate), or the checksum of the complete data wrong (so you don't get the edid data used by X at all). Either way, could you send the output of the get-edid > Philips170B.edid as attachment to this bug, and possibly the xorg mailing list, so we can see what's wrong with the data and add a quirk for it in the Xorg code?

Revision history for this message
Vedran Rodic (vrodic) wrote :

get-edid is in the read-edid package, and it runs as root

Revision history for this message
yop (yop) wrote :

Ok here is the terminal output and I have attached the file as well.

get-edid: get-edid version 1.4.1

        Performing real mode VBE call
        Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
        Function supported
        Call successful

        VBE version 300
        VBE string at 0x11110 "Intel(r)Grantsdale-G Graphics Chip Accelerated VGA BIOS"

VBE/DDC service about to be called
        Report DDC capabilities

        Performing real mode VBE call
        Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
        Function supported
        Call successful

        Monitor and video card combination does not support DDC1 transfers
        Monitor and video card combination supports DDC2 transfers
        0 seconds per 128 byte EDID block transfer
        Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
        Read EDID

        Performing real mode VBE call
        Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
        Function supported
        Call successful

Revision history for this message
unggnu (unggnu) wrote :

Could you please recheck it with latest Ubuntu Gutsy Gibbon 7.10 or the Live CD? If you have Gutsy already please change the Driver i810 to intel which is the default one in Gutsy.

Changed in xserver-xorg-video-i810:
status: Confirmed → Incomplete
Revision history for this message
yop (yop) wrote : Re: [Bug 50048] Re: Unable to adjust refresh rate..

Yes, it does work like it should do in 7.10

On 10/22/07, unggnu <email address hidden> wrote:
>
> Could you please recheck it with latest Ubuntu Gutsy Gibbon 7.10 or the
> Live CD? If you have Gutsy already please change the Driver i810 to
> intel which is the default one in Gutsy.
>
> ** Changed in: xserver-xorg-video-i810 (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Unable to adjust refresh rate..
> https://bugs.launchpad.net/bugs/50048
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Eduard Wulff (mail-eduard-wulff) wrote :

work as expected in 7.10

for me: close this bug

Thanks!

Revision history for this message
Peter Clifton (pcjc2) wrote :

Marking this as fixed, as this is reported as working in 7.10.

Changed in xserver-xorg-video-i810:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers