Xorg i810 driver crashes on resume after sleep (i815) "Active ring not flushed"

Bug #41692 reported by Antonio Censi on 2006-04-27
12
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Ubuntu)
Medium
Unassigned

Bug Description

On my notebook Sony PCG-R505JL, with the 815 chipset, upon resuming from sleep mode, xserver crashes with garbage on screen with the following logged in Xorg.0.log.old:
(II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
pgetbl_ctl: 0xe840001 pgetbl_err: 0x0
ipeir: 0 iphdr: 28cc0800
LP ring tail: d00 head: 48c len: f001 start 300000
eir: 0 esr: 1 emr: 3d
instdone: ff7a instpm: 0
memmode: 4 instps: 810
hwstam: bac7 ier: 0 imr: bac7 iir: 0

Fatal server error:
Active ring not flushed

After the crash, no text terminals can be used, only a power off-on cycle to recover.

Hibernate is working completely.

Tried also with i810_drv and libshaddow from http://www.fairlite.demon.co.uk/intel.html, as there is a somewhat similar situation with chipset 830. Same results.

If dri is enabled, xserver crashes without messages in log, with a blank screen.

Everything else is working perfecty with Dapper.

Paul Sladen (sladen) wrote :

Could this be bug #28326 ?

My first approach was that, so I tried the binary from
http://www.fairlite.demon.co.uk/intel.html, that is supposed to solve at
least partially the i830 bug #28326.

In my case the chip and the code are different, i815 and code is
i810WaitLpWait, similar but with differences from i830WaitLpRing.

Today by looking more carefully in the code, it seems that the error occurs
upon saving state of chip; the error is thown out in a save routine, at the
end of a DoSave, in a section commented as i810Save. So the crash shoud be
occurring before suspending,,not on resuming!

On 4/29/06, Paul Sladen <email address hidden> wrote:
>
> Could this be bug #28326 ?
>
> --
> Xorg crashes on resume after sleep
> https://launchpad.net/bugs/41692
>

--
A. C. Censi
accensi [em] gmail [ponto] com
accensi [em] montreal [ponto] com [ponto] br
accensi [em] gmail [ponto] com - Google Talk

Timo Aaltonen (tjaalton) wrote :

Closing an old bug. If you can reproduce it with Feisty, please reopen. Xorg developers have fixed a similar bug a long ago.

Changed in xserver-xorg-video-i810:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers