No player can play screencasts recorded with Istanbul

Bug #120669 reported by Grzegorz Galezowski
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: istanbul

Hi,
I recently updated Istanbul and was pleased, that the bug which made Istanbul hang on recording of full screen in 1280x800 (wide screen laptop) was gone. But then it appeared, that, though I can record such screencasts, all players I have (Totem, MPlayer, Helix) refuse to play the video file I have saved. It seems strange, because when i finish recording the screencast, I can view it in Istanbul's 'Save Screencast' dialog, and, after saving it to the desktop (for example by the name movie.ogg), the screencast icon is represented by a frame from the movie, so it looks like 'something' can recognize it after all. But when I try to start it, Totem appears for a while, and then shuts down. Other mentioned players don't even seem to recognize the file as correct Theora movie.
This occurs only after I choose "Full Size" from recording options. Totem doesn't have any problems with full screen movie recorded with "half width and height". Also, when I choose "Full size", but select smaller (than full screen) area in "Select area to record", everything seems fine as well.

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :

I record screencasts with other applications (not istanbul), and sometimes the high resolution (1024x768 and above) ones don't play on some machines. I believe this is down to a problem with the video memory/driver rather than istanbul itself. This is confirmed by the fact that you have tried multiple players - totem uses the gstreamer backend by default and mplayer doesn't. So I'd say that rules out totem and mplayer, the fact that I get the same with other non-gstreamer-based screen recorders says it's not the recorder either.

Can you confirm what video chipset you have? I have noticed this problem on machines with Intel video chipsets.

Revision history for this message
Grzegorz Galezowski (spectral) wrote :

Yes, I'm using Intel video chipset.

Revision history for this message
Grzegorz Galezowski (spectral) wrote :

To be precise: Mobile 945GM/GMS/940GML Express Integrated Graphics Controller.

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :

Are you using the i810 driver (see /etc/X11/xorg.conf" or the intel modesetting one).

I just did a test with istanbul 0.2.2 under Gutsy recording at 1400x1050 with the Intel 945 chipset and it played back in mplayer and totem fine.

I am using the intel modesetting driver "xserver-xorg-video-intel".

alan@mother:~$ dpkg -l xserver-xorg-video-intel | grep ^ii
ii xserver-xorg-video-intel 2:2.0.0-1ubuntu2 X.Org X server -- Intel i8xx, i9xx display driver

Revision history for this message
Grzegorz Galezowski (spectral) wrote :

I was using i810 driver xorg-xserver-video-i810. After your coment I changed it to xserver-xorg-video-intel and now screencasting works where it wasn't before:).
So it seems that it was a driver issue after all.
Thanks for your help.

Changed in istanbul:
status: Unconfirmed → Confirmed
Revision history for this message
unggnu (unggnu) wrote :

I am closing this bug since it seems to be fixed in Gutsy and in Feisty through installing xserver-xorg-video-intel.

Changed in xserver-xorg-video-i810:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers