i810 video driver does not detect video modes

Bug #112701 reported by Robert
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

In XUbuntu Feisty, when checking Settings | Display Settings, when using the xserver-xorg-video-i810 driver, only two modes are detected on my Intel 915GM video card (thinkPad Z60m): 1024x768@60 and 1280x768@60. No 800x600 or 640x480 modes.

The modes were manually added to xorg.conf file, e.g.

      SubSection "Display"
              Depth 24
              Modes "3584x769" "1920x1440" "1600x1200" "1472x770" "1
280x1024" "1280x800" "1024x768" "800x600" "640x480" "512x771" "400x772"
      EndSubSection

but still they are not detected.

When I switch to the intel driver xserver-xorg-video-intel, the other modes show up as options in Display Settings. However, choosing them causes the X Server to stop and gdm to restart back in the original mode.

Revision history for this message
Basil Shubin (bashux) wrote :

Yes I can confirm the same issue on HP Compaq nx6110 with i915GM.

Using xserver-xorg-video-intel crashes the xorg on resolution changing...

lspci info attached. What also I should check

BTW, this is in Ubuntu 7.04

Revision history for this message
unggnu (unggnu) wrote :

Could you please recheck it with Gutsy RC or newer? It is shipped with the new Intel driver which should fix this issue.

Changed in xserver-xorg-video-i810:
status: New → Incomplete
Revision history for this message
Robert (robrwo) wrote :

I don't have a spare machine to run Gutsy on, so I'll have to delay rechecking this until after I upgrade to Gutsy (which probably won't be as soon as Gutsy is released).

Revision history for this message
unggnu (unggnu) wrote :

Please recheck it with Gutsy Final Live CD. It wouldn't take long since no upgrade is needed.

Revision history for this message
Basil Shubin (bashux) wrote :

I had checked it on Gutsy, after uprgading from Feisty and I can say that it's working, ie. I am able to change screen resolution via Gnome's Screen Resolution Preferences.

Revision history for this message
unggnu (unggnu) wrote :

I am closing this bug because it seems to be fixed. Feel free to open it again if the issue still happens with Gutsy Gibbon and the new Intel driver.

Changed in xserver-xorg-video-i810:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments