Intel i740 max resolution 800x600 Lubuntu 10.04

Bug #555044 reported by Anthony
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i740 (Ubuntu)
Undecided
Unassigned

Bug Description

Using Intel integrated graphics i740. Max resolution is only 800x600. Installed Lubuntu Lucid 10.04. CRT Monitor - Compaq FS 740 which supports up to 1280x1024.

Output from xandr:
Screen 0: minimum 320 x 240, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
   800x600 60.0* 56.0
   640x480 60.0
   400x300 60.0 56.0
   320x240 60.0

unable to add/change mode. executed the following lines:
* xrandr --newmode "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
* xrandr --addmode default 1024x768_60.00
* xrandr --output default --mode 1024x768_60.00

Returns: xrandr: Configure crtc 0 failed

Revision history for this message
Sebastian Bator (eremit7) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xserver-xorg-video-i740.
(With many applications, you can report a future bug directly on the appropriate package by opening the application's "Help" menu and choosing "Report a Problem". https://wiki.ubuntu.com/ReportingBugs)

affects: ubuntu → xserver-xorg-video-i740 (Ubuntu)
Revision history for this message
Sebastian Bator (eremit7) wrote :

I forgot, if you running the system in Virtualbox please install the guestextensions and mark this bug as invalid.

Revision history for this message
Anthony (anthony-mlist) wrote :

It's not running in a Virtual Server. Full install on the system.

description: updated
Bryce Harrington (bryce)
tags: added: lucid
Revision history for this message
Bryce Harrington (bryce) wrote :

Hi Anthony,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-i740 (Ubuntu):
status: New → Incomplete
Revision history for this message
Anthony (anthony-mlist) wrote :
Download full text (5.1 KiB)

pionex@pionex-desktop:~$ lspci -vvnn
00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge [8086:7190] (rev 03)
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 64
 Region 0: Memory at e0000000 (32-bit, prefetchable) [size=64M]
 Capabilities: <access denied>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:01.0 PCI bridge [0604]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge [8086:7191] (rev 03)
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
 I/O behind bridge: 0000d000-0000dfff
 Memory behind bridge: e4000000-e5ffffff
 Prefetchable memory behind bridge: e6000000-e6ffffff
 Secondary status: 66MHz+ FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- <SERR- <PERR-
 BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B+
  PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
 Kernel modules: shpchp

00:07.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (rev 02)
 Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0

00:07.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01) (prog-if 80 [Master])
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Region 0: [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
 Region 1: [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
 Region 2: [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
 Region 3: [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
 Region 4: I/O ports at f000 [size=16]
 Kernel driver in use: ata_piix

00:07.2 USB Controller [0c03]: Intel Corporation 82371AB/EB/MB PIIX4 USB [8086:7112] (rev 01)
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Interrupt: pin D routed to IRQ 10
 Region 4: I/O ports at e000 [size=32]
 Kernel driver in use: uhci_hcd

00:07.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 02)
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin ? routed to IRQ 9
 Kernel driver in use: piix4_smbus
 Kernel modules: i2c-piix4

00:08.0 Ethernet controller [0200]: AD...

Read more...

Revision history for this message
Anthony (anthony-mlist) wrote :
Download full text (24.5 KiB)

pionex@pionex-desktop:~$ dmesg
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.32-19-generic (buildd@palmer) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 (Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1)
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] NSC Geode by NSC
[ 0.000000] Cyrix CyrixInstead
[ 0.000000] Centaur CentaurHauls
[ 0.000000] Transmeta GenuineTMx86
[ 0.000000] Transmeta TransmetaCPU
[ 0.000000] UMC UMC UMC UMC
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000000bff0000 (usable)
[ 0.000000] BIOS-e820: 000000000bff0000 - 000000000bff3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000000bff3000 - 000000000c000000 (ACPI data)
[ 0.000000] BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
[ 0.000000] DMI 2.1 present.
[ 0.000000] last_pfn = 0xbff0 max_arch_pfn = 0x100000
[ 0.000000] MTRR default type: uncachable
[ 0.000000] MTRR fixed ranges enabled:
[ 0.000000] 00000-9FFFF write-back
[ 0.000000] A0000-BFFFF uncachable
[ 0.000000] C0000-C7FFF write-protect
[ 0.000000] C8000-EFFFF uncachable
[ 0.000000] F0000-FFFFF write-through
[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 000000000 mask FF8000000 write-back
[ 0.000000] 1 base 008000000 mask FFC000000 write-back
[ 0.000000] 2 disabled
[ 0.000000] 3 disabled
[ 0.000000] 4 disabled
[ 0.000000] 5 disabled
[ 0.000000] 6 disabled
[ 0.000000] 7 disabled
[ 0.000000] PAT not supported by CPU.
[ 0.000000] e820 update range: 0000000000002000 - 0000000000006000 (usable) ==> (reserved)
[ 0.000000] Scanning 1 areas for low memory corruption
[ 0.000000] modified physical RAM map:
[ 0.000000] modified: 0000000000000000 - 0000000000002000 (usable)
[ 0.000000] modified: 0000000000002000 - 0000000000006000 (reserved)
[ 0.000000] modified: 0000000000006000 - 000000000009fc00 (usable)
[ 0.000000] modified: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] modified: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] modified: 0000000000100000 - 000000000bff0000 (usable)
[ 0.000000] modified: 000000000bff0000 - 000000000bff3000 (ACPI NVS)
[ 0.000000] modified: 000000000bff3000 - 000000000c000000 (ACPI data)
[ 0.000000] modified: 00000000ffff0000 - 0000000100000000 (reserved)
[ 0.000000] initial memory mapped : 0 - 00c00000
[ 0.000000] init_memory_mapping: 0000000000000000-000000000bff0000
[ 0.000000] Using x86 segment limits to approximate NX protection
[ 0.000000] 0000000000 - 0000400000 page 4k
[ 0.000000] 0000400000 - 000bc00000 page 2M
[ 0.000000] 000bc00000 - 000bff0000 page 4k
[ 0.000000] kernel direct mapping tables up...

Revision history for this message
Anthony (anthony-mlist) wrote :

File attached: Xorg.0.log

Revision history for this message
Anthony (anthony-mlist) wrote :

File attached: Xorg.0.log.old

Revision history for this message
Anthony (anthony-mlist) wrote :

/etc/X11/xorg.conf not available. Didn't use a custom xorg.conf file either.

Revision history for this message
Bryce Harrington (bryce) wrote :

Thanks for the Xorg log. We also need the lspci -vnvn output attached to this bug as a file

tags: removed: needs-xorglog
Changed in xserver-xorg-video-i740 (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
Anthony (anthony-mlist) wrote :
Download full text (5.1 KiB)

pionex@pionex-desktop:~$ lspci -vnvn
00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge [8086:7190] (rev 03)
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 64
 Region 0: Memory at e0000000 (32-bit, prefetchable) [size=64M]
 Capabilities: <access denied>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:01.0 PCI bridge [0604]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge [8086:7191] (rev 03)
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
 I/O behind bridge: 0000d000-0000dfff
 Memory behind bridge: e4000000-e5ffffff
 Prefetchable memory behind bridge: e6000000-e6ffffff
 Secondary status: 66MHz+ FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- <SERR- <PERR-
 BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B+
  PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
 Kernel modules: shpchp

00:07.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (rev 02)
 Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0

00:07.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01) (prog-if 80 [Master])
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Region 0: [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
 Region 1: [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
 Region 2: [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
 Region 3: [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
 Region 4: I/O ports at f000 [size=16]
 Kernel driver in use: ata_piix

00:07.2 USB Controller [0c03]: Intel Corporation 82371AB/EB/MB PIIX4 USB [8086:7112] (rev 01)
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64
 Interrupt: pin D routed to IRQ 10
 Region 4: I/O ports at e000 [size=32]
 Kernel driver in use: uhci_hcd

00:07.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 02)
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin ? routed to IRQ 9
 Kernel driver in use: piix4_smbus
 Kernel modules: i2c-piix4

00:08.0 Ethernet controller [0200]: AD...

Read more...

Revision history for this message
Anthony (anthony-mlist) wrote :

i assumed this is the same as 'lspci -vvnn' (see #5)

Revision history for this message
Bryce Harrington (bryce) wrote :

Thanks for the files Anthony. Unfortunately we do not do support for the i740 driver in Ubuntu. In fact I'm not sure this driver is supported at all, but your best chance would be to go upstream with it. Our support efforts with intel hardware focuses on the xserver-xorg-video-intel driver.

Changed in xserver-xorg-video-i740 (Ubuntu):
status: Incomplete → Won't Fix
Revision history for this message
Anthony (anthony-mlist) wrote :

Thanks for looking into the bug. Unfortunately, I don't understand what you mean by going upstream with it. I ran Vector Linux on this old desktop last week and the graphics were just fine. I can get higher resolution without any problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers