xf86-video-geode: DDC probing broken on GX2/CS5535 since 2.9.0 (patch)

Bug #255991 reported by Martin-Éric Racine
8
Affects Status Importance Assigned to Milestone
xserver-xorg-video-geode (Ubuntu)
Fix Released
Undecided
Unassigned
Nominated for Intrepid by Martin-Éric Racine
Hardy
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-geode

Since the GEODE X.org driver switched to the common libDDC for probing monitor resolutions in version 2.9.0, a regression was introduced that makes probing fail on Geode platforms that use a CS5535 companion chip.

This is caused by a hard-coded value that makes DDC probing only possible on the CS5536 companion chip.

Upstream already committed a fix in upstream GIT and, while I don't have access to Geode hardware with a CS5535 chip to validate the fix, it should work.

For Hardy, I propose making a 2.9.0-1ubuntu2.5 for hardy-updates that includes only this patch.

For Intrepid, the fix will be included in 2.10.0-7 for Debian/experimental and can soon be synchronized from there.

Future upstream releases will include this fix in GEODE 2.10.1 (X server 1.4 branch) and 2.12.0 (X server 1.5 branch).

Revision history for this message
Martin-Éric Racine (q-funk) wrote :
Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Here is the debdiff for the Hardy-Proposed SRU.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Test packages based on the above debdiff for Hardy-Proposed are in my PPA at:

deb http://ppa.launchpad.net/q-funk/ubuntu hardy main
deb-src http://ppa.launchpad.net/q-funk/ubuntu hardy main

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Here is the unified diff on a sample X restart between 2.4 and 2.5 on LX+CS5536.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Upstream will release a GEODE 2.10.1 later this week that includes the above DDC for CS5535 fix and a RandR scaling fix.

I propose uploading this as-is to Debian/unstable (freeze exception already granted) then importing into Intrepid.

For Hardy, I propose applying both changes as a patch to the existing 2.9.0 package. Alternately, if an SRU to get the whole 2.10.1 into Hardy-updates is acceptable, this could be another possibility.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

This is what the git-diff looks like between 2.9.0 and GIT master (which will become 2.10.1 by Friday).

The benefits versus 2.9.0:

* Adds final OLPC support.
* Fixes a number of build bugs.
* Fixes DDC probing via CS5535 companion chip.
* Fixes RandR rotation issues with EXA pixmaps.

Would this be acceptable as an SRU for Hardy, instead of backporting fixes in a piecemeal way?

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

2.10.1-1 is now in Debian/unstable and ready to sync into Ubuntu/Intrepid. It includes the above fix.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

I welcome comments on what would be the best way to solve the same issues for Hardy (hand-picking patches or doing an SRU with 2.10.1).

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Intrepid should instead import from Debian/experimental for 2.10.1-3 to include the above fix.

Revision history for this message
Steve Langasek (vorlon) wrote :

please cherry-pick just the changes that meet the SRU guidelines. E.g., fixing "build bugs" is not relevant in an SRU for a package that isn't failing to build...

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Asides from CS5535 probing and EXA bugfixes, would OLPC support qualify for the SRU (keeping in mind that "adds support for new hardware" can be a reason to introduce a whole new upstream via SRU)?

Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 255991] Re: xf86-video-geode: DDC probing broken on GX2/CS5535 since 2.9.0 (patch)

On Wed, Aug 20, 2008 at 06:31:41PM -0000, Martin-Éric Racine wrote:
> Asides from CS5535 probing and EXA bugfixes, would OLPC support qualify
> for the SRU (keeping in mind that "adds support for new hardware" can be
> a reason to introduce a whole new upstream via SRU)?

Yes, I think the added OLPC support is appropriate.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

I welcome help from the Ubuntu X team to cherry-pick 2.10.1 elements towards the Hardy SRU.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-geode:
status: New → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Bryce Harrington [2008-09-10 0:54 -0000]:
> ** Attachment added: "diff_geode_2.9.0_git2.10.1-stripped4sru.diff"

This looks appropriate for an SRU, please go ahead and upload.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Is there any news on getting this 2.9.0-1ubuntu2.5 into Hardy-updates?

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

One small request from the Ubuntu-mobile team: please add lpia to Arch also.

For Intrepid, I'll just directly add it to the upstream Debian package.

For Hardy-updates, it needs to be done with the above 2.9.0-1ubuntu2.5 instead.

Revision history for this message
Loïc Minier (lool) wrote :

(We don't need lpia support in hardy.)

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Here's the debdiff to produce 2.9.0-1ubuntu2.5 for Hardy, based on Bryce's cleaned diff.

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

And here's the build log.

Changed in xserver-xorg-video-geode:
assignee: nobody → q-funk
status: New → In Progress
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

uploaded to hardy-proposed.

Changed in xserver-xorg-video-geode:
assignee: q-funk → nobody
status: In Progress → Fix Committed
Revision history for this message
Bryce Harrington (bryce) wrote :

Reuploaded

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

Marking back to Committed, since this still hasn't moved from hardy-proposed to hardy-updates and thus cannot be considered as Released.

Changed in xserver-xorg-video-geode:
status: Fix Released → Fix Committed
Revision history for this message
Martin-Éric Racine (q-funk) wrote :

I'll add that this produces no regression on two LX/CS5536 platforms at my disposal (Artec ThinCan DBE61 and FIC ION603 e.g. Linutop-2, Koolu).

I am however unable to test other changes (bugfixes and support for new hardware).

Revision history for this message
Martin-Éric Racine (q-funk) wrote :

... since I do not have any spare OLPC XO-1 to install Ubuntu, nor any GX2/CS5535 hardware to test this.

Revision history for this message
Martin Pitt (pitti) wrote :

Regression tests are more important than double-checking that it now actually works on previously unsupported platforms, so let's move this to -updates now.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-geode - 2.9.0-1ubuntu2.5

---------------
xserver-xorg-video-geode (2.9.0-1ubuntu2.5) hardy-proposed; urgency=low

  * Stripped duplicated lines in debian/rules.
  * Enabled simple-patchsys.mk CDBS include in debian/rules.
  * Backported CS5535/GX2 and OLPC hardware support from 2.10.0 release.
    + Added to debian/patches/ and applied with simple-patchsys.mk
    Thanks to Bryce Harrington for thining the patch to the essentials!
    (LP: #255991)

 -- Martin-Eric Racine <email address hidden> Sat, 18 Oct 2008 13:42:15 +0300

Changed in xserver-xorg-video-geode:
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

does not affect intrepid/jaunty.

Changed in xserver-xorg-video-geode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers