Comment 11 for bug 236019

Using 2.9.0-4ubuntu3 I get a working desktop at 1024x768 with my existing xorg.conf (driver changed from vesa to geode).

Removing xorg.conf and starting x to get the configuration thing:-

I have a Viewsonic 20" VA2012w (not listed as a display) - native res is 1680x1050.

I choose the geode

I choose Generic LCD Panel 1680x1050 (with 'widescreen monitor' NOT ticked), the resolutions options I get are 640x480, 800x600, 1024x768, 1280x960, 1280x1024 and 1400x1050.

Using the "test" feature, I seem to be able to get 1400x1050 okay. However when I say "ok" I get GDM at 640x480, starting the XFCE the display properties only shows 640x480.

http://popey.com/~alan/viglen/auto1_xorg.conf is the xorg.conf that got created.

However if I tick 'widescreen monitor' i get 800x600, 1280x720, 1280x768, 1440x900, 1600x1024 and 1680x1050.

I then choose 1680x1050 and "test" i get a screen where the resolution is high, but I have a small viewport, so have to pan around to find the "15 seconds to accept" thing. Clicking "ok", this gets configured:-

http://popey.com/~alan/viglen/auto2_xorg.conf

Starting GDM and XFCE as before results in a 640x480 desktop.

Rebooting with that xorg.conf obviously results in a 640x480 desktop.

It's a Viglen MPC-L
http://www.viglen.co.uk/viglen/Products_Services/Product_Range/Product_file.aspx?eCode=XUBUMBCL&Type_Info=Description&Type=Desktops&GUID=

In fact it's an FTC device internally.
http://www.fic.com.tw/product/minipc.aspx

I have dumped everything I can into http://popey.com/~alan/viglen/

If you want more info about this, feel free to ask.

For any canonical people reading, I have also run the hwtest-gtk for this device which is assigned to the email address on my lp account.

Suggestions welcome.