geode driver gives corrupt output

Bug #236019 reported by Alan Pope 🍺🐧🐱 🦄 on 2008-05-30
Affects Status Importance Assigned to Milestone
xserver-xorg-video-geode (Ubuntu)

Bug Description

Using the geode driver (forced into xorg.conf as due to bug 219630, it's not autodetected) on Hardy, when X starts the output is corrupt on the screen. The output looks like semi-random coloured pixels, but there is alternating patterns which I guess is the cursor flashing in GDM. Moving the mouse causes patterns to change, but nothing is readable or distinguishable.

Martin-Éric Racine (q-funk) wrote :

Can you try the xserver-xorg-core and xserver-xorg-video-geode from hardy-proposed and see if this helps?

Tried that (now have xserver-xorg-video-geode 2.9.0-1ubuntu2) and I get the same result.

Martin-Éric Racine (q-funk) wrote :

What if you try 2.9.0-3ubuntu2 from my PPA? Once you install -geode, please purge -amd to be sure. Does it help any?

An additional question: what is the hardware on which you get this bug? Manufacturer? Brand name? Model number?

Using 2.9.0-4ubuntu3 I get a working desktop at 1024x768 with my existing xorg.conf (driver changed from vesa to geode).

Removing xorg.conf and starting x to get the configuration thing:-

I have a Viewsonic 20" VA2012w (not listed as a display) - native res is 1680x1050.

I choose the geode

I choose Generic LCD Panel 1680x1050 (with 'widescreen monitor' NOT ticked), the resolutions options I get are 640x480, 800x600, 1024x768, 1280x960, 1280x1024 and 1400x1050.

Using the "test" feature, I seem to be able to get 1400x1050 okay. However when I say "ok" I get GDM at 640x480, starting the XFCE the display properties only shows 640x480. is the xorg.conf that got created.

However if I tick 'widescreen monitor' i get 800x600, 1280x720, 1280x768, 1440x900, 1600x1024 and 1680x1050.

I then choose 1680x1050 and "test" i get a screen where the resolution is high, but I have a small viewport, so have to pan around to find the "15 seconds to accept" thing. Clicking "ok", this gets configured:-

Starting GDM and XFCE as before results in a 640x480 desktop.

Rebooting with that xorg.conf obviously results in a 640x480 desktop.

It's a Viglen MPC-L

In fact it's an FTC device internally.

I have dumped everything I can into

If you want more info about this, feel free to ask.

For any canonical people reading, I have also run the hwtest-gtk for this device which is assigned to the email address on my lp account.

Suggestions welcome.

Martin-Éric Racine (q-funk) wrote :

To retrace my steps and verify that this indeed solves the Geode issues, some people might find either of the two following methods suitable:

Martin-Éric Racine (q-funk) wrote :

Please note that all required package updates have now entered Hardy-updates and are already present in Intrepid. Can you please test them by following the above procedure and confirm whether this fixes the issue you reported?

Martin-Éric Racine (q-funk) wrote :

Alan, does the package that is in hardy-updates solve the issue for you? If not, can you try the slightly newer package in my PPA and see if it improves your results?

Will do within the next few days - on holiday at the moment.

Tony Whitmore (tonywhitmore) wrote :

I have the same device and noticed the same effect described by popey on a fresh Hardy install (Xubuntu, but at the gdm screen.) Switching to the console (Ctrl Alt F1) and back to X (Alt F7) solves the distortion, although X is only showing the upper left hand 640x480 of an 800x600 GDM screen.

Tony Whitmore (tonywhitmore) wrote :

The version in Martin's PPA seems to resolve the corruption for me. It still leaves me with ridiculously small fonts in GDM and X though....

Martin-Éric Racine (q-funk) wrote :

Could the people affected by this bug please upgrade to Hardy and try the GEODE package that is in hardy-proposed (2.9.0-1ubuntu2.5). Alternately, the bug should also be fixed on Intrepid.

Bryce Harrington (bryce) on 2008-11-14
Changed in xserver-xorg-video-geode:
status: New → Confirmed
Martin-Éric Racine (q-funk) wrote :

Alan, can you confirm whether the bug still exists?

Changed in xserver-xorg-video-geode:
status: Confirmed → Incomplete
Martin-Éric Racine (q-funk) wrote :

Marking this bug as Invalid, due to incomplete information. Feel free to mark this bug as New again if you can confirm that it wasn't fixed by 2.9.0-1ubuntu2.5 (hardy-proposed), 2.10.1-3build1 (intrepid) or 2.11.0-1 (jaunty).

Changed in xserver-xorg-video-geode:
status: Incomplete → Invalid
Martin-Éric Racine (q-funk) wrote :

Please note that Geode found in Karmic (and via my PPA for earlier releases) fixes this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers