freeze with lots of usb events due to lack of x86emu updates [koolu geode lx]

Bug #213212 reported by Metiu on 2008-04-07
8
Affects Status Importance Assigned to Milestone
xserver-xorg-video-geode (Ubuntu)
High
Unassigned
Hardy
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-amd

With latest hardy upgrades, (xorg 1:7.3+10ubuntu7, kernel 2.6.24.15.17 ), the geode lx (koolu) will work with xorg only with fb driver.
With the amd driver it will freeze with the X cursor on a black background, and the Xorg log fills with mouse and keyboard events, with the cursor staying still in the center.

By the way, this is the same rebuilding the geode driver (new name) from git sources.

Martin-Éric Racine (q-funk) wrote :

Similar issues have been previously reported with the Koolu hardware. This issue also affects the Linutop-2 and Sumo.
All three products are based on similar FIC hardware. See http://www.fic.com.tw/product/minipc.aspx for details.

The main issue is that some patches against the x86emu component in xserver-xorg-core have yet to be merged upstream.

Bryce Harrington (bryce) wrote :

Martin-Eric, can you provide a pointer to the x86emu components? Perhaps we can include them in Ubuntu locally.

Bryce Harrington (bryce) on 2008-04-10
Changed in xserver-xorg-video-amd:
importance: Undecided → High
status: New → Confirmed
milestone: none → ubuntu-8.04
Bryce Harrington (bryce) wrote :

On upstream https://bugs.freedesktop.org/show_bug.cgi?id=12642 it's mentioned:

"The driver is broken with X server 1.3 or newer because it uses x86emu whereas
all previous X servers used vm86. It affects BIOS polling in a number of ways."

However, as near as I can tell, we've already included all available x86emu fixes for -amd/-geode, but if there are more let me know.

Martin-Éric Racine (q-funk) wrote :

Koolu just contacted the Geode X.org mailing list with their findings. Hopefully, a solution will be found soon. I'll update the info on this bug as I learn more.

Martin-Éric Racine (q-funk) wrote :

Koolu people confirmed that the BIOS used by their hardware supplier has issues.

Bryce Harrington (bryce) wrote :

As per the ongoing discussion with upstream, Koolu, and Geode, it looks like a fix for this is being targeted for June, so moving the milestone to 8.04.1.

Changed in xserver-xorg-video-amd:
milestone: ubuntu-8.04 → ubuntu-8.04.1
Martin-Éric Racine (q-funk) wrote :

Agreed.

Martin-Éric Racine (q-funk) wrote :

geode 2.9.0-1 in Intrepid and 2.9.0-1ubuntu1 in Hardy-proposed should fix this. Please test and report back whether this helps.

Martin-Éric Racine (q-funk) wrote :

Hardy-proposed now has both a newer X server core and GEODE driver available:

deb http://ee.archive.ubuntu.com/ubuntu/ hardy-proposed main universe restricted #multiverse
deb-src http://ee.archive.ubuntu.com/ubuntu/ hardy-proposed main universe restricted #multiverse

Please test and report your findings ASAP. If no major issue is reported within the next couple of weeks, this will be pushed into Hardy as an update.

PS: Intrepid already has both fixes uploaded since a few days too.

Metiu (matteo-fortini) wrote :

Sorry, but it freezed my koolu again...

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nome Versione Descrizione
+++-==============-==============-============================================
ii xserver-xorg-v 2.9.0-1ubuntu1 X.org server -- AMD Geode GX/LX display driv

Martin-Éric Racine (q-funk) wrote :

2.9.0-1ubuntu2 was just replaced by 2.9.0-1ubuntu3 to completely close this issue. It's already available in my PPA and should soon be uploaded to Hardy-proposed. For Intrepid, package 2.9.0-3 (pending import from Debian/unstable) includes the same fixes.

Metiu (matteo-fortini) wrote :

I tried it, no luck.

Attached my Xorg.0.log

Steve Langasek (vorlon) wrote :

Martin-Éric,

Is there an ETA for the upload of 1ubuntu3 to hardy-proposed? The window of opportunity for 8.04.1 is closing quickly.

Changed in xserver-xorg-video-geode:
importance: Undecided → High
milestone: none → ubuntu-8.04.1
status: New → In Progress
Steve Langasek (vorlon) wrote :

leaving as 'in progress' for intrepid, since there's a report that the bug is not actually fixed.

Changed in xserver-xorg-video-geode:
milestone: ubuntu-8.04.1 → none
status: Confirmed → In Progress
Metiu (matteo-fortini) wrote :

Sorry guys, I had some more time to try the new driver, and I found that it is fixed on my Koolu too, only I had specified the FBSize options with 64MBs (which is what I had set in the BIOS), but the BIOS for some strange reasons keeps losing that setting.

So let's call it fixed on my part.

Thanks a lot

Martin-Éric Racine (q-funk) wrote :

Metiu, thanks for informing us of this. Marking as Fixed now.

Changed in xserver-xorg-video-geode:
status: In Progress → Fix Released
Martin-Éric Racine (q-funk) wrote :

To fix Hardy, we still need to merge the backports I have in my PPA for -nsc and -geode.

Steve Langasek (vorlon) wrote :

This bug has been milestoned, but this bug number doesn't appear in any of the packages that have been uploaded to -proposed to date. Is something still missing to fix this for hardy?

Steve Langasek (vorlon) wrote :

is this bug still in progress for 8.04?

Changed in xserver-xorg-video-geode:
milestone: ubuntu-8.04.1 → ubuntu-8.04.2
Martin-Éric Racine (q-funk) wrote :

AFAIK what's in hardy-proposed should already fix it.

Steve Langasek (vorlon) wrote :

Presumed fixed in hardy-updates based on the latest comment. If you find that this issue still affects you, please reopen.

Changed in xserver-xorg-video-geode:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.