DisplayLink driver unloads when Screen 0 is handled by Nvidia driver

Bug #629244 reported by imnuts on 2010-09-03
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
xserver-xorg-video-displaylink (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-displaylink

Ubuntu 10.04.01 LTS; xserver-xorg-video-displaylink 0.3-0ubuntu4; nvidia-current 192.36.24-0ubuntu1~10.04
kernel upgraded to 2.6.34-020634-generic

What happens: DisplayLink driver unloads when Nvidia driver is used by Screen 0.

What's expected: DisplayLink driver remains loaded when Nvidia driver is used by Screen 0.

Workaround: Assign devices so Nvidia is used by Screen 1.

The only difference in xorg.conf to produce the two Xorg.0.log files was the change of Screen number 0->1,1->0 in Section "ServerLayout".

imnuts (7-launchpad-gcarl-net) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-displaylink (Ubuntu):
status: New → Confirmed
Bryce Nesbitt (bryce2) wrote :

This is confirmed also by this howto.
http://how-to.cc/get-a-displaylink-video-adapter-working-with-ubuntu-12-04

I'll offer a bounty of free displayLink hardware to someone able to make this a GUI setup in the monitors panel, for Ubuntu 13.

no longer affects: hexr
Virgil Titeu (vtechdir) wrote :

Thank you very much,

I have a Sony Vaio with Nvidia video card and I can run 2 monitors off it (TwinView or Xinerama via Nvidia configuration).
I also have 2 USB adapters to run two additional monitors. I can do this on Windows easily, but the laptop suffers due to Windows size.
I tried your advice and have set the two monitors driven by the Nvidia card as "screen2" and "screen3"and the DL monitors as "screen0" and "screen1" and disabled Twinview and only used Xinerama.
All monitors are found under X (except the one using the laptop's VGA port), but there is no X11 starting on any of them.
Is it possible to have this configuration working?

I would like to use X11 on all of them, but there is a segmentation error 0x41a0 in the log file and it drops out.

Anybody any ideas?

Regards

ignotus (ignotus) wrote :

http://askubuntu.com/questions/321532/how-to-make-ubuntu-13-04-work-with-displaylink-monitor

Try with a Kernel 3.9+
I followed this instructions and it works (do not use Nvidia native driver, use the opensource one).
It's slow but woks!
You can share windows (dragging them) between your different graphic cards!

Hi,

I did the same with Ubuntu 12.04 and a thinkvision lt1421. The console will show, when the desktop is load the screen will get black...

Ideas?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints