Add IDs for new AMD Evergreen/Fusion SKUs

Bug #990632 reported by Mike L on 2012-04-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Low
Unassigned

Bug Description

This graphics driver has no compiz or Unity 3d support. I understand that this is a new laptop, but please, do include support for this graphics card soon.This graphics driver has no compiz or Unity 3d support. I understand that this is a new laptop, but please, do include support for this graphics card soon, that is, if you can cherry-pick a patch to make 3d work on this thing. If not now, please try for the next Ubuntu release. Running Precise Pangolin with the latest patches.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-radeon 1:6.14.99~git20111219.aacbd629-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.1:

ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CasperVersion: 1.315
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: None
Date: Sat Apr 28 17:09:12 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Device [1002:9649] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3566]
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Hewlett-Packard HP Pavilion g7 Notebook PC
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/22/2012
dmi.bios.vendor: Insyde
dmi.bios.version: F.46
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3568
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.39
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.46:bd02/22/2012:svnHewlett-Packard:pnHPPaviliong7NotebookPC:pvr0690130000204610000620100:rvnHewlett-Packard:rn3568:rvr21.39:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion g7 Notebook PC
dmi.product.version: 0690130000204610000620100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Mike L (mikerl) wrote :
Mike L (mikerl) wrote :

I've heard that this may also be a kernel bug, but not 100% sure.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Julian Wiedmann (jwiedmann) wrote :
summary: - No support for AMD Radeon HD 6480G on Precise
+ Add IDs for new AMD Evergreen/Fusion SKUs
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdrm (Ubuntu):
status: New → Confirmed
Changed in mesa (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

Is this fixed in Ubuntu 12.10 "Quantal Quetzal"?

Julian Wiedmann (jwiedmann) wrote :

The mesa task is tracked in bug 1072096.

Changed in libdrm (Ubuntu):
status: Confirmed → Fix Released
madbiologist (me-again) wrote :

There is a fix for this graphics SKU in the upstream 3.13-rc7 kernel - see https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=61ef8be7fa4302180c163fb56a259610fd84ee13

A PPA of this kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

Mike L, could you please perform the test requested in https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/990632/comments/9 and advise to the results?

no longer affects: mesa (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
madbiologist (me-again) wrote :

The fix mentioned in comment #9 is now also available in the upstream 3.12.7 kernel.

A PPA of this kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

madbiologist (me-again) wrote :

I neglected to mention that for 3D work (eg. the Unity Desktop) you will need the corresponding fix in mesa 10.0.2. This fix is also available in the xorg-edgers PPA at https://launchpad.net/~xorg-edgers/+archive/ppa

madbiologist (me-again) wrote :

The final piece of the puzzle is the corresponding fix that has just been released in xf86-video-ati 7.3.0 (xserver-xorg-video-ati in Ubuntu) - see http://lists.freedesktop.org/archives/xorg/2014-January/056338.html

xserver-xorg-video-ati 1:7.3.0-1ubuntu1 has just been added to Ubuntu 14.04 "Trusty Tahr" repositories.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers