herd-5 graphical install -- no matching modes

Bug #94314 reported by Reece on 2007-03-21
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Graphical installation fails during X setup. The X log says

EE VESA(0): No matching modes
EE Screen(s) found, but none have a usable conf

This is on a HP nw8440 laptop.
lspci -vv says:
[yada yada]
ATI Technologies Inc M56P [Radeon Mobility X1600]
Subsystem: Hewlett-Packard Company Unknown device 30b4

I also tried the "safe graphics" mode and got the same behavior.

trollord (trollenlord) wrote :

The issue that you reported is one that should be reproducable with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed release. You can find out more about the development release at [WWW] http://www.ubuntu.com/testing/

Reece (reece) wrote :

I tried Gutsy Gibbon Tribe 5 also fails to install on a HP NW8440.

I didn't fill out a laptop testing page because it didn't seem too useful given that I can't even start the install, and, besides, the LaptopTestingTeam/Template page doesn't exist. (Confusingly, it suggests itself as an alternative to its own non-existence. That'll take a few reads and a try to see what I mean... https://wiki.ubuntu.com/LaptopTestingTeam/Template).

I'm happy to try suggestions.

-Reece

Reece (reece) wrote :

I should clarify: I can make GG Tribe 5 install, but not out-of-the-box. Here's the process:

1) Boot dvd. Select boot option 1 or 2 (safe). X will fail to start because of "no valid modes left".

2) Hit ctrl-alt-F1 to get to a shell.

3) In the shell, type:
$ sudo -i (become root)
# apt-get update
# apt-get install xorg-drivers-fglrx
# depmod -a (not sure this is required)
# ati-config --initial
# startx
(perhaps I should have dropped to non-root for startx, but this worked)

4) X will start. Install normally. Reboot to new installation.

5) X will fail to start again with packages from new installation. Repeat step 3 above.

Colin Watson (cjwatson) wrote :

Sorry that this languished on the wrong package for some time. I believe the free ATI driver has improved a lot recently, so you may not need to use fglrx any more with more recent releases ...

Bryce Harrington (bryce) wrote :

Hi Reece,

Like colin points out, -ati has improved tons in the last year. My guess is your issue is long since gone. Would you mind testing against an Intrepid Beta livecd (available from http://cdimage.ubuntu.com/releases/intrepid/beta/) and see if you're able to boot up okay now?

If it _still_ isn't working, please post a fresh Xorg.0.log from that attempt, and we'll go from there.

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers