Ubuntu

bad flickering with Radeon drivers in 12.04 Precise

Reported by Britt Yazel on 2012-02-16
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

There is terrible flickering happening with the Radeon driver in Ubuntu Unity as well as gnome-shell. This flickering has been present when doing things that require 3d for a long time, and there was recently a fix that was released that is not really a fix at all.

The fix that was released only fixes the flickering for a short while after first logging in, but if you do anything graphics intensive (such as clicking the workspace switcher 5-6 times in repetition) the flickering comes back as bad as ever.

I gnome shell the flickering shows up whenever you mouse down to the lower right hand corner and have the shadow gradient come up from the bottom. The sides of any open windows will have graphical glitches. The flickering also happens in unity any time I use the workspace switcher, I open the Dash, or when I use the full-screen snap feature.

I would like to mention that I do not have any of these issues when running Arch linux, but I do in Fedora 16, but not to the extreme to which I have them in Ubuntu 12.04. I know that Ubuntu uses a custom xorg version, so perhaps there is a regression in the way Ubuntu has it's xorg assembled.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-radeon 1:6.14.99~git20111219.aacbd629-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,mousepoll,regex,compiztoolbox,resize,imgpng,grid,move,gnomecompat,snap,vpswitch,session,wall,animation,fade,workarounds,expo,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Feb 15 22:50:20 2012
DistUpgraded: Log time: 2012-01-29 16:18:13.520427
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 3.2.0-16-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series] [1002:9712] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0360]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Acer Aspire 5553
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-16-generic root=UUID=e49eb218-80c6-43a9-be04-f706272ad1b0 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: Upgraded to precise on 2012-02-16 (0 days ago)
XorgConf:

dmi.bios.date: 04/25/2011
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.23
dmi.board.name: JV51_DN
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.23:bd04/25/2011:svnAcer:pnAspire5553:pvrNotApplicable:rvnAcer:rnJV51_DN:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5553
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Britt Yazel (bwyazel) wrote :
Sam_ (and-sam) wrote :

No flicker with unity and wall plugin on notebook, but on pc with cube and rotating via mouse-wheel.
Due to bug 933615 flickering can be demonstrated vividly. (video)
~$ lspci -nnk | grep -i VGA -A2
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV710 [Radeon HD 4350] [1002:954f]
 Subsystem: PC Partner Limited Device [174b:174b]
 Kernel driver in use: radeon

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2012-02-23
tags: added: flicker
Bryce Harrington (bryce) wrote :

Britt, a few questions.

First, is this a regression? If so, when did you first start noticing the flickering?

You mentioned there was a recent fix released; can you supply some additional pointers as to what that fix was or when it went in?

You mentioned you don't see it in Arch linux; what version of X.org, mesa, and kernel were you running there?

Have you tried installing fglrx? If so, do you see the bad behavior when running that? (Note that the fglrx currently in Precise has a bug when playing video with Xv, so you may wish to uninstall it and return to the foss driver once you're done testing.)

Given that you see similar misbehaviors in gnome shell and unity, it does seem reasonable to assume it is due to an X.org/mesa/kernel driver issue.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Britt Yazel (bwyazel) wrote :

This is not necessarilly a regression, as I have yet to know an experience in Ubuntu with the open sourced Radeon drivers without a fair amount of flicker. (There has been flicker since 10.10 when I first started using AMD graphics on my laptop and desktop). The bug that was filed said "fixed flicker using the radeon driver with Compiz" or something to that extent, but I do not know of the specifics of the package that carried the patch. (possibly a compiz patch or a Unity patch, I read a lot of changelogs and it has slipped my mind).

I tried searching for the updates that I installed on the 16th of Feburary, and I installed full updates to my compiz and my unity both on the same day, so it is most likely in the changelogs for one of those projects.

In Arch linux I was running the 1.11 version of X.org, Mesa 7.11, and I was running the linux kernel 3.2.0 (or some variation of that version); as arch updates so readily it is hard to know exactly which version of the kernel it was, but all times I have ran arch with open sourced Radeon drivers it has been a flawless and seamless experience. Is there any way to get any of the Ubuntu devs to try out Arch on a system with Radeon graphics to see what they are doing and possibly merge any patches they have made into mainline Ubuntu?

Yes I have tried installing fglrx, that is what I am currently running as to avoid the screen flicker. I do not see any flickering behavior with fglrx, but the desktop itself is noticably slower when dragging windows and interacting with the desktop. (On a side note I have noticed that Precise still is using an old version of fglrx from a couple months ago which does not contain a lot of the fixes that AMD released for Gnome-shell integration. Is this going to be changed at all? I would like to see a more up-to-date video driver for some of the fixes.) Also, when running the fglrx driver in the system settings>details it registers as a VESA driver, when it is clearly the fglrx driver that is activated....but that is a different issue ;-)

I do believe that it could be a x.org/mesa/kernel driver issue, and I have seen similar flickering issues in an out-of-the-box install of Fedora 16, but in subsequent updates it seemed to have cleared up. And, like I have mentioned before, Arch linux has a absolutely fabulously working version of the FOSS Radeon stack.

I would love to render any assistance that I can towards fixing this issue, but my knowledge of programing is slim at best. I am a work-in-progress when trying to learn more about patches and the bug fixing process, so I may or may not be able to help.
I am mostly just reporting what I have seen with my various dabbles with other linux based operating systems, and how Ubuntu differs in my experience with them.

Britt Yazel (bwyazel) wrote :

I would also like to note that my laptop with my Mobility Radeon 4200 series is the one that has the flickering, my desktop with a Radeon HD 6950 does not have any flickering.

Britt Yazel (bwyazel) wrote :

Just an update, but with the last few xorg updates that have appeared in the past few days, this issue is still apparent.

Daniel van Vugt (vanvugt) wrote :

Britt -
1. Please provide a video of the flicker if possible.
2. Please also try tweaking some radeon driver options in /etc/X11/xorg.conf:
       Section "Device"
         Identifier "devname"
         Driver "radeon"
         Option "SwapbuffersWait" "on"
       EndSection
3. Try a workaround: In "ccsm", Workarounds, enable "Force full screen redraw (buffer swap) on repaint".
4. The slowness you experienced with fglrx is bug 763005 which should be fixed in compiz 0.9.7.0.

Sam_ (and-sam) -
You are experiencing bug 862430. Not this one.

Britt Yazel (bwyazel) wrote :

WoW!!!

Using step 2 from above and tweaking the radeon driver [Option "SwapbuffersWait" "on"] in the xorg.conf file solved this problem perfectly!

This issue has been bugging me for almost a full year since 11.10.

Now that we know that this is the problem and your fix works, is there any chance of incorporating this as a default value so that way the others with this same problem will not have to manually create and populate the xorg.conf file?

Britt Yazel (bwyazel) wrote :

Wait, I take it back. It worked beautifully initially on startup, but after about 5 min of use the flicker has come back. Why would it work right at startup, but begin to flicker after a few min of use?

Britt Yazel (bwyazel) wrote :

Another note. After completely removing the xorg.conf file, at first startup the flicker dissapeared, and, again, came back after a couple of minutes of use. Setting [Option "SwapbuffersWait" "on"] in the xorg.conf file was ineffective, and there is no difference between with or without the xorg.conf file as far as screen tearing/flickering is concerned.

Also, enabling "Force full screen redraw (buffer swap) on repaint" in ccsm did not aleviate any flickering and only caused more artifacts and screen glitching than before.

Daniel van Vugt (vanvugt) wrote :

I have seen the diagonal tearing on just about every ATI/AMD graphics chip I've ever tried. Though I only remember seeing it with fglrx, not radeon. That strange diagonal tearing is certainly something you'll only see with ATI/AMD graphics. It seems to be something to do with the ATI hardware or driver architecture. But it's still possibly something we can workaround in software...

Sorry, I don't know why the problem would take 5 minutes to come back.

Please try the workaround: In "ccsm", Workarounds, enable "Force full screen redraw (buffer swap) on repaint".

Changed in compiz-core:
status: New → Opinion
Daniel van Vugt (vanvugt) wrote :

Not sure if this relates to compiz-core really, but link to compiz-core so we keep the bug in view.

Changed in compiz-core:
status: Opinion → Incomplete
Britt Yazel (bwyazel) wrote :

I did try enabling "Force full screen redraw (buffer swap) on repaint" in ccsm did not aleviate any flickering and only caused more artifacts and screen glitching than before.

Also, it isn't by any means exactly 5 min, and I believe that it is more based on usage. Sometimes the tearing will happen after 30 seconds if I put strain on it, and others up to 5 min if I dont open any windows and just let it sit.

Britt Yazel (bwyazel) wrote :

Also, like I stated way before in the thread, when I was running Arch Linux there was no flicker using open sourced drivers. I am wondering if we can backport a fix that they used. I do not know enough about this to be of much use though

Daniel van Vugt (vanvugt) wrote :

Britt, if "Force full screen redraw (buffer swap) on repaint" doesn't work then that confirms there is a problem with the driver. or hardware (probably driver). Because that option should give you flawless silky-smooth graphics so long as vsync or SwapBuffersWait support is enabled in the driver.

Also, your Xorg logs confirm that you already have SwapBuffersWait enabled by default:
[ 1524.476] (II) RADEON(0): SwapBuffers wait for vsync: enabled

So if "Force full screen redraw (buffer swap) on repaint" is also enabled then it's definitely a driver or hardware problem. Sorry :(

Other options you can try with the radeon driver are documented on the "radeon" manual page:
http://manpages.ubuntu.com/manpages/precise/man4/radeon.4.html

no longer affects: compiz-core
Daniel van Vugt (vanvugt) wrote :

Option "EXAVSync" "on"
also sounds promising...

Britt Yazel (bwyazel) wrote :

I am testing that option right now, I will report back once I give it some time to test.

Britt Yazel (bwyazel) wrote :

The EXAVSync option did not make any difference, nor did the Option "DisplayPriority" "BIOS" or Option "DisplayPriority" "HIGH" options. I did not see any noticeable difference between the two.

Right now the status on this ticket is incomplete; is there anything I need to do on my part to get some attention on this issue or to make it so this issue is confirmed?

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Sam_ (and-sam) wrote :

Daniel, thanks for pointing to 862430 since I was affected by the recently duped 876198.
However for this one it might be worth extending my comment #2 where my notebook (unity+wall) isn't affected by the flicker while it has the same graphics card as the op [Mobility Radeon HD 4200 Series] [1002:9712], using open source radeon driver here, instead of Acer it's a HP 625 and it was a fresh alpha installation instead of Oneiric upgrade.

derp herp (junkmail-trash) wrote :

Just a "me too" here. Bad flickering in darkened areas after a return from an idle screen shutoff with the radeon drivers on a MBP 8,2 and Unity on 11.10. None of the above fixes worked for me

lspci:

01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M]

uname:

Linux paperweight 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 20:45:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Britt Yazel (bwyazel) wrote :

This bug is still prominent in the Open Sourced drivers. I have found many many references to people with this same issue and also with AMD 4200 series cards.

http://askubuntu.com/questions/57400/why-does-my-screen-flicker-whenever-im-in-a-3d-program

for example.

Britt Yazel (bwyazel) wrote :

After installing the ppa:xorg-edgers/ppa the flicker seems to have been fixed. This leads me to conclude that the issue was caused by something done in the default Ubuntu install of X. However, it would be nice to see some of the changes with the 1.12 server and drivers to be brought into mainline for inclusion, as this seems to have fixed the issue.

Michael Murphy (mmstick) wrote :

This flicker is far worse on GCN hardware (Radeon HD 7xxx). The instant you boot into Ubuntu with the open source radeon drivers, there is massive amounts of black boxes flickering all over the screen. Even with xorg-edgers/ppa like above, it does not solve the issue. The only driver GCN hardware is functional on is fglrx.

Michael Murphy (mmstick) on 2013-11-15
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers