[r300] ati driver unusably slow if using EXA

Bug #90604 reported by hjanetzek on 2007-03-08
16
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

Since one week using the free radeon driver became unusable for me. I dont use compiz or anything like that. The problem is mainly with gtk applications. For example sylpheed-claws needs one minute to become fully drawn and uses 100% cpu. I use enlightenment as windowmanager and its dialogs and configuration-windows are drawn as fast as usual. xterm also hasn't this problem.
It doesn't matter if i have EXA enabled or XAANoOffscreenPixmaps set.

Composite also became unusable since then.

with fglrx it works ok as usual...

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

Could you attach (not paste) /var/log/Xorg.0.log, /etc/X11/xorg.conf and the output of commands lspci -vv and lspci -nvv.

hjanetzek (hannes-janetzek) wrote :

ok. i also added some profiling with oprofile. it shows the cpu-usage while resizing the frames inside sylpheed-claws. it seems that all cpu goes into memcpy operations. the same action with fglrx doesn't cause this.

the evas_benchmark file shows the performance differences between software- and xrender-rendering with radeon and fglrx. though the differences here are not so big that they could be the reason for the sluggish gtk and qt(it's also slow as hell) performance

Timo Jyrinki (timo-jyrinki) wrote :

Could you also add the xorg.conf file? It seems that in the log you're using EXA, and it definitely causes slowdowns. Ideally you should not have anything else in the Device section than the Driver "ati" and the name of the device. Add XAANoOffscreenPixmaps if you want to try out compiz/beryl.

hjanetzek (hannes-janetzek) wrote :

Indeed now it works again, if i disable EXA.
hm, i'm sure i tried that before...

I think i should ask on the xorg list what's up with EXA these days.

Timo Jyrinki (timo-jyrinki) wrote :

If you have interest, please try to compile and use the latest pre-release of the ati driver: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-ati-6.6.191.tar.bz2

There seems to be a couple of EXA fixes, too, in the changelog.

hjanetzek (hannes-janetzek) wrote :

I tried that one but it wasn't much better and i had also to compile xserver 1.3, etc.

But i got the good EXA perfomance back by a hint I got to this bug-report
https://bugs.freedesktop.org/show_bug.cgi?id=10474:
''Could it be that xserver-xorg-core went from 1.1 to 1.2? If so, Option
"MigrationHeuristic" "greedy" might give you back the previous performance.''

Changed in xserver-xorg-video-ati:
status: Unconfirmed → Confirmed
Timo Aaltonen (tjaalton) on 2007-10-09
Changed in xserver-xorg-video-ati:
importance: Undecided → Medium
Timo Jyrinki (timo-jyrinki) wrote :

This is now fixed for my Radeon X800 under Ubuntu 8.04 development version. Using EXA without any additional parameters results in a smooth, fast desktop without lags or other problems.
Please reopen if it still doesn't work for you under the current devlopment version (which has xserver 1.4.1, ati driver 6.7.196 etc.)

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released

Do you know starting with what version it works OK? as I have seen somewhere that 6.7.194 should be good already, and gutsy has .195 - so maybe this is already fixed in gutsy?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers