Suggested package "firmware-linux" does not exist

Bug #894693 reported by Tomi Hukkalainen on 2011-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

xserver-xorg-video-radeon suggests to install firmware-linux, which does not exist. Bug #565482 was marked not fix, because the suggestion already exists in Debian. However this is not a bug in there, since that package does indeed exist in Debian, but not in Ubuntu. The correct package in ubuntu is linux-firmware, which combines the debian packages firmware-linux-free and firmware-linux-nonfree (firmware-linux is a metapackage that pulls in both of the real packages). linux-firmware is crucial because without the radeon microcodes, using the radeon driver would be impossible (see http://wiki.x.org/wiki/radeonBuildHowTo#Missing_firmware).

The problem hasn't manifested because many people have linux-firmware already installed due to other dependencies. However I do not believe that is a proper reason to leave the dependencies of this package broken in purpose, especially when this is trivial to fix. For example people running their own custom kernels wouldn't have the firmware package pulled in at all (and please don't go and say that only power users do that and power users don't matter).

Bryce Harrington (bryce) on 2011-11-25
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:6.14.99~git20111219.aacbd629-0ubuntu2

---------------
xserver-xorg-video-ati (1:6.14.99~git20111219.aacbd629-0ubuntu2) precise; urgency=low

  * debian/control: Suggest linux-firmware rather than firmware-linux.
    The latter is only in Debian.
    (LP: #894693)
 -- Bryce Harrington <email address hidden> Fri, 03 Feb 2012 14:10:31 -0800

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers