MASTER: no r5xx support in radeon driver (X1300, X1400, X1600, X1800, X1900, X1950)

Bug #87244 reported by Matt Galvin on 2007-02-23
112
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Wishlist
Unassigned

Bug Description

The 'radeon' driver does not support ATI's r5xx series of chips (i.e. cards X1xxx), which is included in the MacBook Pro.

Matt Galvin (mgalvin) wrote :
Matt Galvin (mgalvin) wrote :
Matt Galvin (mgalvin) wrote :

At the bottom of the log it seems to indicate that it cannot find the display device although it *is* there as you can see in the config.

--- snip ---
(II) Primary Device is: PCI 01:00:0
(II) ATI: Candidate "Device" section "Generic Video Card".
(EE) No devices detected.

Fatal server error:
no screens found
--- snip ---

This only happens when using the "ati" driver even thought the log says driver itself does load.

tokj (tokj-deactivatedaccount) wrote :

Hello and thank you for your bug report.

What version of Ubuntu are you running and which is your ATI video card? Did you try to reconfigure the X server?

Matt Galvin (mgalvin) wrote :

Ubuntu version is up to date feisty i386 installed using the 20070222 daily alternate cd.

Video card is a ATI Radeon Mobility X1600 on a 15 inch MacBook Pro.

I ran dpkg-reconfigure xserver-xorg, it said it could not detect the card. I manually selected the ati driver, ran through the rest of the config and X still crashes. Same error/log/config as already attached.

I see xorg 7.2 was just uploaded... will try that as soon as it is available. A quick glance at the changelog leads me to believe it will have no fix for this issue but I will still update to it as soon as it hits the archive.

tokj (tokj-deactivatedaccount) wrote :

Fine. Thank you for all informations that you gave.

Anyway I change the Bug status to confirmed. Inform us if the upgrade to Xorg 7.2 will resolve this issue in your case or not.

Best regards

Changed in xorg:
assignee: tokj → nobody
status: Needs Info → Confirmed
Matt Galvin (mgalvin) wrote :

the upgrade to 7.2 had no effect. although oddly enough messages in the log file still print out the 7.1.1 version number even though 7.2 is installed. The log files seem mostly the same but I am attaching the new ones anyway just in case.

Matt Galvin (mgalvin) wrote :
Matt Galvin (mgalvin) wrote :
Daniel Stone (daniels) wrote :

there is no support for the r5xx series of chips (card numbering X1xxx), because ati refuse to release documentation. for the time being (i.e. until the reverse-engineered driver works), vesa is your only option.

description: updated

The other option is installing the fglrx drivers.

Matt Galvin (mgalvin) wrote :

I am using fglrx and it partially works. I at least get the correct resolution of 1440x900 so thats good. The issues that still exist with the fglrx drivers are also completely out of our hands so I didn't bother opening another bug about a problem we can't fix.

tokj (tokj-deactivatedaccount) wrote :

The bug report can be rejected or marked as wishlist. However, i think that the problem isn't solvable by developers until ATI doesn't release documentation.

I leave to the decision of what to do with this report to a member of the Ubuntu QA.

Best regards

Timo Aaltonen (tjaalton) wrote :

marking as wishlist, don't hold your breath for this ;)

Changed in xorg:
importance: Undecided → Wishlist
Giovanni Lovato (heruan) wrote :

I think we can give a feedback to ATI Linux driver crew at: http://support.ati.com/ics/survey/survey.asp?deptID=894&surveyID=508&type=web
At least to give us support to Composite in fglrx... Let our voice be heard!

Bryce Harrington (bryce) wrote :

Good news, R500 is now reverse engineered: http://lists.freedesktop.org/archives/xorg/2007-June/025506.html

However: "Please note that this is intended only for people interested in working on this and normal users should not try it yet as it actually needs you to add your graphic card pci id in order for it to work."

Changed in xserver-xorg-video-ati:
status: Confirmed → In Progress

I have same problem with ATi X1600 in my Packard Bell Laptop and Ubuntu 7.10 (Gusty) Tribe 5.
I can't start the X with the Live CD.
Thank you!

Timo Jyrinki (timo-jyrinki) wrote :

There's an alpha version of the r5xx driver in Ubuntu 7.10 now, named "xserver-xorg-video-radeonhd". It's in the universe repository, so it's not in use by default. However, Gutsy should have fixes to have VESA compatibility mode work on more cards, so that people get graphical desktop on the live CD.

Giovanni Lovato (heruan) wrote :

A new fglrx driver version is out, it claims to support AIGLX:
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run
I hope it will be soon backported to Gutsy!

Timo Jyrinki (timo-jyrinki) wrote :

Giovanni, fglrx has nothing to do with this bug report. This is about the open source ati/radeon driver that is the default driver in Ubuntu. That said, AMD/ATI does not recommend distributors to distribute the version of fglrx you mentioned (in the release notes). Fglrx bug reports are those filed to linux-restricted-modules-2.6.22, for example.

Tormod Volden (tormodvolden) wrote :

The newest git version of the -ati driver has support for these cards. You can find test builds on https://wiki.ubuntu.com/XorgOnTheEdge . For quicker turnaround, file related bugs directly on bugs.freedesktop.org or talk with the developers on IRC #radeon.

Luke Faraone (lfaraone) wrote :

Seemed to work, but upon logging in (Hardy) gnome started to load, and I saw my background, but then the screen turned white (I can still move my mouse).

Tormod Volden (tormodvolden) wrote :

Sounds like a compiz problem. Try without compiz (uninstall it if needed). I am not sure, but this should disable it for your account:
 touch $HOME/.config/compiz/disable-compiz
(Run the command on a console screen, or in a Failsafe Terminal session.)

Bryce Harrington (bryce) wrote :

We now carry the 6.8 driver in Hardy, which has support for these cards, so I'm closing this bug as fixed.

If you find other new issues, please file them as new bug reports. Note that radeonhd supports these cards as well, and while it is not our default driver for this chipset, it can be considered a supported alternative of -ati is currently not working for you.

Changed in xserver-xorg-video-ati:
status: In Progress → Fix Released
Eli (professionalnet) wrote :

I was using Jaunty and an ATI Radeon X1650 Sapphire card. FGLRX or ati wouldn't work for this card. Not to mention no support for tv out what so ever. Even using xrandr after forcing tvout wouldn't display lines in the display.

Tormod Volden (tormodvolden) wrote :

Eli, there has been recent work on TV-out support. Maybe you can try an ati/radeon package for Jaunty from my PPA https://launchpad.net/~tormodvolden/+archive/ppa

If this does not work, filing a new bug would be a good step to have this improved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers