Natty: Screen brightness set to minimum and brightness controls not working

Bug #773415 reported by Victor Marin on 2011-04-29
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Just trying new Ubuntu 11.04; Lowest default brightness makes screen barely visible.

ATI Catalyst Control Center does not work and brightness control applet in panel also makes nothing.

I can't change screen brightness level.

Same problem in Xubuntu Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-power-manager 2.32.0-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx wl
Architecture: amd64
Date: Fri Apr 29 18:23:03 2011
GnomeSessionIdleInhibited: Unknown
GnomeSessionInhibitors: Failed to acquire
GnomeSessionSuspendInhibited: Unknown
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Hewlett-Packard HP Compaq 6735b
ProcEnviron:
 LANGUAGE=es:en_US:en_AU:en_CA:en_GB:en
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=85753454-c858-4895-b526-fbaf05fe11ff ro acpi_osi=Linux quiet splash vt.handoff=7
SourcePackage: gnome-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/19/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68GTT Ver. F.07
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30E3
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 96.1C
dmi.chassis.asset.tag: CNU8414XL2
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68GTTVer.F.07:bd09/19/2008:svnHewlett-Packard:pnHPCompaq6735b:pvrF.07:rvnHewlett-Packard:rn30E3:rvrKBCVersion96.1C:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Compaq 6735b
dmi.product.version: F.07
dmi.sys.vendor: Hewlett-Packard

Victor Marin (vms368) wrote :
affects: ubuntu → xserver-xorg-video-ati (Ubuntu)
bugbot (bugbot) on 2011-04-30
tags: added: xubuntu
Victor Marin (vms368) wrote :

And, it also affects Kubuntu 11.04.

It seems it's a bug on the new kernel, Linux 2.6.38, as it also affects to openSUSE and Arch Linux, as example:

http://lists.suse.com/opensuse-bugs/2011-03/msg06610.html
http://lists.suse.com/opensuse-bugs/2011-04/msg02843.html
https://bbs.archlinux.org/viewtopic.php?id=116804

Fn+F9 or Fn+F10 don't work, too.

Hope it to be solved asasp (or meanwhile to get a workaround, if possible).

Victor Marin (vms368) wrote :

A workaround: Pressing Ctrl + Alt + Fn as well as F10 or F9 (in my laptop a HP 6735b, or F1 to F6 in other laptops) to increase or diminish the screen brightness.

I found it at: http://www.tainguyen.com/linux/2011/05/01/it-is-finally-here-ubuntu-11-04-released/

Victor Marin (vms368) wrote :

Such workaround didn't work anymore for me.

So finally I uninstalled Natty and went back to install Maverick; The screen brightness (also changing it with the applet) and everything else is working fine for me now.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Victor Marin (vms368) wrote :

Hi from Pardus 2011,2 (which has a kernel 2.6.37 and hence hasn't the screen brightness problem which came from the Linux kernel 2.6.38 and up),

I just downloaded and tried (by a USB pendrive) Ubuntu 11.10 BETA-2 64 bits.

I remark you that the Linux kernel 3.0.0 it still has this same problem which simply makes unusable the OS on the HP 6735b model of laptop (quite likely, in others too).

This is a severe regression which affects all distros since kernel 2.6.38, but it lasts most 6 months already.

Rgds.,
Victor

Bryce Harrington (bryce) wrote :

Hey vms368,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Victor Marin (vms368) wrote :

Hi Bryce,

I think that the screen brightness problem is still there in Ubuntu Oneiric.

I tested the 64 bits version of Ubuntu 11.10 Beta 2, as well. But, nothing yet; It still was this same problem there. Hence I went back to Ubuntu (but, Maverick) after I learned that Pardus has quite few applications on its repositories yet and, moreover, it hasn't 32bits support for the 64bits version (and an annoying restart-required or log-out/log-in required for any changes on the menu to appear after programs installation of its edition).

I don't know whether it has something to do with the screen brightness bug in -many- laptops, but Phoronix has found out other power problems on latest Linux kernels:
http://www.phoronix.com/scan.php?page=article&item=linux_31_power_regress&num=1

All of these seem to be more than noticeable problems arising on Linux kernels lately. Why? I don't know, of course, but it dents Linux reputation of trustable, rock-solid OS.

Perhaps, it would be better to secure current features before adding so quickly new ones to the kernel. But this is just my humble opinion.

Rgds.,
Victor

Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-ati (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/773415

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers