Ubuntu

[RS690M] No 3d acceleration in Radeon X1200 with new Gallium r300 / 3d drivers in 11.04 (Needs kernel quirk)

Reported by André Oliva on 2011-04-09
96
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
xserver-xorg-driver-ati
Fix Released
High
Fedora
Unknown
Unknown
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

The bug is active also in Freedesktop.org : https://bugs.freedesktop.org/show_bug.cgi?id=37679

[edit]
The bug seems to be fixed with a patch provided by Freedesktop.org team.
[/edit]

[edit]
This bug is caused by interrupts. They're not working. The solution for this problem is:
- To see if Ubuntu 10.04 (where all things worked well) used UMS instead of KMS.
- If Lucid used KMS, to bisect the kernel to see what change caused the problem.

[/edit]

[edit]
The bug description, updated:

The symptoms: No 3d acceleration (glxgears shows a black window, Unity doesn't start), *but* no fallback into the software-rendering mode (glxinfo reports that the 3d acceleration is working)

The hardware: ATI Radeon RS690M X1200 series

The version of Ubuntu: Ubuntu 11.04 (final release) [and Maverick also]. The behavior was also observed in Debian and Fedora 15, as noted below (so it seems not to be Ubuntu-specific).

The version of xserver-xorg-video-ati: 1:6.14.0-0ubuntu4 (default in Natty). Same problems with the xorg-edgers PPA in Natty Beta2.

The software affected: Compiz (doesn't start because requires direct rendering); then, Unity (just the wallpaper or black screen and the mouse pointer). glxgears, Stellarium, Blender, Adobe Flash Player in fullscreen mode and Visual module of Python work if software rendering is forced (but of course they run very very slow).

The history of the bug: all worked as expected (out of the box) in 10.04, but in 10.10 the problems started. The workaround was to disable KMS, but now, in Maverick, since the new Gallium driver doesn't have a non-KMS mode, that workaround is not available. This issue was reported when using 11.04 Beta 1 and Beta 2, then, in the descriptions below there are some strange things (xorg crash during startup, software rendering fallback), that don't occur any more. The issue is just the description given here.

The exceptions: **sometimes** (??) the 3d acceleration does work as expected, but at the moment there is no way for us to know when it will work or not [help please!]. And, sometimes the 3d acceleration work but is so slow that it seems to be actually software rendering.

The workarounds: `vblank_mode=0 glxgears` (or other program) gives correct 3d accelerated output. `export vblank_mode=0` also allows to start Compiz and 3d acceleration works after running that. That is just a workaround and the problem is not solved yet.

[/edit]
Binary package hint: xorg

I installed Ubuntu 11.04 Beta 1, and I'm not able to run Unity and Compiz, because I have no 3d acceleration. However, I was able to run Compiz once, the next time I booted, I don't know why, Compiz doesn't work. After several reboots, I see the following:

1. Sometimes (?), I have 3d acceleration via software rendering. When I run `glxinfo | grep render` I get:
direct rendering: Yes
OpenGL renderer string: Software Rasterizer
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fragment_program,
And if I run `compiz --replace`, I get the following error:

Backend : gconf
Integration : true
Profile : default
Adding plugins
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Compiz (opengl) - Fatal: GLX_EXT_texture_from_pixmap is missing
Compiz (opengl) - Fatal: Software rendering detected
Compiz (bailer) - Info: Ensuring a shell for your session
prueba@prueba:~$ Window manager warning: Locale not understood by C library, internationalization will not work

(metacity:2357): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
Window manager warning: last_user_time (1302379766) is greater than comparison timestamp (1200358). This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE_WINDOW. Trying to work around...
Window manager warning: 0x3401006 (prueba@pru) appears to be one of the offending windows with a timestamp of 1302379766. Working around...
Window manager warning: 0x340103e (prueba@pru) appears to be one of the offending windows with a timestamp of 1302379766. Working around...

prueba@prueba:~$ Window manager warning: last_user_time (1302379766) is greater than comparison timestamp (1228188). This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE_WINDOW. Trying to work around...
Window manager warning: 0x340103e (prueba@pru) appears to be one of the offending windows with a timestamp of 1302379766. Working around...
Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x340103e (prueba@pru)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

From Xorg.0.log:
[ 261.329] (II) AIGLX: Screen 0 is not DRI2 capable
[ 261.329] drmOpenDevice: node name is /dev/dri/card0
[ 261.329] drmOpenDevice: open result is 12, (OK)
[ 261.330] drmOpenByBusid: Searching for BusID pci:0000:01:05.0
[ 261.330] drmOpenDevice: node name is /dev/dri/card0
[ 261.330] drmOpenDevice: open result is 12, (OK)
[ 261.330] drmOpenByBusid: drmOpenMinor returns 12
[ 261.330] drmOpenByBusid: Interface 1.4 failed, trying 1.1
[ 261.330] drmOpenByBusid: drmGetBusid reports pci:0000:01:05.0
[ 261.330] (II) AIGLX: Trying DRI driver /usr/lib/dri/r300_dri.so
[ 261.394] (EE) AIGLX error: Calling driver entry point failed
[ 261.420] (EE) AIGLX: reverting to software rendering

2. Sometimes, I have direct 3d acceleration, but it's unusable. glxgears doesn't work (black window). Also, if I run compiz, I get a blank screen (no Unity, no windows, just the mouse pointer and the background image). In this case, if I run `glxinfo | grep render`, I get:

direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on ATI RS690
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_light_max_exponent,

So, I'm using the Gallium driver. I had a similar problem with Maverick and the radeon driver. I solved the problem turning off the Kernel Mode Setting (# echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf). I don't know how to do that with the Gallium driver. I want also to try using the radeon driver, but I don't know how to do it.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
Date: Sat Apr 9 14:02:35 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-7-generic, i686: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, i686: installed
GraphicsCard:
 ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:01fd]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
MachineType: Dell Inc. Inspiron 1721
ProcEnviron:
 LANGUAGE=es_CR:en
 LANG=es_CR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=f00be871-e8f8-4c57-83dc-3d166efb4e78 ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/03/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0UK441
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd02/03/2008:svnDellInc.:pnInspiron1721:pvr:rvnDellInc.:rn0UK441:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1721
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110407-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

André Oliva (gandreoliva) wrote :
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
André Oliva (gandreoliva) wrote :

I see that this bug is closely related to Bug #715330 , but even if the symptoms are the same, I'm running the version of the Kernel that they say has the fix released, and also, I tried the workaround described on comment #17 and that doesn't solve my problem.

bugbot (bugbot) on 2011-04-10
tags: added: 3d
André Oliva (gandreoliva) wrote :

This is my Xorg.0.log when I have software rendering. I see that there is an error in the line 746, that forces to revert to software rendering (line 747), but the lines 663, 671 and 674 show that the direct rendering was enabled. What does it mean?

Bryce Harrington (bryce) wrote :

Two answer one of your questions, the gallium driver does not have a non-KMS mode, so the modeset=0 workaround isn't available there. (With some work you may be able to revert to using the non-gallium radeon driver, but let's focus this bug report on fixing the bug itself.)

description: updated
summary: - No 3d acceleration in Radeon X1200 with new Gallium 3d drivers in 11.04
- Beta 1
+ [RS690M] No 3d acceleration in Radeon X1200 with new Gallium 3d drivers
+ in 11.04 Beta 1
summary: - [RS690M] No 3d acceleration in Radeon X1200 with new Gallium 3d drivers
- in 11.04 Beta 1
+ [RS690M] No 3d acceleration in Radeon X1200 with new Gallium r300 / 3d
+ drivers in 11.04 Beta 1

What is the output of this command?

$ ls /etc/alternatives/gl_conf -l

Also, did you do a full reinstall or an upgrade?

You don't need /etc/X11/xorg.conf, may as well remove it - the driver will automatically load radeon.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Ben (threadstone) wrote :

same problem here with x1200 and Natty reinstall (but also with Fedora 15)...

$ ls /etc/alternatives/gl_conf -l
lrwxrwxrwx 1 root root 24 Apr 8 13:20 /etc/alternatives/gl_conf -> /usr/lib/mesa/ld.so.conf

Bryce Harrington (bryce) on 2011-04-20
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
André Oliva (gandreoliva) wrote :

Output of `ls /etc/alternatives/gl_conf -l`:
lrwxrwxrwx 1 root root 24 Apr 8 12:42 /etc/alternatives/gl_conf -> /usr/lib/mesa/ld.so.conf

the same of Ben.

@Bryce Harrington: Ah, I understand now (about KMS)... I installed Beta 1 from scratch, and I will try now to install Beta 2 also from scratch to see if something has changed. At the moment I have removed the xorg.conf file.

André Oliva (gandreoliva) wrote :

Ah, I forgot to mention that I installed also the most recent drivers from the xorg-edgers PPA, but that didn't helped. And also I'm having problems when I boot (GDM doesn't start). I'm attaching the Xorg.1.log file, and I see that there is an error parsing the config file (?). I'll install Beta 2 to see if something has changed, including this strange error.

Bryce Harrington (bryce) wrote :

[ 17.844] Parse error on line 15 of section Screen in file /etc/X11/xorg.conf
 "EndSectionSection" is not a valid keyword in this section.

Typo in your xorg.conf

Bryce Harrington (bryce) wrote :

@Ben, can you file a new bug report via 'ubuntu-bug xorg' and then set it as a dupe to this bug? (Or just paste the bug # here). André's bug is quite odd, so I'd like to compare and contrast your logs with his. Also, there's several ways one could end up with no 3D so I'd like to rule those out in your case.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
André Oliva (gandreoliva) wrote :

@Bryce Harrington: The problem parsing the file is another very strange problem, it occurs "sometimes", and other times I can boot normally as right now. By this reason I will try to install Beta 2 (to see if it's something already fixed). I also thought that it was a typo in my xorg.conf but right now I don't have a xorg.conf file in my /etc/X11 directory.

Bryce Harrington (bryce) wrote :

Check if you have anything in /etc/X11/xorg.conf.d/

Also check the timestamp on your Xorg.1.log to make sure it's not just a left over from some earlier boot.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
André Oliva (gandreoliva) wrote :

Ok, I have installed in another partition Ubuntu 11.04 Beta 2 and this is what I found:
1. No 3d acceleration
2. No booting problems (3 boots without any kind of problem)
3. When I try to start unity/compiz --replace I get a blank screen (just the wallpaper and mouse).
4. Everything in the Xorg.0.log file looks fine, but I still have no 3d acceleration.
5. When I run `glxgears`, I get a blank window (see attachment)
6. When I run `glxinfo | grep render` I get this:
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on ATI RS690
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_light_max_exponent,

And...
7. I booted up editing the GRUB command line: I added "nomodeset", and I got software rendering.
So, the problem is not related to the two errors that appear on Xorg.0.log... (I'm sorry, when I reported the bug [Beta 1] I forgot that I forced the system to use "nomodeset"...)

André Oliva (gandreoliva) wrote :
André Oliva (gandreoliva) wrote :
summary: [RS690M] No 3d acceleration in Radeon X1200 with new Gallium r300 / 3d
- drivers in 11.04 Beta 1
+ drivers in 11.04 Beta 2
Bryce Harrington (bryce) on 2011-04-22
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
André Oliva (gandreoliva) wrote :

After booting several times and trying to use Ubuntu, I got again 3d acceleration, but after rebooting, no 3d acceleration again (Compiz doesn't start, glxgears as in the screenshot). This is the same behavior that I observed in Maverick, but I solved that disabling KMS. Now, with the Gallium 3d drivers, as noted by Bryce, that workaround is not an option. All I can do for now is to install Unity-2d and to use software rasterization (`export LIBGL_ALWAYS_SOFTWARE=1` and then executing the program), and activating Metacity composition, but of course, software rasterization is very slow and it's "acceptable" only if the window of the program is very small... It's strange. In Lucid radeon driver worked fine and out of the box...

Martín Ferrari (tincho) wrote :

I have a similar issue.

I installed Natty a couple of days ago. When Unity came up, it was sluggish and many apps crashed. I switched to "classic with no effects", and continued setting up stuff. Later I realised that hardware acceleration was not working. I fixed it (don't remember how), and the problems became worse.

Since my idea for this machine is to use it as a media center, I installed many of this apps, and thought that there were buggy, as I could only see blank screens.

Later I realised that not even glxgears works. If I disable KMS, or set LIBGL_ALWAYS_SOFTWARE=1, they work, but so slow that the apps are unusable.

I have already tried installing the propietary drivers, which tell me that my card is unsupported. I installed the X edgers drivers, with no improvement. Tried different xorg.conf tweaks that I found on the 'net, no dice.

As most of these media apps for some reason require 3d accel (stupid shiny effects), I need to make this work.

$ lspci |grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

$ glxinfo |grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on ATI RS690
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_light_max_exponent,

André Oliva (gandreoliva) wrote :

@Martín: Yes, it's the same problem I have... Radeon X1200 is no longer supported by ADM (???!!!), and, of course, software rasteriaztion is really slow.

I installed Natty (final release), and have the same problem.

It's a good idea to report a bug in freedesktop.org?

summary: [RS690M] No 3d acceleration in Radeon X1200 with new Gallium r300 / 3d
- drivers in 11.04 Beta 2
+ drivers in 11.04

Hi André,

On Sun, May 1, 2011 at 15:09, André Oliva <email address hidden> wrote:
> @Martín: Yes, it's the same problem I have... Radeon X1200 is no longer
> supported by ADM (???!!!), and, of course, software rasteriaztion is
> really slow.
>
> I installed Natty (final release), and have the same problem.
>
> It's a good idea to report a bug in freedesktop.org?

Dunno... In debian the hardware accel works (according to glxinfo),
but is as slow as soft render...
--
Martín Ferrari

André Oliva (gandreoliva) wrote :

But as I noted in comment #17, "sometimes" I do have 3d acceleration
working, and I've seen that sometimes the 3d acc. is very slow, just as you
said; and sometimes, I'm lucky and 3d acc. works as expected. But about 70%
of times 3d acc. fails, and at the moment I'm unable to predict when 3d will
work or not. By this reason I think it's not Ubuntu-specific.

El 01/05/2011 12:46, "Martín Ferrari" <email address hidden> escribió:

Hi André,

On Sun, May 1, 2011 at 15:09, André Oliva <email address hidden> wrote:
> @Martín: Yes, it's t...
Dunno... In debian the hardware accel works (according to glxinfo),
but is as slow as soft render...
--
Martín Ferrari

--
You received this bug notification because you are a direct subscriber
of the bug.
https://bugs...

This is a duplicate of bug #556782.

This bug has a bug open on xorg, which appears not to be moving.

Martín Ferrari (tincho) wrote :

Brian, thanks for the heads up!

André Oliva (gandreoliva) wrote :

Yes, thank you...

Brian Visel (eode) wrote :

:-) You're absolutely welcome.

Brian Visel (eode) wrote :

I was incorrect when I marked this as a duplicate of the other bug (or at least it's not definitely the same issue).
I hate when that happens to a bug I'm working on, and apologize for any inconvenience.

Martin, I've re-subscribed you as I believe your reasoning for unsubscribing was that this bug was marked duplicate, and I think you need to be informed.

Changed in xserver-xorg-driver-ati:
status: New → Confirmed
Changed in linux:
status: New → Confirmed
description: updated
description: updated
bugbot (bugbot) on 2011-05-16
tags: added: edgers
Phil Cole (filcole) wrote :

Similar problem occurs with fedora 15 with RS690. See https://bugzilla.redhat.com/show_bug.cgi?id=698011

André Oliva (gandreoliva) wrote :

I filed Bug 37679 in freedesktop.org against xorg. If you have comments, ideas or attachmets please comment the bug report there... Clearly this is a non Ubuntu-specific issue...

https://bugs.freedesktop.org/show_bug.cgi?id=37679

affects: xserver-xorg-video-ati (Fedora) → fedora
André Oliva (gandreoliva) wrote :

As noted in the freedesktop.org bug reported, running "vblank_mode=0 glxgears" or "vblank_mode=0 [name_of_application]" works, but Compiz still doesn't start. Workaround found. Does this workaround work for you?

description: updated
André Oliva (gandreoliva) wrote :

Compiz works after running "export vblank_mode=0", and then "compiz --replace" or logging out and then logging into Unity 3d, for me that works, but very slow. As noted in freedesktop.org, this is just a *workaround* and something is bad at the moment. This issue is not resolved.

description: updated
Tommy_CZ (t-kijas) wrote :

I have ATI x1250 and compiz works for me but no game like trackmania can be started and altought compiz works, it is terrible slow. Every move of an window is a pain.

krmolot (krmolot) wrote :

I'm add "noapic" to GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub and it's work wor me at last. Also it fix some skype sound problems. But i have x1250 video. If someone have x1200 plz test this workaround solution.

p.s. "vblank_mode=0 glxgears":
3345 frames in 5.0 seconds = 668.866 FPS

cat /proc/interrupts :
11: 143899 XT-PIC-XT-PIC ehci_hcd:usb1, ohci_hcd:usb3, ohci_hcd:usb4, ohci_hcd:usb5, ohci_hcd:usb6, ahci, eth1, radeon

sorry for poor eng :)

dima-tr (dima-tr) wrote :

This helped:
- get mesa3d from ftp://ftp.freedesktop.org/pub/mesa/7.10.2/ . Build it following the instructions on http://mesa3d.org which is basically ./configure && make
- sudo cp <mesa>/lib/r300_dri.so /usr/lib/dri/
(and probably the same for radeon_dri.so )

Usual performance for my glxgears 250 fps is back, I had the same and the CPU is down to 0 (yoohoo!), but at some moment during my experiments I had 286 fps (the CPU was still at ~0!). At the moment I have no idea how to reproduce this. The experiments have involved:
1) building x86-ati-driver from the latest sources,
2) building mesa with drmProto,
3) fiddling around with Section "Device" at specially created /usr/share/X11/xorg.conf.d/20-device.conf,
4) copying <mesa>/lib/* to /sr/local/lib/GL and setting in ~/.bashrc
  export LIBGL_DRIVERS_PATH=/usr/local/lib/GL
  export LD_LIBRARY_PATH=/usr/local/lib/GL:$LD_LIBRARY_PATH

Then some parts were left from the rep versions, and some were overwritten. What namely gave a 20% faster combination is a mystery.

I'm synced to the latest Ubuntu 11.04 repositories, xorg-edgers is NOT installed.

Muhammet Aklan (aklan) wrote :

Hello.

This bug also affects other graphics cards. I have ATI Radeon RV370 X550 and it has the same problem. None of the suggestions above have solved the problem. It started to occur when I installed 11.04, I'm using 11.10 Alpha 3 now and there is still the same problem here.

André Oliva (gandreoliva) wrote :

@Muhammet Aklan:

If
export vblank_mode=0
glxgears

didn't worked, perhaps it's another bug... Please check it that works (you must see the gears).

----------------------
Update (from the freedesktop-bugs 37679):
This bug is caused by interrupts. They're not working. The solution for this problem is:
- To see if Ubuntu 10.04 (where all things worked well) used UMS instead of KMS.
- If Lucid used KMS, to bisect the kernel to see what change caused the problem.

description: updated
Muhammet Aklan (aklan) wrote :

@André Oliva,

Thanks for the answer. I'm currently using 10.04 with Linux kernel 3.0.0.12, which is backported from Oneiric (from Ubuntu kernel team's PPA). So I'm sure that what causes the bug isn't the difference between kernel versions.

I'm booting Lucid with "nomodeset" option, because it runs too slow when I don't use that option. However, on Oneiric, that option causes lack of support for Unity 3D. Without using it, Compiz doesn't start, so both Unity's and GNOME's 3D versions cannot be started although it seems that Unity 3D support is available.

I think the best solution for this problem is returning to LTS for now. I hope the bug will be solved soon.

90 comments hidden view all 166 comments

Does 2.6.32.36 work correctly if you boot with pci=nomsi on the kernel command line in grub? How about 3.0.4?

2.6.32 with pci=nomsi:

It's "bad". irq # 19 count is frozen. glxgears draws, but the FPS is reduced 70, while without "nomsi" it was 240. Xorg log is the same. dmesg is same except "irq for nomsi".

I haven't reported this before, but when it's "bad", redraw of my x terminal, urxvt, is snail-slow, and I saw it with "nomsi", too. (I don't need opengl, so this is the biggest trouble for me.)

3.0.4: no much difference with pci=nomsi, it's anyway bad. (In 2.6.39 and 3.0.4, in most cases glxgears is not drawn, showing only black box. But in 2.6.32, every time I tried gears were drawn even with nomsi, but the test is not thorough.)

Most of dmesg differences are trivial, but I quote one hunk here FYI:
------------------------------------------------------------------------
--- dmesg-3.0.4 2011-10-18 17:02:54.743566206 +0900
+++ dmesg-3.0.4-nomsi 2011-10-18 16:57:38.871537255 +0900
@@ -268,9 +266,7 @@
 ACPI: PCI Interrupt Routing Table [\_SB_.C08B._PRT]
 ACPI: PCI Interrupt Routing Table [\_SB_.C08B.C08C._PRT]
 ACPI: PCI Interrupt Routing Table [\_SB_.C08B.C0FC._PRT]
- pci0000:00: Requesting ACPI _OSC control (0x1d)
- pci0000:00: ACPI _OSC request failed (AE_NOT_FOUND), returned control mask: 0x1d
-ACPI _OSC control for PCIe not granted, disabling ASPM
+ pci0000:00: Unable to request _OSC control (_OSC support mask: 0x0f)
 ACPI: PCI Interrupt Link [C145] (IRQs 10 11) *0, disabled.
 ACPI: PCI Interrupt Link [C146] (IRQs 10 11) *0, disabled.
 ACPI: PCI Interrupt Link [C147] (IRQs 10 11) *0, disabled.
------------------------------------------------------------------------

Created attachment 52475
enable msi

Looks like only MSIs work on your system. Does the attached patch fix newer kernels?

I patched 3.0.4. It's a must-have, but not simple.

It partially fixes. "black box glxgears" nor "irq count freeze" never happen. "pageflip" on-or-off doesn't matter. Xorg.0.log isn't affected. dmesg is the same with unpatched 3.0.4, except MSI:
------------------------------------------------------------------------
@@ -8,12 +8,10 @@
 radeon 0000:01:05.0: GTT: 512M 0x0000000060000000 - 0x000000007FFFFFFF
 [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
 [drm] Driver supports precise vblank timestamp query.
+radeon 0000:01:05.0: irq 42 for MSI/MSI-X
+radeon 0000:01:05.0: radeon: using MSI.
 [drm] radeon: irq initialized.
 [drm] Detected VRAM RAM=128M, BAR=128M
 [drm] RAM width 128bits DDR
------------------------------------------------------------------------

Glxgears fps is always only 60 (which is 240 with good kms), regardless of "pageflip" or "vblank_mode=0".

But that's not all; The first time I booted the patched kenel, right after udev loaded the module, (I was on VT1) it seemed ok - the screen went high resolution, the previous screen contents were correctly shown, and the cursor continued blinking - but it halted there. Keypresses are echoed to the screen, but Ctrl+Alt+Del didn't work.

It happened only once, and after that, all 5 boots were successful.

It also seems to have a nice side effect; when kms is enabled in the bad kernel, I often experinced a problem in s2ram, but with your patch s2ram has succeeded in some 10 trials in row. So I think we're in the right direction.
(The problem was that for most times suspend doesn't complete, or takes too long, after the screen turns black.)

Since I don't need opengl, I'm quite satisfied with this patch. =P

What are your pci device and subsystem ids? lspci -vnn

Created attachment 52722
lspci -vnn of katabami's PC

In short, same as Phil Cole's:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f] (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device [103c:30c2]

Thank you very much for taking care.
With kind regards.

Created attachment 52758
fix 1/2

Patch 1/2

Created attachment 52759
fix 2/2

patch 2/2

Can you try these two patches? It looks like a platform/bios bug rather than a driver bug since legacy irqs should always work AFAIK, but I'm not sure where the problem lies. This patch just adds a quirk to always enable MSIs on your system.

Thanks, it surely works, again for 3.0.4.

I forgot to report that built-in driver (= not as modules) doesn't work with 2.6.32, nor with 3.0.4 + your patch.

If someone wants to bisect: it'll take some 18-20 times of kernel compilation, I guess. I've done kernel bisect twice, but both were straightforward. As usual, you can ask helps at forums. You can also ask me by email for basic procedures. (Login here to see my email address.)

(In reply to comment #83)
> Thanks, it surely works, again for 3.0.4.
>
> I forgot to report that built-in driver (= not as modules) doesn't work with
> 2.6.32, nor with 3.0.4 + your patch.

Did you include the required firmware in your kernel image?

Can anyone else on this report check if attachment 52475 helps you as well?

(In reply to comment #84)
Thanks again. Built-in works just like module by adding the firmware, radeon/RS690_cp.bin, for each version.

# Oh my ass, I've never heard of that magic. ;)

Created attachment 52873
Xorg.0.log from 2.6.32

Some notes on glxgears FPS: 2.6.32 reports more resolution modes, and fps varies among modes. In 3.0.4 + patch, fps is about 60 in all modes.

Let me attach Xorg server's logs. This file is from 2.6.32.

Created attachment 52874
Xorg.0.log from 3.0.4

Xorg.0.log from 3.0.4

Just completed a fresh install of Fedora 15 x86 and rebuilt the stock Fedora kernel (2.6.40.6) keeping the exact same configuration apart from the addition of the two patches from Comment 81 and Comment 82 and it fixes the problem as far as I can see.

Boots fine without kernel param "nomodeset".
glxgears gives approx 57-60fps.
Gnome3 much more responsive.

Thanks Alex for your persistence with this bug. Thanks katabami too.

I, the original reporter of this bug, want to thank also Alex and all the
people involved for all the effort and the time spent in this bug. These
weeks I simply didn't have enough time to try to bisect the Kernel and to
try the patches (I'm unfamiliar with that and it's something that I have to
learn how to do it). Sorry for that. But really, thank you very much!

2011/10/29 <email address hidden>

> https://bugs.freedesktop.org/show_bug.cgi?id=37679
>
> --- Comment #89 from Phil Cole <email address hidden> 2011-10-29 12:09:28 UTC
> ---
> Just completed a fresh install of Fedora 15 x86 and rebuilt the stock
> Fedora
> kernel (2.6.40.6) keeping the exact same configuration apart from the
> addition
> of the two patches from Comment 81 and Comment 82 and it fixes the problem
> as
> far as I can see.
>
> Boots fine without kernel param "nomodeset".
> glxgears gives approx 57-60fps.
> Gnome3 much more responsive.
>
> Thanks Alex for your persistence with this bug. Thanks katabami too.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>

description: updated
104 comments hidden view all 166 comments
André Oliva (gandreoliva) wrote :

There is a patch in freedesktop.org bug tracker, that seems to fix the problem. If someone wants to try it, it's there, but please be careful.

Changed in xserver-xorg-driver-ati:
status: Confirmed → In Progress
Changed in linux:
status: Confirmed → In Progress
Ian McMichael (ian-sigma-uk) wrote :

The performance of my HP Compaq 6715b with an RS690M has regressed so badly in Oneiric that I've been forced into action. Based on the work done in Bug #874784 and the patches provided by Alex Deucher in https://bugs.freedesktop.org/show_bug.cgi?id=37679 I have built my first kernel. It builds on 3.0.0-13-generic #22 from the Oneiric Proposed repository and I have only built the i386, which is what I run.

I have attached a copy of the new kernel I am running, which restored the 3D acceleration on my hardware. It would be great if others could test and then we could work out a way to get these patches incorporated into the next kernel release for Oneiric.

Ian McMichael (ian-sigma-uk) wrote :

Generic headers for the above kernel

Ian McMichael (ian-sigma-uk) wrote :

i386 headers for above kernel

tags: added: kernel-graphics
Changed in linux:
status: In Progress → Fix Committed
Changed in xserver-xorg-driver-ati:
status: In Progress → Fix Committed
102 comments hidden view all 166 comments

I hope it's ok for me to say, but Alex Deucher has kindly commited the patches 10 days ago, and the fix seems available in 3.0.9 and 3.1.1.

Let me express my gratitude to Alex, and all involved people. If André and Phil didn't report it, I was clueless. :)

With best regards.

Bryce Harrington (bryce) on 2011-11-15
Changed in xserver-xorg-driver-ati:
importance: Undecided → Unknown
status: Fix Committed → Unknown
summary: [RS690M] No 3d acceleration in Radeon X1200 with new Gallium r300 / 3d
- drivers in 11.04
+ drivers in 11.04 (Needs kernel quirk)
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
assignee: Bryce Harrington (bryce) → nobody
status: Confirmed → Triaged
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
status: Unknown → Confirmed
Ian McMichael (ian-sigma-uk) wrote :

Having upgraded to the 3.0.0-13-generic #22-Ubuntu kernel (without the RS690M patch) after the security release a couple of days ago, I realise that there is really no improvement on my HP Compaq 6715b whether I run Alex's patch or not. The graphics are very lagged in both Unity 3D and 2D.

For an example of this, pull down the far-right (what is the name for that, settings?) from the top bar and move your mouse pointer up and down over the menu items. The orange highlight bar lags substantially behind the mouse pointer position. The same can be observed by picking a window up by its title bar and dragging it around the workspace. The mouse pointer becomes more and more detached from the title bar of the window as you drag and the window lags behind.

Hopefully this explains the usability impact of this bug? If there's any more technical data I can collect from my particular RS690M installation that would help, please just ask?

Ian McMichael (ian-sigma-uk) wrote :

OK, I spoke too early in my last post. The machine was working fine all day Thursday with the official 3.0.0-13-generic kernel. Then when I booted it on Friday morning, lightdm displayed fine but the UI froze logging into any account with a background bitmap and mouse cursor. Unity did not display, and apart from using CTRL+ALT+F1 to switch to another console, the GUI was completely unusable.

Thinking I may have an ecryptfs issue, I booted off a USB stick with the live Oneric i386 image on it. This gave the same error. I removed the hard disk from the machine and tried again to completely remove any existing configuration or broken file-system causes. The result was the same, the GUI froze.

Next I downloaded a Natty i386 CD image and put this on the flash drive. This release had never caused me any issues on the HP Compaq 6715b. However, this now caused the same GUI freeze trying to launch Unity.

Eventually, I went back to the Lucid LTS i386 image with Gnome and everything booted fine and I was able to use the GUI from the flash drive. I used this UI to download the patched kernel I have posted in this bug and copied it back to my system. I booted back into the hard-drive installation, switched to console 1 with CTRL+ALT+F1 and used dpkg to re-install my 3.0.0.13 kernel with the AMD patches. After a reboot I was again able to log in and the Unity interface displays again. However, the horrific lagging and general lack of usability of the interface on this machine remain.

Does the RS690M have some sort of firmware the kernel can corrupt? The Canonical 3.0.0-13-generic kernel is the first time on this particular machine I have ever had a complete show-stopper bug where the UI fails to display. (This is after running Natty for 6 months on the same machine previously!) I now believe we may have two bugs here. One that corrupts the firmware in some way and actually stops the RS690M working on these machines, and another (maybe Compiz) that causes the horrendous lag and lack of usability.

What do others experiencing these issues think?

1 comments hidden view all 166 comments

A patch referencing this bug report has been merged in Linux v3.2-rc1:

commit b362105f7f5223fa4d2e03ceeea0e51da754ccc6
Author: Alex Deucher <email address hidden>
Date: Tue Oct 25 15:11:08 2011 -0400

    drm/radeon/kms: Add MSI quirk for HP RS690

A patch referencing this bug report has been merged in Linux v3.2-rc1:

commit a18cee15ed4c8b6a35f96b7b26a46bac32e04bd9
Author: Alex Deucher <email address hidden>
Date: Tue Nov 1 14:20:30 2011 -0400

    drm/radeon/kms: add MSI module parameter

I have the same problem with my DELL Inspiron 1521 laptop and the patch doesn't fix the problem cause my video card reports another subsystem_device:
cat /sys/bus/pci/devices/0000:01:05.0/subsystem_device
0x01fc

So I just changed subsystem_device in the patch and now it works fine.

Created attachment 55596
Add another DELL quirk

I've sent this additional patch upstream.

A patch referencing this bug report has been merged in Linux v3.2-rc1:

commit 01e718ec194e30b3e8eb3858c742c13649757efc
Author: Alex Deucher <email address hidden>
Date: Tue Nov 1 14:14:18 2011 -0400

    drm/radeon/kms: Add MSI quirk for Dell RS690

A patch referencing this bug report has been merged in Linux v3.3-rc2:

commit 44517c44496062180a6376cc704b33129441ce60
Author: Alex Deucher <email address hidden>
Date: Sun Jan 15 08:51:12 2012 -0500

    drm/radeon/kms: Add an MSI quirk for Dell RS690

I have this problem with my Radeon 9600XT

I had this problem on an install of Ubuntu Natty and so far the only thing I can confirm with repeatability is that 3D works when the S-video output is 'detected' and doesn't work when it isn't.

If I boot into Windows XP (dual boot) and enable the TV-Out on S-Video (even without a TV plugged in) and then reboot into Ubuntu Natty I get a 2nd screen on S-video showing up in the displays control panel and I get 3D acceleration to work.

I installed a test copy of Ubuntu Oneiric onto a USB HDD and so far haven't had issues with 3D.

HOWEVER: I recently did an upgrade to Oneiric inside the currently-installed Natty and the 3D issue is still present, so perhaps that is from something still there from the old installation?

Again, enabling S-video in Windows and rebooting is the only sure way to make 3D work.

Occasionally it will boot up and detect the S-video and enable 3D by itself but this is not often.

(In reply to comment #98)
> I have this problem with my Radeon 9600XT

No, you probably don't. This problem is (was? Looks like this report can be resolved now?) specific to RS690 chipsets.

Please file your own report with the usual information attached, i.e. at least Xorg.0.log and the output of dmesg and glxinfo from when the problem occurs (and maybe also from when it doesn't). Please also describe in more detail what exactly "3D acceleration doesn't work" means in your case.

7 comments hidden view all 166 comments
Leonardo Brás (leonardobsp) wrote :

It the bug was gone in Precise beta1.

8 comments hidden view all 166 comments
Download full text (7.5 KiB)

Hello. Plz tell me, where i can find detailed information about my Radeon x1250. Something like this:
if ((rdev->pdev->device == 0x791f) &&
(rdev->pdev->subsystem_vendor == 0x1028) &&
(rdev->pdev->subsystem_device == 0x01fc))
Simple hack "return true;" work.
Notebook: Emachines D620
Thanks.
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] nee ATI RS690 Host Bridge [1002:7910]
 Subsystem: Gateway 2000 Device [107b:0185]
 Flags: bus master, 66MHz, medium devsel, latency 64
 Kernel modules: ati-agp

00:01.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RS690 PCI to PCI Bridge (Internal gfx) [1002:7912] (prog-if 00 [Normal decode])
 Flags: bus master, 66MHz, medium devsel, latency 64
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
 I/O behind bridge: 00009000-00009fff
 Memory behind bridge: f0000000-f01fffff
 Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
 Capabilities: <access denied>
 Kernel modules: shpchp

00:04.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI Device [1002:7914] (prog-if 00 [Normal decode])
 Flags: bus master, fast devsel, latency 0
 Bus: primary=00, secondary=02, subordinate=04, sec-latency=0
 I/O behind bridge: 0000a000-0000afff
 Memory behind bridge: f0200000-f02fffff
 Capabilities: <access denied>
 Kernel driver in use: pcieport
 Kernel modules: shpchp

00:05.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RS690 PCI to PCI Bridge (PCI Express Port 1) [1002:7915] (prog-if 00 [Normal decode])
 Flags: bus master, fast devsel, latency 0
 Bus: primary=00, secondary=05, subordinate=07, sec-latency=0
 Memory behind bridge: f0300000-f03fffff
 Capabilities: <access denied>
 Kernel driver in use: pcieport
 Kernel modules: shpchp

00:12.0 SATA controller [0106]: Advanced Micro Devices [AMD] nee ATI SB600 Non-Raid-5 SATA [1002:4380] (prog-if 01 [AHCI 1.0])
 Subsystem: Gateway 2000 Device [107b:0185]
 Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 22
 I/O ports at 8440 [size=8]
 I/O ports at 8434 [size=4]
 I/O ports at 8438 [size=8]
 I/O ports at 8430 [size=4]
 I/O ports at 8400 [size=16]
 Memory at f0609000 (32-bit, non-prefetchable) [size=1K]
 Capabilities: <access denied>
 Kernel driver in use: ahci

00:13.0 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI0) [1002:4387] (prog-if 10 [OHCI])
 Subsystem: Gateway 2000 Device [107b:0185]
 Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
 Memory at f0404000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:13.1 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI1) [1002:4388] (prog-if 10 [OHCI])
 Subsystem: Gateway 2000 Device [107b:0185]
 Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
 Memory at f0405000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:13.2 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI SB600 USB (OHCI2) [1002:4389] (prog-if 10 [OHCI])
 Subsystem: Gateway 2000 Device [107b:0185]
 Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18
 Memory at f0406000 (32-bit, non-prefetchable) [size=4K]
 Kernel driver in use: ohci_hcd

00:13.3 USB controller [0c03...

Read more...

cat /sys/bus/pci/devices/0000:01:05.0/subsystem_device
0x0185

Created attachment 67737
fix for gateway laptop

This patch should fix your gateway laptop.

Created attachment 67738
force MSIs for all RS690s

For anyone with an RS690, try this patch and see if it helps.

On my Acer Emachine e625 laptop, enabling MSI seems to be an improvement.
`vblank_mode=0 glxgears` give me 690 FPS when I had 590 without MSI.

However, the desktop experience (Unity 3D) feels the same with or without it.

(In reply to comment #102)
> Created attachment 67737 [details] [review]
> fix for gateway laptop
> This patch should fix your gateway laptop.

Yes, it's work. Can you send this patch in upstream? :)
cat /proc/interrupts
...
43: 20852 PCI-MSI-edge radeon
Thanks.

(In reply to comment #105)

> Yes, it's work. Can you send this patch in upstream? :)

Yes, it's already queued for 3.7 and stable.

I forgot this about my system:
cat /sys/bus/pci/devices/0000:01:05.0/subsystem_device
0x0213

Let me know if you need something else.

(In reply to comment #107)
> I forgot this about my system:
> cat /sys/bus/pci/devices/0000:01:05.0/subsystem_device
> 0x0213

The patch in attachment 67738 should handle your card.

Yes, this patch does enable MSI and so does solve most of my problems with this laptop.
Though the patch does not apply as is (at least on the Ubuntu kernel).

Fixed in 3.6.2 / 3.5.7 / 3.4.14 .

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Oibaf (oibaf) wrote :

3.5.7 fixed this and is on 12.10

Changed in linux:
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Invalid
Displaying first 40 and last 40 comments. View all 166 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.