Ubuntu

[RV515] low OpenGL frame rates

Reported by Daniel Lipowicz on 2011-03-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Tormod Volden

Bug Description

Binary package hint: xserver-xorg-video-ati

Card is not supported because the system detects it as ATI Technologies Inc M71 [Mobility Radeon X2100]. I have HD 2300. How do I use glxgears FPS = ~ 40 is very low.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: kwin
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wAyDADhAAAAAAAQAQOAIRV4CvNwmFlTjScjUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYAS88QAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMR1BoaWxpcHNMQ0QKAAAA/gBMUDE1NFdYNC1UTEIyANM=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Thu Mar 17 11:46:46 2011
DistUpgraded: Log time: 2011-03-05 18:02:31.262646
DistroCodename: natty
DistroVariant: kubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-6-generic, i686: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-5-generic, i686: installed
 virtualbox-ose, 4.0.4, 2.6.38-6-generic, i686: installed
 virtualbox-ose, 4.0.4, 2.6.38-4-generic, i686: installed
 virtualbox-ose, 4.0.4, 2.6.38-5-generic, i686: installed
GraphicsCard:
 ATI Technologies Inc M71 [Mobility Radeon X2100] [1002:7210] (rev ce) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:012e]
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.3)
MachineType: Acer Aspire 5710Z
ProcEnviron:
 LANGUAGE=
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=d8af07e0-a0be-44b8-9b8f-242b9c858cd5 ro quiet splash
Renderer: Unknown
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: Upgraded to natty on 2011-03-05 (11 days ago)
dmi.bios.date: 06/29/2007
dmi.bios.vendor: Acer
dmi.bios.version: V1.40
dmi.board.name: Acadia
dmi.board.vendor: Acer
dmi.board.version: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrV1.40:bd06/29/2007:svnAcer:pnAspire5710Z:pvrV1.40:rvnAcer:rnAcadia:rvrN/A:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5710Z
dmi.product.version: V1.40
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4-0ubuntu5
version.libdrm2: libdrm2 2.4.24+git20110307.3b04c736-0ubuntu0sarvatt
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11.0+git20110316.b47d5084-0ubuntu0sarvatt
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Tormod Volden (tormodvolden) wrote :

Don't worry about the "HD2300", it is just text coming from lspci which has a typo in its database. The driver recognizes it correctly, as a RV515 device (the HD2100 is just a marketing name). This can be seen in Xorg.0.log:
[ 30.780] (--) RADEON(0): Chipset: "ATI Mobility Radeon HD 2300" (ChipID = 0x7210)

Did you ppa-purge the xorg-edgers PPA before upgrading to natty? Otherwise that would be the reason, you have got a mixture of xorg-edgers and normal packages installed.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Tormod Volden (tormodvolden)
status: New → Incomplete
Download full text (4.2 KiB)

No, I did not have the xorg-edgers Nutty before upgrading. If good detect
why I have a little FPS?
17-03-2011 20:11 użytkownik "Tormod Volden" <email address hidden>
napisał:
> Don't worry about the "HD2300", it is just text coming from lspci which
has a typo in its database. The driver recognizes it correctly, as a RV515
device (the HD2100 is just a marketing name). This can be seen in
Xorg.0.log:
> [ 30.780] (--) RADEON(0): Chipset: "ATI Mobility Radeon HD 2300" (ChipID =
0x7210)
>
> Did you ppa-purge the xorg-edgers PPA before upgrading to natty?
> Otherwise that would be the reason, you have got a mixture of xorg-
> edgers and normal packages installed.
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Assignee: (unassigned) => Tormod Volden (tormodvolden)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/736760
>
> Title:
> detects wrong graphics card
>
> Status in "xserver-xorg-video-ati" package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: xserver-xorg-video-ati
>
> Card is not supported because the system detects it as ATI
> Technologies Inc M71 [Mobility Radeon X2100]. I have HD 2300. How do I
> use glxgears FPS = ~ 40 is very low.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic i686
> Architecture: i386
> CompizPlugins: No value set for
`/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: kwin
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
> edid-base64:
AP///////wAyDADhAAAAAAAQAQOAIRV4CvNwmFlTjScjUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYAS88QAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMR1BoaWxpcHNMQ0QKAAAA/gBMUDE1NFdYNC1UTEIyANM=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> Date: Thu Mar 17 11:46:46 2011
> DistUpgraded: Log time: 2011-03-05 18:02:31.262646
> DistroCodename: natty
> DistroVariant: kubuntu
> DkmsStatus:
> bcmwl, 5.100.82.38+bdcom, 2.6.38-6-generic, i686: installed
> bcmwl, 5.100.82.38+bdcom, 2.6.38-5-generic, i686: installed
> virtualbox-ose, 4.0.4, 2.6.38-6-generic, i686: installed
> virtualbox-ose, 4.0.4, 2.6.38-4-generic, i686: installed
> virtualbox-ose, 4.0.4, 2.6.38-5-generic, i686: installed
> GraphicsCard:
> ATI Technologies Inc M71 [Mobility Radeon X2100] [1002:7210] (rev ce)
(prog-if 00 [VGA controller])
> Subsystem: Acer Incorporated [ALI] Device [1025:012e]
> InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Alpha i386
(20100803.3)
> MachineType: Acer Aspire 5710Z
> ProcEnviron:
> LANGUAGE=
> LANG=pl_PL.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic
root=UUID=d8af07e0-a0be-44b8-9b8f-242b9c858cd5 ro quiet splash
> Renderer: Unknown
> SourcePackage: xserver-xorg-video-ati
> UpgradeStatus: Upgraded to natty on 2011-03-05 (11 days ago)
> dmi.bios.date: 06/29/2007
> d...

Read more...

Looks like you have a mix of normal and xorg-edgers packages.
Please run: aptitude search '~Vsarvatt'
This should identify most of the xorg-edgers packages.
With all of the packages listed, install the normal natty packages, like this:
 sudo apt-get install libdrm2/natty libgl1-mesa-dri/natty (... etc ...)

Is anything else than glxgears running slowly? Note also that with vsync enabled, the 3D applications will not try to repaint more often than the screen is refreshed (~60 Hz).

I went back sarvatt to the natty package versions but FPS unchanged.
Next is low. Other applications also.

E-mail wysłano za pomocą programu Thunderbird 3.1.10pre Linux

On 17.03.2011 23:27, Tormod Volden wrote:
> Looks like you have a mix of normal and xorg-edgers packages.
> Please run: aptitude search '~Vsarvatt'
> This should identify most of the xorg-edgers packages.
> With all of the packages listed, install the normal natty packages, like this:
> sudo apt-get install libdrm2/natty libgl1-mesa-dri/natty (... etc ...)
>
> Is anything else than glxgears running slowly? Note also that with vsync
> enabled, the 3D applications will not try to repaint more often than the
> screen is refreshed (~60 Hz).
>

Try first to remove your .drirc file.

What FPS do you get if you run:
 /usr/lib/xscreensaver/glblur -fps

Please run this and attach the resulting glxinfo.txt file:
 LIBGL_DEBUG=1 glxinfo > glxinfo.txt 2>&1

  /usr/lib/xscreensaver/glblur -fps
FPS ~18

E-mail wysłano za pomocą programu Thunderbird 3.1.10pre Linux

W dniu 18.03.2011 13:29, Tormod Volden pisze:
> Try first to remove your .drirc file.
>
> What FPS do you get if you run:
> /usr/lib/xscreensaver/glblur -fps
>
> Please run this and attach the resulting glxinfo.txt file:
> LIBGL_DEBUG=1 glxinfo> glxinfo.txt 2>&1
>

Was it faster in Ubuntu 10.10?

summary: - detects wrong graphics card
+ [RV515] low OpenGL frame rates
Tormod Volden (tormodvolden) wrote :

Please try these 3 things independently:
1) Create an /etc/X11/xorg.conf with this contents:
Section "Device"
  Identifier "myradeon"
  Option "SwapbuffersWait" "False"
EndSection

2) Create a .drirc file with this contents:
<driconf>
    <device screen="0" driver="dri2">
        <application name="Default">
            <option name="vblank_mode" value="0" />
        </application>
    </device>
</driconf>

3) This would work in Ubuntu 10.10 but I think not in 11.04 (gallium needs KMS):
Boot with adding this to the kernel options in the grub menu: radeon.modeset=0

Download full text (3.5 KiB)

No.
18-03-2011 16:06 użytkownik "Tormod Volden" <email address hidden>
napisał:
> Was it faster in Ubuntu 10.10?
>
> ** Summary changed:
>
> - detects wrong graphics card
> + [RV515] low OpenGL frame rates
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/736760
>
> Title:
> [RV515] low OpenGL frame rates
>
> Status in "xserver-xorg-video-ati" package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: xserver-xorg-video-ati
>
> Card is not supported because the system detects it as ATI
> Technologies Inc M71 [Mobility Radeon X2100]. I have HD 2300. How do I
> use glxgears FPS = ~ 40 is very low.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic i686
> Architecture: i386
> CompizPlugins: No value set for
`/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: kwin
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
> edid-base64:
AP///////wAyDADhAAAAAAAQAQOAIRV4CvNwmFlTjScjUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYAS88QAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMR1BoaWxpcHNMQ0QKAAAA/gBMUDE1NFdYNC1UTEIyANM=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> Date: Thu Mar 17 11:46:46 2011
> DistUpgraded: Log time: 2011-03-05 18:02:31.262646
> DistroCodename: natty
> DistroVariant: kubuntu
> DkmsStatus:
> bcmwl, 5.100.82.38+bdcom, 2.6.38-6-generic, i686: installed
> bcmwl, 5.100.82.38+bdcom, 2.6.38-5-generic, i686: installed
> virtualbox-ose, 4.0.4, 2.6.38-6-generic, i686: installed
> virtualbox-ose, 4.0.4, 2.6.38-4-generic, i686: installed
> virtualbox-ose, 4.0.4, 2.6.38-5-generic, i686: installed
> GraphicsCard:
> ATI Technologies Inc M71 [Mobility Radeon X2100] [1002:7210] (rev ce)
(prog-if 00 [VGA controller])
> Subsystem: Acer Incorporated [ALI] Device [1025:012e]
> InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Alpha i386
(20100803.3)
> MachineType: Acer Aspire 5710Z
> ProcEnviron:
> LANGUAGE=
> LANG=pl_PL.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic
root=UUID=d8af07e0-a0be-44b8-9b8f-242b9c858cd5 ro quiet splash
> Renderer: Unknown
> SourcePackage: xserver-xorg-video-ati
> UpgradeStatus: Upgraded to natty on 2011-03-05 (11 days ago)
> dmi.bios.date: 06/29/2007
> dmi.bios.vendor: Acer
> dmi.bios.version: V1.40
> dmi.board.name: Acadia
> dmi.board.vendor: Acer
> dmi.board.version: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: N/A
> dmi.modalias:
dmi:bvnAcer:bvrV1.40:bd06/29/2007:svnAcer:pnAspire5710Z:pvrV1.40:rvnAcer:rnAcadia:rvrN/A:cvnAcer:ct10:cvrN/A:
> dmi.product.name: Aspire 5710Z
> dmi.product.version: V1.40
> dmi.sys.vendor: Acer
> version.compiz: compiz 1:0.9.4-0ubuntu5
> version.libdrm2: libdrm2 2.4.24+git20110307.3b04c736-0ubuntu0sarvatt
> version.libgl1-mesa-glx: libgl1-mesa-glx
7.11.0+git20110316.b47d5084-0ubuntu0sarvatt
> version.xserver-xorg: xserver-xor...

Read more...

Bryce Harrington (bryce) wrote :

See #9

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers