regression after latest xorg upgrade in edgy: video mode 1440x960 got missing

Bug #63994 reported by Herbert V. Riedel on 2006-10-04
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Medium
Fabio Massimo Di Nitto

Bug Description

after the latest xorg update yesterday or today, the x11 server falls back to 800x600 mode display on my powerbook, telling me that no 1440x960 mode exists anymore (see old working Xorg.0.log.old vs. bad new Xorg.0.log)

Herbert V. Riedel (hvr) wrote :
Herbert V. Riedel (hvr) wrote :
Herbert V. Riedel (hvr) wrote :

seems I had to reenable

        Option "UseFBDev" "true"

in my xorg.conf... go figure...

please attach your config file.

I can confirm that with this conf i get 800x600 (with no external CRT connected) while readding UseFBDev will get the right resolution.

Fabio

Setting importance to medium and target for release, even tho the default ubuntu config does set UseFBDev by default.

Fabio

Changed in xserver-xorg-video-ati:
assignee: nobody → fabbione
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Herbert V. Riedel (hvr) wrote :

btw, I guess that by setting UseFBDev I lose the ability to use the external DVI connector for a dualhead configuration (can't test it right now due to lack of monitor)

Here's a proposed fix

The patch seems to work for me.

Herbert can you please install and test this package both with and without UseFBDev?

http://people.ubuntu.com/~fabbione/xserver-xorg-video-ati_6.6.2-0ubuntu3_powerpc.deb

and let me know ASAP if it works so i can upload it to the archive.

Thanks
fabio

Herbert V. Riedel (hvr) wrote :

yes, now it works with and without UseFBDev again

(and while at it, 3d accelerations seems still broken, see Bug #61607 )

 xserver-xorg-video-ati (1:6.6.2-0ubuntu4) edgy; urgency=low
 .
   * Fix radeon DAC power on for CRT presence check:
     - Add patch 09_radeon_dac_power.diff
   (Closes Ubuntu: #63994)
 .
   Thanks Ben H. for the patch.

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers