Desktop CD starts with wrong resolution

Bug #61390 reported by David Fokkema
20
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

When booting the desktop CD (dapper, edgy eft knot 2, edgy eft knot 3) a resolution of 1024x768 is chosen for my ati radeon mobility 9000 which is capable of 1400x1050. If I choose 1400x1050x32 with the F4 key in the bootup menu, X still starts with 1024x768. The only difference (with edgy eft knot 3) is that _with_ the 1400x1050 option the splash screen is shown right up to the moment X starts whereas _without_ the option the splash screen is corrupted when the progress bar is nearing 50% and I'm stuck with a text-mode login prompt until X starts.

When I run 'sudo dpkg-reconfigure xserver-xorg' and hit enter a lot of times the 1400x1050 resolution is automatically chosen and when I restart X everything works flawlessly. So my guess is that the 'configuring X' bootup script is fouling up which may or not may be related to the splash screen corrupting halfway through the boot process.

Revision history for this message
Vassilis Pandis (pandisv) wrote :

Can you please attach your correct xorg.conf as well as the output of "lspci -vv", "lspci -vvn" and "dmesg" ? Thanks in advance.

Revision history for this message
David Fokkema (dfokkema) wrote :

Here they come!

Revision history for this message
David Fokkema (dfokkema) wrote :
Revision history for this message
David Fokkema (dfokkema) wrote :
Revision history for this message
David Fokkema (dfokkema) wrote :
Revision history for this message
David Fokkema (dfokkema) wrote :

The files previously posted are from edgy beta and not knot 3. With beta, the desktop cd still starts up in 1024x768. However, even without the F4 VGA option, the splash screen is _not_ corrupted. So there's progress, I suppose. The splash screen is shown in 1024x768 (I believe).

Revision history for this message
Luka Renko (lure) wrote :

I have same problem with Kubuntu Edgy RC on HP nw8240 with ATI FireGL V5000 PCIE with 1920x1200 resolution.

Desktop CD starts correctly (now that bug 22985 is fixed for me), but in 1024x768 resolution. This is true for both usplash as well as KDE desktop.

I have also user Alternate CD (Kubuntu Edgy RC) and it did not auto detect resolution and installer asked me to specify one - after specifying resolution it worked after the boot.

Changed in xorg:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Revision history for this message
Johan Walles (walles) wrote :

I'm not convinced that I agree with the "Low" importance assigned to this bug. Some people's first impression of Edgy is "Look, a low resolution screen that flickers terribly!".

I know I had that. I was able to find the answer in here and am now happily upgraded, but not everybody might be able to do that.

Revision history for this message
Luka Renko (lure) wrote :

This is still the case with Feisty Herd1 on HP nw8240 with ATI FireGL V5000 PCIE with 1920x1200 resolution.

Revision history for this message
Luka Renko (lure) wrote :

Feisty Herd2 on HP nw8240 with ATI FireGL V5000 PCIE with 1920x1200 resolution: problem still exists.

Revision history for this message
Erik Andrén (erik-andren) wrote :

Feisty herd 5 contains an updated version of xorg (7.2), please try and see if it makes a difference.

Revision history for this message
mikael henrikson (mikael-henrikson) wrote :

Still flickering in Feisty Herd 5 with FireGL 5000
(https://launchpad.net/bugs/20283)

Revision history for this message
David Fokkema (dfokkema) wrote :

Feisty Beta still starts with 1024x768 on my 1400x1050 screen. When the install is final, I have to manually run dpkg-reconfigure xserver-xorg, which, I think, might be important to include in the release notes before less knowlegdeable people will instantly switch to some other distro which _does_ support their resolution.

Revision history for this message
Luka Renko (lure) wrote :

I would just like to notify others that this bug is fixed for me with Kubuntu Gutsy Tribe5 Live CD - I get proper resolution (1920x1200) and DPI (145) on my HP nw8240 (ATI FireGL V5000 PCIE).

David, Mikael, Johan: can you check Tribe5 CD on your system and confirm that it is fixed for you too?

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete
Revision history for this message
David Fokkema (dfokkema) wrote :

You beat me to it, Luka!

It works for me too, so I'm happy!

(However, now dri is not enabled by default because of some module mix-up, I think. When I'm back home I'll open a new report and attach a lsmod and a lsmod after reloading the radeon module, which fixes it.)

Revision history for this message
Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Gutsy Gibbon. It won't be fixed in previous versions of Ubuntu because the bug doesn't fit requirements for backporting. See [WWW] https://help.ubuntu.com/community/UbuntuBackports for more information.

Changed in xserver-xorg-video-ati:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers