[drm:radeon_dvi_detect] *ERROR* DVI-I-2: probed a monitor but no|invalid EDID

Bug #612687 reported by Richard Eames
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Fix Released

Bug Description

Binary package hint: xserver-xorg-video-ati

One of the upgrades in the past few days has made my second monitor not work. Error description in dmesg log.
xrandr gives the following:

$ xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 8192 x 8192
DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050 60.0*+
   1600x1200 60.0
   1280x1024 75.0 60.0
   1440x900 75.0 59.9
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
DIN disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)

I tried unplugging the cables for the monitor, and reconnecting them, making sure they were in firmly, and still the same problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-radeon 1:6.13.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-13.18-generic 2.6.35-rc6
Uname: Linux 2.6.35-13-generic x86_64
Architecture: amd64
 status: disconnected
 enabled: disabled
 dpms: On
Date: Mon Aug 2 12:22:29 2010
DkmsStatus: Error: [Errno 2] No such file or directory
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-13-generic root=UUID=7d5251d0-2720-4c47-a560-b182e12fd2ae ro noquiet splash
 PATH=(custom, user)
SourcePackage: xserver-xorg-video-ati
dmi.bios.date: 04/01/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0903
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M3A78-T
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0903:bd04/01/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3A78-T:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
glxinfo: Error: [Errno 2] No such file or directory
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-13-generic

Revision history for this message
Richard Eames (naddiseo) wrote :
Bryce Harrington (bryce)
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Revision history for this message
sam tygier (samtygier) wrote :

bryce, do you think Bug #601376 and Bug #539851 are the same issue? and maybe https://bugzilla.redhat.com/show_bug.cgi?id=533632

Revision history for this message
Ilia (look256) wrote :

Well, it looks like I'm affected by the same bug. But my xrandr shows the state of monitor cables correctly. But the second monitor goes to the safemode on booting ubuntu 10.04 and 10.10. it affected kernel 2.6.32 and 2.6.34 in 10.04. and bare installing 10.10

radeon x1600.

Revision history for this message
bugbot (bugbot) wrote :

Hey Richard,

Thanks for testing maverick during its development period. Unfortunately it looks like this bug report didn't get attention during the maverick development period. But I see there's not been more comments on the bug since the release, which makes me wonder if this is still an issue for you?

If you've not seen this issue since maverick's release yourself, it may have been solved by kernel or X or other updates that occurred late in the release; if so, would you mind please closing the bug for us? Go to the URL mentioned in this bug report, click the yellow icon(s) in the status column and set to 'Fix Released'.

If you no longer have the hardware needed to reproduce the problem, or otherwise feel the bug no longer needs tracked in Launchpad, you can set the status to 'Invalid'.

If you are the original reporter and still have this issue, just reply to this email saying so. (Or set the bug status to Confirmed.) If you are able to re-test this against 11.04 Natty Narwhal (our current development focus) and find the issue still affects Natty, please also run 'apport-collect <bug-number>' while running natty, which will add fresh logs and debug data, and flag it for the Ubuntu-X development team to look at.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Ilia (look256) wrote :

Well. I confirm? that it's still an issue for me. I'll check if it was solved by updates this week and describe it here. let's set 25.02.11 as a deadline :).

Revision history for this message
Ilia (look256) wrote :

I confirm that it's still an issue for me. DistroRelease: Ubuntu 10.10, Ubuntu 10.04. Last updates don't solved that issue. It looks like something connected with KMS.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
assignee: nobody → Ilia (look256)
Revision history for this message
Chris Routh (routhinator) wrote :

This also affects my Toshiba L300D Laptop. Affects 11.04 Natty.

Revision history for this message
madbiologist (me-again) wrote :

The L300D problem should be solved in the latest kernels, namely 3.1 (upstream), 3.0.4 (upstream) and 3.0.0-10.16 (available in the Ubuntu 11.10 "Oneiric Ocelot" repositories). This fix was also cc'd to upstream's stable kernel series so it should be coming to Ubuntu 11.04 "Natty Narwhal" in a future SRU.

Revision history for this message
madbiologist (me-again) wrote :

If you want to try the L300D fix in the meantime, PPA's of the mainline kernels are available at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Revision history for this message
Bryce Harrington (bryce) wrote :

Sounds like this got fixed in the kernel a while ago; since there's been no subsequent comments I'm going to assume the problem is resolved.

See also bug 992346 for the more general problem of invalid edid and working around it by installing an alternate EDID file.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.