Ubuntu

Radeon driver "No buffer for z buffer" error

Reported by Anton Salikhmetov on 2010-05-16
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Confirmed
Medium
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

X-Plane Demo fails to start with the following error:

drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

Corresponding `dmesg' snippet is as follows:

[53540.965939] [drm:r100_cs_track_check] *ERROR* [drm] No buffer for z buffer !
[53540.965945] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

The free installer is available through the following address:

http://dev.x-plane.com/update/installers9/X-PlaneDemoInstallerLinux.zip

The `radeon' driver is in use. The xorg.conf is not used in my system. The video card is ATI Mobility Radeon X2500 aka X1600. Latest updates for Lucid are installed.
---
Architecture: amd64
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
MachineType: ASUSTeK Computer Inc. F3Se
Package: xserver-xorg-video-ati 1:6.13.0-1ubuntu5
PackageArchitecture: amd64
ProcCmdLine: root=UUID=973084d5-6b81-4ea8-883a-8c71ba195dec quiet
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid lucid
Uname: Linux 2.6.32-22-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev sbuild scanner video
dmi.bios.date: 07/31/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 206
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: F3Se
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr206:bd07/31/2007:svnASUSTeKComputerInc.:pnF3Se:pvr1.0:rvnASUSTeKComputerInc.:rnF3Se:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: F3Se
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

Bryce Harrington (bryce) on 2010-05-16
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi Anton,

Please run the command 'apport-collect BUGNUMBER', which will attach several files we need for debugging.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Bryce Harrington (bryce) on 2010-05-21
tags: added: lucid

X-Plane Demo fails to start with the following error:

drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

Corresponding `dmesg' snippet is as follows:

[53540.965939] [drm:r100_cs_track_check] *ERROR* [drm] No buffer for z buffer !
[53540.965945] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

The free installer is available through the following address:

http://dev.x-plane.com/update/installers9/X-PlaneDemoInstallerLinux.zip

The `radeon' driver is in use. The xorg.conf is not used in my system. The video card is ATI Mobility Radeon X2500 aka X1600.

More information on logs is available at Launchpad:

https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/581233

Can you please try Mesa 7.8? There are walls of commits from Maciej for the R300c driver and a lot of fixes among them too.

(In reply to comment #1)
> Can you please try Mesa 7.8? There are walls of commits from Maciej for the
> R300c driver and a lot of fixes among them too.

Though Ubuntu Lucid does not yet ship Mesa 7.8, I used the following PPA instead:

https://edge.launchpad.net/~bryceharrington/+archive/bronze

The behavior is the same as for Mesa 7.7.1 which was in use before the upgrade.

Apparently there have been no changes that would affect this error.

Bryce Harrington (bryce) on 2010-05-26
tags: removed: needs-xorglog
tags: removed: needs-lspci-vvnn
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
madbiologist (me-again) wrote :

Is this still occurring in Ubuntu 10.10 "Maverik Meerkat"?

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.