Ubuntu

[x1400] Dual monitor distortion / crash (Lucid AMD64)

Reported by johanbondt on 2010-05-01
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

OS: Ubuntu Linux 10.04LTS final release. Fresh install 30th April 2010.
Laptop: Fujitsu Siemens Amilo Pi 1536 Video card: ATI mobility Radeon X1400
No third party video drivers installed.
Without second monitor, the laptop-screen looks fine. 3D compiz works smooth. Colors are fine.
In 9.10 the laptop screen and a second monitor worked fine too.

Problem occurence:
When plugging in a second monitor (HP1530) in the DVI-bus on my laptop this is recognized in the ' Monitors' preferences' applet. The second screen shows the extended desktop with regularly appearing distortion stripes (like "shocks") in it.
When trying to shut the HP1530 off with the 'Monitors' preferences' applet, the laptop screen distorted. (The screen image shifts right; the colors are mixed/the resolution is bad).
When I restart the laptop everything is looking good again.
Trying to reproduce the error, I plugged the monitor in again. ( again in the DVI-bus on the laptop with DVI-cable). Now the monitor says ' input signal out of range' and no image appears on the monitor. I try to change the frequency in the Monitors preferences applet. (In 9.10 all frequencies worked fine.) The monitor says "Cable disconnected", but Ubuntu still extends the desktop to the second screen. The 'Monitors'-applet still recognizes the HP1530 second screen. I change the frequency again. The laptop screen distorts like before. In this distorted screen I am filing this bug.

This bug looks a bit like:
Bug #556232 "Radeon HD 2600 - Dualscreen problem"
Bug #533269 "External display not working"
Bug #544525 "[RV380] dual monitor not working - M24 1P [Radeon Mobility X600]"

I decided to file it separately, because it has some differences in appearance and onset.

Looking at the other bugs it could be a linux kernel bug or an xserver-xorg-video-ati bug.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-video-ati 1:6.13.0-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
CheckboxSubmission: b4311ae1e5eb4c6cf0cecd051cc9f7c2
CheckboxSystem: 331fbefb4b1f6727f4a8261fee7507c9
Date: Sat May 1 22:28:36 2010
DkmsStatus: Error: [Errno 2] Bestand of map bestaat niet
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: FUJITSU SIEMENS AMILO Pi 1536
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=85104184-f3e6-4e54-b4a9-271c4902296a ro quiet splash
ProcEnviron:
 LANG=nl_NL.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-ati
dmi.bios.date: 07/19/2007
dmi.bios.vendor: FUJITSU SIEMENS
dmi.bios.version: 1.25
dmi.board.name: AMILO Pi 1536
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: Not Applicable
dmi.modalias: dmi:bvnFUJITSUSIEMENS:bvr1.25:bd07/19/2007:svnFUJITSUSIEMENS:pnAMILOPi1536:pvrNotApplicable:rvnFUJITSUSIEMENS:rnAMILOPi1536:rvrNotApplicable:cvnFUJITSUSIEMENS:ct10:cvrNotApplicable:
dmi.product.name: AMILO Pi 1536
dmi.product.version: Not Applicable
dmi.sys.vendor: FUJITSU SIEMENS
glxinfo: Error: [Errno 2] Bestand of map bestaat niet
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-21-generic

johanbondt (johanbondt) wrote :
SergeiFranco (sergei-franco) wrote :

As per thread: http://ubuntuforums.org/showthread.php?t=1468217 I can confirm this problem.
My hardware:
Compaq nc8430
ATI mobility Radeon X1400

64bit Lucid Kubuntu.

Shang Wu (shangwu) wrote :

Please try to use the kernel parameter "nomodeset" or "radeon.modeset=0" and see if that help.

From bug:
https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096

johanbondt (johanbondt) wrote :

Thanks for the comment.
I have tried radeon.modeset=0
and
adding "options radeon modeset=0" to /etc/modprobe.d/radeon-kms.conf
(from Bug #537640 .)
and this unfortunately doesn't solve anything.

johanbondt (johanbondt) on 2010-05-25
tags: added: kernel-graphics xserver-xorg-video-ati
Dave Hayslett (hayslett) wrote :

Also seeing this issue with a fresh Lucid install on
IBM T60 ThinkPad
ATI Radeon Mobility X1400
IBM/Lenovo 20" Monitor

For the external monitor in Lucid, setting refresh rates of either 70Hz or 72Hz results in an "Input signal out of range" message on the external monitor. In Karmic, either of those settings (as well as 60Hz & 75Hz) worked fine. Setting a 75Hz refresh rate shows less of the 'vibration' effect, but it's still quite bad.

I don't think this is particularly relevant, but the Lucid Monitor Preferences dialog identifies the external monitor as 'Lenovo Group Limited 20"', while the Karmic dialog identified it as simply as 'Lenovo 20"'.

Dave Hayslett (hayslett) wrote :

Neglected to mention that this is 32-bit i686 kernel 2.6.32-22-generic

Pete (pete-lists-n) wrote :

Also having this issue on an upgraded (Karmic > Lucid) 64-bit install. This worked fine in Karmic:

IBM T60 Thinkpad
ATI Radeon Mobility X1400
Dell 17" Monitor.

External monitor shows the vibration / shivering effect mentioned above. It's pronounced at 60hz and reduced (but still present) at 75hz.

This patch: http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=267364ac17f6474c69b03034340f769b22f46105

seems related.

Greg Gorman (gregg-public) wrote :

Same for me, IBM T60p Thinkpad
ATI Mobility FireGL 5250 (M56GL)
Acer AL1916 external monitor.

Boots to dual-screen and the external monitor is fuzzy. Then when I open the "Monitor Preferences" panel all displays freeze. Only fix is to hard-reset and then enable 'fglrx' instead of open source video.

johanbondt (johanbondt) wrote :

WARNING: I am not an expert.
No real experts seem to respond to this bug report, but people seem to work on almost the same problem in Bug #537640 . So I think the best thing is to wait.

But if you need the dual display badly...I looks like it is a kernel problem, so I tried something like this:
http://swiss.ubuntuforums.org/showpost.php?p=9223503&postcount=30

but installing (in this order):
linux-headers-2.6.34-020634rc7_2.6.34-020634rc7_all.deb
linux-headers-2.6.34-020634rc7-generic_2.6.34-020634rc7_amd64.deb
linux-image-2.6.34-020634rc7-generic_2.6.34-020634rc7_amd64.deb

and adding "options radeon.dynpm=1" to /etc/modprobe.d/radeon.conf

It looks like the two displays work for me, but it gives still some strange, unhealthy-looking graphical noise at boot.

WARNING: I am not an expert. These kernels are not fully tested by the Ubuntu team and not officially released, so your system can maybe become unstable.

I also uninstalled the last kernel update 2.6.32.22, because that kernel seems not to work.

kurt belgrave (trinikrono) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xserver-xorg-video-ati.
Goodluck :D

affects: ubuntu → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2010-09-05
tags: added: crash
tags: added: dual-head
marfal (marfal) wrote :

running AMD + ATI radeon graphics card - ok on single monitor (1280x1024), but when extended to two monitors (2560x1024) screen became fuzzy (horizontal flicker/wobble).

Found this post:

http://www.niccolofavari.com/ubuntu-10.04-lucid-issues-with-external-monitor-and-ati-radeon-card

"Solution

I just did the following (on a bare install of Ubuntu 10.04)
Fire up the terminal and type

gksudo gedit /etc/modprobe.d/radeon-kms.conf
a blank file will open up. Type in the following.

options radeon modeset=0
Save, exit and reboot."

This worked for me (although no accelerated Graphics).

jcervilla (jcervilla) wrote :

Yes marfal, it worked for me. I'm happy... Thank you very much.

summary: - [Lucid AMD64] Dual monitor distortion / crash - ATI mobility Radeon
- X1400
+ [x1400] Dual monitor distortion / crash (Lucid AMD64)

Will there be a resolution to this issue at some point in the near future?

I have the same exact issue on Thinkpad T60 which has a x1400 ATI Radeon Chip. My problem is that I cannot use this laptop for presentations as the projector is essentially unusable!

Disabling KMS works but distorts boot screen and leaves visible artifacts on the screen until mouse is moved over them - in a consistent manner. This, thus, is not a solution.

I have read that running 2.6.34-Lucid version of kernel fixes the issue, but I would like not to deviate from official packages. This, therefore, is not a solution either.

I wonder if there are any plans to address this?

Thanks.

kurt belgrave (trinikrono) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Natty Narwhal. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
Günter (guenter-grodotzki) wrote :

Same problem here since latest Natty update && upgrade.

Used to work in all other Natty versions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers