Ubuntu

xorg 7 dissables capture - ATI Radeon 7500 RV200 QW - WARNING ! Radeon memory controller is misconfigured, disabling capture

Reported by jwmislan on 2006-07-26
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

How to duplicate -

Ubuntu 6.06 LTS (Dapper Drake)
Kernel - uname -r = 2.6.15-26-k7

KT600 Dragon Ultra - Platinum Edition (VIA Chipset Based ATX Motherboard)

Video card - ATI All-In-Wonder 7500 RV200 QW

xorg version: 7.0.0 - standard version Issued by Ubuntu 6.06

Working xorg - ati - theatre connectors= tuner - composite - svideo . These presently, will only work to view video data, and are NOT working for capture !

My Module modifications
km_drv module (gatos)
km_api_drv (gatos)

Applications - AvView and xawtv
AvView (gatos) TV viewing works and knows that the km modules are inserted.

xawtv also works for Viewing TV,composite,or Svideo

lsmod - pertainant loaded modules= radeon 119200 1
drm 78292 2 radeon
v4l1_compat 15620 0
v4l2_common 6336 0
km_drv 43448 0
km_api_drv 19168 1 km_drv
agpgart 37072 2 drm,via_agp
vesafb 8924 1
fbcon 44640 72
tileblit 3072 1 fbcon
font 8640 1 fbcon
bitblit 6592 1 fbcon
softcursor 2752 1 bitblit

dmesg
 [17193684.080000] Processing "VIDEO_STREAM_ACTIVE"="1" int_value=1

[17193684.080000] Purging transfer queue

[17193684.080000] WARNING ! Radeon memory controller is misconfigured, disabling capture

[17193684.080000] WARNING ! upgrade your Xserver and DRM driver
[17193684.080000] km: no data is available until AVview or xawtv is started

If you request any - glxinfo - xdpyinfo xinfo - xorg.conf or any else, please email <email address hidden> for requests.
as I visit bug-list infrequently and I'm occupied with other issues too .

 The information I've given should obviate your needing anything else unless you think so, as all - glxinfo - xdpyinfo - xvinfo, and my xorg.conf appear (to me) as normal readings.

The exception is of course, the dmesg error pertaining to xorg 7
not configuring memory registers properly, which is the subject,and the point of this bug report.

I have just recently upgraded my SuSE linux partition to opensuse 10.1 which uses earilier xorg version 6.9 .

Checking to see if my radeon card video capture would ever
 work in xorg, I was astounded by the reality that it does work if
required conditions exist, and stay consistant in xorg.
Video Capture works , and works very well with the earilier xorg
6.9 .
 Something has gone very wrong between releases of xorg 6.9, and 7.0 that disturbs the consistancy of functionality through the radeon driver for ati video cards.

This is quite annoying because we would like to trust that critical
operating system components can be depended on between version releases.

I hope that this can be fixed Soon ! and not put to a subordinate bug shelf.
!!
jwmislan

jwmislan (jwmislan) on 2006-07-26
description: updated
luis (luis-montes) wrote :

similar configuration: Kt266 motherboard, ATI Technologies Inc Radeon RV200 QW [Radeon 7500] graphics card, using Ubuntu Feisty with all the updates. I can confirm that this bug is present with Xorg 7.2.0 and kernel 2.6.20-16-386. Same error is reported by km:
[263532.480000] km: probing 0000:01:00.0
[263532.480000] km: using irq 11
[263532.480000] Register aperture is 0xe1000000 0x00010000
[263532.480000] kms variables: reg_aperture=0xf8f60000
[263532.480000] km: DMA_GUI_STATUS=0x00000002 entries=2
[263532.484000] sizeof(kmfl_template)=780 sizeof(KM_FIELD)=52
[263532.484000] Device 0000:01:00.0 (0x1002:0x5157) corresponds to /dev/video0
[263532.484000] kms variables: reg_aperture=f8f60000
[263602.872000] Processing "VIDEO_STREAM_ACTIVE"="1" int_value=1
[263602.872000] Purging transfer queue
[263602.872000] WARNING ! Radeon memory controller is misconfigured, disabling capture
[263602.872000] WARNING ! upgrade your Xserver and DRM driver
[263602.872000] km: no data is available until AVview or xawtv is started

Bryce Harrington (bryce) on 2007-07-18
Changed in xorg:
importance: Undecided → Medium
status: New → Confirmed
luis (luis-montes) wrote :

Just to check that Xorg 6.9 indeed worked I installed Slackware 10.1 (that came with 6.8, where capture does not work out of the box) in a spare partition and compiled Xorg 6.9 on top. Capture works fine there. I thought that 6.9 and 7.0 shared the same code, the differences were just in the new "modular" build architecture for 7.0 ? Maybe it's some silly #define that somebody forgot to transfer to the new build system? I'll try to find out what's different, but I'm not familiar with the new modular architecture, and just barely familiar with the old, so if anybody knows better, let me know ...

Bryce Harrington (bryce) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release (Hardy)? Thanks in advance.

If it does still occur, please attach your /var/log/Xorg.0.log file.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete
Connor Imes (rocket2dmn) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xserver-xorg-video-ati:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers