[lucid] desktop runs out of video memory on ATI Radeon Mobility 7500

Bug #507148 reported by Marc Deslauriers on 2010-01-13
60
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
High
linux (Ubuntu)
High
Manoj Iyer
Lucid
High
Manoj Iyer
xserver-xorg-video-ati (Ubuntu)
High
Manoj Iyer
Lucid
High
Manoj Iyer

Bug Description

Binary package hint: xorg

This is with the 20100113 lucid i386 livecd on a Thinkpad T30.

The livecd will not boot to the desktop. Selecting "install" from the boot menu will install lucid, but after typing in password at gdm screen, desktop session will not start.

ProblemType: Bug
Architecture: i386
Date: Wed Jan 13 14:32:59 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
Lsusb:
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: IBM 236684U
Package: xorg 1:7.5+1ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-10-generic root=UUID=6420e365-513d-4f8d-97b7-552d3b37da8c ro quiet splash
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu1
 libgl1-mesa-glx 7.7-0ubuntu4
 libdrm2 2.4.17-0ubuntu1
 xserver-xorg-video-intel 2:2.9.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20091125.0061c4db-0ubuntu2
SourcePackage: xorg
Tags: lucid
Uname: Linux 2.6.32-10-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
Xrandr: Error: command ['xrandr', '--verbose'] failed with exit code 1: Can't open display
dmi.bios.date: 08/08/2005
dmi.bios.vendor: IBM
dmi.bios.version: 1IET70WW (2.09 )
dmi.board.name: 236684U
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1IET70WW(2.09):bd08/08/2005:svnIBM:pn236684U:pvrNotAvailable:rvnIBM:rn236684U:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 236684U
dmi.product.version: Not Available
dmi.sys.vendor: IBM
fglrx: Not loaded
glxinfo: Error: [Errno 2] No such file or directory
setxkbmap: Error: command ['setxkbmap', '-print'] failed with exit code 255: Cannot open display "default display"
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-10-generic
xdpyinfo: Error: command ['xdpyinfo'] failed with exit code 1: xdpyinfo: unable to open display "".
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: Error: Cannot open display ":0"
                   Exiting

Marc Deslauriers (mdeslaur) wrote :
tags: added: iso-testing

dmesg shows:

[ 213.812640] [TTM] Failed moving buffer. Proposed placement 0x00060004
[ 213.812650] [TTM] Out of aperture space or DRM memory quota.
[ 213.812660] [drm:radeon_object_create] *ERROR* Failed to allocate TTM object (5914624, 0x00060004, 0)
[ 213.812667] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (5914624, 4, 4096)

summary: - [lucid] xorg fails to start on Thinkpad T30
+ [lucid] desktop fails to start on Thinkpad T30
Bryce Harrington (bryce) on 2010-01-14
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)

Users with this card are reporting that their systems either do not boot up (systems with 16MB video ram) or lose compiz shortly after booting (systems with 32MB). dmesg indicates TTM has run out of memory:

[ 213.812640] [TTM] Failed moving buffer. Proposed placement 0x00060004
[ 213.812650] [TTM] Out of aperture space or DRM memory quota.
[ 213.812660] [drm:radeon_object_create] *ERROR* Failed to allocate TTM object (5914624, 0x00060004, 0)
[ 213.812667] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (5914624, 4, 4096)

[Original Report]
The livecd will not boot to the desktop. Selecting "install" from the boot menu will install lucid, but after typing in password at gdm screen, desktop session will not start.
This is with the 20100113 lucid i386 livecd on a Thinkpad T30.

Architecture: i386
Date: Wed Jan 13 14:32:59 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
MachineType: IBM 236684U
Package: xorg 1:7.5+1ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-10-generic root=UUID=6420e365-513d-4f8d-97b7-552d3b37da8c ro quiet splash
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu1
 libgl1-mesa-glx 7.7-0ubuntu4
 libdrm2 2.4.17-0ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20091125.0061c4db-0ubuntu2
Uname: Linux 2.6.32-10-generic i686
dmi.bios.date: 08/08/2005
dmi.bios.vendor: IBM
dmi.bios.version: 1IET70WW (2.09 )
dmi.board.name: 236684U
dmi.board.vendor: IBM
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.product.name: 236684U
dmi.sys.vendor: IBM

Created an attachment (id=32876)
XorgLog.txt

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] [1002:4c57]
 Subsystem: IBM Device [1014:0517]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B+ DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 66 (2000ns min), Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 11
 Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
 Region 1: I/O ports at 2000 [size=256]
 Region 2: Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at d0120000 [disabled] [size=128K]
 Capabilities: [58] AGP version 2.0
  Status: RQ=48 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2,x4
  Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x4
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: radeon
 Kernel modules: radeonfb, radeon

Created an attachment (id=32877)
CurrentDmesg.txt

Created an attachment (id=32878)
BootDmesg.txt

Fwiw, a very similar bug was reported against -nouveau too:
https://bugs.freedesktop.org/show_bug.cgi?id=24810

I am one of the people seeing this in the Launchpad bug. I've got an IBM T42 with the radeon 7500 (but with 32MB video ram).

Disabling KMS and compiz so far seems to make things better.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed

Discussed this with Marc (the reporter), and I have a T42 with the same radeon chipset, but with 32MB of video ram instead of the T30's 16MB. I can login into the desktop, but after a while compiz dies.

I have this in dmesg:

[88457.578314] [TTM] Failed moving buffer. Proposed placement 0x00060004
[88457.578323] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
[88457.578327] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[88461.802935] [TTM] Failed moving buffer. Proposed placement 0x00060004
[88461.802945] [TTM] Out of aperture space or DRM memory quota.
[88461.802952] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
[88461.802958] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !

This is a very serious regression over Jaunty, where X ran well (with a couple of xorg.conf tweaks). In Lucid, this occurs with or without an xorg.conf (the above was from without). This may affect LTS upgrades significantly.

summary: - [lucid] desktop fails to start on Thinkpad T30
+ [lucid] desktop runs out of video memory on ATI Radeon Mobility 7500
tags: added: regression-potential
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

The upstream bug attached to this was for -nouveau, so I've re-upstreamed it to -ati. Might be one and the same bug, but I think having the radeon team look at it will increase the likelihood of it getting solved.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Unknown
Changed in xserver-xorg-video-ati (Ubuntu Lucid):
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Fwiw, I suspect this will require a fix to the kernel drm code, especially given that it appears to affect -nouveau too, thus I'm adding a kernel task.

Meanwhile, please subscribe to the upstream bug report at https://bugs.freedesktop.org/show_bug.cgi?id=26302 - they may have additional questions or wish you to test something.

Changed in linux (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Marc Deslauriers (mdeslaur) wrote :

Turning off KMS with "radeon.modeset=0" works around the issue for me.

Jeremy Foshee (jeremyfoshee) wrote :

Bryce,
     Thanks, I'll add this to my list.

Regards,

-JFo

Steve Langasek (vorlon) on 2010-01-29
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04 → ubuntu-10.04-beta-1
Changed in linux (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
Bryce Harrington (bryce) wrote :

I talked to airlied about this today, and he suggests it's a kernel issue fixed by some commits upstream:

<bryceh> agd5f, would you mind taking a look at http://bugs.freedesktop.org/show_bug.cgi?id=26302 ? I've had a bunch of people inquiring about that problem.
<airlied> bryceh: you should maybe get some of the r100 fixes from 2.6.33
<airlied> 47381156a8f0d793bacfa346cc4cc515399525f7 will help a bit
<bryceh> airlied, ok thanks
<airlied> but you might need some other bits around it
 if you are really intent on shipping 2.6.32 with KMS enabled it would be nice to backport 2.6.33 radeon into it
 otherwise I doubt we can really help you
 though I expect there are still some r100 issues
 its just not high on anyone's priority list
<bryceh> airlied, will help be provided for the 2.6.33 radeon bits once development focus has moved to 2.6.34?
<airlied> bryceh: yes as we'll be maintaining them for a while longer
<airlied> bryceh: like if you ship 2.6.32 bits please tuirn off KMS
<airlied> I'd rather not be flooded with users complainging in here

Forwarding the bug to the kernel team to ensure these patches are included to solve this problem.

Changed in xserver-xorg-video-ati (Ubuntu Lucid):
milestone: none → lucid-alpha-3
Bryce Harrington (bryce) on 2010-02-09
tags: added: xorg-needs-kernel-fix

I have tried various things to help diagnose this. To enable/disable KMS, I pass radeon.modeset=1 or 0 (respectively). To enable compiz, I turn on desktop effects from within the System/Preferences/Appearance/Visual Effects in Ubuntu. Checking Xorg.0.log, with KMS, EXA is enabled by default. Without KMS, XAA is disabled by default. To force EXA or XAA, I create a simple xorg.conf and use AccelMethod. Performance based on general responsiveness and resizing firefox windows.

Here are my findings:

* KMS/EXA/compiz: compiz crash (out of memory) (this bug, fairly easy to reproduce with a couple of large applications (firefox and OO.o))
* KMS/EXA/no compiz: lockup, but much harder to reproduce (saw it once after several hours of use)
* no KMS/XAA/compiz: lockup and garbling (https://launchpad.net/bugs/513950, https://launchpad.net/bugs/513956)
* no KMS/XAA/no compiz (stable after several full days of use, but needs RenderAccel "off" due to https://launchpad.net/bugs/513968)
* no KMS/forced EXA/compiz: limited testing, seems stable, but performance is very poor. Had difficulty turning on compiz in all circumstances (see this comment: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/513950/comments/4)
* no KMS/forced EXA/no compiz: limited testing, seems stable, but performance is very poor

Performance with EXA and KMS is generally good. Performance with EXA and without KMS is very poor. Performance with XAA without KMS is better than EXA with KMS.

Note that I tried to force XAA when using KMS, by using AccelMethod "XAA", but EXA was used anyway. Xorg.0.log gave:
...
(**) RADEON(0): Option "AccelMethod" "XAA"
...
(II) RADEON(0): EXA: Driver will not allow EXA pixmaps in VRAM
...
(II) Loading sub module "exa"
(II) LoadModule: "exa"
(II) Loading /usr/lib/xorg/modules/libexa.so
(II) Module exa: vendor="X.Org Foundation"
        compiled for 1.7.3.902, module version = 2.5.0
        ABI class: X.Org Video Driver, version 6.0
(--) Depth 24 pixmap format is 32 bpp
(II) RADEON(0): [DRI2] Setup complete
(II) RADEON(0): Front buffer size: 5808K
(II) RADEON(0): VRAM usage limit set to 20577K
(==) RADEON(0): Backing store disabled
(II) RADEON(0): Direct rendering enabled
(II) RADEON(0): Render acceleration enabled for R100 type cards.
(II) RADEON(0): Setting EXA maxPitchBytes
(II) EXA(0): Driver allocated offscreen pixmaps
(II) EXA(0): Driver registered support for the following operations:
(II) Solid
(II) Copy
(II) Composite (RENDER acceleration)
(II) UploadToScreen
(II) DownloadFromScreen
(II) RADEON(0): Acceleration enabled
(==) RADEON(0): DPMS enabled
(==) RADEON(0): Silken mouse enabled
(II) RADEON(0): Set up textured video

This unsurprisingly resulted in the same out of memory bugs as KMS/EXA tests above.

XAA doesn't work with KMS. Is there any chance you could try the drm from the soon to be released 2.6.33 and the latest fixes from the mesa 7.7 branch?

I'd be happy to test anything to get this bug resolved. I'll need help from Bryce for this testing though.

Jamie, you should be able to get what you need out of xorg-edgers and the kernel team's kernel crack ppa.

[Btw, take care not to block on needing something from me, as I'm utterly swamped with non-bug work currently (and may be so for a while).]

Bryce, all the help I needed was making sure I had the latest drivers with matched libraries. Since you say that is all in xorg-edgers, that's really I all need (thanks).

Running kernel 2.6.33-020633rc7-generic with the following from xorg-edgers:
libdrm-intel1 2.4.17+git20100209.fdcde592-0ubuntu0sarvatt
libdrm-nouveau1 2.4.17+git20100209.fdcde592-0ubuntu0sarvatt
libdrm-radeon1 2.4.17+git20100209.fdcde592-0ubuntu0sarvatt
libdrm2 2.4.17+git20100209.fdcde592-0ubuntu0sarvatt
libgl1-mesa-dri 7.8.0~git20100207.1a45c2bc-0ubuntu0sarvatt3
libgl1-mesa-glx 7.8.0~git20100207.1a45c2bc-0ubuntu0sarvatt3
libglu1-mesa 7.8.0~git20100207.1a45c2bc-0ubuntu0sarvatt3
xserver-common 2:1.7.4.902~git20100205+server-1.7-branch.85b04bb0-0ubuntu0sarvatt3
xserver-xorg-core 2:1.7.4.902~git20100205+server-1.7-branch.85b04bb0-0ubuntu0sarvatt3
xserver-xorg-input-evdev 1:2.3.2+git20100121.e81cd935-0ubuntu0sarvatt
xserver-xorg-input-synaptics 1:1.2.0+git20100120.f7559a5e-0ubuntu0sarvatt
xserver-xorg-video-ati 1:6.12.99+git20100205.b7ca1ab1-0ubuntu0sarvatt
xserver-xorg-video-intel 2:2.10.0+git20100209.41784e15-0ubuntu0sarvatt
xserver-xorg-video-radeon 1:6.12.99+git20100205.b7ca1ab1-0ubuntu0sarvatt
xserver-xorg-video-vesa 1:2.3.0~git20100120.069c1f82-0ubuntu0sarvatt2

Preliminary testing shows things seem better with KSM/EXA/compiz. I will run this configuration over the next few days and will report back either way.

So far no compiz crashes or X lockups, but I do see in dmesg:
[ 1619.165507] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1621.021223] radeon 0000:01:00.0: f68b6a00 reserve failed for wait
[ 1622.019113] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1625.180631] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1635.140476] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1638.083010] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1651.321702] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1654.865365] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1796.527251] radeon 0000:01:00.0: f2e8a900 reserve failed for wait
[ 1812.721192] radeon 0000:01:00.0: f3ddc100 reserve failed for wait
[ 1812.950009] radeon 0000:01:00.0: f2e8a600 reserve failed for wait
[ 1827.848932] radeon 0000:01:00.0: f3ddc100 reserve failed for wait
[ 2030.822699] radeon 0000:01:00.0: f0b5fc00 reserve failed for wait
[ 2077.402390] radeon 0000:01:00.0: f0b5fc00 reserve failed for wait
[ 2133.374053] radeon 0000:01:00.0: f4197900 reserve failed for wait
[ 2138.921975] radeon 0000:01:00.0: f4197900 reserve failed for wait
[ 2176.425268] radeon 0000:01:00.0: f68b6a00 reserve failed for wait
[ 2182.572320] radeon 0000:01:00.0: f4197900 reserve failed for wait
[ 2294.752798] radeon 0000:01:00.0: f0b5ed00 reserve failed for wait
[ 2305.080870] radeon 0000:01:00.0: f4197900 reserve failed for wait
[ 2306.921465] radeon 0000:01:00.0: f4197900 reserve failed for wait
[ 2324.561097] radeon 0000:01:00.0: f68b6a00 reserve failed for wait
[ 2353.239300] radeon 0000:01:00.0: f11f1100 reserve failed for wait
[ 2386.327292] radeon 0000:01:00.0: f0b5ff00 reserve failed for wait
[ 2387.067951] radeon 0000:01:00.0: f68b6a00 reserve failed for wait
[ 2387.880629] radeon 0000:01:00.0: f0b5ff00 reserve failed for wait

Jamie Strandboge (jdstrand) wrote :

FYI-- gave extensive testing results for the current Lucid kernel and ati drivers in http://bugs.freedesktop.org/show_bug.cgi?id=26302#c7.

Manoj Iyer (manjo) on 2010-02-09
Changed in xserver-xorg-video-ati (Ubuntu Lucid):
assignee: nobody → Manoj Iyer (manjo)
Manoj Iyer (manjo) wrote :

can someone one please test the kernel in the link below and report results back here ?

http://people.ubuntu.com/~manjo/lp507148-lucid/

This kernel has the radeon fixes that might fix this issue.

This is a 64bit kernel, I can also upload a x86 kernel on request.

Changed in xserver-xorg-video-ati (Ubuntu Lucid):
status: Triaged → Incomplete

On Tue, Feb 9, 2010 at 7:43 PM, Manoj Iyer <email address hidden> wrote:
>
> *snip*
>
> This is a 64bit kernel, I can also upload a x86 kernel on request.
>

Radeon 7500 is far older than x86_64. It is from year 1999 if my
memory servers right.

Jamie Strandboge (jdstrand) wrote :

I'll need i386.

Manoj Iyer (manjo) wrote :

@pauli, heh, did not even think of it !

@jdstrand, uploaded i386 image.

Manoj Iyer (manjo) on 2010-02-09
Changed in linux (Ubuntu Lucid):
assignee: nobody → Manoj Iyer (manjo)
status: Triaged → Incomplete
Marc Deslauriers (mdeslaur) wrote :

@Manoj: unfortunately, the test kernel images don't work on my Thinkpad T30. It just turns the screen black and nothing happens.

Marc Deslauriers (mdeslaur) wrote :

Even removing "quiet" and "splash" doesn't work. I get the kernel boot messages and as soon as gdm is supposed to come up, the screen turns black.

Manoj Iyer (manjo) wrote :

@marc can you pls try with kernel boot option "nomodeset" , that will disable the kernel modesetting feature which is not good. But atleast we will know that the kernel boots.

Marc Deslauriers (mdeslaur) wrote :

With nomodeset, the kernel boots. When gdm comes up, I have a garbled screen with a mouse cursor that displays in the left half of the screen, and I hear the login drumroll sound.

Marc Deslauriers (mdeslaur) wrote :

Tomorrow, I'll try the the xorg-edgers PPA to see if that fixes it.

Marc Deslauriers (mdeslaur) wrote :

Sorry, no luck with the xorg-edgers PPA either. Blank screen when booted normally, corrupted screen when booted with "nomodeset".

I installed the following from xorg-edgers:
libdrm2_2.4.17+git20100209.fdcde592-0ubuntu0sarvatt_i386.deb
libdrm-intel1_2.4.17+git20100209.fdcde592-0ubuntu0sarvatt_i386.deb
libdrm-nouveau1_2.4.17+git20100209.fdcde592-0ubuntu0sarvatt_i386.deb
libdrm-radeon1_2.4.17+git20100209.fdcde592-0ubuntu0sarvatt_i386.deb
libgl1-mesa-dri_7.8.0~git20100207.1a45c2bc-0ubuntu0sarvatt3_i386.deb
libgl1-mesa-glx_7.8.0~git20100207.1a45c2bc-0ubuntu0sarvatt3_i386.deb
libglu1-mesa_7.8.0~git20100207.1a45c2bc-0ubuntu0sarvatt3_i386.deb
radeontool_1.5+git+20091128-0ubuntu0tormod_i386.deb
xserver-common_2%3a1.7.4.902~git20100205+server-1.7-branch.85b04bb0-0ubuntu0sarvatt3_all.deb
xserver-xorg-core_2%3a1.7.4.902~git20100205+server-1.7-branch.85b04bb0-0ubuntu0sarvatt3_i386.deb
xserver-xorg-input-evdev_1%3a2.3.2+git20100121.e81cd935-0ubuntu0sarvatt_i386.deb
xserver-xorg-input-synaptics_1%3a1.2.0+git20100120.f7559a5e-0ubuntu0sarvatt_i386.deb
xserver-xorg-video-ati_1%3a6.12.99+git20100205.b7ca1ab1-0ubuntu0sarvatt_i386.deb
xserver-xorg-video-intel_2%3a2.10.0+git20100209.41784e15-0ubuntu0sarvatt_i386.deb
xserver-xorg-video-radeon_1%3a6.12.99+git20100205.b7ca1ab1-0ubuntu0sarvatt_i386.deb
xserver-xorg-video-vesa_1%3a2.3.0~git20100120.069c1f82-0ubuntu0sarvatt2_i386.deb

I tried using 2.6.33-rc7 from the Ubuntu kernel dailies. This kernel was very slow (unrelated to this bug-- it seemed to be IO or possibly filesystem related).

I then tried the backported radeon fixes for the Ubuntu Lucid kernel as mentioned in the Launchpad bug:
"can someone one please test the kernel in the link below and report results back here ? http://people.ubuntu.com/~manjo/lp507148-lucid/
This kernel has the radeon fixes that might fix this issue."

Using KMS/EXA/compiz, this kernel did not crash compiz nearly as quickly on my T42, but after prolonged usage compiz crashed with this in dmesg:

[15040.618564] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
[16936.764884] [TTM] Failed moving buffer. Proposed placement 0x00060004
[16936.764891] [TTM] Out of aperture space or DRM memory quota.
[16936.764895] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
[16936.764898] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[17015.483860] Unpin not necessary for d095f600 !

Using plymouth with KMS results in a system lockup very early during boot (with no output that I could see).

Marc Deslauriers mentioned in the Launchpad bug that his T30 (16MB of video ram as opposed to my 32MB) did not show any significant improvement with the xorg-edgers packages and backported radeon fixes.

I might also mention that connecting my T42 to an external 1680x1050 monitor (my LCD is 1400x1050) would make compiz crash readily when using xrandr.

Created an attachment (id=33219)
T42 dmesg after updating to latest drivers

Created an attachment (id=33220)
T42 Xorg.log after using updated drivers

Marc Deslauriers (mdeslaur) wrote :

After uninstalling plymouth, I get to the gdm screen, and can actually log in. Unfortunately, as soon as I start firefox, the window decorations don't show up and I get the "Out of aperture space or DRM memory quota" message in dmesg.

Marc Deslauriers (mdeslaur) wrote :

After discussion with jdstrand, the following makes my laptop usable:

- Uninstalling plumouth
- Turning off KMS with radeon.modeset=0
- Using an xorg.conf with the following:
  - Option "AccelMethod" "XAA"
  - Option "RenderAccel" "off"

By default, compiz is disabled for me.

Jamie Strandboge (jdstrand) wrote :

Using the xorg-edgers drivers and Manoj's kernel seemed to help somewhat. It took longer to crash compiz but ultimately it did crash with the same error. :( This is with no xorg.conf file, with KMS, with EXA and with compiz. Attaching an external monitor with a higher resolution than the laptop (eg 1680x1050 vs 1400x1050) will crash compiz readily when using xrandr (same out of memory errors).

Installing plymouth makes the laptop completely unusable-- with a hard system lock very early in the boot process and no text displayed on the screen. Only the backlight is on.

As mentioned, a usable, but a regressed configuration (over Jaunty, where compiz is usable) is to disable KMS, use XAA with RenderAccel off, disable desktop effects (compiz) and remove plymouth.

For more details, see my extensive comments in the upstream bug.

Manoj Iyer (manjo) wrote :

@jdstrand, @marc

Can you give the kernel below a spin and let me know if that works better ?

http://people.canonical.com/~manjo/lp507148-lucid/v2/

Marc Deslauriers (mdeslaur) wrote :

@Manoj: With the new kernel I still get the blank screen when using plymouth.

Booting with radeon.modeset=0 now shows me the plymouth text-mode progress bar, which I wasn't getting before, but still comes up with a corrupted screen.

Jamie Strandboge (jdstrand) wrote :

Manoj,

plymouth is still a no go using radeon.modeset=0 or 1. Removing plymouth allows me to login with gdm. I'll report back as soon as I have problems or in a couple of days if no problems (ie, for the KMS/EXA/compiz combination).

More backports from Manoj on our Ubuntu kernel did not solve the issue. From the launchpad bug:

KMS/EXA/compiz still does not work. The following is from kern.log. Compiz crashing did not occur until 'Feb 11 08:03:07', but there seemed to be problems before then too:

Feb 10 14:35:44 lupin kernel: [ 62.914451] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 10 14:37:46 lupin kernel: [ 185.291637] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 10 15:07:14 lupin kernel: [ 1952.805591] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 10 15:07:14 lupin kernel: [ 1952.805601] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 10 15:07:14 lupin kernel: [ 1952.805604] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 10 17:46:34 lupin kernel: [11512.724244] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 10 17:48:58 lupin kernel: [11656.683713] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 10 17:48:58 lupin kernel: [11656.683721] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 10 17:48:58 lupin kernel: [11656.683725] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 10 23:05:59 lupin kernel: [30677.701509] ipw2200: Firmware error detected. Restarting.
Feb 11 07:17:34 lupin kernel: [60173.557731] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 11 07:17:35 lupin kernel: [60173.785871] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 11 07:35:38 lupin kernel: [61257.151019] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 11 07:35:38 lupin kernel: [61257.151027] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 11 07:35:38 lupin kernel: [61257.151030] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 11 07:39:25 lupin kernel: [61483.682603] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 11 07:39:25 lupin kernel: [61483.682611] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 11 07:39:25 lupin kernel: [61483.682614] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 11 07:47:07 lupin kernel: [61946.073790] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 11 08:03:07 lupin kernel: [62906.436901] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 11 08:03:07 lupin kernel: [62906.436908] [TTM] Out of aperture space or DRM memory quota.
Feb 11 08:03:07 lupin kernel: [62906.436912] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 11 08:03:07 lupin kernel: [62906.436915] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !

Jamie Strandboge (jdstrand) wrote :

Manoj,

KMS/EXA/compiz still does not work. The following is from kern.log. Compiz crashing did not occur until 'Feb 11 08:03:07', but there seemed to be problems before then too:

Feb 10 14:35:44 lupin kernel: [ 62.914451] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 10 14:37:46 lupin kernel: [ 185.291637] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 10 15:07:14 lupin kernel: [ 1952.805591] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 10 15:07:14 lupin kernel: [ 1952.805601] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 10 15:07:14 lupin kernel: [ 1952.805604] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 10 17:46:34 lupin kernel: [11512.724244] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 10 17:48:58 lupin kernel: [11656.683713] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 10 17:48:58 lupin kernel: [11656.683721] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 10 17:48:58 lupin kernel: [11656.683725] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 10 23:05:59 lupin kernel: [30677.701509] ipw2200: Firmware error detected. Restarting.
Feb 11 07:17:34 lupin kernel: [60173.557731] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 11 07:17:35 lupin kernel: [60173.785871] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 11 07:35:38 lupin kernel: [61257.151019] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 11 07:35:38 lupin kernel: [61257.151027] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 11 07:35:38 lupin kernel: [61257.151030] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 11 07:39:25 lupin kernel: [61483.682603] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 11 07:39:25 lupin kernel: [61483.682611] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 11 07:39:25 lupin kernel: [61483.682614] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
Feb 11 07:47:07 lupin kernel: [61946.073790] [drm:radeon_object_busy_domain] *ERROR* radeon: failed to reserve object for waiting.
Feb 11 08:03:07 lupin kernel: [62906.436901] [TTM] Failed moving buffer. Proposed placement 0x00060004
Feb 11 08:03:07 lupin kernel: [62906.436908] [TTM] Out of aperture space or DRM memory quota.
Feb 11 08:03:07 lupin kernel: [62906.436912] [drm:radeon_object_list_validate] *ERROR* radeon: failed to validate.
Feb 11 08:03:07 lupin kernel: [62906.436915] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !

Manoj Iyer (manjo) wrote :

@jdstrand can you pls turn off kms and try this kernel ? In Jaunty there was no radeon KMS suppport, so lets see if my small set of kernel patch backports work, then you will .

It will not be possible to do a complete back port of drm at this point, I did a backport and I am building a kernel now, and it amounts to 172 patches.

Jamie Strandboge (jdstrand) wrote :

From irc:
12:27 < manjo> jdstrand, can you turn off kms and try with the kernel you installed yesterday ?
12:27 < jdstrand> manjo: I am running it now-- with XAA and no compiz. XAA with compiz locks up
12:27 < manjo> jdstrand, radeon+kms did not exist for jaunty, so we want to make sure the other bits work ok
12:28 < jdstrand> manjo: XAA and compiz worked on jaunty

Jamie Strandboge (jdstrand) wrote :

Marking Confirmed since all information has been provided.

Changed in linux (Ubuntu Lucid):
status: Incomplete → Confirmed
Changed in xserver-xorg-video-ati (Ubuntu Lucid):
status: Incomplete → Confirmed
Jamie Strandboge (jdstrand) wrote :

This is not fixed with 2.6.32-14.20-generic and up to date xorg-edgers drivers.

Bryce Harrington (bryce) wrote :

As per the upstream discussion, this is believed to be a kernel drm bug rather than an issue needing fixed in the DDX, so we don't need to keep this bug open against -ati.

Changed in xserver-xorg-video-ati (Ubuntu Lucid):
milestone: lucid-alpha-3 → ubuntu-10.04-beta-1
status: Confirmed → Invalid
Andy Whitcroft (apw) wrote :

@Jamie -- could you test the kernel in the PPA below and report back here. Thanks!

    https://edge.launchpad.net/~apw/+archive/red/+packages

After trying the fully-backported drm code from .33 (see the LP bug), KMS+compiz+EXA crashed, but this time only this was in the kern.log:

[ 738.880732] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation

(In reply to comment #17)
> After trying the fully-backported drm code from .33 (see the LP bug),
> KMS+compiz+EXA crashed, but this time only this was in the kern.log:
>
> [ 738.880732] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation
>

Was there any additional info? Maybe in your dmesg?

Created an attachment (id=33665)
kern.log with backported drm from .33

That was from dmesg. There was nothing in XorgLog either. Here is the full kern.log for the session containing the crash.

Jamie Strandboge (jdstrand) wrote :

I've installed it and am testing (with latest drivers from xorg-edgers). So far so good, but sometimes it takes a while to hit the bug. I'll report back with positive results in a couple days or right away if there is a problem.

Jamie Strandboge (jdstrand) wrote :

meh, as soon as I submitted that last comment, I opened a gnome-terminal, typed dmesg and compiz crashed. This time all that is in dmesg is:

[ 738.880732] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation

This is with KMS, with compiz and with EXA (no xorg.conf).

For my own records or anyone trying to get it to crash somewhat quickly, it seems this will do it (eventually-- I don't have a simple reproducer yet):
open firefox
open OO.o Writer
open OO.o Draw
open Gimp
open gnome-terminal
open a second gnome-terminal, and send a lot of text to it (like dmesg)

Jamie Strandboge (jdstrand) wrote :

Here is the dmesg using apw's kernel.

Jamie Strandboge (jdstrand) wrote :
Manoj Iyer (manjo) wrote :

@jdstrand there is an upstream patch that fixes this ERROR, I will cherry-pick this patch (linux-next commit 17aafccab4352b422aa01fa6ebf82daff693a5b3) and build a kernel for you to test today.

With a fully backported .33 DRM to 2.6.32 and the latest xorg-edgers drivers, the situation has not improved.

$ cat /proc/version_signature
Ubuntu 2.6.32-16.24-generic

* no KMS/XAA/compiz: lockup and garbling. No errors in kern.log --
  https://launchpad.net/bugs/513950, https://launchpad.net/bugs/513956
* KMS/EXA/compiz: compiz crash. Errors in kern.log (see below)
  https://launchpad.net/bugs/507148

  Messages in kern.log are:
  [ 415.461546] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 1754.333393] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 1754.347688] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 2089.468099] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 2089.482369] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 3899.003282] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 3922.245559] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
  [ 3948.117491] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !

Andy Whitcroft (apw) on 2010-03-09
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Changed in xserver-xorg-video-ati (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → none
Jamie Strandboge (jdstrand) wrote :

On up to date Lucid as of 2010-03-09, this is still a problem with no xorg.conf file, with KMS and with compiz. (X defaults to EXA).

$ cat /proc/version_signature
Ubuntu 2.6.32-16.24-generic

Messages in kern.log are:
[ 415.461546] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 1754.333393] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 1754.347688] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 2089.468099] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 2089.482369] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 3899.003282] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 3922.245559] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
[ 3948.117491] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !

Marc Deslauriers (mdeslaur) wrote :

Tested an up to date Lucid as for 2010-03-09 on my T30. I can actually log into the desktop now but unfortunately, as soon as I open a couple of windows, the window decorations don't appear and I get the same messages in kern.log as jdstrand above.

I am using no xorg.conf, with KMS, and no compiz (no compiz is the default setting on a T30). I have Ubuntu 2.6.32-16.24-generic also.

Seth (seth-hollen) wrote :

OK about half of the time when I boot up I get a corrupted login screen it's black except for some staic looking black and white stuff at the bottom quarter of my screen.

mine is a Thinkpad T43 with ATI X300 video card.

If at the corrupted screen I goto another terminal I get a lot of these errors

------------------
Mar 12 21:06:13 sparrow kernel: [ 120.041087] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Mar 12 21:06:13 sparrow kernel: [ 120.053581] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(7).
Mar 12 21:06:13 sparrow kernel: [ 120.053586] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Mar 12 21:06:13 sparrow kernel: [ 120.053926] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(8).
Mar 12 21:06:13 sparrow kernel: [ 120.053929] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Mar 12 21:06:13 sparrow kernel: [ 120.058659] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(9).
Mar 12 21:06:13 sparrow kernel: [ 120.058664] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Mar 12 21:06:13 sparrow kernel: [ 120.061766] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(10).
Mar 12 21:06:13 sparrow kernel: [ 120.061770] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
Mar 12 21:06:13 sparrow kernel: [ 120.066168] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(11).
------------------------------------------------------

Killing Xorg does nothing. but if I reboot (sometimes reboot 3 or 4 times) it will go away and boot and run fine.

what can I do to help?

Lollerke (pumba88) wrote :

Try it without KMS.
DRM causes a lot of problem with KMS:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/509273

Manoj Iyer (manjo) wrote :

Here is the calling sequence before it gets to that error. Looks like it really is not able to allocate any more memory in some cases.

radeon_bo_list_validate():
r = ttm_bo_validate(&bo->tbo, &bo->placement, true, false);

ttm_bo_validate():
ret = ttm_bo_move_buffer(bo, placement, interruptible, no_wait);

ttm_bo_move_buffer():
        spin_lock(&bo->lock);
        ret = ttm_bo_wait(bo, false, interruptible, no_wait);
        spin_unlock(&bo->lock);

ttm_bo_wait():
ret = driver->sync_obj_wait(sync_obj, sync_obj_arg, lazy, interruptible);
@sync_obj_wait: See ttm_fence_api.h not found.

since radeon driver is in use, and these functions are setup by
the driver. sync_obj_wait maps to radeon_sync_obj_wait.

radeon_sync_obj_wait():
return radeon_fence_wait((struct radeon_fence *)sync_obj, interruptible);

radeon_fence_wait(): returns a negative number when a lot of windows are open.

Created an attachment (id=34228)
fallback on VRAM memory placement

Created an attachment (id=34229)
don't print pointless errors.

I've attached two patches that let compiz start and run here as long as I dont have a screen size greater than 2048 in any direction.

compiz fails badly if > 2048 screen size.

Marc Deslauriers (mdeslaur) wrote :

In case no one has noticed, there are a couple of patches in the upstream bug report now...

Manoj Iyer (manjo) wrote :

Built kernel using patch from upstream, compiz seems work great on the T42, but I have been running it only for 4hrs now, will update with more info this evening. If I dont see any problems by eobd today I will submit the 2 patches to Lucid for review.

Manoj Iyer (manjo) wrote :

Screen shot of the T42 running all possible apps with System->Preferences->Appearence->Visual Effects set to Extra.

Marc Deslauriers (mdeslaur) wrote :

The upstream patches solve the problem on my T30!

Manoj Iyer (manjo) wrote :

test kernel available at, you may need to --force-all to install the headers. http://people.canonical.com:/home/manjo/public_html/lp507148-lucid

Andy Whitcroft (apw) on 2010-03-30
Changed in linux (Ubuntu Lucid):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable various multitouch devices
    - LP: #541453

  [ Chase Douglas ]

  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ John Johansen ]

  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.

  [ Luke Yelavich ]

  * [Config] Enable Nouveau DRM module on powerpc

  [ Stefan Bader ]

  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673

  [ Steve Conklin ]

  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * drm/i915: Part of: Add initial bits for VGA mode...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released

These patches resolve this issue completely. After a lot of automated testing and many hours of real world use with up to date packages that include these fixes, it no longer crashes. Thanks to everyone who helped fix this. :)

From our kernel changelog:
  [ Upstream Kernel Changes ]
  ...
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  ...

Jamie Strandboge (jdstrand) wrote :

After a lot of automated testing and many hours of real world use with up to date packages, it no longer crashes. Thanks to everyone who helped fix this (especially Manoj :).

Rovano (rovano) wrote :

Ubuntu 10.04 beta2 32bit+updates 10.4.2010
Seeing video *.flv in Totem and...
Graphic card is integrated in motherboard Ati X1250.

Rovano (rovano) wrote :

Ubuntu 10.04 beta2 32bit+updates 10.4.2010
Seeing video *.flv in Totem and...
Graphic card is integrated in motherboard Ati X1250.

Rovano (rovano) wrote :
Rovano (rovano) wrote :
Rovano (rovano) wrote :
Rovano (rovano) wrote :

Compiz and KMS was enabled.

Rovano (rovano) wrote :
Rovano (rovano) wrote :

Och sorry for post comments. I dont see bug released :/

Yves Glodt (yglodt) wrote :

I still see this issue on my acer travelmate 8000 with it's ati radeon mobility 9700 (rv350) using the -20 kernel.

when I boot with kms enabled, I get to see plymouth nicely, but as soon as kdm starts, the screen is corrupted. swicthing back to the console shows the same errors printed out continously as in #61 https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/507148/comments/61

Yves Glodt (yglodt) wrote :

Probably my last comment belongs to issue 509273

Jamie Strandboge (jdstrand) wrote :

Yves and Rovano, this bug is specifically for the Radeon 7500 which is now fixed. Your bugs seem different and you should file new bugs. Thanks!

M E (bobhdj) wrote :

Sadly have to report that I have issues with Lucid and my Radeon 7500. Randomly the system goes black, shows some quick text (the only part I have caught says something like "checking battery state") and I am prompted to log back in.
  Also, when booting up, the splash screen is in funky (maybe inverted?) colors. After login there is a fairly long wait till the desktop becomes visible.
  I have a Thinkpad T40, and had no issues with 9.04.

Happy to help if I can in any way

Jamie Strandboge (jdstrand) wrote :

M E, the splash screen issue is bug #564471. You can workaround this by removing the 'splash' option from GRUB_CMDLINE_LINUX_DEFAULT in /etc/default grub and running 'sudo update-grub'.

Regarding the system going to black, I have seen this on a T40 too and it is a significant regression. Can you file a new bug and reference it here? It would be great if you could provide steps to reproduce as well. Thanks!

It seems the fallback fix is not in Linus' tree yet. The discussion continued in late April at http://lists.freedesktop.org/archives/dri-devel/2010-April/000309.html with proposed better patches, but apparently they're now waiting for testing feedback on the newest patch revision?

Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Andy Whitcroft (apw) wrote :

It appears that the original fix for this issue has triggered a regression on other systems. Upstream indicates that a slightly different fix should be applied. Could those affected please test the kernels at the URL below, these contains the original fix reverted and brings up to the latest apparent fixes from upstream. Please report any testing back here. The kernels are here:

    http://people.canonical.com/~apw/lp652934-maverick/

Thanks!

Jamie Strandboge (jdstrand) wrote :

I can verify that the new fix doesn't regress Lucid release (which has the original fix) if provided a Lucid kernel.

Andy Whitcroft (apw) wrote :

@Jamie -- fair enough. Below should be the same fixes back ported to Lucid, perhaps you could test those and report back here. Kernels are at the URL below:

    http://people.canonical.com/~apw/lp652934-lucid/

Thanks.

Marc Deslauriers (mdeslaur) wrote :

I have tested the test kernel on my Thinkpad T30, and it seems to work fine in the few minutes I've played around with it.

Jamie Strandboge (jdstrand) wrote :

I have installed the i386 lucid kernel and so far have no problems. On the unpatched kernel it would sometimes take a while to manifest (sometimes days on my machine) so I'd like to continue testing for a few days before saying there are no regressions.

Jamie Strandboge (jdstrand) wrote :

Ok, I have installed this kernel in a couple of places and am waiting to see real world use. That said, I have a script that:

1. plays a 500M flv file in totem, in repeat mode
2. launches 'glxgears -geometry 1400x1050' (the native resolution of the display, but not full screen mode)
3. launches /usr/bin/gnome-*, firefox and oowriter one at a time, in a loop

This brings the system to a crawl, which is fine but with the updated kernel I get a bunch of messages like this in kern.log:
[ 2168.016130] radeon 0000:01:00.0: ec7c4600 reserve failed for wait

It wasn't until I added glxgears to the mix that these messages started showing up every couple of seconds (prior to running glxgears it only happened once). I booted back into the latest official lucid kernel and ran the same script and saw those messages did not show up in kern.log. The system seems otherwise fine (ie no crashes), but I don't know if that message is purely informational or an indication of something going wrong.

I can also say that with the latest official lucid kernel, the guest session is completely unusable, though differently than from Vish in the upstream bug. After upgrading to the patched lucid kernel, the guest session is fully usable.

Marc Deslauriers (mdeslaur) wrote :

Laptop is still running, but I'm getting the "reserve failed for wait" messages also.

Following Jamie's comment, I tried the guest session, and it's now working for me also.

Vish (vish) wrote :

I had reported Bug #652934 , which was a regression to the patch here.

I can confirm the same kern.log messages Jamie mentions, and i have also *not* noticed any visible side-effects related to those messages.

Andy Whitcroft (apw) wrote :

@jamie -- i am unsure why the new kernel would provoke those more than before (or are we saying it didn't work before so you could not provoke it). But looking at the latest kernels this messasge is now officially gone from the kernel under the commit below, the commentary there implies this message is totally benign:

  commit a8c051f0c8d2f81c665e820f765aaddf86161640
  Author: Jean Delvare <email address hidden>
  Date: Fri Oct 8 14:34:49 2010 +0200

    drm/radeon/kms: Silent spurious error message

    I see the following error message in my kernel log from time to time:
    radeon 0000:07:00.0: ffff88007c334000 reserve failed for wait
    radeon 0000:07:00.0: ffff88007c334000 reserve failed for wait

    After investigation, it turns out that there's nothing to be afraid of
    and everything works as intended. So remove the spurious log message.

    Signed-off-by: Jean Delvare <email address hidden>
    Reviewed-by: Jerome Glisse <email address hidden>
    Signed-off-by: Dave Airlie <email address hidden>

Jamie Strandboge (jdstrand) wrote :

@Andy -- I'm saying that using what is in official Lucid works fine for everything except the guest session (which I never tried until comment #94). If I run my automated tests on official Lucid, there are no 'reserve failed for wait' log messages ever. If I run my automated tests with your kernel, there are 'reserve failed for wait' log messages, but everything appears otherwise ok and the guest session now works. There are more 'reserve failed for wait' log messages by far when running glxgears than anything else.

I have tested the driver on Andy's kernel quite a bit (all with KMS/EXA -- the default in a Lucid install):
* suspend/resume works
* compiz works
* metacity works
* switching the System/Preferences/Appearance/Visual Effects to 'None', 'Normal' and 'Extra' all work
* firefox works
* OpenOffice.org writer works
* flash works
* full screen totem totem movie works
* ~12 hours of automated tests with glxgears, totem playing a large flv file in repeat mode, and many applications launched/closed all works as well as before

In addition, the kernel has seen real world testing on another system (also T42 with the same radeon 7500 chipset) with firefox, flash plugin, wine, evolution, empathy, suspend/resume, etc, for one work day. That system did not have any of the spurious log messages (no extended use of 3D other than compiz effects). In terms of performance, the system feels the same, but I have not performed instrumented performance tests.

I looked at the 'drm/radeon/kms: Silent spurious error message' patch and I think it is ok to push Andy's kernel with this patch applied. I will continue to keep Andy's current kernel on the other system for continued real world testing and report back if there are any issues, but I think getting the fix into lucid-proposed is a go. Once if lucid-proposed I can retest with my automated script and get that kernel real world testing as well.

Changed in xserver-xorg-driver-ati:
importance: High → Unknown
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.