[KMS][RV530] compiz very slow on Radeon AGP video cards

Bug #496653 reported by Hebert
100
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Mesa
Fix Released
Medium
desktop-screenshots
New
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

$ uname -a
Linux ubuntu 2.6.32-7-generic #10-Ubuntu SMP Sun Dec 6 13:54:12 UTC 2009 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu lucid (development branch)
Release: 10.04
Codename: lucid

compiz:
  Instalado: 1:0.8.4-0ubuntu9
  Candidato: 1:0.8.4-0ubuntu9
  Tabela de versão:
 *** 1:0.8.4-0ubuntu9 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

On Ubuntu Lucid using KMS (ON) + AGPMODE (4x/8x) compiz, while is on, turns the system unbearably slow. I mean, even a click on the gnome menu takes seconds to actually happen.

[lspci]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV530 [Radeon X1600] [1002:71c2]
     Subsystem: PC Partner Limited Device [174b:0850]

Revision history for this message
Tormod Volden (tormodvolden) wrote :

Thanks for your report. Can you please run "apport-collect 496653" to attach more information? Does it help to turn off AGP with radeon.agpmode=-1 ?

affects: compiz (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Tormod Volden (tormodvolden)
status: New → Incomplete
Revision history for this message
Hebert (hebert-bernardo) wrote : apport-collect data

Architecture: amd64
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Package: xserver-xorg-video-ati 1:6.12.99+git20091215.3a30210d-0ubuntu0tormod
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-8-generic root=UUID=16df3350-8c5e-4c18-a40f-4c5d9c46a94a ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=pt_BR.UTF-8
 LANGUAGE=pt_BR.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-8.12-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5~3ubuntu4
 libgl1-mesa-glx 7.8.0~git20091217.294bd53d-0ubuntu0tormod
 libdrm2 2.4.16+git20091217.f1660c24-0ubuntu0sarvatt
 xserver-xorg-video-intel 2:2.9.99.901+git20091211.8ecf70ea-0ubuntu0sarvatt
 xserver-xorg-video-ati 1:6.12.99+git20091215.3a30210d-0ubuntu0tormod
Tags: lucid
Uname: Linux 2.6.32-8-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 03/14/2006
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FD
dmi.board.name: 8VT880P Combo
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFD:bd03/14/2006:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rn8VT880PCombo:rvr:cvn:ct3:cvr:
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.32-8-generic

Revision history for this message
Hebert (hebert-bernardo) wrote : BootDmesg.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : CurrentDmesg.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : Dependencies.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : Lspci.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : Lsusb.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : PciDisplay.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : ProcCpuinfo.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : ProcInterrupts.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : ProcModules.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : UdevDb.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : UdevLog.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : XorgLog.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : XorgLogOld.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : Xrandr.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : glxinfo.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : setxkbmap.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : xdpyinfo.txt

apport-collect data

Revision history for this message
Hebert (hebert-bernardo) wrote : xkbcomp.txt

apport-collect data

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
Revision history for this message
Hebert (hebert-bernardo) wrote : Re: Compiz very slow using Kernel-Modesetting with Radeon driver on AGP hardware

At this present time, I'm already using the xorg-edgers PPA, but just like Lucid archive packages, to no help.

I believe you're also the PPA's maintainer. Right?

It doesn't help to use radeon.agpmode=-1 Only nomodeset does, but I lose all the goods KMS brings on.

I'm available to further help.

Let's hope we can sort this bug out fast.

Thanks

summary: - Compiz very slow using Kernel-Modesetting with Radeon driver on AGP
- hardware
+ [KMS][RV530] compiz very slow on AGP hardware
Revision history for this message
Tormod Volden (tormodvolden) wrote : Re: [KMS][RV530] compiz very slow on AGP hardware

Can you please try the drm-next and the daily kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/ ?

Revision history for this message
Hebert (hebert-bernardo) wrote :

I'm trying right now the -current drm-next kernel. I booted using radeon.modeset=1 radeon.agpmode=8 but compiz doesn't work.

$ compiz --replace
compiz (core) - Fatal: Software rendering detected.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

Revision history for this message
Hebert (hebert-bernardo) wrote :

Let re-post it:

I tested using radeon.modeset=1 radeon.agpmode=8 on the linux kernel 2.6.32-996-generic_2.6.32-996.200912181514_amd64 and 2.6.33-999-generic_2.6.33-999.200912181148_amd64

Compiz on both kernels don't work.

$ compiz --replace
compiz (core) - Fatal: Software rendering detected.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

The same output on both.

Any ideas?

Revision history for this message
Hebert (hebert-bernardo) wrote :

Just to let you know

I have also tried to boot with KMS (ON) and AGP disabled (radeon.agpmode=-1) but it doesn't work either.

Revision history for this message
In , Nemrood (nemrood) wrote :

I use Radeon 4650 AGP (RV730). System: Archlinux. CPU: AMD Athlon(tm) 64 Processor 3000+

I use kernel 2.6.33 rc8 with ati kms support. I have compiled mesa and driver from git (exact compile options in attachments). I can get no more than 600fps in glxgears.

glxgears
2529 frames in 5.0 seconds = 505.756 FPS
2415 frames in 5.0 seconds = 482.971 FPS
2440 frames in 5.0 seconds = 487.853 FPS
1905 frames in 5.0 seconds = 380.890 FPS
1901 frames in 5.0 seconds = 380.119 FPS
1935 frames in 5.0 seconds = 386.888 FPS
1887 frames in 5.0 seconds = 377.399 FPS
1843 frames in 5.0 seconds = 368.464 FPS
^C

I must say, I didn't do anything when I ran glxgears. What is strange just after I startx, I get 550-600 fps. When I start a few apps (like, psi, firefox, a few urxvt terminals (nothing more is running in background except openbox and tint2) it looks like above. After some time, I have ~ 110fps (as when I'm writing this report now).

Tried also extreme tux racer. I can run it ( ~ 9fps), but it crashes after while (1024x768, rest of the options not touched).

Inside the attachment I've put all used pkgbuilds, kernel config, glxinfo, X log.

If you need any more info, please ask - I'll do my best to answer.

Regards

Revision history for this message
In , Nemrood (nemrood) wrote :

Created an attachment (id=33405)
configs and logs

Revision history for this message
In , Martin-peres (martin-peres) wrote :

Well, I have also been experiencing the same behaviour for at least one month.

I'm using an HD4470 -> rv740 with the latest radeon-testing branch.

Also, when dragging glxgears in a composited environnement, gears are slowing down to a few fps.

Tell me if you need more information.

Revision history for this message
In , Lists-andyfurniss (lists-andyfurniss) wrote :

(In reply to comment #0)

> I use kernel 2.6.33 rc8 with ati kms support.

I have a similar sounding problem on an AGP card since early Feb.

http://article.gmane.org/gmane.comp.video.dri.devel/42770

As I am running git drm-radeon-testing, to fix all I need to do is -

git revert db78e27de7e29a6db6be7caf607cf803d84094aa

I suppose you could try making a normal diff out of the revert below.

    Revert "drm/ttm: Avoid conflicting reserve_memtype during ttm_tt_set_page_caching."

    This reverts commit db78e27de7e29a6db6be7caf607cf803d84094aa.

diff --git a/drivers/gpu/drm/ttm/ttm_tt.c b/drivers/gpu/drm/ttm/ttm_tt.c
index e2123af..9c2b1cc 100644
--- a/drivers/gpu/drm/ttm/ttm_tt.c
+++ b/drivers/gpu/drm/ttm/ttm_tt.c
@@ -198,26 +198,17 @@ EXPORT_SYMBOL(ttm_tt_populate);
 static inline int ttm_tt_set_page_caching(struct page *p,
                                          enum ttm_caching_state c_state)
 {
- int ret = 0;
-
        if (PageHighMem(p))
                return 0;

- if (get_page_memtype(p) != -1) {
- /* p isn't in the default caching state, set it to
- * writeback first to free its current memtype. */
-
- ret = set_pages_wb(p, 1);
- if (ret)
- return ret;
+ switch (c_state) {
+ case tt_cached:
+ return set_pages_wb(p, 1);
+ case tt_wc:
+ return set_memory_wc((unsigned long) page_address(p), 1);
+ default:
+ return set_pages_uc(p, 1);
        }
-
- if (c_state == tt_wc)
- ret = set_memory_wc((unsigned long) page_address(p), 1);
- else if (c_state == tt_uncached)
- ret = set_pages_uc(p, 1);
-
- return ret;
 }
 #else /* CONFIG_X86 */
 static inline int ttm_tt_set_page_caching(struct page *p,

Revision history for this message
In , agd5f (agd5f) wrote :

This bug is a duplicate of this one:
http://bugzilla.kernel.org/show_bug.cgi?id=15328

Revision history for this message
In , Nemrood (nemrood) wrote :

(In reply to comment #3)

Thanks, this seems to work. Now I have stable ~540 fps in glxgears,

However, overall 3d performance is still rather poor: ~10fps in scorched3d minimum settings 1024x768, same in extreme tux racer. Tried q2 demo too and it seems slightly better. Though I know some cases where ppl on r6xx or even r7xx cards achieve much better performance than me.

Could it be that if my card is AGP one instead of PCIE is the cause of such poor performance (this is what I suspect)? I hope something could be done with this.

Revision history for this message
In , Liquid-acid (liquid-acid) wrote :

Same card model as Martin here (and PCIe also) and also hitting this bug.

Revision history for this message
In , Liquid-acid (liquid-acid) wrote :

Already wrote that on kernel.org, but it looks like that my problem is not really related to the DRM since it also happens when KMS is disabled.

Probably some change in mesa or libdrm...

Revision history for this message
In , Liquid-acid (liquid-acid) wrote :

I'm really at a loss here.

Just went back several weeks in git history with xf86-video-ati, libdrm and mesa and the problem still happens.

Furthermore I noticed that it's not only the 3D performance that collapsed. 2D is also affected. Playing a Youtube video was previously no problem at all, now the image is jerky and the system is fully loaded - most of the cycles are burned by X - something is really wrong here....

Bryce Harrington (bryce)
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce)
tags: added: compiz
Revision history for this message
In , agd5f (agd5f) wrote :

*** Bug 26816 has been marked as a duplicate of this bug. ***

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: Tormod Volden (tormodvolden) → nobody
affects: xserver-xorg-driver-ati → mesa
Changed in mesa:
status: Unknown → Confirmed
Revision history for this message
In , Lists-andyfurniss (lists-andyfurniss) wrote :

(In reply to comment #9)
> *** Bug 26816 has been marked as a duplicate of this bug. ***
>

I wasn't too sure about this when it was changed and running todays drt confirms for me, that they are not the same issue.

comment #4 has this as a dup of

http://bugzilla.kernel.org/show_bug.cgi?id=15328

which was a regression caused by a specific commit affecting 2D & 3D perf over time, which now seems to be fixed in current drt.

http://bugs.freedesktop.org/show_bug.cgi?id=26816

was not a regression and running todays drt has actually got worse (though possibly not same xserver) - I can't even play the vid I used in that bug using x11 now, mplayer shows 125% in vo.

Revision history for this message
In , agd5f (agd5f) wrote :
Revision history for this message
In , Lists-andyfurniss (lists-andyfurniss) wrote :

(In reply to comment #11)
> Does xf86-video-ati from git master help? Specifically this commit:
> http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=488c9fd8300505cc6c0c2f8f0f00849f27cc5d63
>

No that doesn't help this -vo x11 issue.

It does boost xv perf so that kms now beats ums, previously kms ate a bit more cpu, but nothing like as much as this x11 issue ie. not really measurable at SD res but about 18% more 1280x720@30fps.

I retested with the last drt kernel and the figures are still the same as posted in my bug - so it's a further drt regression not xserver.

Bryce Harrington (bryce)
tags: added: lucid
Bryce Harrington (bryce)
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Revision history for this message
Tpugliese (thomas-pugliese) wrote : Re: [KMS][RV530] compiz very slow on AGP hardware

I see this problem as well, but not 100% of the time. It seems that I can get usable 3D performance with KMS if I reboot with radeon.modeset=0, select "Normal" for Visual Effects, then reboot again with radeon.modeset=1. It's still not great compared to when KMS is disabled but much better than if I boot with KMS enabled then start compiz after logging in.

I have been able to use this workaround twice now after running in the slow desktop problem.

Bryce Harrington (bryce)
description: updated
Revision history for this message
In , Lists-andyfurniss (lists-andyfurniss) wrote :

(In reply to comment #12)

This is fixed for me now that the ttm page allocator is in drm-radeon-testing.

Revision history for this message
In , Lists-andyfurniss (lists-andyfurniss) wrote :

(In reply to comment #13)
> (In reply to comment #12)
>
> This is fixed for me now that the ttm page allocator is in drm-radeon-testing.

The further commits to drt may have regressed this again - I can't be sure as I can't run todays head, but while bisecting for -

https://bugs.freedesktop.org/show_bug.cgi?id=27536

I noticed on the "goods" close to the problematic commit that x11 putimage perf had regressed.

Revision history for this message
supercompman (supercompman) wrote : Re: [KMS][RV530] compiz very slow on AGP hardware

Seeing the same problem here with an AGP Radeon x1650. I don't know if this will narrow anything down, but I've noticed that With Compiz disabled, when I run Neverball it runs just fine, but when I enter the Options menu, this bug is triggered and it becomes too slow to be usable.

Revision history for this message
In , Lists-andyfurniss (lists-andyfurniss) wrote :

(In reply to comment #14)

> The further commits to drt may have regressed this again - I can't be sure as I
> can't run todays head, but while bisecting for -
>
> https://bugs.freedesktop.org/show_bug.cgi?id=27536
>
> I noticed on the "goods" close to the problematic commit that x11 putimage perf
> had regressed.

That bug is fixed now and the perf with todays drt is OK, so as far as I am concerned this bug is fixed.

Revision history for this message
hpis2cool (hpis2cool) wrote : Re: [KMS][RV530] compiz very slow on AGP hardware

Since I upgraded to Lucid from Ubuntu Jaunty, my 3D performance has been about half what it used to be. I use a Toshiba Satellite laptop. It's so bad that even with the desktop effects set as "normal" the mouse will sometimes stutter or skip, it's hard to describe. But I used to be able to play HD videos on Jaunty, so this bug is very upsetting.

Revision history for this message
darkshado (darksoldier1) wrote :

Same problem, when i install ubuntu lucid with "KMS"=ON the 3D effect with compiz are very slow, the solution for me was to desactived KMS with this command:

sudo su
echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

Now compiz is working fine, but i hope they gonna solve this bug! :)

my graphic card -> ati x1650pro agp

my motherboard -> asus A7N8X-Deluxe rev. 2.0

darkshado (darksoldier1)
Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Jan-Christoph Deinert (jan-deinert) wrote :

I have the same problem - extremely slow window behavior with compiz turned on - with my ATI mobility radeon X600.

Revision history for this message
Hebert (hebert-bernardo) wrote :

This bug will probably be solved on Maverick.

I'm already running Gallium 3D using xorg-edgers ppa and only now it is possible to have KMS (ON) and Compiz (ON) on a usable way

It still lacks some adjustment (performance wise). Artifacts are showing up. But, finally Gallium has arrived!!!

I did even get my HD playback back on VLC.

your mileage may vary.

I don't recommend to use Gallium 3D on production machines... yet.

http://i.imgur.com/2Phgl.png

Revision history for this message
Federico Fallabrino (ffalla-gmail) wrote :

I have the same problem, compiz goes so slow that it becomes impossible to operate the asset.

Graphics card ==> X1550

summary: - [KMS][RV530] compiz very slow on AGP hardware
+ [KMS][RV530] compiz very slow on Radeon AGP hardware
summary: - [KMS][RV530] compiz very slow on Radeon AGP hardware
+ [KMS][RV530] compiz very slow on Radeon AGP video cards
Revision history for this message
VolCh (vcher) wrote :

I have the same with my Radeon 9600XT (RV350 chip, AGP). Any 3D apps (compiz, glxgears, games) are very slow after upgrade from 9.10 to 10.04.

Revision history for this message
John Doe (jodo-deactivatedaccount) wrote :

I don't know if this help, but I suffer the same on an ATI X600m (PCIE). No AGP Card. But I can confirm that disabling KMS recovers a lot of performance.

Revision history for this message
Federico Fallabrino (fede-falla) wrote :

I just got a kernel update Lucile and this, or update tables and ati drivers from http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu, left the compiz running very stable and fast.

Revision history for this message
darkshado (darksoldier1) wrote :

Yes because they turn OFF KMS.

Revision history for this message
Dominik Smatana (dominik-smatana) wrote :

I'm not sure if this is related to this bug, but I got the same problem (ATI Radeon x1650 + compiz = VERY slow) so far.

Compiz is working very fine again after today's update (linux 2.6.32-23.37).

Revision history for this message
Sven (anders-anduras) wrote :

Ok, I tested the new kernel with my X1600 Pro HDMI (1002:71c2 / 1002:71e2), but
it is still slow. I'm not sure, but I have the feeling, that it's faster than the older kernel,
but I can be mistaken.
Currently I'm using "options radeon modeset=0" to run a usable system...

Revision history for this message
Torpedo (ellechon) wrote :

As Dominik, I have an x1650 and with any level of visual effects activated it starts to freeze sometimes. If it is needed some more data just ask for it.

Revision history for this message
Alberto Verdoja (nerduma) wrote :

As all of you, I don't know why, but Radeon + KMS + Compiz doesn't work: it's too slow!
I use an ATI X1600.
Even if I use Radeon driver and KMS is enable, Compiz doesn't work.
Hope it will be fixed soon, i'm very curious to know the benefit of KMS .
(Of course Compiz works with KMS disabled)

Revision history for this message
julien (versiontrial1) wrote :

Same here
Compiz unusable on X1950 AGP+radeon+KMS
glxgears takes over 70% cpu

Revision history for this message
Tpugliese (thomas-pugliese) wrote : Re: [Bug 496653] Re: [KMS][RV530] compiz very slow on Radeon AGP video cards

Uh oh. You mentioned glxgears. Now this will never get fixed.

Seriously though. Does anyone know if this has been fixed upstream?

On Wed, Jul 28, 2010 at 1:29 PM, julien <email address hidden> wrote:
> Same here
> Compiz unusable on X1950 AGP+radeon+KMS
> glxgears takes over 70% cpu
>
> --
> [KMS][RV530] compiz very slow on Radeon AGP video cards
> https://bugs.launchpad.net/bugs/496653
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Mesa: Confirmed
> Status in “xserver-xorg-video-ati” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: compiz
>
> $ uname -a
> Linux ubuntu 2.6.32-7-generic #10-Ubuntu SMP Sun Dec 6 13:54:12 UTC 2009 x86_64 GNU/Linux
>
> $ lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description:    Ubuntu lucid (development branch)
> Release:        10.04
> Codename:       lucid
>
> compiz:
>  Instalado: 1:0.8.4-0ubuntu9
>  Candidato: 1:0.8.4-0ubuntu9
>  Tabela de versão:
>  *** 1:0.8.4-0ubuntu9 0
>        500 http://archive.ubuntu.com lucid/main Packages
>        100 /var/lib/dpkg/status
>
> On Ubuntu Lucid  using KMS (ON) + AGPMODE (4x/8x) compiz, while is on, turns the system unbearably slow. I mean, even a click on the gnome menu takes seconds to actually happen.
>
> [lspci]
> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV530 [Radeon X1600] [1002:71c2]
>        Subsystem: PC Partner Limited Device [174b:0850]
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mesa/+bug/496653/+subscribe
>

Revision history for this message
Dominik Smatana (dominik-smatana) wrote :

Well.. my compiz is very slow again after fresh reinstall of Ubuntu 10.04 (x1650)

Changed in mesa:
importance: Unknown → Medium
Revision history for this message
Tpugliese (thomas-pugliese) wrote :

The Maverick RC live CD shows much improved performance on my setup.

Revision history for this message
spoon_man (stonedonkies) wrote :

I can confirm that this bug appears to have been resolved in the Maverick RC. (I performed a clean install of the root partition, from 10.04 to 10.10, while retaining the original /home partition, if that matters.) Compiz works now without a hitch for this Radeon x1550 AGP card.

Revision history for this message
Tormod Volden (tormodvolden) wrote :

Great! On basis of this, and Hebert's comment 47, I will close this bug report.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
affects: xserver-xorg-driver-ati → desktop-screenshots
Changed in mesa:
importance: Medium → Unknown
Changed in mesa:
importance: Unknown → Medium
Revision history for this message
In , Andreas-boll-dev (andreas-boll-dev) wrote :

(In reply to comment #15)
> (In reply to comment #14)
>
> > The further commits to drt may have regressed this again - I can't be sure as I
> > can't run todays head, but while bisecting for -
> >
> > https://bugs.freedesktop.org/show_bug.cgi?id=27536
> >
> > I noticed on the "goods" close to the problematic commit that x11 putimage perf
> > had regressed.
>
> That bug is fixed now and the perf with todays drt is OK, so as far as I am
> concerned this bug is fixed.

Closing.

Changed in mesa:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.