Ubuntu

screen corruption with Radeon 4770

Reported by Phil Hughes on 2009-10-02
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

There is reproducable corruption of the screen when using a Sapphire Radeon 4770 card with the open source radeon and fglrx drivers.

It takes the form of a "chequered" effect, looking a bit like a chequer / checkerboard.

In Gnome, this is most noticeable when the screen goes greyed (eg when typing gksudo ..) but can also be seen at other times eg in the previews shown in System Preferences->Appearance->Theme. The menus in KeePassX are corrupted.

In KDE, this is much more noticeable right away in the the menu and the ublog on the desktop.

When using the fglrx driver the effect does not show when the screen is greyed, though the theme previews do still show the same corruption.

 An attachment shows a screenshot of the grey screen effect.

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 2 13:22:54 2009
DistroRelease: Ubuntu 9.10
Package: xorg 1:7.4+3ubuntu5
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=86a4bbc7-fdbc-440c-963e-2b1acd6dfc20 ro quiet splash
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu6
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: xorg
Uname: Linux 2.6.31-11-generic x86_64
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 09/02/2007
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BX97510J.86A.1487.2007.0902.1724
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: D975XBX
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD27094-302
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrBX97510J.86A.1487.2007.0902.1724:bd09/02/2007:svn:pn:pvr:rvnIntelCorporation:rnD975XBX:rvrAAD27094-302:cvn:ct2:cvr:
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-11-generic

Phil Hughes (phil-hughes) wrote :
Bryce Harrington (bryce) on 2009-10-03
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2009-10-03
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Alexandre Gatelli (algatelli) wrote :

This bug also affect the fgrlx proprietary driver.

ceg (ceg) wrote :

Logging into kde the errors are all over the place.

ceg (ceg) on 2009-12-29
summary: - Occasional screen corruption with Radeon 4770
+ screen corruption with Radeon 4770
ceg (ceg) wrote :

Looks like they had the same prob, but I don't understand their solutions:
http://www.phoronix.com/forums/showthread.php?t=18687

ceg (ceg) on 2009-12-30
description: updated
Phil Hughes (phil-hughes) wrote :

Following ceg's link to Phoronix, I can confirm that setting Option "EXANoDownloadFromScreen" "true" in Section "Device" of xorg.conf fixes / works round this problem.

Ceg - you need an xorg.conf with this line in it. However you may not have an existing xorg.conf - the following xorg.conf worked for me. If you need more help than this, you should probably ask in the forums.

Section "Screen"
 Identifier "Default Screen"
 DefaultDepth 24
EndSection

Section "Device"
 Identifier "Default Device"
 Driver "ati"
 Option "EXANoDownloadFromScreen" "true"
EndSection

ceg (ceg) wrote :

Phil, thank you for pointing me to the xorg.conf. (your help worked out great :)

description: updated
Ákos Maróy (akos-maroy) wrote :

I also have a similar issue, with a Mobility Radeon HD 5830 card - but the above xorg.conf sample makes the whole X unable to start :(

Bryce Harrington (bryce) on 2010-02-27
tags: added: corruption
Bryce Harrington (bryce) on 2010-03-03
tags: added: kubuntu
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers