Ubuntu

[RV200] (32MB) certain windows drawn garbled when XAA is used

Reported by Michael McKinley on 2009-09-09
582
This bug affects 114 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Andy Whitcroft
xserver-xorg-driver-ati
Won't Fix
Medium
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned
Nominated for Karmic by sprelacart

Bug Description

Binary package hint: xserver-xorg-video-ati

Certain applications, such as notify-osd and gnome-do, always draw windows that are unusably garbled.

I have not experienced this behavior in any other application, only gnome-do and notify-osd, nor can I reproduce it on a computer with nvidia drivers (both machines are running karmic and are completely up-to-date).

The issue is not otherwise related to a quirk in my system config, as I can reproduce the bug on an alpha 5 livecd.

ProblemType: Bug
Architecture: i386
Date: Tue Sep 8 20:41:40 2009
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 002: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: IBM 2379R5U
Package: xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-9-generic root=UUID=7f994ed0-cee1-4748-8123-e1dee66dd27c ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.12+git20090801.45078630-0ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.31-9-generic i686
dmi.bios.date: 06/02/2006
dmi.bios.vendor: IBM
dmi.bios.version: 1RETDPWW (3.21 )
dmi.board.name: 2379R5U
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1RETDPWW(3.21):bd06/02/2006:svnIBM:pn2379R5U:pvrThinkPadT42:rvnIBM:rn2379R5U:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2379R5U
dmi.product.version: ThinkPad T42
dmi.sys.vendor: IBM
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-9-generic

[lspci]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] [1002:4c57]
     Subsystem: IBM Device [1014:0530]

Created an attachment (id=26375)
xorg.conf

Created an attachment (id=26376)
Xorg.0.log

Does

    Option "RenderAccel" "off"

work around the problem? If not, what about commenting out driver options, in particular "AGPFastWrite", "EnableDepthMoves" or "EnablePageFlipping"?

Thank you!

Adding
   Option "RenderAccel" "off"

to xorg.conf actually solved it.

Binary package hint: xserver-xorg-video-ati

Certain applications, such as notify-osd and gnome-do, always draw windows that are unusably garbled.

I have not experienced this behavior in any other application, only gnome-do and notify-osd, nor can I reproduce it on a computer with nvidia drivers (both machines are running karmic and are completely up-to-date).

The issue is not otherwise related to a quirk in my system config, as I can reproduce the bug on an alpha 5 livecd.

ProblemType: Bug
Architecture: i386
Date: Tue Sep 8 20:41:40 2009
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 002: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: IBM 2379R5U
Package: xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-9-generic root=UUID=7f994ed0-cee1-4748-8123-e1dee66dd27c ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.12+git20090801.45078630-0ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.31-9-generic i686
dmi.bios.date: 06/02/2006
dmi.bios.vendor: IBM
dmi.bios.version: 1RETDPWW (3.21 )
dmi.board.name: 2379R5U
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1RETDPWW(3.21):bd06/02/2006:svnIBM:pn2379R5U:pvrThinkPadT42:rvnIBM:rn2379R5U:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2379R5U
dmi.product.version: ThinkPad T42
dmi.sys.vendor: IBM
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-9-generic

Michael McKinley (m-mckinley) wrote :
Bryce Harrington (bryce) on 2009-09-09
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
jean-baptiste (jbateau54) wrote :

openoffice

jean-baptiste (jbateau54) wrote :

firefox

Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
nahtgesicht (nahtgesicht) wrote :

I am experiencing this bug on karmic with the radeon driver with a Radeon Mobility M6 LY on a IBM X31 Thinkpad.

Package: xserver-xorg-video-radeon
Version: 1:6.12.99+git20090929.7968e1fb-0ubuntu1

Linux X31 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

lolikandr (lolikandr) wrote :

I have the same bug in https://bugs.launchpad.net/notify-osd/+bug/462490.
Also i have the same bug with yakuake https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/462549.
My solution:
1. sudo init 1 # for exiting from Xorg
2. # choose root shell in menu
3. Xorg -configure # make default config of Xorg
4. cp /root/xorg.conf.new /etc/X11/xorg.conf
5. nano /etc/X11/xorg.conf
6. # change line from
   #Option "AccelMethod" # <str>
into
   Option "AccelMethod" "EXA" # <str>
7. # F3 and F2
8. init 3 # or reboot

Jan-Philipp Litza (jplitza) wrote :

That may solve the garbled windows, but drops performance significantly (scrolling a simple file list takes several seconds with EXA for me [ATI Radeon M7])

As pointed out in bug 455601, the driver runs out of memory if using EXA with only 32MB VRAM, so reducing virtual screen size or colour depth are workarounds.

This might be less of a problem when using KMS, where video memory is handled by a memory manager.

summary: - certain windows drawn garbled when compiz is disabled
+ (EXA and 32MB) certain windows drawn garbled when compiz is disabled
A. Tombol (atombol) wrote :

i have this bug with 16 bits depth, M6 LY
EXA causes garbage around fonts for me
last time I tried KMS, X wouldn't load

summary: - (EXA and 32MB) certain windows drawn garbled when compiz is disabled
+ (EXA and 32MB) certain windows drawn garbled when XAA is used

I can say that the problem is even more severe for me. I get hard locks if I don't use EXA on my T42 with a fresh install of Ubuntu 9.10. The live cd and install worked fine, then I logged in, connected to my wifi, enabled encrypted swap and rebooted. I could get to gdm, but then after authenticating the computer would hard lock. Using EXA allowed my to login successfully and everything seems to be working ok.

$ lspci|grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
(II) RADEON(0): Detected total video RAM=32768K, accessible=65536K (PCI BAR=131072K)
(--) RADEON(0): Mapped VideoRAM: 32768 kByte (64 bit DDR SDRAM)

Jamie Strandboge (jdstrand) wrote :

For me, I did the 'sudo Xorg -configure' command to get an xorg.conf, then adjusted it to have:
Section "Device"
        ...
        Driver "radeon"
        Option "AccelMethod" "EXA"
EndSection

Jamie Strandboge (jdstrand) wrote :

Actually, bug #429295 was pointed out to me. Simply using:
Option "RenderAccel" "off"

works and I don't have to use EXA to prevent lockups. I had in my notes that I've needed this on my Radeon 7500 for quite some time. Couldn't we detect the card and do this automatically so new installs can benefit?

summary: - (EXA and 32MB) certain windows drawn garbled when XAA is used
+ (32MB) certain windows drawn garbled when XAA is used

Tormod, i have these symptoms on a 16MB M6 LY
this description still doesn't represent everyone affected

Tormod Volden (tormodvolden) wrote :

a.tom, ok, it's <= 32 MB so it's close enough.

For those who want to try KMS, there are some issues with KMS in Karmic due to a module loading order problem. Try adding "fbcon" to /etc/modules. See also https://wiki.ubuntu.com/X/RadeonKMS

Tormod Volden (tormodvolden) wrote :

We should probably disable RenderAccel when using XAA. This might only be a problem when running out of VRAM, but we are only using XAA in low-memory conditions in the first place.

Jamie Strandboge (jdstrand) wrote :

I previously wrote:
"Actually, bug #429295 was pointed out to me. Simply using:
 Option "RenderAccel" "off"

 works and I don't have to use EXA to prevent lockups."

Turns out this was a lie. It helped but I would still get lockups. The RenderAccel did help with bug #429295 though.

Andy Whitcroft (apw) on 2009-10-29
Changed in ubuntu-release-notes:
assignee: nobody → Andy Whitcroft (apw)
status: New → In Progress
Andy Whitcroft (apw) on 2009-10-29
Changed in ubuntu-release-notes:
status: In Progress → Fix Released
Tormod Volden (tormodvolden) wrote :

> Turns out this was a lie. It helped but I would still get lockups. The RenderAccel did help with bug #429295 though.

Jamie, I believe this report is about the same issue. Please file a new bug for your lockup issue (and check https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk).

jean-baptiste (jbateau54) wrote :

hello,
somebody with a T42 (2374) can look after this bug ( https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/446674 ). It's a Mesa 7.6 issue. Personnaly i solve my probleme as i explain in the last comment of this bug.
thank in advance
jb

Steve McGrath (smcgrath23) wrote :

I've been working around this for myself and others by setting AccelMethod to EXA.
Can I assume that if this works, it's preferable to setting RenderAccel off?
I'm just guessing that disabling RenderAccel would hurt performace, worse than switching to EXA?
I could use a little clarification here for when I'm helping people deal with this on the forums and IRC...

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Tormod Volden (tormodvolden) wrote :

Steve, yes, using EXA instead of disabling RenderAccel should generally be better for performance. However, EXA has proven to perform poorly on cards with little memory, which is why XAA is chosen by default for these cards.

Dr. Kenobi (drkenobi) wrote :

I am experiencing this bug on karmic with ATI Mobility Radeon 7500 Graphics Controller with 32 MB of DDR video RAM on a Compaq Evo n610c. I have problems with the notifications and with System Monitor

Dr. Kenobi (drkenobi) wrote :
JW (james-west22) wrote :

I am experiencing this bug on karmic with ATI Mobility Radeon 7500 Graphics Controller on a Dell C640. I have problems with the OSD-notifications and with System Monitor.

I have not been able to run Xorg -configure because there is a lock file /tmp/.X0-lock that I can't seem to work around. I tried the recovery console but fails to go into recovery mode and just boots back to the login screen.

so yes, big problem here

Steve McGrath (smcgrath23) wrote :

In regards to comment #22, in order to run X -configure, you must not have X running. The best way in my experience to accomplish this is to switch to a virtual console with Ctrl-Alt-F1, and stop GDM with "sudo /etc/init.d/gdm stop"

Stefan (stefan-helmer) wrote :

My Inspiron 4150 also has a Mobility Radeon 7500 card and has the same issues.

Colin Beckingham (colbec) wrote :

Toshiba Satellite 1110 with small video memory also has this problem.
Tried above suggestions related to xorg.conf and acceleration settings, this results in a system that refuses to boot into Ubuntu and has to be hard reset.
What does work (so far) on this machine is to set System -> Preferences -> Appearance -> Visual Effects to "None".
However good luck getting to change the setting in the GUI since it defaults to "Normal" which is marginally usable on this old machine.

Ylon (ylon) wrote :

I can confirm (on [url=http://www.thinkwiki.org/wiki/Category:T42]Thinkpad T42[/url]) same issue on Karmic:

glxgears: (no crash)
[code]*********************************WARN_ONCE*********************************
File radeon_tcl.c function radeon_run_tcl_render line 499
Rendering was 79 commands larger than predicted size. We might overflow command buffer.
***************************************************************************[/code]

google earth 5 (crash):

[code]*********************************WARN_ONCE*********************************
File radeon_tcl.c function radeon_run_tcl_render line 499
Rendering was 426 commands larger than predicted size. We might overflow command buffer.
***************************************************************************

drmRadeonCmdBuffer: -12. Kernel failed to parse or rejected command stream. See dmesg for more info.
Google Earth has caught signal 11.[/code]

Stellarium (crash on run):
[code]QProcess: Destroyed while process is still running.
 -------------------------------------------------------
[ This is Stellarium 0.10.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2009 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "/home/user/.stellarium/log.txt"
File search paths:
  0 . "/home/user/.stellarium"
  1 . "/usr/share/stellarium"
Config file is: "/home/user/.stellarium/config.ini"
Segmentation fault[/code]

Second Life: (freeze to complete crash)
[code]*********************************WARN_ONCE*********************************
File radeon_tcl.c function radeon_run_tcl_render line 499
Rendering was 127 commands larger than predicted size. We might overflow command buffer.
***************************************************************************[/code]

all with or without compiz effect.
-------------end report-------

I had similar problem back on Linux Mint 7 (wich is based upon ubuntu) when I'd try update some xorg file on ~tormod update (it add some dependencies with something like ~libgl-drm~ like). Switch back with the normal xorg dependencies it did work, but update with the ~tormod update, give me back these problem.

I would like to try again the old xorg driver (without ~tormod addon) to test if this solve my problem.. but I don't know how since it was on another repository (the xorg file with ~less~ problem)

Tormod Volden (tormodvolden) wrote :

Ylon, please file a new bug (using ubuntu-bug xserver-xorg-video-ati) because this report is not about crashes or warnings. Identify your graphics card with "lspci -nn | grep VGA".

tyskey (taisuke) wrote :

I just disabled all the visual effects in System > Preferences > Appearance > Visual Effects and worked like a charm.

IBM ThinkPad X31 Mobility Radeon

David Barth (dbarth) on 2009-11-15
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
assignee: Canonical Desktop Team (canonical-desktop-team) → Bryce Harrington (bryceharrington)
tags: added: iso-testing
Martin G Miller (mgmiller) wrote :

I have a Dell C510 with the radeon mobility M6 ly video and in Karmic, using no xorg.conf or one with xaa acceleration causes the screen garbling noted above. I also can't run system monitor or some of the screen savers without getting a badly distorted window or no display at all.

Creating an xorg.conf and changing to exa allows everything to display correctly, but the video performance is badly degraded. I have not experienced any lockups in either mode.

pcr (petitchevalroux) wrote :

[code]
pcr@thinkbuntu:~$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
[/code]

I just updated some xorg package but no fix for the moment. XAA does not support compiz EXA is too slow for me. I tried KMS (thanks toTormod Volden cmt #27) the only benefit is that both XAA and EXA are able to launch compiz (EXA used to freeze my X31) but i get some other strange FX (see attachments)

For me the right configuration is XAA+RenderAccel="False" ... EXA is too slow on my laptop.

pcr (petitchevalroux) wrote :
zcacogp (ogp) wrote :

I am having problems with my X31 IBM Thinkpad, and think it may be this bug. (I was referred here from this thread:

http://ubuntuforums.org/showthread.php?p=8416481#post8416481 )

My xorg.conf file is copied at the end of this post, and things work as they should sometimes. If you turn desktop effects off, re-login, and turn them on again then all is fine and the machine works as it should. However, if you logout and login again then you get a series of lines along the top of the screen, which get progressively worse. Turning desktop effects off and on again re-sets it, but it then goes bad again next time you reboot. Forgive me for saying this, but this would imply that it can work, but something is reset when the machine is rebooted which causes this problem - non?

ALSO, whenever the green lines appear (as described above), I find myself unable to select things which are placed on my desktop. Is this a known facet of this problem?

Oli.

P.S. My xorg.conf file is thus:

Section "Device"
 Identifier "Radeon7500"
 Driver "ati"
 BusID "PCI:1:0:0"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Option "AGPMode" "4" # optional
 Option "AGPSize" "32" # optional
 Option "DRI" "true" # imprtant
 Option "DRI2" "false" # important
 Option "RenderAccel" "true"
 Option "AccelMethod" "XAA"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Randall Ross (randall) wrote :

The above changes do not allow Compiz to run at all on my computer with ATI controller:

[code]
randall@ubuntuwillchangetheworld:~$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
[/code]

Does anyone know the command line equivalent of enabling the following?
1) System:Preferences:Appearance Preferences: Visual Effects: Normal
1) System:Preferences:Appearance Preferences: Visual Effects: Extra

Perhaps a command line will yield further clues...

Tormod Volden (tormodvolden) wrote :

As far as I know, the only difference between Normal and Extra is the number of active compiz plugins, which can be inspected with gconf-editor (or by running: gconftool2 --get /apps/compiz/general/allscreens/options/active_plugins). On my computer (lucid) it just adds "shift" and "wobbly".

A. Tombol (atombol) wrote :

here is how I work around this bug on a Radeon Mobility M6 LY with only 8MBs of vram:
first of all, it's a good idea to install the latest driver from the xorg edgers drivers only ppa:
xserver-xorg-video-radeon 1:6.12.99+git20091125.0061c4db-0ubuntu0tormod2
then we need to optimize our settings to fit in the low memory:
-set the screen depth to 16 bits. on these old displays it's just barely noticeable, I highly recommend this because of the advantages.
-set virtual size to your screen size, if you don't use external display.
these must be enough to use DRI on EXA (compositioning, readable notifications, etc.) perfectly, if you have 16MB or more ram.
i had to do some additional tuning, because with EXA I had problems with font rendering (black pixel garbage around fonts)
the key to the solution is the FBTexPercent option in xorg.conf. with it, you can add extra memory to EXA at the expense of OpenGL textures. setting it to 32% made the font garbage go away for me.
see my attached xorg.conf
please mind that the other options that work for me (fastwrite, acceldfs, etc.) may cause problems on your machine.
and one last hint:
if you manage to enable DRI, you can gain a little more power by enabling HyperZ in driconf.

A. Tombol (atombol) wrote :

sorry, i forgot to add the most important part :)
with the settings above, notifications and all applications that were problematic earlier are running fine, while using compositioning with xfwm4, and getting ~3700 fps on glxgears.

Olli Savolainen (pilpi) wrote :

reducing color depth helped for me, too. attaching my new xorg.conf with relatively minimal modifications.

pcr (petitchevalroux) wrote :

I just tried a.tom's xorg.conf and it works pretty well with gnome and visual FX on from pannel board. I only get some black vertical line reading video in totem with compiz enable (So i will disable it for the moment).

One other problem is the DynamicPM option enable : When my screen goes to sleep mode I am unable to restore something ... (if someone else can confirmed or help i opened a bug : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/489981).

Just one more question to a.tom can you give me the ppa repository in order to try latest xorg...ati-driver package ?

A. Tombol (atombol) wrote :

Tormod, do you have any advices/remarks on these options I've set in the xorg.conf? I based it on the radeon man file, having only the information written there.

Guys, you could also test KMS, I tried it on a desktop Radeon 7500 card and had some slight performance improvement.
It doesn't work on my laptop though.
Here you can add the test results: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/478493

enabling KMS is quite easy, its just a GDM shutdown, module reload, GDM restart as written in:
https://wiki.ubuntu.com/X/RadeonKMS

Dear ones,

Do you think that
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/434376
is about this same bug, please?

(In reply to comment #5)
> Dear ones,
>
> Do you think that
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/434376
> is about this same bug, please?
>

Does
Option "RenderAccel" "off"
fix the problem? If so, it probably is.

*** Bug 25229 has been marked as a duplicate of this bug. ***

Is this a driver bug, please?

(In reply to comment #8)
> Is this a driver bug, please?
>

It's XAA bitrot in the xserver.

Dear Alex,

Are you referring to the term bitrot as in
http://en.wikipedia.org/wiki/Bitrot#Problems_with_software ?

If so, then I would assume that this is a bug in the XAA code in the X server? Perhaps because development is going towards EXA and XAA is kind of being abandoned, left to "rot" and this bug is an example of this degradation?

What should be done? I'm interested, please.

In that understanding, will XAA "rot" even more in the future?

What about EXA performance for our ancient r100 hardware? What will happen?
Will EXA ever give the same performance as XAA on such hardware?
And how come it does not yet? What are the obstacles?

My T42 with radeon 7500 still has several years to live.

(In reply to comment #10)
> What should be done? I'm interested, please.
>

We should just disable XAA render support.

(In reply to comment #11)
> In that understanding, will XAA "rot" even more in the future?
>
> What about EXA performance for our ancient r100 hardware? What will happen?
> Will EXA ever give the same performance as XAA on such hardware?
> And how come it does not yet? What are the obstacles?

It's mostly the lack of a decent memory manager, however, EXA support should preform pretty well with KMS since it provides a memory manager.

Bryce Harrington (bryce) on 2009-12-15
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody

*** Bug 23668 has been marked as a duplicate of this bug. ***

zvqra (zvqra3) on 2009-12-15
Changed in ubuntu-release-notes:
status: Fix Released → Confirmed
status: Confirmed → Fix Released

I'd be interested in someone trying Fedora 12 with EXA on crappy hw it should work fast enough, at least I can use it on my T42, haven't really compared it with XAA though.

This is still present in Lucid Alpha 1. Bug #416001 appears to be the same; unfortunately both it and this bug have significant activity so neither one is easily marked duplicate. See also bug #429251, which seems to be related.

Shahar Or (mightyiam) wrote :

Marked.

I don't know about bug #529251 .

jtniehof (jtniehof) wrote :

I misspoke (too many windows open). Bug #416001 is related but not the same, unmarked. Bug #429251 is essentially the same but, as I mentioned, there's no clear distinguishing whether it or this should be marked dupe (and each links the other in comments)

Shahar Or (mightyiam) wrote :

I don't know about the formal bug squad procedures, but I'm just guessing that if a bug is essentially the same then it should be marked as a dupe. That's obvious... What harm will it do to just mark one as a dupe of the other? I selected this bug as the original because this is marked as affecting the Ubuntu release notes and is bigger in terms of duplicates and people affected. Marking one as a dupe would, I assume, add up the number of people affected thus placing this bug in it's rightful place in the search results, better demonstrating it's importance.

Shahar Or (mightyiam) wrote :

In a personal message, jtniehof agreed that bug #416001 is a duplicate of this one.

Brad Krause (brad-krause) wrote :

Changing the color depth from 24-bit to 16-bit would be great EXCEPT I have Xubuntu 9.10 running and there is no xorg.conf file, as XRandR manages everything. There is no option in the display menu and I cannot find documentation on how to change the color depth in a terminal window. How do I change the color depth?

Note: Same problem on the ATI Radeon 7200.

A. Tombol (atombol) wrote :

just copy one of the attached xorg.conf files to your /etc/X11 directory

Brad Krause (brad-krause) wrote :
Download full text (6.6 KiB)

Changed to 16bpp on 64MB ATI card, less than max. resolution, and problem still exists.

I opened a terminal and ran 'xwininfo', which reported 'Depth: 24', so we know the color depth was set to 24 bpp. I also ran 'lspci' which reported I am not running in the highest resolution, so there should be extra video memory. NOTE: My card has 64MB, see the first screen in the attached image for graphics details and notify-osd problem.

I restarted the system in single-user mode and ran 'Xorg -configure' then edited /root/xorg.conf.new to configure only the video information. Adding 'DefaultDepth 16' was necessary to force 16bpp mode. 'xwininfo' reported 'Depth: 16', and the problem still exists. See the second screen in the attached image for graphics details and notify-osd problem.

/root/xorg.conf.new
--------------------------------
Section "ServerLayout"
 Identifier "X.org Configured"
 Screen 0 "Screen0" 0 0
 InputDevice "Mouse0" "CorePointer"
 InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
 ModulePath "/usr/lib/xorg/modules"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
 FontPath "built-ins"
EndSection

Section "Module"
 Load "dri2"
 Load "extmod"
 Load "glx"
 Load "dri"
 Load "dbe"
 Load "record"
EndSection

Section "InputDevice"
 Identifier "Keyboard0"
 Driver "kbd"
EndSection

Section "InputDevice"
 Identifier "Mouse0"
 Driver "mouse"
 Option "Protocol" "auto"
 Option "Device" "/dev/input/mice"
 Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 #DisplaySize 300 230 # mm
 Identifier "Monitor0"
 VendorName "DEL"
 ModelName "DELL D1028L"
 HorizSync 30.0 - 69.0
 VertRefresh 48.0 - 120.0
 Option "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option "NoAccel" # [<bool>]
        #Option "SWcursor" # [<bool>]
        #Option "Dac6Bit" # [<bool>]
        #Option "Dac8Bit" # [<bool>]
        #Option "BusType" # [<str>]
        #Option "CPPIOMode" # [<bool>]
        #Option "CPusecTimeout" # <i>
        #Option "AGPMode" # <i>
        #Option "AGPFastWrite" # [<bool>]
        #Option "AGPSize" # <i>
        #Option "GARTSize" # <i>
        #Option "RingSize" # <i>
        #Option "BufferSize" # <i>
        #Option "EnableDepthMoves" # [<bool>]
        #Option "EnablePageFlip" # [<bool>]
        #Option "NoBackBuffer" # [<bool>]
        #Option "DMAForXv" # [<bool>]
        #Option "F...

Read more...

Brad Krause (brad-krause) wrote :

Addition to above: All updates were applied before testing.

New trial solution:
Just tried enabling compositing in Xubuntu 9.10 -- entire screen filled with garbage. Disabled.

A. Tombol (atombol) wrote :

you have to set AccelMethod to EXA

Yes, the desktop environment has worked satisfactorily since but EXA is
a little "flakey" handling the screensaver.

a.tom wrote:
> you have to set AccelMethod to EXA
>
>

--
John Hofstetter
10 E 4th St #17
Frederick, MD 21701-5257
301-668-7446
<email address hidden>
<email address hidden>

FOUND WORK-AROUND: (This is not a proper solution, just a work-around that works well.)

Install package: notification-daemon 0.4.0-1ubuntu3 (gets rid of garbage in notification balloons)
optional: libnotify-bin (notify-osd library containing command-line 'notify-send')

Fixes: Garbage displayed in notify-osd balloon. Balloon now contains text and a countdown timer (if specified, and there isn't any documentation in 'man notify-send' on how to get the timer).

Side-effect: Balloon position may not be the same, and moving the mouse over the balloon doesn't hide it.

Note: xorg.conf setting of 24 bits/pixel -> 16 bits/pixel may not be needed. (Tested with 64MB video RAM, not 32MB).

Olli Savolainen (pilpi) wrote :

@Brad, I tried that too but it did not work, also garbled. The only workable solution seems to have been the xorg.conf change.

mistr (mstrecke) wrote :

I'm not sure where to look for the video ram size. I didn't find anything in the Xorg log file.
lspci -v reports:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
 Subsystem: Compaq Computer Corporation Device 00b7
 Flags: bus master, stepping, 66MHz, medium devsel, latency 66, IRQ 11
 Memory at 48000000 (32-bit, prefetchable) [size=128M]
 I/O ports at 3000 [size=256]
 Memory at 40400000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at 40420000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel modules: radeon, radeonfb

My guess: 128M (which wouldn't fit the 32 MB of less theory)

Initial situation:
- Laptop, Compac Evo 610c, Karmic 32 bit
- The well-known garbled output in the gnome-notifier and gnome-system-monitor with compiz off (my normal setting).
- No problems with compiz turned on.
- Problem still present with the current xorg-edgers drivers.

Current work-around:
Automatically generated xorg.conf with a single change:
        Option "RenderAccel" "off"

Test done so far:
- EXA: works but is visibly slower
- KMS: works, but is visibly slower, leaves artifacts on the screen when objects are moved (which will be cleaned up eventually)

Brad Krause (brad-krause) wrote :

To find the amount of video memory (note VGA is in upper case):

lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD [Radeon 7200]

Use the device number to get the card information:

lspci -v -s 01:00.0
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD [Radeon 7200]
 Subsystem: ATI Technologies Inc Device 0538
 Flags: bus master, stepping, 66MHz, medium devsel, latency 64, IRQ 11
 Memory at f0000000 (32-bit, prefetchable) [size=64M]
 I/O ports at c800 [size=256]
 Memory at ff880000 (32-bit, non-prefetchable) [size=512K]
 Expansion ROM at ff860000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel modules: radeon, radeonfb

The first 'Memory' line shows this card has 64MB RAM. The line of interest in mistr's post is:
 Memory at 48000000 (32-bit, prefetchable) [size=128M]

mistr has a card with 128MB RAM.

On Tue, 19 Jan 2010 19:10:06 -0000
Brad Krause <email address hidden> wrote:

> To find the amount of video memory (note VGA is in upper case):
>
> lspci | grep VGA
> 01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R100
> QD [Radeon 7200]
>
> Use the device number to get the card information:

Thanks for the details.

For what it's worth, I see this on:

root@dragon:~# lspci -v -s $(lspci | grep VGA | cut -f1 -d' ')
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
 Subsystem: IBM Device 0530
 Flags: bus master, stepping, fast Back2Back, 66MHz, medium devsel, latency 66, IRQ 11
 Memory at e0000000 (32-bit, prefetchable) [size=128M]
 I/O ports at 3000 [size=256]
 Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at c0120000 [disabled] [size=128K]
 Capabilities: [58] AGP version 2.0
 Capabilities: [50] Power Management version 2
 Kernel modules: radeon, radeonfb

root@dragon:~#

--

Charles Curley /"\ ASCII Ribbon Campaign
Looking for fine software \ / Respect for open standards
and/or writing? X No HTML/RTF in email
http://www.charlescurley.com / \ No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0 809C FFF6 4C48 4ECD DFDB

I am not sure this number is correct; it disagrees with what
cat /var/log/Xorg.0.log|grep "Allocating from a screen of"
produces here.

Clay Weber (claydoh) wrote :

I am assuming mistr has similar hardware as my Compaq Evo N610c laptop, which only has 32mb vram (dedicated card, not shared)

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
        Subsystem: Compaq Computer Corporation Device 00b7
        Flags: bus master, stepping, 66MHz, medium devsel, latency 66, IRQ 11
        Memory at 48000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at 40400000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at 40420000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
        Kernel modules: radeon, radeonfb

To fix this problem, I simply needed to create an xorg.conf with this:

 Section "Device"
 Identifier "Configured Video Device"
 Driver "radeon"
 Option "AccelMethod" "XAA"
 Option "RenderAccel" "off"
 Option "EnablePageFlip" "true"
EndSection

The EnablePageFlip seems to remedy some graphical artifacts during Kubuntu's login

As a side note, in Kubuntu all the plasma components show this graphical corruption: the taskbar, main menu, window decorations, etc.

mistr (mstrecke) wrote :

I now have a definitve answer. I found the "Maintanance and Service Guide" for my laptop. It reads: "32 MB of discrete video memory".

At least it shows, that lspci does not report the actual video memory, and if the Xorg log doesn't report it either, answering this question is non trivial.

The bug description remains valid.

Brad Krause (brad-krause) wrote :

According to ATI, the Radeon 7200 I list previously comes with 64MB onboard RAM. Even if it did not, I used a lower resolution and 16-bpp depth instead of full resolution and 24-bpp.
http://ati.amd.com/products/radeon7200/index.html

apinunt (apinunt) wrote :

Fix released? Where is it? What is it? How can I have it applied?

FYI Its not a problem for me in Lucid Alpha 2! Meantime you can create
an xorg.conf file as such:

Section "Device"
    Identifier "Radeon 7200"
    Driver "ati"
    Option "AccelMethod" "EXA"
EndSection

The Identifier and Driver lines may not be necessary, naturally use your
display adapter model as the identifier and copy file to /etc/X11. At
best I'd consider EXA to be a little flakey but it should address the
problem.

apinunt wrote:
> Fix released? Where is it? What is it? How can I have it applied?
>
>

Lucid alpha 2 works well for my COMPAQ EVO N610C, EXCEPT for the notifications which have lines and oddities on them. The System Monitor works well. I can change visual effects perfectly.

On Karmic, I had to install sun java (not open java) in order to be able to switch visual effect modes. In Karmic, without sun java, I had to leave the visual effects in "normal", if I went to "none" visual effects, my open office would not be able to show buttons and check boxes correctly. I had to switch to "none" effects in order to show videos in Karmic in Open Office Impress. Once in "none" visual effects mode, I'd be trapped there, and could not return to "normal" without a reinstall.

In Lucid alpha 2 I found open office to function normally. So apart from the notifications being messy, Lucid seems to solve my problems with this issue. Attached screenshot of notification issue.

Steve Langasek (vorlon) wrote :

The messy notification in Lucid alpha2 isn't a bug, it's intentional debugging code for the alpha. Upgrading to current lucid resolves this.

Can others confirmed that the original issue here is resolved in lucid?

I can also confirm that in Lucid Alpha 2 this bug is not an issue anymore for Dell Inspiron 5100 with Radeon Mobility 7500. Everything works well including notification pop-ups. The only problem that appeared again - flash works terribly slow in Firefox. It worked well in Jaunty, then it became too slow in Karmic, then somewhere in between Lucid Alpha 1 and Alpha 2 it worked normally. But now after several updates it works bad again.

Tormod Volden (tormodvolden) wrote :

dicka, slow flash might be independent of the graphics driver - try removing the swfdec-mozilla package (disabling in Firefox is not enough) if you are using the Adobe flashplugin-installer. Sorry I can't find the bug reference.

Hi Tormod
I just wanted to confirm that this issue is resolved for my old Radeon in latest Lucid Alpha. Concerning the slow flash - I never had swfdec installed on that system. I use flashplugin-installer only. As far as I know, Adobe uses OpenGL to accelerate video playback and requires some OpenGL features to be implemented. I'm not an OpenGL expert, so I just guess - flash playback is too slow because of the fact that Radeon driver and/or my quite old hardware don't support some essential feature.

Bryce Harrington (bryce) on 2010-02-27
tags: added: corruption
jtniehof (jtniehof) wrote :

Lucid alpha 2 and 3 display the notifcation windows fine on what lspci identifies as "Radeon Mobility M7 LW [Radeon Mobility 7500]" (ThinkPad T30). However, checking X.0.log shows that the X server is using EXA, not XAA. This may explain the slow performance some people are noting. I was unable to force XAA using an xorg.conf. Bug #513956 suggests that XAA still exists, however, and is being used for some cards.

apinunt: the "fix" is to the release notes, describing the problem, not fixing it.

Randall Ross (randall) wrote :

I can confirm that this bug does not exist in Lucid Lynx a3 with the following graphics adapter:
ATI Technologies Inc Radeon Mobility M6 LY

(here's the output...)
me@910:~$ lspci -vvnn

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M6 LY [1002:4c59]
 Subsystem: Sharp corporation Device [13bd:103b]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B+ DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 66 (2000ns min), Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 10
 Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
 Region 1: I/O ports at 2000 [size=256]
 Region 2: Memory at e8100000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at e8120000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel modules: radeon, radeonfb

Bryce Harrington (bryce) on 2010-03-17
description: updated
Robert Hooker (sarvatt) on 2010-03-22
summary: - (32MB) certain windows drawn garbled when XAA is used
+ [RV200] (32MB) certain windows drawn garbled when XAA is used

Closing as WONTFIX; XAA is too far gone these days. If EXA does not work, file a new bug or attach yourself to an existing bug matching your issues.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Won't Fix
Bryce Harrington (bryce) wrote :

Thanks for the confirmations that this is resolved now. If anyone still has an issue, please treat it as a new bug, as it is probably something unrelated to this one and in any case will be easier to analyze on a fresh bug report.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.