Artifacts with cairo dock 2.0 [openGL]

Bug #408065 reported by Vish on 2009-08-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
cairo-dock (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

When using the latest version of cairo dock 2.0 , on hover over the dock the background becomes black.

Even in normal state the transparency is not perfect.

ProblemType: Bug
Architecture: i386
Date: Sun Aug 2 23:14:21 2009
DistroRelease: Ubuntu 9.10
MachineType: Acer, inc. Aspire 5670
Package: xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-4-generic root=UUID=070f2a33-a167-4055-9429-e626203105d4 ro splash
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.5-1ubuntu1
 libdrm2 2.4.12-1ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu4
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.31-4-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 02/08/06
dmi.bios.vendor: Acer
dmi.bios.version: v1.3219
dmi.board.name: Bodensee
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3219:bd02/08/06:svnAcer,inc.:pnAspire5670:pvrNotApplicable:rvnAcer,Inc.:rnBodensee:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 5670
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-4-generic

[lspci]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility X1400 [1002:7145]
     Subsystem: Acer Incorporated [ALI] Device [1025:0094]

Vish (vish) wrote :
Vish (vish) wrote :

Attaching a screenshot of the problem:

screenshot legend:
1: as soon as the dock starts , not fully transparent[ the icons dont appear and the logo from the nearby panel is retained!]
2: on hover the dock background turns black
3: even on release of hover the dock has the black background , and at random returns to state 1 , where the icons disappear and the logo from the nearby panel is retained

The only solution is to not use the openGL version and to run caio-dock as[non-openGL] :
$cairo-dock -c

Bryce Harrington (bryce) on 2009-08-03
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-08-13
tags: added: karmic
Matthieu Baerts (matttbe) wrote :

Hello,

I'm part of the Cairo-Dock Team.
We confirm this bug. There was the same problem with Intel graphic cards but all seems ok now (Ubuntu Karmic - 13 Aug 2009) (even with an Eeepc701 while having multiple visual effects and remains fluid!).

We think that this black background with ATI cards is due to this function 'GL_EXT_texture_from_pixmap' in OpenGL. We suppose that the composite support needs to be improved.

I don't know how can we help you but we can try to answer to all your questions !

The problem is the same with Catalyst 9.7 (black background and some artifacts in indirect rendering mode)

You can also test with an the indirect rendering mode :
   $ cairo-dock -o -i

Thanks to mac_v for having reported this bug. And thanks to Bryce for having confirmed it !

PS : Our ppa is now activated : https://edge.launchpad.net/~cairo-dock-team/+archive/ppa
You can download sources code on Berlios http://developer.berlios.de/project/showfiles.php?group_id=8724 or on lp : https://launchpad.net/cairo-dock-core/+download and https://launchpad.net/cairo-dock-plug-ins/+download or via SVN (svn://svn.berlios.de/cairo-dock/trunk) but this development branch is transfering from svn to bzr in lp.

Vish (vish) wrote :

So how do we proceed now? Does this need to be sent upstream ?
If so , Upstream for ATI is link ?

@Matthieu Baerts:
How come the ppa says "stable" and has a 2.0.9 version while the BerliOS site only has 2.0.8 ?

PS: Just to check , I'v tested with the indirect rendering mode and the ppa too.
Still no improvement... :(

Matthieu Baerts (matttbe) wrote :

@ mac_v : Simply because I have to use a new version (2.0.9) in order to not have any conflict (our DEB packages are now split in more parts and we want use these packages on the official Ubuntu repositories and in the future in our repository (on cairo-dock.org)).

Thanks for your help and we hope that this bug can be solved one day (but not too late ;-) )

Created an attachment (id=28733)
cairo-dock problem.png

Forwarding this bug from Ubuntu reporter mac_v:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/408065

[Problem]
Artifacts with cairo dock 2.0 due perhaps to error in 'GL_EXT_texture_from_pixmap' in OpenGL.

[Original Description]
When using the latest version of cairo dock 2.0 , on hover over the dock the background becomes black.

Even in normal state the transparency is not perfect.

Attaching a screenshot of the problem.
screenshot legend:
1: as soon as the dock starts , not fully transparent[ the icons dont appear and the logo from the nearby panel is retained!]
2: on hover the dock background turns black
3: even on release of hover the dock has the black background , and at random returns to state 1 , where the icons disappear and the logo from the nearby panel is retained

The only solution is to not use the openGL version and to run caio-dock as[non-openGL] :
$cairo-dock -c

Architecture: i386
Date: Sun Aug 2 23:14:21 2009
DistroRelease: Ubuntu 9.10
MachineType: Acer, inc. Aspire 5670
Package: xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-4-generic root=UUID=070f2a33-a167-4055-9429-e626203105d4 ro splash
ProcEnviron:
 LANG=en_INProcVersionSignature: Ubuntu 2.6.31-4.23-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.5-1ubuntu1
 libdrm2 2.4.12-1ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu4
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.31-4-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 02/08/06
dmi.bios.vendor: Acer
dmi.bios.version: v1.3219
dmi.board.name: Bodensee
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3219:bd02/08/06:svnAcer,inc.:pnAspire5670:pvrNotApplicable:rvnAcer,Inc.:rnBodensee:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 5670
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
system: architecture: i686kernel: 2.6.31-4-generic

Created an attachment (id=28734)
glxinfo.txt

Created an attachment (id=28735)
XorgLog.txt

Created an attachment (id=28736)
CurrentDmesg.txt

Created an attachment (id=28737)
BootDmesg.txt

Bryce Harrington (bryce) wrote :

I've forwarded this bug upstream for you to https://bugs.freedesktop.org/show_bug.cgi?id=23386 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Vish (vish) wrote :

I do realize that this has nothing to do with cairo dock per-se , but I've added cairo dock in the also affects , so that
This bug can be easily found when users search for bugs in cairo dock.

Changed in cairo-dock (Ubuntu):
status: New → Incomplete

I assume Cairo Dock may use the depth 32 GLX visual for translucency, which cannot work properly with DRI1. Does the problem also happen with DRI2 (requires KMS)?

Vish (vish) wrote :

@Matthieu Baerts :
Upstream , Michel Dänzer , has commented>

" I assume Cairo Dock may use the depth 32 GLX visual for translucency, which
cannot work properly with DRI1. Does the problem also happen with DRI2
(requires KMS)? "

Could you reply to Michel Dänzer 's comment upstream ?

(In reply to comment #5)
> I assume Cairo Dock may use the depth 32 GLX visual for translucency, which
> cannot work properly with DRI1. Does the problem also happen with DRI2
> (requires KMS)?

This bug is still present on Ubuntu Karmic 9.10 with an ATI Radeon card and with the last kernel (2.6.31-6). So I suppose that DRI2 is used.

Thanks a lot for your help !

Default Kamric installation doesn't include DRI2. You need to install mesa 7.6 and set kernel parameter radeon.modeset=1.

You can check dri version from "glxinfo |grep nGL"

(In reply to comment #7)
> Default Kamric installation doesn't include DRI2. You need to install mesa 7.6
> and set kernel parameter radeon.modeset=1.
>
> You can check dri version from "glxinfo |grep nGL"
>

Hi, I'm the original reporter of the launchapd bug

$ glxinfo |grep nGL
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.4 Mesa 7.5
OpenGL extensions:

So i guess i have to use mesa 7.6 ?

I'm not sure how to install mesa 7.6 on karmic ? is it from ppa or ...?
also , where does the setting the Kernel parameter need to be done? xorg.conf?

(In reply to comment #8)
> (In reply to comment #7)
> > Default Kamric installation doesn't include DRI2. You need to install mesa 7.6
> > and set kernel parameter radeon.modeset=1.
> >
> > You can check dri version from "glxinfo |grep nGL"
> >
>
> Hi, I'm the original reporter of the launchapd bug
>
> $ glxinfo |grep nGL
> OpenGL vendor string: DRI R300 Project
> OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
> OpenGL version string: 1.4 Mesa 7.5
> OpenGL extensions:
>
> So i guess i have to use mesa 7.6 ?
>
> I'm not sure how to install mesa 7.6 on karmic ? is it from ppa or ...?
> also , where does the setting the Kernel parameter need to be done? xorg.conf?
>

xorg-edgers ppa (https://launchpad.net/~xorg-edgers/+archive/ppa) has the latest 3D drivers for Ubuntu.

Kernel parameter can be set in grub when you boot. You can just append it to current kernel boot options. Another option is to set it in /etc/modprobe.d/ but that would require grub command line modifications in case something goes wrong.

Matthieu Baerts (matttbe) wrote :

@mac_v : Thank you. But can you confirm this comment if you are on Karmic ? (with the last kernel 2.6.31 => this kernel have a support for ATI Radeon graphics cards with the KMS (Kernel-based mode-setting))

I haven't any ATI card but I have transfered this message to our forum.

Vish (vish) wrote :

@Matthieu Baerts :
Yes , I'm using Karmic up-to date,as of now kernel > 2.6.31-6-generic

BTW , the bug description has my kernel and Ubuntu version also ;)

Vish (vish) wrote :

@Matthieu Baerts :
A link to the forum discussion regarding this would be nice. :)

Matthieu Baerts (matttbe) wrote :

@mac_v :
Sorry I just wanted to know if you are using Karmic up-to date :)

You can follow the forum discussion : http://www.cairo-dock.org/bg_topic.php?t=2976 but it's in French ! In it we also say that Cairo-Dock with OpenGL doesn't work with Catalyst 9.8 ( http://ati.cchtml.com/show_bug.cgi?id=1626 )

Thanks for your help !

(In reply to comment #9)
>
> xorg-edgers ppa (https://launchpad.net/~xorg-edgers/+archive/ppa) has the
> latest 3D drivers for Ubuntu.
>
> Kernel parameter can be set in grub when you boot. You can just append it to
> current kernel boot options. Another option is to set it in /etc/modprobe.d/
> but that would require grub command line modifications in case something goes
> wrong.
>

I installed the ppa and tried with kernel mode setting.
But my system became very sluggish, i mean really very very sluggish.

Even so, i tried cairo-dock but it *would not start* .
I ran cairo-dock in debug mode and it had only one line:

drmRadeonCmdBuffer: -22

I'm still running the ppa but without KMS , if i run cairo-dock using openGL it has the same artifacts as before.[i understand this problem would only improve with KMS but just mentioning].

So now ,
1 . does the above error i got for cairo-dock with KMS , have to be dealt with by cairo-dock or by the graphics driver?

2. Could i have a link to the bug for the radeon KMS slow behavior, i wouldnt mind testing any unstable drivers which fix this.

Thanx for the help :)

(In reply to comment #10)
> Even so, i tried cairo-dock but it *would not start* .
> I ran cairo-dock in debug mode and it had only one line:
>
> drmRadeonCmdBuffer: -22

Check the dmesg output.

(In reply to comment #11)
> (In reply to comment #10)
> > Even so, i tried cairo-dock but it *would not start* .
> > I ran cairo-dock in debug mode and it had only one line:
> >
> > drmRadeonCmdBuffer: -22
>
> Check the dmesg output.
>

I checked , but nothing gets logged in /var/log/dmesg for this problem.
[and nothing else was logged in the dmesg while i was testing this with KMS]

Vish (vish) wrote :

As per upstream comments , I tried with kernel mode setting.

I tried cairo-dock[OpenGL] but it *would not start* .
I ran cairo-dock in debug mode and it had only one line:

drmRadeonCmdBuffer: -22

So , does the above error i got for cairo-dock with KMS , have to be dealt with
by cairo-dock or by the graphics driver?

Matthieu Baerts (matttbe) wrote :

Cairo-Dock with OpenGL works without any problem with nVidia and Intel graphic cards (only on Karmic for these Intel cards).

One Cairo-Dock dev have an old laptop with a radeon graphic card. He has tested with the xorg-edgers ppa and "radeon.modeset=1" option but his system became unstable due to Xorg.

After a 'dpkg-reconfigure' for Xorg packages, he has tested Cairo-Dock but there is still a black background and "glxinfo | grep nGL" gives "OpenGL version string: 2.1 Mesa 7.5"

@mac_v : Can you confirm the version of Mesa ?

PS : I quote Phoronix : "It happened on Friday night, but the Linux 2.6.31-rc7 kernel is now available. The seventh release candidate for the Linux 2.6.31 kernel brings a variety of small fixes, including a Radeon DRM update. The Linux 2.6.31-rc7 release announcement can be read at LKML.org.

The Linux 2.6.31 kernel should be released in early September and it brings staging support for ATI kernel mode-setting support, the mainlining of the TTM memory manager, various graphics DRM driver improvements to ATI and Intel in particular, improvements to different file-systems, new drivers, and much more."

Vish (vish) wrote :

my Mesa was
~$ glxinfo |grep nGL
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.4 Mesa 7.5
OpenGL extensions:

Upstream recommended me to use the xorg-edgers ppa (https://launchpad.net/~xorg-edgers/+archive/ppa) which has the
latest 3D drivers for Ubuntu.

Now my mesa is
~$ glxinfo |grep nGL
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RV515 7145) 20090101 x86/MMX/SSE2 TCL
OpenGL version string: 1.5 Mesa 7.6-devel
OpenGL extensions:

Since they said mesa 7.6 was the latest.

But there are other problems with KMS , as in the drastic sluggishness. which is an xorg problem
But that aside, during KMS setting, when i use cairo-dock with openGL in debug mode it get the error:
drmRadeonCmdBuffer: -22

and it wont start. while the non-openGL version works with KMS.

Without using KMS , i dont think it will display properly , hence it still shows the black background for me too.

Vish (vish) wrote :

I think there needs to be some tweaking in cairo-dock too for OpenGL version to work for ATI cards.
the sluggishness will be taken care of by the xorg

Below is the output is get when i run from the terminal:

~$ cairo-dock -o
warning : (cairo-dock-draw-opengl.c:cairo_dock_get_opengl_config:1690)
  couldn't find an appropriate visual ourself, trying something else, this may not work with some drivers ...
warning : (cairo-dock-modules.c:cairo_dock_preload_module_from_directory:327)
  while opening module '/usr/lib/cairo-dock/libcd-xfce-integration.so' : (libthunar-vfs-1.so.2: cannot open shared object file: No such file or directory)
gtk_widget_get_gl_context: assertion `GTK_IS_WIDGET (widget)' failed
OpenGL version: 1.5 Mesa 7.6-devel
OpenGL vendor: DRI R300 Project
OpenGL renderer: Mesa DRI R300 (RV515 7145) 20090101 x86/MMX/SSE2 TCL DRI2
if your drivers are crappy, we'll know it immediately ... ok, they seem fine enough.
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll speed'
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll accel'
cairo_dock_replace_values_in_conf_file (/home/vish/.config/cairo-dock/current_theme/plug-ins/rendering/rendering.conf)
cairo_dock_replace_key_values (0)
g_key_file_has_key: assertion `key_file != NULL' failed
warning : (cairo-dock-keyfile-utilities.c:cairo_dock_flush_conf_file_full:72)
  Couldn't find any installed conf file
cairo_dock_replace_values_in_conf_file (/home/vish/.config/cairo-dock/current_theme/plug-ins/dialog-rendering/dialog-rendering.conf)
cairo_dock_replace_key_values (0)
cairo_dock_replace_values_in_conf_file (/home/vish/.config/cairo-dock/current_theme/plug-ins/Animated-icons/Animated-icons.conf)
cairo_dock_replace_key_values (0)
drmRadeonCmdBuffer: -22

And OpenGL version wont start.

~$ cairo-dock -c
warning : (cairo-dock-modules.c:cairo_dock_preload_module_from_directory:327)
  while opening module '/usr/lib/cairo-dock/libcd-xfce-integration.so' : (libthunar-vfs-1.so.2: cannot open shared object file: No such file or directory)
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll speed'
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll accel'
cairo_dock_replace_values_in_conf_file (/home/vishnoo/.config/cairo-dock/current_theme/plug-ins/rendering/rendering.conf)
cairo_dock_replace_key_values (0)
g_key_file_has_key: assertion `key_file != NULL' failed
warning : (cairo-dock-keyfile-utilities.c:cairo_dock_flush_conf_file_full:72)
  Couldn't find any installed conf file
cairo_dock_replace_values_in_conf_file (/home/vishnoo/.config/cairo-dock/current_theme/plug-ins/dialog-rendering/dialog-rendering.conf)
cairo_dock_replace_key_values (0)
cairo_dock_replace_values_in_conf_file (/home/vishnoo/.config/cairo-dock/current_theme/plug-ins/Animated-icons/Animated-icons.conf)
cairo_dock_replace_key_values (0)

Non-OpenGL Starts and works fine.

Matthieu Baerts (matttbe) wrote :

Many thanks for your help ;)

Just to know : do you have the same error if you launch glxgears ?
  ~$ glxgears

Can I ask you if you can test it again with the kernel 2.6.31-7 ? I don't see it now in Ubuntu Karmic repositories but there will be integrated soon.

Vish (vish) wrote :

The same error ? as in the output in terminal when i run glxgears?

No, i dont get any error , in terminal , with glxgears, it reports the FPS with no errors. i tried both with KMS and without KMS .I have no problems there.

Or did you mean black background? I thought that was how it was supposed to work !
- Attaching a screenshot of the glxgears .

If this is not how glxgears is supposed to display , just out of my own curiosity , could you attach an image of how it does display with your graphics card ?
Thanx. :)

Matthieu Baerts (matttbe) wrote :

@mac_v : No, all is correct :)
I suppose that there is no more informations if you launch cairo-dock in a terminal with :
  ~$ cairo-dock -ol debug

But this error "drmRadeonCmdBuffer: -22" is strange. In my last comment I asked you to launch glxgears in order to know if you have this error, so if DRI works without any problem. I you can move the glxgears window without any bugs I really don't know why Cairo-Dock doesn't work ! I suppose it's due to a particular function used but which one :)
I think it's the first time that I see this error with Cairo-Dock.

If someone know if it's a bug in Cairo-Dock and/or if we can apply a workaround for mesa 7.6 : don't be shy ;)
Our source code is available here : http://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-core/cairo-dock/files/head:/src/

Thank you for having taken time to help us !

Vish (vish) wrote :

Oh , i have the glxgears bug while movement > Bug #96991 , this is a long standing issue. the gears get stuck at the initial place and then appear where the window is placed. [testing this at the moment with KMS is near impossibility , with the sluggishness]

I was mentioning that i did not receive the error "drmRadeonCmdBuffer: -22" with glxgears. or any errors in the terminal.[with and without KMS]

Maybe *Bryce Harrington* can throw some light on this error.

Hi,

I'm a member of cairo-dock team and I got an old laptop using an ATI Mobility Radeon 9600 (RV350)
Just tested new kernel (2.6.31-7) with latest mesa driver (7.6 devel) using KMS (setting radeon.modeset=1 on grub command line)

Boot is fine, glxgears is working great (I can move it, transparency is here)
Cairo-Dock is now working with no artefact but has still a black background

Outputs are attached

Created an attachment (id=28928)
dmesg (using latest kernel, mesa driver and kms)

Created an attachment (id=28929)
glxinfo (using latest kernel, mesa driver and kms)

Created an attachment (id=28930)
Picture of the actual situation (using latest kernel, mesa driver and kms)

(In reply to comment #13)
> I'm a member of cairo-dock team and I got an old laptop using an ATI Mobility
> Radeon 9600 (RV350)

Excellent - can you explain how cairo-dock tries to achieve the translucency effect with OpenGL?

(In reply to comment #13)
> Hi,
>
> I'm a member of cairo-dock team and I got an old laptop using an ATI Mobility
> Radeon 9600 (RV350)
> Just tested new kernel (2.6.31-7) with latest mesa driver (7.6 devel) using KMS
> (setting radeon.modeset=1 on grub command line)
>
> Boot is fine, glxgears is working great (I can move it, transparency is here)
> Cairo-Dock is now working with no artefact but has still a black background
>
> Outputs are attached
>

While the graphics driver performance has definitely improved ,
cairo-dock does not work for me, [Using the latest kernel 2.6.31-7 with kms]. Cairo-dock still does *not* start.
This is in an ATI Mobility Radeon X1400

When i start cairo-dock from the terminal i get the same output as before.
~$ cairo-dock -o
warning : (cairo-dock-draw-opengl.c:cairo_dock_get_opengl_config:1690)
  couldn't find an appropriate visual ourself, trying something else, this may not work with some drivers ...
warning : (cairo-dock-modules.c:cairo_dock_preload_module_from_directory:327)
  while opening module '/usr/lib/cairo-dock/libcd-xfce-integration.so' : (libthunar-vfs-1.so.2: cannot open shared object file: No such file or directory)
gtk_widget_get_gl_context: assertion `GTK_IS_WIDGET (widget)' failed
OpenGL version: 1.5 Mesa 7.6-devel
OpenGL vendor: DRI R300 Project
OpenGL renderer: Mesa DRI R300 (RV515 7145) 20090101 x86/MMX/SSE2 TCL DRI2
if your drivers are crappy, we'll know it immediately ... ok, they seem fine enough.
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll speed'
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll accel'
cairo_dock_replace_values_in_conf_file (/home/vish/.config/cairo-dock/current_theme/plug-ins/rendering/rendering.conf)
cairo_dock_replace_key_values (0)
g_key_file_has_key: assertion `key_file != NULL' failed
warning : (cairo-dock-keyfile-utilities.c:cairo_dock_flush_conf_file_full:72)
  Couldn't find any installed conf file
cairo_dock_replace_values_in_conf_file (/home/vish/.config/cairo-dock/current_theme/plug-ins/dialog-rendering/dialog-rendering.conf)
cairo_dock_replace_key_values (0)
cairo_dock_replace_values_in_conf_file (/home/vish/.config/cairo-dock/current_theme/plug-ins/Animated-icons/Animated-icons.conf)
cairo_dock_replace_key_values (0)
drmRadeonCmdBuffer: -22

Note the same error in the last line as before. .

(In reply to comment #18)

> While the graphics driver performance has definitely improved ,
> cairo-dock does not work for me, [Using the latest kernel 2.6.31-7 with kms].
> Cairo-dock still does *not* start.
> This is in an ATI Mobility Radeon X1400

> OpenGL version: 1.5 Mesa 7.6-devel
> OpenGL vendor: DRI R300 Project
> OpenGL renderer: Mesa DRI R300 (RV515 7145) 20090101 x86/MMX/SSE2 TCL DRI2
> if your drivers are crappy, we'll know it immediately ... ok, they seem fine
> enough.

> Note the same error in the last line as before. .
>

Regarding driver detection, it seems that your card is better recognized than mine (maybe has better performance too). I didn't post any cairo-dock debug but it was saying that I got only 4 Visuals and that wasn't enough so he will try another way

Yann SLADEK (yann-sladek) wrote :

Hi,

as this is the original bug, I'd like to say that I've updated the desciption of the bug upstream

With new kernel, new mesa drivers and KMS enabled, I'm now able to move glxgears correctly but cairo-dock still has a black background
See : https://bugs.freedesktop.org/show_bug.cgi?id=23386

Vish (vish) wrote :

I get the same error as before for me with the latest kernel. 2.6.31-7 and KMS.

Has *not* improved for me.
glxgears works better than before. but cairo-dock still gives the same error as before and deos *not* start.

Created an attachment (id=28977)
Cairo-dock debug with kernel -8

Hi,
I'v now upgraded to kernel 2.6.31-8 and I'm using KMS
Running cairo-dock with openGL in debug mode now gives more information.

But ends with the same line as before.

Attaching the debug log. Hope it helps. Thanks.

"couldn't find an appropriate visual ourself, trying something else, this may not work with some drivers ..."

means it didn't find an FBConfig that fits its needs (4 channel, depth=32, if I remember corerctly)
so then it's trying to find a visual from another way, but usually it won't give better result (it will probably give a visual with no transparency, hence the black background.)

I don't have the code in front of me, but it's in cairo_dock_get_opengl_config(), in cairo-dock-draw-opengl.c, ~ line 1650

(In reply to comment #21)
> "couldn't find an appropriate visual ourself, trying something else, this may
> not work with some drivers ..."
>
> means it didn't find an FBConfig that fits its needs (4 channel, depth=32, if I
> remember corerctly)

If that's using KMS, please attach the glxinfo output, assuming it's different from the one already attached. With KMS I get such a large selection of GLX visuals and fbconfigs that I'm not sure what could be missing.

(In reply to comment #21)
> "couldn't find an appropriate visual ourself, trying something else, this may
> not work with some drivers ..."
>
> means it didn't find an FBConfig that fits its needs (4 channel, depth=32, if I
> remember corerctly)
> so then it's trying to find a visual from another way, but usually it won't
> give better result (it will probably give a visual with no transparency, hence
> the black background.)
>
Actually, cairo-dock does not start at all, as always. I forgot to mention that again in the last comment.

one can read there are 4 matching FBConfigs, which is quite poor.
maybe there are plenty of them but then with no alpha or not the good depth.
or maybe there is still another way to get the FBConfigs ?

2009/8/28 <email address hidden>

> http://bugs.freedesktop.org/show_bug.cgi?id=23386
>
>
>
>
>
> --- Comment #22 from Michel Dänzer <email address hidden> 2009-08-28
> 05:48:17 PST ---
> (In reply to comment #21)
> > "couldn't find an appropriate visual ourself, trying something else, this
> may
> > not work with some drivers ..."
> >
> > means it didn't find an FBConfig that fits its needs (4 channel,
> depth=32, if I
> > remember corerctly)
>
> If that's using KMS, please attach the glxinfo output, assuming it's
> different
> from the one already attached. With KMS I get such a large selection of GLX
> visuals and fbconfigs that I'm not sure what could be missing.
>
>
> --
> Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.

(In reply to comment #24)
> one can read there are 4 matching FBConfigs, which is quite poor.
> maybe there are plenty of them but then with no alpha or not the good depth.
> or maybe there is still another way to get the FBConfigs ?
>

Fab,

please have a lot at the file attached at the top of the page named ' glxinfo (using latest kernel, mesa driver and kms)'
I got 64 GLX Visual (one with depth=32) and 96 GLXFBConfigs (16 with depth=32, I don't knwo where to find channels)

@Michel :

here is the portion of code where we are getting config : http://svn.berlios.de/wsvn/cairo-dock/trunk/cairo-dock/src/cairo-dock-draw-opengl.c (function : cairo_dock_get_opengl_config)

Okay, I think I see the problem. It looks for a visual which

1. Has depth and stencil bits.
2. Has a corresponding picture format with alpha bits.

1. is satisfied by many visuals, but 2. is only satisfied by the depth 32 visual, which probably doesn't have stencil bits. It may be possible to fix this with yet another rework of the xserver GLX visual code, but in the meantime could cairo-dock work without a stencil buffer?

actually I've added the stencil buffer some times after the integration of
OpenGL into the dock (for the Curve view)
And I remember that the number of Visuals I got with my NVidia was
unchanged, so I'm not sure it is the problem. At that time, there was
already no matching visuals on other cards, even without this condition on
the stencil.

but well, I can try to double check, the first time with sterncil, the
second without.

By the way, what's the difference with gdk_gl_config_new_by_mode and
glXChooseFBConfig
?
the first one always gives more results, but (on my NVidia), both give me a
valid Visual that I can use.

2009/8/28 <email address hidden>

> http://bugs.freedesktop.org/show_bug.cgi?id=23386
>
>
>
>
>
> --- Comment #27 from Michel Dänzer <email address hidden> 2009-08-28
> 07:51:25 PST ---
> Okay, I think I see the problem. It looks for a visual which
>
> 1. Has depth and stencil bits.
> 2. Has a corresponding picture format with alpha bits.
>
> 1. is satisfied by many visuals, but 2. is only satisfied by the depth 32
> visual, which probably doesn't have stencil bits. It may be possible to fix
> this with yet another rework of the xserver GLX visual code, but in the
> meantime could cairo-dock work without a stencil buffer?
>
>
> --
> Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>

Hi,

Cairo-Dock in rev 1922 is now working properly with ati driver with no freeze, no black rectangle and no problems :)
It's now working when the dock try to get a visual, then try to get one without stencil buffer, he finally got a visual with alpha-support

So thanks a lot for your improvement in this driver

Now we can say that GL_EXT_texture_from_pixmap extension is working

Maybe mac_v can try with latest svn revision and tell us if it works

BTW, my graphic card is a Mobility Radeon 9600 Pro (RV350)

(In reply to comment #29)
> Cairo-Dock in rev 1922 is now working properly with ati driver with no freeze,
> no black rectangle and no problems :)

Cool, resolving this report as fixed. mac_v, if it still fails to start for you, please file a separate report if there isn't one about that problem yet.

> Now we can say that GL_EXT_texture_from_pixmap extension is working

That's been working for several years. The problem here was that DRI1 couldn't handle OpenGL rendering to windows redirected via the Composite extension, which has been fixed with DRI2.

yep thanks for your advice, that did the trick. :)
However, the lack of Stencil buffer will cause some visual bugs (for the
reflects), so it would be nice to add it.
but I guess it's another bug.

2009/8/29 <email address hidden>

> http://bugs.freedesktop.org/show_bug.cgi?id=23386
>
>
> Michel Dänzer <email address hidden> changed:
>
> What |Removed |Added
>
> ----------------------------------------------------------------------------
> Status|NEW |RESOLVED
> Resolution| |FIXED
>
>
>
>
> --- Comment #30 from Michel Dänzer <email address hidden> 2009-08-29
> 05:15:54 PST ---
> (In reply to comment #29)
> > Cairo-Dock in rev 1922 is now working properly with ati driver with no
> freeze,
> > no black rectangle and no problems :)
>
> Cool, resolving this report as fixed. mac_v, if it still fails to start for
> you, please file a separate report if there isn't one about that problem
> yet.
>
>
> > Now we can say that GL_EXT_texture_from_pixmap extension is working
>
> That's been working for several years. The problem here was that DRI1
> couldn't
> handle OpenGL rendering to windows redirected via the Composite extension,
> which has been fixed with DRI2.
>
>
> --
> Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released

(In reply to comment #30)
> (In reply to comment #29)
> > Cairo-Dock in rev 1922 is now working properly with ati driver with no freeze,
> > no black rectangle and no problems :)
>
> Cool, resolving this report as fixed. mac_v, if it still fails to start for
> you, please file a separate report if there isn't one about that problem yet.
>

I'v checked with svn rev 1925 and i get the same error as before.

Sorry , Michel. I'm reopening this bug, because:
- I could not find another bug regarding this.
- All the relevant information is already present here , opening a new bug leads to unnecessary duplication , people who have commented here would have to be informed about the new bug and would have to again comment on the new bug.
- I'm the original reporter of the bug , if it has not been fixed for in the initially reported hardware , how is it a Fixed status? It's like saying an ATI driver bug was Fixed in a NVidia driver!

Or Maybe I'm making some mistake , in using the KMS :
On boot , Press E and I edit the kernel line and add the "radeon.modeset=1" without quotes, one space after the "splash" entry.
and After adding the option , i just use Crtl+X to start the system.
Did i miss some step?

$glxgears works fine with KMS , but just reports a lower FPS than without KMS , nearly half the FPS.[With KMS its ~500FPS , but without its ~1000FPS]

Same cairo-dock error as before:>
warning : (cairo-dock-draw-opengl.c:cairo_dock_get_opengl_config:1690)
  couldn't find an appropriate visual ourself, trying something else, this may not work with some drivers ...
warning : (cairo-dock-modules.c:cairo_dock_preload_module_from_directory:327)
  while opening module '/usr/lib/cairo-dock/libcd-xfce-integration.so' : (libthunar-vfs-1.so.2: cannot open shared object file: No such file or directory)
gtk_widget_get_gl_context: assertion `GTK_IS_WIDGET (widget)' failed
OpenGL version: 1.5 Mesa 7.6-devel
OpenGL vendor: DRI R300 Project
OpenGL renderer: Mesa DRI R300 (RV515 7145) 20090101 x86/MMX/SSE2 TCL DRI2
if your drivers are crappy, we'll know it immediately ... ok, they seem fine enough.
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll speed'
warning : (cairo-dock-config.c:cairo_dock_get_double_key_value:172)
  Key file does not have key 'scroll accel'
cairo_dock_replace_values_in_conf_file (/home/vishnoo/.config/cairo-dock/current_theme/plug-ins/rendering/rendering.conf)
cairo_dock_replace_key_values (0)
g_key_file_has_key: assertion `key_file != NULL' failed
warning : (cairo-dock-keyfile-utilities.c:cairo_dock_flush_conf_file_full:72)
  Couldn't find any installed conf file
cairo_dock_replace_values_in_conf_file (/home/vishnoo/.config/cairo-dock/current_theme/plug-ins/dialog-rendering/dialog-rendering.conf)
cairo_dock_replace_key_values (0)
cairo_dock_replace_values_in_conf_file (/home/vishnoo/.config/cairo-dock/current_theme/plug-ins/Animated-icons/Animated-icons.conf)
cairo_dock_replace_key_values (0)
drmRadeonCmdBuffer: -22

@mac_v :

could you please check if you got this line in dmesg ?
[drm] radeon: kernel modesetting successfully initialized.

Then could you please try to launch CD with this command line :

cairo-dock -o
cairo-dock -c
cairo-dock -io

(In reply to comment #32)
> - I'm the original reporter of the bug , if it has not been fixed for in the
> initially reported hardware , how is it a Fixed status? It's like saying an ATI
> driver bug was Fixed in a NVidia driver!

No, you're saying the bug you reported (rendering artifacts) isn't fixed because you're now seeing a different bug (failure to start).

It's very simple: Each problem needs to be tracked in its own report. Anything else is not manageable.

> Same cairo-dock error as before:>
> warning : (cairo-dock-draw-opengl.c:cairo_dock_get_opengl_config:1690)
> couldn't find an appropriate visual ourself, trying something else, this may
> not work with some drivers ...

If there's nothing like

'couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...'

before this, you don't seem to have Yann's changes.

(In reply to comment #34)
>
>
> If there's nothing like
>
> 'couldn't find an appropriate visual, trying to get one without Stencil buffer
> (it may cause some little deterioration in the rendering) ...'
>
> before this, you don't seem to have Yann's changes.
>

Oops, you are right! the svn install hadnt been done properly.
And the error was because i was still running the old version.

I re-installed the svn and checked again.
This problem has been fixed. Cairo-dock works fine.

Thanks to all who have worked on this .... :) you rock \o/

PS: Michel , Kindly direct me to the bug# regarding the slow FPS with KMS?
The closet I could find was > http://bugs.freedesktop.org/show_bug.cgi?id=21508
or is that the bug?

Bryce Harrington (bryce) on 2009-10-10
description: updated
Bryce Harrington (bryce) wrote :

Hrm, this bug report has gotten very confusing and seems to be combining multiple different issues. I see the upstream bug is now closed, so no further work will be done there and new bug reports need to be opened for the other issues.

I am going to upload a new -ati and uploaded a new mesa earlier, which I believe fixes at least some of the issues being commented on. I would ask that you guys re-test with those installed and file NEW bugs for any remaining problems. Please be clear and specific, as upstream requires one-bug-report-per-issue to make it feasible to track changes.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:6.12.99+git20090929.7968e1fb-0ubuntu1

---------------
xserver-xorg-video-ati (1:6.12.99+git20090929.7968e1fb-0ubuntu1) karmic; urgency=low

  * New upstream git snapshot 20090929 (master) up to commit
    7968e1fb, includes: (FFe LP: #420803)
    + [718a611f] radeon: fix zaphod
    + [917f2d7c] RV280: add agp quirk
    + EXA fixes (LP: #408065)
    + Many r6xx/7xx fixes
    + Many KMS fixes
    + [55fbdbae] Fix random screen blanking (LP: #310864)

  [Tormod Volden]
  * debian/rules: clean up after (un)patching

  [Bryce Harrington]
  * Drop 100_radeoninit3dengine_crash.patch: Included upstream

 -- Bryce Harrington <email address hidden> Tue, 13 Oct 2009 14:38:06 -0700

Changed in xserver-xorg-video-ati (Ubuntu):
status: Fix Committed → Fix Released
Fabounet (fabounet03) wrote :

I mark this bug as fixed then, thanks for your work on Intel drivers guys !

Changed in cairo-dock (Ubuntu):
status: Incomplete → Fix Released
Bernerd (beaguirre) on 2009-10-31
Changed in xserver-xorg-video-ati (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.