Ubuntu

Xv UYVY overlay garbled

Reported by Arne Caspari on 2006-04-06
10
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

The UYVY Xv overlay only displays garbled output, at least on PPC machines. YUY2 overlay seems to work fine.

This behaviour occured only with the recent dapper updates, most propably with the update from 6.5.7.3-0ubuntu3 to 6.5.7.3-0ubuntu4.

SDL applications using the UYVY overlay suffer the same issue.

To reproduce:
 Either:
 - Use an application that uses the SDL UYVY overlay like 'coriander' and display live video ( requires a camera )

 OR:

 - Download 'unicap' from http://www.unicap-imaging.org and compile with:
  'configure --enable-thing'
 Then compile and run the 'unicapgtk_smallapp' sample program. It offers a 'thing' capture device which displays an UYVY test screen on a Xv UYVY overlay.

I confirm this bug on i386:

 - coriander crashes or freezes as soon as I try to display an image:

Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 25 error_code 2 request_code 141 minor_code 19
Xlib: unexpected async reply (sequence 0x1b32)!

 - unicapgtk_smallapp crashes with this error message:

The program 'unicapgtk_smallapp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 15894 error_code 2 request_code 141 minor_code 18)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

When ATI provides a new driver version, will it appear in dapper-updates ?

Timo Jyrinki (timo-jyrinki) wrote :

Does this still happen in Ubuntu 6.10?

Btw, ATI does not provide the drivers, the open source community does. Unfortunately ATI/AMD is not currently really supporting the development of these drivers, unlike Intel for its integrated graphics. ATI does have its own closed source offering that has to be installed separately, but it often has more problems.

Arne Caspari (arne-datafloater) wrote :

Timo:

I am sorry I can not test this issue anymore since my PPC machine is out of order.

Timo Aaltonen (tjaalton) wrote :

Fixed by this upload:

 xserver-xorg-video-ati (1:6.6.3-2ubuntu5) feisty; urgency=low
 .
   * debian/patches/108_fix_planar_yuv.diff
     - Patch from upstream which makes UYVY overlay work correctly
       (LP: #38345)

Changed in xserver-xorg-video-ati:
status: Unconfirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Unfortunately, the patch seemed not to work without bringing a whole new radeon_video.c to the driver, so for safety reasons the fix has been postponed. Thus reopening this.

Changed in xserver-xorg-video-ati:
status: Fix Released → Confirmed
Timo Aaltonen (tjaalton) wrote :

Surely this is fixed now in gutsy/7.10. If not, feel free to reopen.

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers