[RV530] [X1600] jaunty: X session (radeon) slows down, crashes

Bug #373434 reported by Marek Szuba
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Invalid
High
Tormod Volden

Bug Description

I run Ubuntu on a first-generation Macbook Pro (dual-core x86; Mobility Radeon X1600), using the 'radeon' video driver, wdm as my X display manager and Blackbox as my window manager. Under Intrepid everything worked fine, however upgrading to Jaunty resulted in the following symptoms:
 - after logging in the X-server process begins to persistently use about 60% of CPU power, even with the system being completely idle;
 - opening X applications takes more and more time: for example, launching the xterm originally takes only a split second as before but trying to do that again a few minutes later implies having to wait for OVER ONE MINUTE from selecting the option from the menu till the moment the window actually appears. The slowdown affects only X applications, whatever I may run e.g. inside an already-active xterm runs just fine;
 - X seems to crash once in a while - all of a sudden I find myself looking at the wdm prompt again. The word 'seem' has been used because oddly enough I cannot find any trace of such crashes in X logs.

The problem is quite clearly related to either the X server or its drivers, as forcibly downgrading xserver-xorg to the Intrepid version (uninstall, switch apt sources back to intrepid, reinstall) makes these problems go away despite the fact libX11 from Jaunty is not entirely compatible with the X server from Intrepid.

Please let me know if you need any more information.

--
MS

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
     Subsystem: Intel Corporation Device [8086:7270]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M56P [Radeon Mobility X1600] [1002:71c5]
     Subsystem: Apple Computer Inc. Device [106b:0080]

Tags: crash jaunty
affects: ubuntu → xserver-xorg-driver-ati (Ubuntu)
Revision history for this message
Tormod Volden (tormodvolden) wrote :

Please run "apport-collect 373434" to attach more information.

affects: xserver-xorg-driver-ati (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Tormod Volden (tormodvolden)
status: New → Incomplete
summary: - jaunty: X session (radeon) slows down, crashes
+ [X1600] jaunty: X session (radeon) slows down, crashes
Revision history for this message
Rolf Leggewie (r0lf) wrote : Re: [X1600] jaunty: X session (radeon) slows down, crashes

Marek, in addition to what Tormod said, can you please take a look at bug 363238 to see if yours is a duplicate report to that? Try XAA instead of EXA as suggested.

Revision history for this message
Marek Szuba (marek-szuba) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-ati 1:6.12.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 LC_MONETARY=pl_PL.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=pl_PL.UTF-8
 PATH=(custom, no user)
 LC_CTYPE=pl_PL.UTF-8
ProcVersion: Linux version 2.6.29.2 (root@shodan) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #1 SMP PREEMPT Thu Apr 30 09:24:56 PDT 2009
Uname: Linux 2.6.29.2 i686
UserGroups:

Xrandr:

glxinfo:

setxkbmap:

xdpyinfo:

xkbcomp:

Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-ati 1:6.12.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 LC_MONETARY=pl_PL.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=pl_PL.UTF-8
 PATH=(custom, no user)
 LC_CTYPE=pl_PL.UTF-8
ProcVersion: Linux version 2.6.29.2 (root@shodan) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #1 SMP PREEMPT Thu Apr 30 09:24:56 PDT 2009
Uname: Linux 2.6.29.2 i686
UserGroups:

Xrandr:

glxinfo:

setxkbmap:

xdpyinfo:

xkbcomp:

Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-ati 1:6.12.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 LC_MONETARY=pl_PL.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=pl_PL.UTF-8
 PATH=(custom, no user)
 LC_CTYPE=pl_PL.UTF-8
ProcVersion: Linux version 2.6.29.2 (root@shodan) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #1 SMP PREEMPT Thu Apr 30 09:24:56 PDT 2009
Uname: Linux 2.6.29.2 i686
UserGroups:

Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote :
Revision history for this message
Marek Szuba (marek-szuba) wrote : Re: [X1600] jaunty: X session (radeon) slows down, crashes

See above fot apport-collect output; sorry about multiple copies having been sent, I initially ran collection outside X.

PS. Switching to XAA does *not* help, neither does setting all the options posted by crjackson in comments on bug 363238.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Bryce Harrington (bryce)
tags: added: crash
Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
tags: added: jaunty
Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new version of the -ati driver is now available in Karmic.

This is a significant update to -ati which brings in kernel mode-setting
(currently disabled) and scores of fixes for DRI2, EXA, etc.

I've posted the new version of this driver to the following PPA,
would you mind testing it and seeing if it resolves the bug you
reported?

  https://edge.launchpad.net/~bryceharrington/+archive/ppa/+sourcepub/709908/+listing-archive-extra

If you're not running this release of Ubuntu, you can try booting the Karmic
LiveCD and loading the PPA onto it, and then log out/in to restart X.
ISOs are available at http://cdimages.ubuntu.com/releases/

After testing Karmic, report back here whether it's still an issue or not,
and if it is please post a fresh Xorg.0.log and 'dmesg' output.

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug xorg'.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Ab3L (himura-kenshin) wrote :

I have a similar problem, but with an ATI RV516 XT Radeon X1600 Series (not Mobility).
The problem is that the screen becomes black for about 1 second each "n" seconds. I think "n" is smaller when the windows are bigger.

I noticed that problem with IRC software like xchat and kvirc, but also with the browser firefox in jaunty and in karmic.
Also the speed of applications seems affected.

I was not so patient to wait until the system becomes too slow to see what it happened after, but I got all this without running compiz nor other visual effects.

Yours faithfully,

Ab3L

Revision history for this message
Tormod Volden (tormodvolden) wrote :

Ab3L, your issue sounds different. Please file a separate bug report.

Robert Hooker (sarvatt)
summary: - [X1600] jaunty: X session (radeon) slows down, crashes
+ [RV530] [X1600] jaunty: X session (radeon) slows down, crashes
Revision history for this message
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from Marek Szuba. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers