[HD3300] Kubuntu: logout crashes X on AMD64

Bug #367053 reported by Toby Meehan on 2009-04-25
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Fresh install of Kubuntu 9.04 AMD64 on new hardware (ASUS M4A78T-E) with onboard ATI Radeon HD 3300 video.

lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

KDE Desktop effects are not enabled. Using the open source driver, not the proprietary ATI driver.

lspci shows this for video controller:
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3300 Graphics

I logout of KDE 4. Expect to be prompted with KDE login screen. Instead, screen goes to text mode with this text:

===
Starting K Display Manager: kdm
* Starting network connection manager NetworkManager
* Starting Avahi mDNS/DNS-SD Daemon avahi-daemon
* Starting Common Unix Printing System: cupsd
sane disabled: edit /etc/default/saned
* Starting anac(h)ronistic cron anacron
* Starting deferred execution scheduler atd
* Starting periodic command scheduler crond
* Checking battery state...
* Reloading Common Unix Printing System: cupsd
* Reloading system log daemon...
===

I wait about 5 minutes and nothing more. So use Alt-F1 to get command prompt and look around. No KDE processes running. Find this in /var/log/kdm.log:

===
Output DIG dpms success
Blank CRTC 0 success
Disable CRTC 0 success
Disable CRTC memreq 0 success
Blank CRTC 1 success
Disable CRTC 1 success
Disable CRTC memreq 1 success
Output CRT1 disable success
Blank CRTC 0 success
Disable CRTC 0 success
Disable CRTC memreq 0 success
Mode 1600x1200 - 2160 1250 5
freq: 202500000
best_freq: 202484800
best_feedback_div: 707
best_ref_div: 10
best_post_div: 5
Set CRTC 0 PLL success
Set CRTC Timing success
Set CRTC 0 Overscan success
Not using RMX
scaler 0 setup success
Set CRTC 0 Source success
crtc 0 YUV disable setup success
Output DAC1 setup success
Output CRT1 enable success
Enable CRTC memreq 0 success
Enable CRTC 0 success
Unblank CRTC 0 success
Output DIG dpms success
Blank CRTC 1 success
Disable CRTC 1 success
Disable CRTC memreq 1 success
(EE) AIGLX error: dlopen of /usr/lib/dri/(null)_dri.so failed (/usr/lib/dri/(null)_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4f1b66]
1: /usr/bin/X(xf86SigHandler+0x41) [0x485a61]
2: /lib/libc.so.6 [0x7fe4a6ad0040]
3: /usr/bin/X [0x539636]
4: /usr/bin/X [0x5398b8]
5: /usr/bin/X [0x53aabb]
6: /usr/bin/X(CreateDefaultStipple+0xf3) [0x45fdb3]
7: /usr/bin/X(main+0x285) [0x433c55]
8: /lib/libc.so.6(__libc_start_main+0xe6) [0x7fe4a6abb5a6]
9: /usr/bin/X [0x433219]
Saw signal 11. Server aborting.
Output CRT1 disable success
Blank CRTC 0 success
Disable CRTC 0 success
Disable CRTC memreq 0 success
Blank CRTC 1 success
Disable CRTC 1 success
Disable CRTC memreq 1 success
Enable CRTC memreq 0 success
Enable CRTC 0 success
Unblank CRTC 0 success
 ddxSigGiveUp: Closing log
 ddxSigGiveUp: re-raising 11
===

Also found this in Xorg.0.log:

===
(II) RADEON(0): MC_AGP_LOCATION : 0x003f0000
freq: 202500000
best_freq: 202484800
best_feedback_div: 707
best_ref_div: 10
best_post_div: 5
(II) RADEON(0): crtc(0) Clock: mode 202500, PLL 202480
(II) RADEON(0): crtc(0) PLL : refdiv 10, fbdiv 0x2C3(707), pdiv 5
Set CRTC 0 PLL success
Set CRTC Timing success
Set CRTC 0 Overscan success
Not using RMX
scaler 0 setup success
Set CRTC 0 Source success
crtc 0 YUV disable setup success
Output DAC1 setup success
Output CRT1 enable success
Enable CRTC memreq 0 success
Enable CRTC 0 success
Unblank CRTC 0 success
Output DIG dpms success
Blank CRTC 1 success
Disable CRTC 1 success
Disable CRTC memreq 1 success
(II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(--) RandR disabled
(EE) AIGLX error: dlopen of /usr/lib/dri/(null)_dri.so failed (/usr/lib/dri/(null)_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Screen 0 is not DRI capable
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0
(II) RADEON(0): Setting screen physical size to 355 x 265

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4f1b66]
1: /usr/bin/X(xf86SigHandler+0x41) [0x485a61]
2: /lib/libc.so.6 [0x7fe4a6ad0040]
3: /usr/bin/X [0x539636]
4: /usr/bin/X [0x5398b8]
5: /usr/bin/X [0x53aabb]
6: /usr/bin/X(CreateDefaultStipple+0xf3) [0x45fdb3]
7: /usr/bin/X(main+0x285) [0x433c55]
8: /lib/libc.so.6(__libc_start_main+0xe6) [0x7fe4a6abb5a6]
9: /usr/bin/X [0x433219]
Saw signal 11. Server aborting.
Output CRT1 disable success
Blank CRTC 0 success
Disable CRTC 0 success
Disable CRTC memreq 0 success
Blank CRTC 1 success
Disable CRTC 1 success
Disable CRTC memreq 1 success
(II) RADEON(0): RADEONRestoreMemMapRegisters() :
(II) RADEON(0): MC_FB_LOCATION : 0x00d700c0 0x00d700c0
(II) RADEON(0): MC_AGP_LOCATION : 0x00000000
(II) RADEON(0): avivo_restore !
Enable CRTC memreq 0 success
Enable CRTC 0 success
Unblank CRTC 0 success
 ddxSigGiveUp: Closing log
===

I ended up just rebooting from the command line. System booted up and I was able to login again. I've not had any other problems with video. This happens everytime I logout. Reboot and shutdown work without issue.

Let me know if you need any more diagnostic info.

It appears the X server crashed, bringing KDE along with it. Let me know if you need any more diagnostic info.

Josep Cols (josep-cols) wrote :

------------------------------------------
I have the same problem, with the same trace, on a X-86 32 bits.
My computer is a Dell Studio 540 and I've upgraded from Kubuntu 8.10 to Kubuntu 9.04

description: updated
description: updated
affects: ubuntu → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi themeehans,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: crash
tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Toby Meehan (themeehans) wrote :

Reproduced issue. Attached files requested.

Toby Meehan (themeehans) wrote :
Toby Meehan (themeehans) wrote :
Bryce Harrington (bryce) on 2009-05-01
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-13
summary: - logout crashes X on Kubuntu 9.04 AMD64 ATI Radeon HD3300
+ [HD3300] logout crashes X on Kubuntu 9.04 AMD64
Bryce Harrington (bryce) on 2009-05-13
summary: - [HD3300] logout crashes X on Kubuntu 9.04 AMD64
+ [HD3300] Kubuntu: logout crashes X on AMD64
Bryce Harrington (bryce) on 2009-08-13
tags: added: kubuntu

May the bug should be filed against xorg and not the ati driver. I have a similar if not an identical problem but with the VIA UniChrome chip.

1) Install Kubuntu Jaunty and update to the latest packages and install
and enable sshd. Boot latest kernel.

2) Login. Logout. Login. Logout. Screen now goes blank, keyboard does
not respond anymore, ctrl+alt+backspace does not kill X.

3) ssh into box. 'sudo killall -HUP kdm' to 'resolve' blank screen after
second logout attempt. Login screen should now appear. (or I guess switch to a terminal except that Ctrl+Alt+F1 did not work for me)

Toby Meehan (themeehans) wrote :

Upgrading to Kubuntu 9.10 x64 fixed this bug for me.

I have this exact problem with Kubuntu 9.10. I'll attach Xorg.0.log, Xorg.0.log.old and

output of sudo lspci -vvnn

Xorg.0.log.old

abemud (abemud) wrote :

I have 32bit and use radeon driver. 9.10 still doesn't work. But after configuring the driver to use XAA instead of EXA, logout never crashes or hang.

During normal usage, the driver still hangs but rarely. Overall the driver is bad.

bugbot (bugbot) on 2011-04-28
tags: added: jaunty
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → New
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers