[RV530] Screen "static noise" using high resolutions

Bug #366651 reported by jMax on 2009-04-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Since update to Jaunty, I'm experiencing very strange bug when using high resolution (1600x1200).
Some kind of static noise (a bit like on TV without antenna) is displayed continuously. As this "snow" is white, it's particularly annoying on black background.

 My screen is Wacom Cintiq 21UX and can handle this resolution (1600x1200) using this refresh rate (60Hz).

Curiously this doesn't occurs with lower resolution as 1280x1024 I switched to using xrandr.

No change using XAA or EXA.

Remarkable output on Xorg.0.log is :
(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0): MC_FB_LOCATION was: 0xefffe000 is: 0xefffe000
(WW) RADEON(0): MC_AGP_LOCATION was: 0x003f0000 is: 0xffffffc0
for warning, and
(EE) RADEON(0): Unable to reserve offscreen area for back buffer, you might experience screen corruption
for errors. No idea if related to my problem. Last log (error) doesn't occurs ou xserver startup, but while using. Seems related to OpenGL context creation.

Full Xorg.0.log and lspci attached

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82Q963/Q965 Memory Controller Hub [8086:2990] (rev 02)
     Subsystem: Hewlett-Packard Company Device [103c:2802]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV530 [Radeon X1600] [1002:71c0]
     Subsystem: Micro-Star International Co., Ltd. Device [1462:0430]

jMax (jmax-red) wrote :
jMax (jmax-red) wrote :
affects: xserver-xorg-driver-ati (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2009-04-28
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed

The radeon driver mostly works for me, but I get distracting light snow and occasional horizontal lines flickering across the screen. I've tried to capture some close-up images with my camera which I'll attach to this bug. The worst corruption is at the far right of the screen.

I don't see the problem with the radeonhd driver. I've tried to switch to the radeon driver a few times but always run into this snag.

I'm running Ubuntu Jaunty with ati_drv.so from xf86-video-ati-6.12.2-76-g2c8e130

My hardware is an HP t5735 thin client with onboard x1200:

$ lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

I'll attach configs, logs and the photos

Created an attachment (id=25431)
xorg.conf for radeon (snowy)

Created an attachment (id=25433)
Xorg.0.log for radeon (snowy)

Created an attachment (id=25436)
xorg.conf for radeonhd (clean)

Created an attachment (id=25438)
Xorg.0.log for radeonhd (clean)

Created an attachment (id=25439)
snapshot of "snow" on lcd monitor

The corruption comes and goes so quickly, I captured this with a relatively long exposure since a fast shot would never catch it.

Created an attachment (id=25440)
second snapshot of "snow" on lcd monitor

The corruption comes and goes so quickly, I captured this with a relatively long exposure since a fast shot would never catch it.

Can you try with the driver from xf86-video-ati git master? Also, you might want to increase the amount of vram allocated to graphics in your bios if possible. your current setting (32 MB) is too small to enable the dri which results in slower 2D performance and no Xv acceleration as well.

Hi Alex, I enjoy watching your daily commits to the driver. Thanks for looking at my bug.

I think I am already running the git master as mentioned in the description (xf86-video-ati-6.12.2-76-g2c8e130). Sorry that wasn't clear. I cloned and built like this:

$ git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-ati
$ cd xf86-video-ati
$ ./configure
$ make
$ cp -fb src/.libs/ati_drv.so /usr/lib/xorg/modules/drivers/ati_drv.so

However I just realized I only copied ati_drv.so and not radeon_drv.so. I assume I can ignore the theatre*.so files.

I'll retry with radeon_drv.so. Also I'll check if I can increase the RAM allocated to video. I wasn't aware that was possible. Thanks!

Okay, I retested with the correct radeon_drv.so. I also copied the theatre*.so files into place just in case, though I don't know what purpose they serve. Unfortunately I get the same snow as before. I'll update the attached Xorg.0.log to the new one.

Regarding RAM allocated to gfx, unfortunately the BIOS doesn't provide any options for changing that. Do you have any suggestions for manipulating that value apart from the supplied BIOS?

Regarding DRI, I'm able to use DRI with the radeonhd driver by setting Virtual 1920 1200. However I've noticed that doesn't work for the radeon driver. I guess the radeon driver needs more memory than radeonhd?

Created an attachment (id=25462)
Xorg.0.log for radeon (snowy)

(In reply to comment #9)
> Regarding RAM allocated to gfx, unfortunately the BIOS doesn't provide any
> options for changing that. Do you have any suggestions for manipulating that
> value apart from the supplied BIOS?
>
> Regarding DRI, I'm able to use DRI with the radeonhd driver by setting Virtual
> 1920 1200. However I've noticed that doesn't work for the radeon driver. I
> guess the radeon driver needs more memory than radeonhd?
>

It should work. The virtual stuff is handled by the xserver. what does the log say when you set the virtual option?

(In reply to comment #11)
> It should work. The virtual stuff is handled by the xserver. what does the
> log say when you set the virtual option?

Sorry, I didn't mean that the Virtual line didn't work. What I meant was that using Virtual 1920 1200 would allow the radeonhd driver to enable DRI, but not the radeon driver.

However I retested and it appears that using Virtual 1920 1200 allows either driver to enable DRI. That's good to know for the future, but it doesn't change anything regarding the "snow" screen corruption which is present with radeon but not radeonhd.

Does disabling colortiling help?

Option "ColorTiling" "FALSE"

Bryce Harrington (bryce) on 2009-05-06
description: updated

(In reply to comment #13)
> Does disabling colortiling help?
> Option "ColorTiling" "FALSE"

Sorry for the delay, this is my primary workstation... I tried the suggestion, it unfortunately doesn't help. Back to radeonhd for now, but I'll update from git and test any further suggestions you want. Thanks.

Maybe you monitor doesn't like coherent mode. try:
xrandr --output DVI-0 --set coherent_mode 0
I don't remember if it takes effect immediately or not, so you may have to force a mode change, e.g.:
xrandr --output DVI-0 --mode 1280x1024
xrandr --output DVI-0 --mode 1920x1200

(In reply to comment #15)
> Maybe you monitor doesn't like coherent mode. try:
> xrandr --output DVI-0 --set coherent_mode 0
> I don't remember if it takes effect immediately or not, so you may have to
> force a mode change, e.g.:
> xrandr --output DVI-0 --mode 1280x1024
> xrandr --output DVI-0 --mode 1920x1200

I tried the sequence above. The snow is gone at 1280 but returns at 1920.

Bryce Harrington (bryce) on 2009-05-15
tags: added: resolution

I can confirm this exact same behaviour. White static on a 1920x1200 resolution, doesn't happen in 1680x1050, 1600x1200 or below. Doesn't happen either on Intrepid + fglrx, or Windows XP. Since I also have the "flickering" bug (sometimes, screen switches off for one second), I tested if the CPU frequency changes anything, but it doesn't. Flickering is not noticeable on a white background, and barely noticeable on a black one. Also, it isn't a heat problem, since it also happens right after a cold boot.

jMax's description of this phenomenon as "static" is quite good. It consists of lines that are always horizontal and seem to be one pixel in width and varying between ~5 to ~50 pixels in length. They are white, although some seem to be reddish. It is a little hard to make out, since they disappear almost instantly. They are not related to any windows or other area of the screen.

My Xorg.0.log contains the same warnings as jMax's, but not the error.

Hardware + system information:
Laptop: Dell Latitude D610
Graphics card: ATI Mobility Radeon X300 128 MB [RV 370]
Monitor: VideoSeven D24W33 24" wide screen, 1920x1200, connected via DVI output on the docking station to HDMI input on monitor
Ubuntu Version: Jaunty with "radeon" driver
Composite: switched off in xfwm4

If you need further information, please ask.

Oh, forgot to mention: doesn't happen on the internal LVDS.

This might be a duplicate of #349160 : https://bugs.launchpad.net/bugs/349160

I have experienced a similar problem on my Dell 5100. For me it seems to have worsened considerably with new kernel versions.

I started running Ubuntu Intrepid on a Dell 5100 laptop at the beginning of March (2009). I don't recall any display problems for the first few weeks. Then a few weeks ago I noticed occasional pixel artifacts and odd horizontal lines. It worsened, and a few days ago became intolerable.

For me the severity seems to depend upon the Linux kernel version. When running 2.6.27-14-generic I get prolonged colorful snowstorms, green and blue blizzards, that last anywhere from seconds to minutes, recurring at intervals from one minute to maybe fifteen minutes. My display becomes pretty much incomprehensible and useless.

Running 2.6.27-11-generic (the previous kernel automatically downloaded by my system update) is somewhat better, but still frustrating. The blizzards are less frequent, but I do see many artifacts and lines.

I've gone back to 2.6.27-7-generic for now. With that kernel I get zero snowstorms (that I recall) and just a few pixel artifacts similar to the snapshots Aron posted.

I can also still boot Windows XP. No displays problems occur then, so it doesn't appear to be failing hardware.

Other technical details:

Here's the panel ID from Xorg.0.log:
(II) RADEON(0): Panel ID string: IBM J1838 ITSX95

Chipset: "ATI Radeon Mobility M7 LW (AGP)" (ChipID = 0x4c57)

This is a Dell 5100, about six years old. Native panel resolution is 1400x1050.

Radeon drivers loading:
(II) Matched radeon from file name radeon.ids
(==) Matched radeon for the autoconfigured driver
(II) LoadModule: "radeon"
(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
(II) AIGLX: Loaded and initialized /usr/lib/dri/radeon_dri.so

My /etc/X11/xorg.conf is all defaults, apparently set by dexconf. I have attempted no tweaking of settings.

I hope that's useful.

Cheers

Oops, I forgot to paste the version info for radeon_drv.so:

(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
 compiled for 1.5.2, module version = 6.9.0
 Module class: X.Org Video Driver
 ABI class: X.Org Video Driver, version 4.1

(In reply to comment #18)
> Oops, I forgot to paste the version info for radeon_drv.so:
> compiled for 1.5.2, module version = 6.9.0

6.9.0 is ancient. You might have more luck with a more recent version. 6.12.2 is that latest release.

Thanks for the version tip.

I've been hoping not to stray from Ubuntu stock downloads, but I'll give the newer radeon driver a try ASAP.

No joy. Or at least, less joy than I hoped for.

radeon_drv.so 6.12.2 still exhibits display corruption for me. At first it seemed better. It ran without any issues the first day. But as I was about to file an update this morning, the problem returned.

One thing I noticed today when I rebooted to a different kernel version: the display corruption persisted even after X apparently shut down. During shutdown, when the display switched to a text console, the plain text became garbled. Even the BIOS POST and boot screen were garbled. The console text cleared up when the GRUB menu ran.

As I type this my display is quivering from side to side, with portions of my browser window shifting several pixels left and right.

I'm trying to take some pictures of my screen. I'll upload a snapshot if I get one that shows the problem.

jMax (jmax-red) wrote :

Reading https://bugs.freedesktop.org/show_bug.cgi?id=21553, I found the problem is related to "coherent mode" (What's that ?!?). Command line below solve the problem.

xrandr --output DVI-0 --set coherent_mode 0

I can enjoy again my 1600x1200 screen !

Does anybody knows how to make coherent mode disabled as default ? I can't found anything related to this reading man ati...

Hope this workaround may help other people...

Hmm, I can't set coherent_mode on my card (see attachment).

The only information I can find on coherent mode is this:

http://bugs.freedesktop.org/show_bug.cgi?id=21050
Quote: "Coherent [mode] ... affects how the clock is recovered in the monitor. Most new monitors prefer coherent, however, that's not always the case."

Just come across this bug - I think it may be related to the one I reported here.

http://bugs.freedesktop.org/show_bug.cgi?id=22229

Would be interesting to know if the fix/hack I found works in your case.

I've incorporated Tom's patch into xf86-video-ati git master. Please test and let me know if it helps.

Alex, this solves the problem for me. I tested this morning with Tom's patch and now I'm running git revision 808c90a24c48da7fa97e15e2f12be5bb8fd8cc96 [Only enable frac fb divs on rs600/rs690/rs740 for now]. Thank you Tom!

I'll try this patch ASAP.

I compiled and installed the current git master. It hasn't run long enough to determine whether the noise and screen corruption have gone away for me.

But it has run long enough to generate several megabytes of this message in Xorg.log:

(EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at radeon_commonfuncs.c:809
(EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at radeon_commonfuncs.c:809
(EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at radeon_commonfuncs.c:809
(EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at radeon_commonfuncs.c:809

(In reply to comment #26)
> I compiled and installed the current git master. It hasn't run long enough to
> determine whether the noise and screen corruption have gone away for me.
>
> But it has run long enough to generate several megabytes of this message in
> Xorg.log:
>
> (EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at
> radeon_commonfuncs.c:809
> (EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at
> radeon_commonfuncs.c:809
> (EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at
> radeon_commonfuncs.c:809
> (EE) RADEON(0): ADVANCE_RING count != expected (6 vs 10) at
> radeon_commonfuncs.c:809
>

Fixed now. However, the pll fix in this bug is only relevant to rs6xx chips and you are running an r1xx chip.

I noticed the chip family selection in the patch code, and I suspected it wouldn't apply to mine. I thought I'd try it anyway.

Is the frequency selection a benign change that could applied safely to my chip version as well?

The screen trash problem just returned while I've been typing. Just like last time it first reappeared while typing in this comment form. An odd coincidence, but probably just Murphy's Law, I think. The display problem happens with various apps running, not just Firefox.

I piggybacked on this bug report because it seemed closely related. If the original reported case is now fixed, would you like me to file a new, separate bug report?

By the way, the current git master does seem to fix another minor cosmetic quirk that I hadn't even reported. So that's an improvement.

I just took a batch of photos while my display was snowed. I'll see if any of them turned out well enough to illustrate the problem.

Cheers

(In reply to comment #28)
> I noticed the chip family selection in the patch code, and I suspected it
> wouldn't apply to mine. I thought I'd try it anyway.
>
> Is the frequency selection a benign change that could applied safely to my chip
> version as well?

It's not relevant as your chip does not have fractional fb dividers.

>
> The screen trash problem just returned while I've been typing. Just like last
> time it first reappeared while typing in this comment form. An odd
> coincidence, but probably just Murphy's Law, I think. The display problem
> happens with various apps running, not just Firefox.
>

Does it happen with acceleration disabled (Option "NoAccel" "True")
or DRI disabled (Option "DRI" "False")? It might also be AGP related. Try:
Option "AGPMode" "X"
where X = 1 or 2 or 4
or Option "BusType" "PCI"

> I piggybacked on this bug report because it seemed closely related. If the
> original reported case is now fixed, would you like me to file a new, separate
> bug report?

It may be the same issue, but the resolutions will probably be different since the chips are so different. Might as well file a new bug.

>
> By the way, the current git master does seem to fix another minor cosmetic
> quirk that I hadn't even reported. So that's an improvement.
>

Good. What was it?

> I just took a batch of photos while my display was snowed. I'll see if any of
> them turned out well enough to illustrate the problem.

That would be helpful. It would also be helpful to get a copy of your video bios and you xorg log and config.

New bug filed, 22256
https://bugs.freedesktop.org/show_bug.cgi?id=22256

The quirk that seems fixed for me involves some artifacts on window decorations after waking up from hibernation. After waking up, I used to see some horizontal lines a few pixels away from window top and bottom edges and some odd shapes at the corners of 3D buttons and such.

My workaround was to restart the gtk-window-decorator process using the command "gtk-window-decorator --replace".

That minor issue seems to have gone away in the current git master revision.

Git is new to me, by the way. I don't yet know how to obtain the git version to be more specific.

Thanks for plugging away at this!

Cheers

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Bryce Harrington (bryce) wrote :

The patch that fixes this according to the upstream bug, is already present in Karmic. According to the git changelogs, this patch caused a regression (subsequently fixed with other changes) so is probably too high of risk for backporting to Jaunty. However once a new official -ati is released, if I have time I'll try adding it to the x-updates ppa.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
status: Unknown → Fix Released

I seem to be getting this in Lucid beta 1 64 bit version. (only tried on live disk version so far)

ubuntu@ubuntu:~$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

Computer is a Dell Studio 15.
Workaround mentioned before doesn't work... Xrandr complains about DVI-0 not existing.

Attached xorg.0.log

Seth Chandler (sethbc) wrote :

I'm getting the same problem Chris mentions above on live installs. There is a static on screen (it feels to me like the refresh rate is off by a fraction). I can't seem to set coherent mode on LVDS using xrandr. Note that I'm also using a studio 15 with the HD 3400. Output of xrandr --prop

sethbc@studio15:~$ xrandr --prop
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
 load detection: 1 (0x00000001) range: (0,1)
LVDS connected 1920x1200+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
 EDID:
  00ffffffffffff004ca3435400000000
  00120103902115780a87f594574f8c27
  27505400000001010101010101010101
  0101010101017241805871b021406420
  26004bcf1000001a7241805871b02140
  642026004bcf1000001a000000fe0058
  583035358131353443540a20000000fe
  00000000000000000002010a20200079
 scaling mode: Full
  supported: None Full Center Full aspect
   1920x1200 60.0*+
   1920x1080 60.0
   1600x1200 59.9
   1680x1050 60.0
   1400x1050 60.0
   1280x1024 59.9
   1440x900 59.9
   1280x960 59.9
   1280x854 59.9
   1280x800 59.8
   1280x720 59.9
   1152x768 59.8
   1024x768 59.9
   800x600 59.9
   848x480 59.7
   720x480 59.7
   640x480 59.4
HDMI-0 disconnected (normal left inverted right x axis y axis)
 coherent: 1 (0x00000001) range: (0,1)
sethbc@studio15:~$

Changed in xserver-xorg-video-ati (Ubuntu):
status: Fix Released → In Progress
rlar (larky82) wrote :

It seems to me that I have exactly the same problem. I have just updated to ubtuntu 10.04.

I'm using a dell inspiron 6400 with an ati x1400 and open source driver. As Seth Chandler I'm posting the output of xrandr --prop

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
 load detection: 1 (0x00000001) range: (0,1)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
 EDID:
  00ffffffffffff004ca3000000000000
  00100103802115780a87f594574f8c27
  27505400000001010101010101010101
  010101010101c71b00a0502017303020
  26004bcf100000190000000f00000000
  00000000002387026400000000fe0044
  463035360331353458330a20000000fe
  002740505a81b0d9ff01010a2020009d
 scaling mode: Full
  supported: None Full Center Full aspect
   1280x800 60.0*+
   1280x720 59.9
   1152x768 59.8
   1024x768 59.9
   800x600 59.9
   848x480 59.7
   720x480 59.7
   640x480 59.4
S-video disconnected (normal left inverted right x axis y axis)
 tv standard: ntsc
  supported: ntsc pal pal-m pal-60
             ntsc-j scart-pal pal-cn secam
 load detection: 1 (0x00000001) range: (0,1)

rlar (larky82) wrote :

This morning I plugged an external monitor and I get the behaviour described in the bug #537640.

One of the solution proposed for that bug is to execute the following command in order to disable KMS:

echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

It worked for me and it seems that it solved also the problem mentioned in this bug... The drawback of this solution is that the correct solution at login is no longer detected. Anyway, all the rest (or at least what I tried till now) works perfectly.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi jMax,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 366651

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 366651 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/366651

Changed in xserver-xorg-video-ati (Ubuntu):
status: In Progress → Incomplete
tags: added: needs-retested-on-lucid-by-june

Personally my laptop is now working perfectly since trying the final release of Lucid. However it seems clear that some people are now getting a similar sort of issue on Lucid. We've had at least 2 people who seem to be able to reproduce it in Lucid so surely it would be premature to mark it as needing retesting in Lucid? Or should a new bug be filed since its a different version of Ubuntu? (seems very confusing since we're encouraged not to file new bugs if there are related ones...)

Bryce Harrington (bryce) on 2010-05-21
tags: added: hardy
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Vish (vish) wrote :

Thanks for following up. This bug report is being closed due to your last comment regarding this being fixed in latest Ubuntu.
If others are facing similar bugs, kindly file a new bug instead. Not all driver issues are the same, the symptoms might be the same but need not be the same underlying problem.
 For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Psy[H[] (vovik-wfa) wrote :

Ubuntu 10.10 32bit with latest updates, also tried updates from x-updates ppa
Hardware: Asus a8sr with radeon hd2400

I've got snow on laptop display. It was there from the point when ati driver got KMS support, and it is still here.
Noise appears only when KMS engaged, both in console and X.
And it is somewhat color-dependent: it appears most striking on grey areas of screen, and almost non-existent on black, white and fully saturated basic colors.

Do I have to open new bug?

Psy[H[] (vovik-wfa) wrote :

Noise is finally gone with upgrade to natty

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.