[RV250] Kubuntu: X Freezes with Radeon driver EXA/XAA Composite

Bug #348332 reported by Jason Scurtu on 2009-03-25
106
This bug affects 12 people
Affects Status Importance Assigned to Milestone
libdrm (Debian)
Fix Released
Unknown
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Fabian Köster
Nominated for Karmic by Fabian Köster
xserver-xorg-video-ati (Debian)
Fix Released
Unknown
xserver-xorg-video-ati (Fedora)
New
Undecided
Unassigned
xserver-xorg-video-ati (Mandriva)
New
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Fabian Köster
Nominated for Karmic by Fabian Köster

Bug Description

Binary package hint: xserver-xorg-video-ati

I am not able to use Jaunty with my Radeon 9000 RV250 Graphicscard..
When leaving the default settings after install it takes only a few minutes or somtimes seconds then X freezes or goes Black.. Default means EXA and Composite enabled.. Even if I just disable composite (KWin), this Bug still apears..

Allthough if I manual swich the accelleration to use XAA by configuring xorg.conf and disable composite then I am able to use my Computer with out having any Freezes or Blackouts, if I use XAA and have composite (KWin) on it will freez again... But using KDE4 without composite is just no fun ;-)

So I dont know where this Bug acually belongs, so I guess in the Radeon driver..
With my other Computer, one with nvidia GPU and another one with intel GPU have no issues..

Systeminfo:
Description: Ubuntu jaunty (development branch)
Release: 9.04 32bit
Linux jscurtu-desktop 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:23 UTC 2009 i686 GNU/Linux

Hardware:
CPU: AMD Sempron(tm) Processor 3000+ processors (1 cpu cores) (version 2.20.00)
Chipset: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
GPU: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01) VIVO

xserver-xorg-video-radeon:
  Installiert: 1:6.12.1-0ubuntu1
  Kandidat: 1:6.12.1-0ubuntu1

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-ati 1:6.12.1-0ubuntu1
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #37-Ubuntu SMP Mon Mar 23 16:40:23 UTC 2009
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.28-11-generic i686

[lspci]
00:00.0 Host bridge [0600]: VIA Technologies, Inc. K8M800 Host Bridge [1106:0204]
     Subsystem: VIA Technologies, Inc. K8M800 Host Bridge [1106:0204]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon RV250 If [Radeon 9000] [1002:4966] (rev 01)
     Subsystem: PC Partner Limited Device [174b:7194]

Jason Scurtu (solard3ity) wrote :
Jason Scurtu (solard3ity) wrote :

Okay... now after I put the NoDRI option in my xorg.conf, I have no more Freezes..... and naturaly still no Desktop effects..... hmmm

Bryce Harrington (bryce) on 2009-03-30
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Fernando Abramowitz (ferabra) wrote :

Same problem to me.

ATI radeon x2300 (M64-S)

Jason Scurtu (solard3ity) wrote :

This bug is really killing me... I am trying out so many things and it just aint getting better... (
I tried out new updatet drm, mesa, dri from https://launchpad.net/~xorg-edgers/+archive/ppa + updated radeon drivers from tormodvolden.. this bug still remains..
I tied Kernel 2.6.29....

I did few new installs, alternate-daily, netinstall ... this bug still remains...... I did whole lot of things.. this bug still remains.. I am about this --><-- close to get an heartattack...

Since the last updates (fresh-install) it got even worse, i can only use Kubuntu Jaunty with the "NoDRI" option...
I had a few segfaults in my kernlog with akonadi, ksmserver and python that happend with libQtCore.so.4.5.0 error 4 or somthing like that...

Is there any chance that this can get fixed before release? or should I just throw my Hardware out of the window? :-)

Yves Glodt (yglodt) wrote :

I experience freezes quite often as well over the last 2 weeks +/-, probably since the moment the radeon driver supports
acceleration.

I use jaunty/amd64, and my hardware is

01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

Today I turned off acceleration (I removed the DRI on and AccelMethod Exa from xorg.conf) and the system seems to be stable again.

Fernando Abramowitz (ferabra) wrote :

I only disable kwin effects without change the xorg.conf and the system is stable.

Yves Glodt (yglodt) wrote :

More info:

I tried with the 2.6.28-10 kernel, and the situation was the same, instability-wise.
Can anyone point me to the upstream bugreport of this issue?
It really makes ,y system unusable as soon as I turn on DRI, I had 3 freezes in 20 minutes of time

Correction to my post #5:

I only put Option "DRI" "off" into the "Device"-section of my xorg.conf, and the system is slow, but stable.

Yves Glodt (yglodt) wrote :

False alarm... Now even with dri off I had another freeze, and I suspect the iwlagn driver on my system, as seen here:
https://bugs.launchpad.net/ubuntu/jaunty/+source/linux/+bug/276990
Sorry for the noise

Jason Scurtu (solard3ity) wrote :

I was curios and look'ed at other Distributions that are also still in development, as they are simular to Ubuntu (Xorg,Kernel) so I ran thier LiveCD's.
And I found that they all had the same problem, so this is not a Ubuntu issue only!! ...

I Tested:

Fedora 11
Mandriva 2009.1 RC2

Jason Scurtu (solard3ity) wrote :

yes its me again :-)

Now a friend gave me a different card for testing, I now have a ATI Radeon 9600XT ..
I first thought hey, it all works now,....... but after about 45min it went black :-( ... This bug still remains also with other ATI cards..

Bryce Harrington (bryce) on 2009-04-21
description: updated
Cyril Buquet (cyril11) wrote :

Confirmed on my system with Mobility X2300 (M64-S)
If i disable kwin composing, no Freeze

Jason Scurtu (solard3ity) wrote :

Good news, at least for me...
Now with the latest Jaunty bugfix updates and using kernel 2.6.29.1 from the Ubuntu Mainline Kernel repository my system now runs with DRI and Kwin Composite enabled... This did not work before...
Allthough using the 2.6.28.XX Kernel from Jaunty still fails..
Can you try this to see if it works for you too?

Tobias Krais (tux-spam) wrote :

Hi together,

I had the same error. When I removed the fglrx packages, the failure was gone.

Greetings, Tobias

Sergio Callegari (callegar) wrote :

Confirmed with ATI Radeon 9600XT on an older Athlon XP PC.

After a few minutes with composing (effects) enabled either:
1) screen and keybord freeze; or
2) the above with the screen also going black; or
3) the above with the screen going black but a cursor present

in the last case (and only in that) it is possible to reboot the machine with ctrl-alt-del.

System was showing a similar (but minor issue) also with the free radeon drivers on intrepid (Xorg going in an infinite loop), but in that case the system remained responsive from the network.

System was otherwise stable with the fglrx drivers (apart from X crashing on some opengl screensavers).

Florian Hofmann (fhaust) wrote :

I can confirm this bug on a Inspiron 6400 running a Radeon Mobility X1400.
Switching off composing effects 'solves' the problem.

Sergio Callegari (callegar) wrote :

Apparently not a bug in the xorg ati driver but in the kernel.

Kernel 2.6.29.1 from the mainline ppa fixes the bug for me. Now my radeon 9600XT works smoothly and it is notably faster at many things than the proprietary driver.

Pre-built mainline kernels are a truly wonderful innovation!!!

Please backport the relevant changes from .29 to the jaunty kernel as radeon 9600s (and probably other ATI cards) make the system unstable to the point of being unusable when attempting opengl stuff with the current stock kernel.

Are you sure sergio? Because the bug is back in 2.6.30rc3 in this case at least with a X300 card.

juhuu (swinter-bw-computer) wrote :

I can confirm that the problem is gone with kernel 2.6.29 - 1 and that re-appears in kernel 2.6.30 RC3...

I confirm this bug on ATI X600 Mobility (M24 chipset).

Disabling composite (Option "Composite" "Disable") does NOT solve the problem.
Switching to XAA acceleration (Option "AccelMethod" "XAA") does NOT solve the problem.
Disabling DRI (Option "DRI" "off") DOES (seem; no freeze in ~150 minutes) to solve the problem.

> uname -a
Linux nb-cdufour 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
> lspci | fgrep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]

A little OT, but this bug does NOT (seem; during my 10 minutes Nexuiz and 20 minutes X-Plane testing) to occur on my nVidia-based workstation (nVidia 180.44 driver).

Alexander L. (zdemoniac) wrote :

Sergio is right - in 2.6.29.1 and 2.6.30-rc3 problem is gone
ATI x1300 PRO (RV515)

Indeed I don't have any freeze with the 2.6.29.1 kernel. But there are still some problem with plasma.

juhuu (swinter-bw-computer) wrote :

hi

should this bug be marked as a duplicate of bug #351990 ?
Problem seems to be very similar except that jason scurtu describes freezes beeing persistent with composite disabled, where in the other bug report freezes wont occour with compositing disabled.

"should this bug be marked as a duplicate of bug #351990?"

No, bug #351990 was logged later and has less subscribers and they have come to the same conclusion (with the kernel) so if anything 351990 should be closed as a duplicate of this fault, at least thats my tuppence worth.

Jason Scurtu (solard3ity) wrote :

So maybe some of you already read on dfaure's blog, not sure thats why ill post some info here..
just take a look here: http://www.kdedevelopers.org/node/3942

He actually recompiled X.org 1.5.2 for jaunty and offers the packages as a download and mentioned that it solved the problem. Proof that the problem is really X.org 1.6.0 and not Kernel!!

link to the packages: http://www.davidfaure.fr/2009/xorg_debs.tar.bz2

David García (dav.garcia) wrote :

Hi,

I'm also affected by this bug in Kubuntu Jaunty with a Radeon X1600PRO:
02:00.0 VGA compatible controller: ATI Technologies Inc RV530 [Radeon X1600]

The system freezes whenever I turn on compositing, with either EXA or XAA.

Package versions:
linux-image-2.6.28-11-generic 2.6.28-11.42
linux-image-generic 2.6.28.11.15
xserver-xorg 1:7.4~5ubuntu18
xserver-xorg-core 2:1.6.0-0ubuntu14
xserver-xorg-video-ati 1:6.12.1-0ubuntu2

Thomas Ohms (tohms) wrote :

It's possible I have the same problem on my Asus F5V with X2300 installed. According to http://cgit.freedesktop.org/xorg/driver/xf86-video-radeonhd/plain/README my card is still supported, but with fglrx I cannot even get my X-Server up and running. As soon as KDM is starting it freezes X with the error "/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/extensions//libdri.so: undefined symbol: atiddxAbiDixLookupPrivate."
If I use radeon drivers, system works, but I have always display errors like flickering in control panel or scrambled play bar in Dragon Player's fullscreen mode. With radeonhd those errors are gone, but movies are not fluently played back anymore.
Guys let me know I have wrong end of the stick here, but is it possible, that my problem is same than yours?

ibex_rider (david-taille-fr) wrote :

Hi all,

not sure I experience exactly the same bug, but I do think there are issues with radeon driver ...

I recently upgraded 8.10 to 9.04 on a Dell D610 ("lspci | grep VGA" says
"01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]").

All was okay but googleearth (version 4.x and 5) freezes the screen about 15-20 seconds after they are run.
The screen sometimes goes blank or show various moving gradients ; the mouse and keyboard remains responsive and the system is still functioning behind the frozen screen : I can soft reboot by blindly hitting the right keystrokes.

I turned DRI off (option "NoDRI" on the device section) ; googleearth warned me about poor performances due to software-emulated OpenGL but it now *does* work.

But it is actually very very slow ...

David

Jason Scurtu (solard3ity) wrote :

hi ibex_rider,

yes this there is a problem... you can downgrade to Xorg 1.5.2 on jaunty, just use these packages that i pointed to more up in this bug report http://www.davidfaure.fr/2009/xorg_debs.tar.bz2
Installing Xorg 1.5.2 fixes this..

Jason

Hi,

I have the same problem on a Dell Inspiron 6400 with a Radeon Mobility X1400 GPU. It happens with both radeon and radeonhd drivers. So in my opinion it is not a problem with graphics drivers. Maybe Jason is right, it could be an Xorg problem, I will try the downgrade later on.

Turning DRI off indeed fixes the problem, but that is not a viable option.

Andi

Hi,

You could try to just disable compositing instead of DRI.
Add or edit this section in /etc/X11/xorg.conf:

Section "Extensions"
        Option "Composite" "Disable"
EndSection

That's the only change I have applied to avoid this bug at the expense of
losing desktop effects.

On Mon, May 4, 2009 at 10:26 AM, Andreas Wiesauer <
<email address hidden>> wrote:

> Hi,
>
> I have the same problem on a Dell Inspiron 6400 with a Radeon Mobility
> X1400 GPU. It happens with both radeon and radeonhd drivers. So in my
> opinion it is not a problem with graphics drivers. Maybe Jason is right,
> it could be an Xorg problem, I will try the downgrade later on.
>
> Turning DRI off indeed fixes the problem, but that is not a viable
> option.
>
> Andi
>
> --
> [RV250][JAUNTY] X Freezes with Radeon driver EXA/XAA Composite
> https://bugs.launchpad.net/bugs/348332
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I have Radeon Mobility x1600 and had the same problems with freezing.

After installing kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.2/ and all freezes with compositing "on" are gone. It is working.

jtholmes (jtholmes) wrote :

Aya makes a good point, and a great suggestion, thanks aya.

However, many of you reporting this but may not be familiar with getting/installing a mainline
kernel, so if you aren't then I would suggest you try the Ubuntu proposed kernel which is
2.6.28-12.43. That kernel cured the problem for some others reporting a similar bug.

To get the proposed kernel use synaptic and to go
Settings ->Repositories -> Updates, check proposed-jaunty, close
then from from Edit menu select Redo, New Repository should
appear in left window, Select New Repository, and in right window
select Image file, apply, and the new image and initrd will install
and you can alter your /boot/grub/menu.lst to boot the 12.43 kernel
and see if the problem subsides.

If you know how to add jaunty-proposed to your apt sources.list then
do so and you can use apt-get to install the 12.43 image file.

pleas continue to post your success stories or failures about this bug here in
the comments section
thx jt

jtholmes (jtholmes) wrote :

Believe this bug is very similar or a dup or 368461 and possibly 351990

benzimmer (bz) wrote :

Running on following hardware using the radeon driver:

01:00.0 VGA compatible controller: ATI Technologies Inc M66-P [Mobility Radeon X1700]

I noticed that the freezes aren't random, mostly they are happening when "minor" windows are being opened, e.g. the progress bar when installing a new package...can somebody confirm this behavior?

Disabling desktop-effects solves the problem for me.

The kernel image jtholmes suggested has no effect on the problem here.

Did not try the X.org 1.5.2 packages. Think I'll give the mainline kernel a shot in the next days...

I can confirm zeroathome's observation.It always happens when opening minor windows. It is strange that disabling desktop effects and also switching to another kernel does not work for me.

Adam Niedling (krychek) wrote :

Is this bug only for Kubuntu? I'm using Ubuntu and have random freezes during playing 3D games. (Urban terror) Also the performance is very poor compared to fglrx that I was using with Intrepid. Is the performance better with the new kernel? I have Mobility Radeon X1600 and I don't have compiz enabled.

Florian Hofmann (fhaust) wrote :

Switching to 2.6.28-12-generic from jaunty-proposed doesn't help.
Also i think i can confirm zeroathome's observation too. System often freezes when opening kopete chat windows.

jtholmes (jtholmes) wrote :

Could one or more of you switch to the mainline kernel
2.6.28 at http://kernel.ubuntu.com/~kernel-ppa/mainline/
if you know how to install one and see if that makes
a difference, or for those that are really brave could
you use the 2.6.29 mainline and report back.

Thanks in advancehttp://kernel.ubuntu.com/~kernel-ppa/mainline/

Download full text (3.3 KiB)

Ok ... i tested both (2.6.28 and 2.6.29, the latest mainline versions).

WARNING: the 2.6.28 version messed up my ecryptfs home directory ...

But there were no blanking problems with either of them.

2009/5/6 jtholmes <email address hidden>

> Could one or more of you switch to the mainline kernel
> 2.6.28 at http://kernel.ubuntu.com/~kernel-ppa/mainline/<http://kernel.ubuntu.com/%7Ekernel-ppa/mainline/>
> if you know how to install one and see if that makes
> a difference, or for those that are really brave could
> you use the 2.6.29 mainline and report back.
>
> Thanks in advancehttp://kernel.ubuntu.com/~kernel-ppa/mainline/<http://kernel.ubuntu.com/%7Ekernel-ppa/mainline/>
>
> --
> [RV250][JAUNTY] X Freezes with Radeon driver EXA/XAA Composite
> https://bugs.launchpad.net/bugs/348332
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: New
> Status in “xserver-xorg-video-ati” source package in Ubuntu: Confirmed
> Status in “xserver-xorg-video-ati” source package in Fedora: New
> Status in “xserver-xorg-video-ati” source package in Mandriva: New
>
> Bug description:
> Binary package hint: xserver-xorg-video-ati
>
> I am not able to use Jaunty with my Radeon 9000 RV250 Graphicscard..
> When leaving the default settings after install it takes only a few minutes
> or somtimes seconds then X freezes or goes Black.. Default means EXA and
> Composite enabled.. Even if I just disable composite (KWin), this Bug still
> apears..
>
> Allthough if I manual swich the accelleration to use XAA by configuring
> xorg.conf and disable composite then I am able to use my Computer with out
> having any Freezes or Blackouts, if I use XAA and have composite (KWin) on
> it will freez again... But using KDE4 without composite is just no fun ;-)
>
> So I dont know where this Bug acually belongs, so I guess in the Radeon
> driver..
> With my other Computer, one with nvidia GPU and another one with intel GPU
> have no issues..
>
> Systeminfo:
> Description: Ubuntu jaunty (development branch)
> Release: 9.04 32bit
> Linux jscurtu-desktop 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:23
> UTC 2009 i686 GNU/Linux
>
> Hardware:
> CPU: AMD Sempron(tm) Processor 3000+ processors (1 cpu cores)
> (version 2.20.00)
> Chipset: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
> GPU: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01)
> VIVO
>
> xserver-xorg-video-radeon:
> Installiert: 1:6.12.1-0ubuntu1
> Kandidat: 1:6.12.1-0ubuntu1
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: xserver-xorg-video-ati 1:6.12.1-0ubuntu1
> ProcEnviron:
> LANGUAGE=
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version
> 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #37-Ubuntu SMP Mon Mar 23 16:40:23 UTC 2009
> SourcePackage: xserver-xorg-video-ati
> Uname: Linux 2.6.28-11-generic i686
>
> [lspci]
> 00:00.0 Host bridge [0600]: VIA Technologies, Inc. K8M800 Host Bridge
> [1106:0204]
> Subsystem: VIA Technologies, Inc. K8M800 Host Bridge [1106:0204]
> 01:00.0 VGA compatible cont...

Read more...

Pépou (yannickw24) wrote :

Same problem on my computer.
I have a dell inspiron 6400 with an ATI radeon mobility 1400.
I have the radeon driver as fglrx is no longer develop for non HD graphic card.
Uname -a : laptop 2.6.28-12-generic #43-Ubuntu SMP Fri May 1 19:27:06 UTC 2009 i686 GNU/Linux

My computer freezes sometimes with some compiz effects.
It freezes after 20 seconds using google earth and after 20 seconds using cooliris (on firefox).

I didn't find any solution to solve this bug yet.

haneya (a-haneya) wrote :

Hi , am facing the same freezing issue with video, and with compiz (using fusion-icon) after some time Restarting X , if going back to xorg 1.5 will solve the problem and i can use fglrx I will do it . Does upgrade the kernel fix this .

ati X1600 ( tried to install fglrx before but I purged it )

2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux (jaunty)

Thanks.

Rolf Leggewie (r0lf) wrote :

related to bug 363238? That one is also about EXA vs. XAA

Schreiber (schreiber07) wrote :

Hi,
after updating to Kubuntu 9.04 Kernel 2.6.28-11-generic using driver radeon or fglrx I cannot even get my X-Server up and running. After starting kdm there was only black sceene. (Ati Mobility Radeon HD 3400 series). I can only use the vesa-driver.
When I go back to my last Kernel 2.6.24-23-generic, I can use the radeon driver in Kubuntu 9.04.
I am Newby with Linux and I think, I should wait for another Kernel in Kubuntu, before updating the kernel again.
In hardy I could use enyng to get the fglrx-driver working good.
Thanks
Sorry English i not my native language

David García (dav.garcia) wrote :

Hi,

I'm now running kernel 2.6.29.3 in Kubuntu Jaunty and the problem is definitely gone.

To try it, just download and install (with dpkg -i) the following packages:
   linux-headers-2.6.29-*_all.deb, linux-headers-2.6.29-*_i386.deb and linux-image-2.6.29-*_i386.deb
from:
   http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.3/

Don't forget to re-enable compositing by changing your /etc/X11/xorg.conf to:
Section "Extensions"
        Option "Composite" "Enable"
EndSection

I've tried most KDE desktop effects and they perform beautifully.
Video is very smooth with no flickering nor glitches.

My card is an ATI X1600PRO (RV530).

Bryce Harrington (bryce) on 2009-05-13
summary: - [RV250][JAUNTY] X Freezes with Radeon driver EXA/XAA Composite
+ [RV250] Kubuntu: X Freezes with Radeon driver EXA/XAA Composite
Pépou (yannickw24) wrote :

As David,
I just install the last kernel 2.6.29.3 on ubuntu jaunty and the freezes are definitely gone.
I can use google earth, cooliris, compiz without being afraid.

My graphic card is an ati radeon mobility X1600

Bye

haneya (a-haneya) wrote :

@ David García ,

I just updated my kernel as u wrote and added the compiste option but video is still freezing and flickering ..

any thing else to do BTW my card is ATI x1600 mobility ( pepou how did u fix this issue ) .

@haneya:

Make sure you reboot your computer using the new kernel (2.6.29.3).
If so, the command:
   uname -r
should display "2.6.29-02062903-generic" (that's just a guess though; I not
at my home computer at the moment).

benzimmer (bz) wrote :

Kernel 2.6.29-02062903-generic seems to have fixed the issue...no freeze for 6 hours now on my x1700 mobility with enabled compositing...

Desktop effects are back (hopefully) for good :)

haneya (a-haneya) wrote :

@David García :

I guess now its ok no freezing until now but still flickering while playing video with ( emesene notification for example ) but , now it better than ever .

Thanks.

haneya (a-haneya) wrote :

OPSS!! again with the freezing it just happened , am really suffering from this ..

Florian Hofmann (fhaust) wrote :

i just installed GNOME (using the ubuntu-desktop task) and altough i
experienced freezing in KDE there is none in GNOME. So ... is this really
related to the kernel? Or is kwin messing up something here?

2009/5/14 haneya <email address hidden>

> OPSS!! again with the freezing it just happened , am really suffering
> from this ..
>
> --
> [RV250] Kubuntu: X Freezes with Radeon driver EXA/XAA Composite
> https://bugs.launchpad.net/bugs/348332
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: New
> Status in “xserver-xorg-video-ati” source package in Ubuntu: Confirmed
> Status in “xserver-xorg-video-ati” source package in Fedora: New
> Status in “xserver-xorg-video-ati” source package in Mandriva: New
>
> Bug description:
> Binary package hint: xserver-xorg-video-ati
>
> I am not able to use Jaunty with my Radeon 9000 RV250 Graphicscard..
> When leaving the default settings after install it takes only a few minutes
> or somtimes seconds then X freezes or goes Black.. Default means EXA and
> Composite enabled.. Even if I just disable composite (KWin), this Bug still
> apears..
>
> Allthough if I manual swich the accelleration to use XAA by configuring
> xorg.conf and disable composite then I am able to use my Computer with out
> having any Freezes or Blackouts, if I use XAA and have composite (KWin) on
> it will freez again... But using KDE4 without composite is just no fun ;-)
>
> So I dont know where this Bug acually belongs, so I guess in the Radeon
> driver..
> With my other Computer, one with nvidia GPU and another one with intel GPU
> have no issues..
>
> Systeminfo:
> Description: Ubuntu jaunty (development branch)
> Release: 9.04 32bit
> Linux jscurtu-desktop 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:23
> UTC 2009 i686 GNU/Linux
>
> Hardware:
> CPU: AMD Sempron(tm) Processor 3000+ processors (1 cpu cores)
> (version 2.20.00)
> Chipset: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
> GPU: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01)
> VIVO
>
> xserver-xorg-video-radeon:
> Installiert: 1:6.12.1-0ubuntu1
> Kandidat: 1:6.12.1-0ubuntu1
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: xserver-xorg-video-ati 1:6.12.1-0ubuntu1
> ProcEnviron:
> LANGUAGE=
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version
> 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #37-Ubuntu SMP Mon Mar 23 16:40:23 UTC 2009
> SourcePackage: xserver-xorg-video-ati
> Uname: Linux 2.6.28-11-generic i686
>
> [lspci]
> 00:00.0 Host bridge [0600]: VIA Technologies, Inc. K8M800 Host Bridge
> [1106:0204]
> Subsystem: VIA Technologies, Inc. K8M800 Host Bridge [1106:0204]
> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon RV250
> If [Radeon 9000] [1002:4966] (rev 01)
> Subsystem: PC Partner Limited Device [174b:7194]
>
>

Bryce Harrington (bryce) on 2009-05-15
tags: added: freeze
BramWillemsen (willemsen-b) wrote :

Its my first time submitting a bug report so i hope i'm not leaving out any required details.
I'm running ubuntu 9.04, installed it on a formatted drive. In 8.10 i never had any freezes with the flgrx drivers. But since im using 9.04 i have occasional freezes when im using simple programs and switching desktops. Only a hard reboot fixes it. Unfortunately the flgrx drivers that worked perfectly under 8.10 do not support my x1950 in jaunty. Therefore i am using the default radeon drivers. If i launch a 3d game like Nexuiz it will always freeze within 10-15 seconds. Nothing responds anymore and i have to reset the computer. I tried reinstalling 9.04 but the problem occured again. I havent had a single freeze in 8.10 or windows for years. Its only ubuntu 9.04 giving me a hard time. I didnt change anything to the graphical settings btw. I will check back here soon if there are requests to post any additional information.

This bug is very critical to me. I lost quite a bit of work when a freeze occured on the desktop. Not being able to use 3d applications like Nexuiz is quite hard too. I'm quite sure the bug is not related to this game since i tried the same version on 8.10 with no problems at all.

kind regards,
Bram

Jason Scurtu (solard3ity) wrote :

Dear Bram Willemsen,

please read the whole bug report, you will notice that you have a few opportunities to solve this problem..

Either you downgrade your xsever to version 1.5.2 that way you can use fglrx or radeon, packages are provided as a archived package in a link more up in this Bugreport...
2nd you can also update your kernel to a 2.6.29 or .30 release using the Ubuntu Vanilla kernel PPA (Ubuntu Mainline Kernel) and upgrade your radeon driver and X with this PPA https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/ wich was reported also to be successful..

Also let us know if you are using either KDE or Gnome as your desktop of choice? As this bug "so far" seems to be kubuntu related only..

BramWillemsen (willemsen-b) wrote :

Thank you jason. I will take a look at your suggestions. I am using ubuntu (gnome) btw.

BramWillemsen (willemsen-b) wrote :

upgrading the kernel seems to have fixed the problem. I played tested Nexuiz for 5 minutes and no crash occured. Normally it would have frozen in 15 seconds so i guess its working now. Thanks for your help!

Jason Scurtu (solard3ity) wrote :

Glad to help Bram... and I guess you just answered Florian Hofmann's question!! :-)

rove (rovewlf) wrote :

I confirm that new kernel 2.6.29 work on my laptop with:
 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
and all problems of freezes with compiz are gone.
Thanks a lot!

Benny (benny-malengier) wrote :

kubuntu, 9.04. The kernel in jaunty proposed did not remove the freeze for me. AMD64, I got the freeze after less than 15 min only typing text in kate (desktop effects enabled).
Installed the 2.6.29.4 kernel ( 2.6.29-02062904-generic) and all is working like a charm now.

Figuring out how to set up xrandr to have a dual head setup (no more xinerama, and bigdesktop was fglrx only) was more difficult, but now also that is working like a charm with KDE4!

Yann (tatrefthekiller) wrote :

Kernel 2.6.29-02062904-generic seems to solve the problems for me too (X700 mobility, Ubuntu 9.04).
I used to have random freezes while using 3D apps.

Thanks.

> Kernel 2.6.29-02062904-generic seems to solve the problems for me too (X700 mobility, Ubuntu 9.04).
> I used to have random freezes while using 3D apps.

Same over here. With a fully updated stock Ubuntu Jaunty on a T43p / i386 with a
  01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
graphics card, the "radeon" driver and the packages
  linux-image-2.6.28-11-generic 2.6.28-11.42
  xserver-xorg 1:7.4~5ubuntu18
  xserver-xorg-video-radeon 1:6.12.1-0ubuntu2
and an empty xorg.conf.

Problems were:
* random freezes with 3D applications [both with compiz enabled or disabled, DRI & AIGLX were always enabled]
* poor Compiz performance

Both issues were solved by upgrading to linux-image-2.6.29-02062904-generic from the above kernel PPA source. I wonder whether the relevant kernel changes will be backported? I could help to track down in detail what caused the issue. The alternative of disabling DRI for all affected users as described in comment 30 isn't particularly nice.

Those whose problems could not be solved by a kernel upgrade seem to be affected by random freezes even when no 3D application runs. Maybe those people could describe their configuration, and used packages in depth? Especially which kernel/xorg combinations work, and which don't. Also, focusing on "future" technologies [recent DRI releases, EXA] instead of downgrading X.Org would be nice, since XAA or support for the old DRI architecture will be discontinued. Also, please try to start with stock packages and _systematically_ vary the kernel/xorg versions.

RedSocrates (redsocrates) wrote :

I believe that I suffered from this same bug (I suffered from a bug with the same symptoms, anyway--though I didn't try XAA as the original poster did). Like the rest of you, the problem disappeared when I upgraded to a 2.6.29 kernel; for me, it was 2.6.29-020629-generic. (I didn't try any others.)

Here's my video card info., for those interested:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS480 [Radeon Xpress 200G Series] [1002:5954]
 Subsystem: Hewlett-Packard Company Device [103c:2a24]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (2000ns min), Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at d8000000 (32-bit, prefetchable) [size=128M]
 Region 1: I/O ports at ef00 [size=256]
 Region 2: Memory at fddf0000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at fdd00000 [disabled] [size=128K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Jason Scurtu (solard3ity) wrote :

It seems that upgrading the Kernel to 2.6.29 only helps with certain chips newer than RV250.. it help'd with a Radeon 9600 pro that I used from a friend wich is a RV300 I think.. , but freezes still remains with my Radeon 7000, it wont even boot to the Desktop it freezes or go's black right after KDM..
My Radeon 7000 has a TV in TV out built in... The only way it wont Freez is if I put Option "NoDRI" in my xorg.conf
I really tried almost everything with that Card, with no success! except NoDRI..
Is there a way to disable the TV tuner in xorg? thats probably the only option I didnt try..

Christian Neumair that would be great :-) even though I just order'd me new Hardware with a AMD 740G chip in it because I am not able to work with my PC, I will still help out to find this VERY annoing bug with my at the moment X unfriendly Hardware..:-)

What info do you need?

Benny (benny-malengier) wrote :

Jason, does xrandr not allow to disable the tv output?
So
xrandr -q

lists your outputs on the card, eg TV-0, then to disable it:
xrandr --output TV-0 --off

If this works, you can add it to xorg, see xrandr man and wiki http://wiki.x.org/wiki/Projects/XRandR

On my Macbook Pro 1.1 (X1600 M56P) the Jaunty (kubuntu) ATI driver seems to lock the machine up as soon as KDM comes up. Upgrading to 2.6.29-02062904-generic (confirmed as installed and running) does not help. Same thing with radeon and radeonhd drivers if DRI is enabled.

Does anyone have Xorg 1.5.2 builds for i386?

kingtiger (kingtiger16) wrote :

I have a dell e1705 i have a radeon mobility x1400 video card.
i have random lockups and freezes, where only the mouse works. also the black screen with no mouse, for the most part i have been able to restart with the alt+SysRq REIUB.
and not sure if it's related but when i try to run x-plane it start's up runs, then just disappears completely, and i'm back at the desktop. if there is any info i can provide that will help please let me know.

This is definitely not a Kubuntu/Kwin/Composite-only bug. On Gnome (with Composite/Compiz disabled), this bug occurs the same (unless DRI is also disabled).
With PPA kernel 2.6.29-02062904-generic (and DRI re-enabled), this bug SEEMS SOLVED (after 10 min. GoogleEarthing)
With Ubuntu (9.10?) kernel 2.6.30-8-generic (and DRI re-enabled), this bug STILL OCCURS (after 10 sec. GoogleEarthing)

I can confirm that this bug happens often when I am using Kopete Chat Windows. But I was not able yet to create a step-by-step reproduction of this freeze.

Is anyone able to give such instructions for reproducing this bug?

I would like to help by debugging with gdb, but if I cannot reproduce it, I cannot debug it... This bug only seems to happen when im not "looking" :D

Any ideas in which function this happens? Or any ideas for breakpoints? I am not so familiar with debugging C/C++ stuff but I would like to get into it.

For the record: I am using Kubuntu Jaunty with standard repositories (jaunty-proposed not enabled), Radeon X1300 Mobile, AccelMethod "XAA", Dual-Head Environment

btw: I think bug #351990 is really a duplicate of this bug.

@maestro_alubia "Is anyone able to give such instructions for reproducing this bug?"

I have a way of reproducing the bug in Kubuntu:

Right click on the 'K-Menu' and select "Menu Editor".
Select an item that has an icon.
Then click on the icon button to reveal the icon selection window.
Select the other icons radio button.
Press the browse button
Then my installation crashes every time.

Obviously I have since updated the kernel and the problems have completely gone away.

Apparently your instructions do not work for me.

Did your X crash or freeze?

So I basically can imagine 4 reasons why this instructions work for you but not for me:

1) You experience a different bug than I am (maybe because you have different hardware)
2) Your software-setup is different
3) Your configuration is different
4) I am not suffering from this bug anymore

I tested your instructions with Composite enabled and disabled in my xorg.conf but X never crashed or freezed. Although my xorg did not crash at all since I disabled Composite. But maybe thats just by chance.

I got a freeze again, so option 4) ist definitely not true.

Furthermore Composite is still disabled so this is not a workaround for the problem.

The hang occured when many applications were open and this time I did not have any Kopete Chat Windows opened (although kopete itself was running).

Just before X freezes the mouse-cursor gets damaged and a few seconds later everything gets real slow.

I than logged via ssh into the defect machine and attached gdb to the process. I append the output of "bt f", hope thats helpful.

I tried to work around the problem using a 2.6.29 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.6/

At least using the specific version 2.6.29-02062906 the bug did NOT disappear! Maybe they are less frequent but for me it is not solved using that kernel.

Again I retrieved a backtrace via gdb. Looks quite similar to me.

Is there any upstream bug-report for this?

I am running 2.6.29.2 (from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.2/) since Saturday (about 3 days) now without any crashes or freezes.

So 2.6.29.2 seems to fix the problem for me, too.

Several people report thatmainline kernel versions 2.6.29.1 to 2.6.29.4 fix the problem, but at least tow people say that 2.6.30rc3 does not.

2.6.29.6 did not work for me, so the problem was probably re-introduced in 2.6.29.5 or 2.6.29.6. Anyone tried 2.6.29.5 ?

juhuu (swinter-bw-computer) wrote :

Hi
For me all kernel version of 2.6.29 fixed the freeze issue, including -5 and -6.
I have tried several 2.6.30 versions in may, all of them re-introduced the freeze issue so that I stick to the 2.6.29 kernel version for now.
I hope this will get fixed, otherwise I am stuck with Jaunty for pretty long....

I can confirm that the problem is existant using kernel 2.6.31rc3 from

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.31-rc3/

Just got a freeze again witz kernel 2.6.29-02062902-generic. So this problem is NOT GONE but happens only very occasionally with kernel 2.6.29.

Just got a freeze again with kernel 2.6.29-02062902-generic. So this problem is NOT GONE but happens only very occasionally with kernel 2.6.29.

Jonas Diemer (diemer) wrote :

Hi,

I have this bug on my machine (ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]) as well. The attached python script (using mayavi2) reproducibly freezes X on a "standard" Kubuntu 9.04 (upgraded to from 8.04).

I installed the 2.6.29-02062904 kernel from PPA, which fixes the problem. I will try the 2.6.29.5 and .6 kernels to see if the bug reappears.

Regards,
Jonas

Jonas Diemer (diemer) wrote :

Just tried 2.6.29.5 and .6 kernels, both work fine for me, however, not the default 2.6.28 kernel... So I can also confirm what juhuu said, the 2.6.29 fix the problem.

Maybe someone else can try my test-script and report his/her findings to help track down this issue.

I tried your test-script and it does NOT freeze my system with Kernel 2.6.29-02062902-generic (from PPA).

But (as said before) I occasionally get freezes using this Kernel. Less frequently then before using the standard kernel 2.6.28 but they happen.

So my assumption is, that your test-script does only reproduce one bug which causes a freeze but there is at least one more bug also causing freezes.

I will try your script with the default 2.6.28 kernel later.

Thank you for your script, I think this is a big step forward if we can really reproduce the bugs!

The script produces a freeze for me using kernel 2.6.28-14-generic (The current Jaunty kernel)

The script does NOT produce a freeze for me using 2.6.31-020631rc5-generic from Kernel-PPA.

Jonas Diemer (diemer) wrote :

Then there must be more than one bug causing a freeze.

The one that can be provoked by the script under the current jauty kerneln and was obviously fixed in kernels 2.6.29.2 .4 .5 and .6 and 2.6.31-020631rc5. Kernels in between may have reintroduced the bug, as Juhuu stated (or Juhuu's freezes came from the other bug)...

The second one seems more rare (I haven't seen one yet under 2.6.29.6) and may even be totally unrelated to the kernel/ATI driver/X11... ?

Your summarization are IMO right, Jonas.

I am not quite sure that the bug is really "fixed" in the stated kernel-versions. The bug just does not appear when using it, right? Maybe thats just a coincidence!?
My point is, that the X-Server freezes with the jaunty-kernel 2.6.28 and nobody could yet specify what is causing this freezes. Furthermore, nobody could specify which change in the kernel-history "fixed" the problem.
Julien Cristau from the Debian-team said [1] that this "sounds like a gpu lockup". I am not an expert on this subject but this may be caused by a bug in a kernel-driver as well as in the radeon-driver or xorg itself.

Regarding the "second bug" which is still existant when using 2.6.29 the question is the same: Which code is causing this freeze?

Should we open another bug report for the "second bug" which is not reproducible by Jonas' script?

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=524558#10

Bryce Harrington (bryce) on 2009-08-13
tags: added: kubuntu
blubaustin (blubaustin) wrote :

Wow, such a long comment/thread page. I have a ATI 9200 SE 64MB AGP, and it will only run nexuiz for like 15 secs or so, then freeze at the splash screen. But on debian lenny which uses an older kernel and xorg it would run fine. I have read the entire comments and I see that certain kernels for some video cards fix it or make it less frequent or also downgrading the xorg to 1.52. But, the whole point I thought of me having new software was to fix security vulernabilities, speed improvements, and better compatibility. I am going to be trying to disable the composite, xaa, and etc tonight then post back here how that works for me.

OS: Xubuntu 9.10 (Karmic)
Kernel: 2.6.31-9-generic
Video Card: 02:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)

Hope this helps

blubaustin (blubaustin) wrote :

I did try it, sorry about the late response. I tried disabling DRI, and etc as other have, and it did help a little but did not fix the problem entirely. I do believe it is a DRI bug, I had a custom kernel on the ubuntu 9.10 machine I was working with. It is now happily back to debian lenny.

Gerardo Campos (macross) wrote :

I have been having the freezes problem, at least every 30 minutes,

I tried all the following suggestions.

1. Setting to none the visual effects
2. Removing compiz
3. Updating the /etc/X11/xorg.conf to several recommendations,

Doing all of the above, reduced the problem to one freeze per day.

I found that updating the kernel to 2.6.29.6 fixed my problem, that eventually allowed me to:

1. Restored /etc/X11/xorg.conf to the default settings
2. Reinstall compiz
3. Set visual effects to normal.

I have been running this for 3 days, and no freeze yet.

Ubunto 9.04 Jaunty, installed in an IBM Thinkpad T43

$ lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M22 [Mobility Radeon X300] [1002:5460]

$ uname -a
Linux mylinux 2.6.29-02062906-generic #02062906 SMP Fri Jul 3 10:56:30 UTC 2009 i686 GNU/Linux

I installed the prebuilt kernel from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.6/

Saludos

Barış (penguen) wrote :

Hello Gerardo,

I have exactly the same video card in a Thinkpad r52. Using a 2.6.30
series kernel fixed my problem. I did not have a freeze for months.

Hope that helps,
Baris

On Wed, Sep 16, 2009 at 1:01 PM, Gerardo Campos <email address hidden> wrote:
> I have been having the freezes problem, at least every 30 minutes,
>
> I tried all the following suggestions.
>
> 1. Setting to none the visual effects
> 2. Removing compiz
> 3. Updating the /etc/X11/xorg.conf to several recommendations,
>
> Doing all of the above, reduced the problem to one freeze per day.
>
> I found that updating the kernel to 2.6.29.6 fixed my problem, that
> eventually allowed me to:
>
> 1. Restored /etc/X11/xorg.conf to the default settings
> 2. Reinstall compiz
> 3. Set visual effects to normal.
>
> I have been running this for 3 days, and no freeze yet.
>
> Ubunto 9.04 Jaunty, installed in an IBM Thinkpad T43
>
> $ lspci -nn | grep VGA
> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M22 [Mobility Radeon X300] [1002:5460]
>
> $ uname -a
> Linux mylinux 2.6.29-02062906-generic #02062906 SMP Fri Jul 3 10:56:30 UTC 2009 i686 GNU/Linux
>
> I installed the prebuilt kernel from:
> http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.6/
>
> Saludos
>
> --
> [RV250] Kubuntu: X Freezes with Radeon driver EXA/XAA Composite
> https://bugs.launchpad.net/bugs/348332
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

Changed in libdrm (Debian):
status: Unknown → New
Changed in xserver-xorg-video-ati (Debian):
status: Unknown → New
Roman Yepishev (rye) wrote :

Same of similar issue as reported by blubaustin @#91 - nexuiz application shows splash screen for some time then locks the X server. Magic SysRq keys work. If nexuiz is killed by logging in through SSH from another machine, then kernel starts to panic.
Unfortunately it is not possible to capture the exact panic info at the moment, but I will keep trying. to fetch it.

description: VGA compatible controller
product: Radeon RV250 If [Radeon 9000]
vendor: ATI Technologies Inc
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 32 bits
clock: 66MHz
capabilities: agp agp-2.0 pm bus_master cap_list
configuration: latency=32 mingnt=8
resources: memory:f0000000-f3ffffff(prefetchable) ioport:e000(size=256) memory:fbe00000-fbe0ffff memory:fbd00000-fbd1ffff(prefetchable)

The same video board behaved correctly in all 3D games under Jaunty, so this is definitely a regression of some sort.

Cyril Buquet (cyril11) wrote :

Never freeze since migration on karmic

Can confirm that there are no freezes anymore since the karmic release and intense use for about a month now.

Thanks to all people who worked on this!

I suggest this bug-report can be closed.

Changed in linux (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released

I have used nVidia cards for years while having a friend who kept telling me ATi cards were ¨better¨. When I saw the Radeon HD5770 at a very good price I succumbed and bought one. Yes it IS fine for Windows but I have lost my 3D, xinerama and other desktop effects and can only run using my 1280 x 1024 LCD, whereas in Widows (and linux when I had an nVidia card, I used a 1680x1250 and the 1280x1024 side by side. I am about to retire and would like to cut down on the cost of computing by moving over to linux full time instead of side-by-side with Windows.

I will NEVER buy another ATi card and am seriously thinking about switching away from AMD, which I have used since the year dot. I think I will give the ATi card to my son who won;t use linux (lol), re-install my nVidia card and lose a few FPS in X-plane.

I know this is not a technical post but I am so ANGRY!

Apologies, guys!

Changed in xserver-xorg-video-ati (Debian):
status: New → Fix Released
Changed in libdrm (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.