(Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

Bug #338669 reported by Luis Silva
246
This bug affects 22 people
Affects Status Importance Assigned to Milestone
KDE Base
Won't Fix
Medium
qt4-x11 (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Medium
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: libqtcore4

After upgrading to qt 4.5 under Jaunty I started getting regions of the screen that are not repainted or are simply filled with static. If those regions contain a widget (a button or a line edit, for example) moving the mouse over them triggers a correct repaint. I am using the intel driver on an asus eeepc 701 4G.I'm submitting this bug against libqtcore but this maight also be a bug in the intel driver or on the X11 speciffic parts of Qt.

Revision history for this message
Andrej Krutak (andree182) wrote :

I'm also experiencing this, using ati opensource driver... I've filled a bug at kde bugzilla - https://bugs.kde.org/show_bug.cgi?id=187775

Revision history for this message
Andrej Krutak (andree182) wrote :

...however, the bug seems to have vanished after changing AccelMethod from EXA to XAA (as I've read elsewhere)........ however, the compositing is too slow afterwards and also firefox webpage scrolling seems to be much slower in composite mode.. gonna fill bug to ati guys then, I guess :-)

Revision history for this message
Luis Silva (lacsilva) wrote :

As far as I know XAA has been deprecated in favor of EXA. In my case I use the intel driver which uses the UXA accel method so this bug seems to be prety much driver/acceleration agnostic. Also I don't have compositing enabled because it is just slow.

Revision history for this message
Rick Spencer (rick-rickspencer3) wrote :

bryce - could you please take a look and advise?

http://imagebin.ca/view/ygCvAo.html

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → bryceharrington
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Rick Spencer (rick-rickspencer3) wrote :

Medium severity, as work around exists (using XAA)

Changed in xserver-xorg-video-ati (Ubuntu):
importance: High → Medium
Revision history for this message
Bryce Harrington (bryce) wrote :

Andrej, your bug and Luis' likely are separate bugs since you're using different video drivers and different video card manufacturers. In any case, if we upstream them we only focus on the original reporter's issue, so unless you're absolutely certain you have the same issue, you probably need to file a new bug report.

Also, we require for X bugs that /var/log/Xorg.0.log and lspci -vvnn be attached, as we can not start any troubleshooting until we have that information. An easy way to do this is to run `apport-collect 338669` from the affected machine.

Revision history for this message
Andreas Wenning (andreas-wenning) wrote : Re: painting artifacts after qt4.5 upgrade on intel chipset

I've split this bug into two. This one for the intel problems, and bug 350120 for problems on radeon.

Changed in xserver-xorg-video-ati:
status: Confirmed → Invalid
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
importance: Undecided → Medium
status: New → Confirmed
Changed in xserver-xorg-video-ati:
assignee: bryceharrington → nobody
Changed in kdebase:
status: Unknown → Fix Released
Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

One thing I noticed is that after changing kwin style to plastique from oxygen. The display corruptions stopped appearing except for dragon player full screen progress/scroll bar though lasting only for a moment.
Thee is a bug with kde https://bugs.kde.org/show_bug.cgi?id=187356 for this.

Revision history for this message
Scott Kitterman (kitterman) wrote :

I switched to uxa and this problem went away, but then I've got stability problems.....

Revision history for this message
Bryce Harrington (bryce) wrote :

[Unassigning myself since this is just medium priority, and since it sounds like UXA will fix it, and both XAA and UXA exist as workarounds for now.]

summary: - painting artifacts after qt4.5 upgrade on intel chipset
+ (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: bryceharrington → nobody
status: Confirmed → Triaged
Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

This is just medium priority?. So kubuntu jaunty intel users has 2 options
1. use a dektop with graphic glitches
2. or use UXA which as per this bug https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/329860
is not recomended because of stability.
So its matter of stability vs graphic corruption very funny!!!
This should be a blocker for kubuntu jaunty release.

Revision history for this message
Bryce Harrington (bryce) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

On Wed, Apr 01, 2009 at 04:30:17AM -0000, Jithin Emmanuel wrote:
> This is just medium priority?
> So its matter of stability vs graphic corruption very funny!!!
> This should be a blocker for kubuntu jaunty release.

If you'd like to trade places with someone having a high priority bug
who can't even get X started and have no workaround, maybe that could be
arranged....

Revision history for this message
Bryce Harrington (bryce) wrote :

I included this bug in the list of issues to discuss with Intel today.
They report that in their experience this issue is caused by the application, not X.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Invalid
Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

But then who is going to fix this. How can users use a desktop with graphical corruptions.
There was no problem with qt 4.4 though.

Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

https://bugs.kde.org/show_bug.cgi?id=187356

Look at what upstream developers have to say. The say they have recommended not to use qt 4.5 with kde 4.2.
And that is the problem, I think. Is jaunty still going to be released with qt 4.5?

Revision history for this message
Andrew Mason (slackmase2) wrote :

I don't think this issue is fixed just by enabling UXA. I have enabled uxa on an intel X4500 card ( Lenovo thinkpad X200) and i am stil getting artifacts. Attached is a screen shot.

Section "Device"
        Identifier "Configured Video Device"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
EndSection
Section "Device"
        Identifier "Configured Video Device"
        Option "AccelMethod" "UXA"
        Option "Tiling" "No"
EndSection

Revision history for this message
Andrew Mason (slackmase2) wrote :
Revision history for this message
sewert (ewi100) wrote :

What about using QT 4.5.1 with KDE 4.2.2? The changelog in QT is long and I can't see if anything is related to this bug.

On the dot one can find an entry about the QT update: http://dot.kde.org/2009/04/23/updates-qt-and-qt-creator-released-today
In the comments there one can find these discussions; they discuss SVG render issues there but at least find a patch against it:
http://rdieter.livejournal.com/13559.html
http://rdieter.livejournal.com/13739.html

So does a QT4.5.1 with that patch help with the problem described in this bug report?

Revision history for this message
Ralph Janke (txwikinger) wrote :

IMHO this is not a minor issue. Every machine I have installed jaunty on has this problem. This happens by default when the machine is upgraded and reduces the desktop experience of users especially non-geeks that we want to win over.

Revision history for this message
Jithin Emmanuel (jithin1987) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

Exactly I am switching to fedora 11 preview. so far I have not heard of this
issue there.

On Wed, Apr 29, 2009 at 6:21 PM, Ralph Janke <email address hidden> wrote:

> IMHO this is not a minor issue. Every machine I have installed jaunty on
> has this problem. This happens by default when the machine is upgraded
> and reduces the desktop experience of users especially non-geeks that we
> want to win over.
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards
Jithin Emmanuel
http://spotm.in
Winston Churchill<http://www.brainyquote.com/quotes/authors/w/winston_churchill.html>
- "The best argument against democracy is a five-minute conversation
with
the average voter."

Revision history for this message
Luis Silva (lacsilva) wrote :

Switching to UXA IS NOT a solution. It gives me a very good video performance but the system becomes unstable. I am also not able to suspend/resume with UXA activated, which is a big deal for any laptop/netbook nowdays.

Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

Atleast switching to UXA works and I am not having any stability problems.
Then suggest a working solution. It seems no one from ubuntu is keen on
fixing this, which is why I am switching to Fedora 11 today. after a long
stint with ubuntu

On Wed, Apr 29, 2009 at 10:09 PM, Luis Silva <email address hidden> wrote:

> Switching to UXA IS NOT a solution. It gives me a very good video
> performance but the system becomes unstable. I am also not able to
> suspend/resume with UXA activated, which is a big deal for any
> laptop/netbook nowdays.
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards
Jithin Emmanuel
http://spotm.in
Mark Twain <http://www.brainyquote.com/quotes/authors/m/mark_twain.html> -
"Get your facts first, then you can distort them as you please."

Revision history for this message
Stephan (stephan-h) wrote :

Comments in this bug offer different workarounds, NONE of which work for me having this video card:
  00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

XAA / UXA (in case EXA is the culprit)
 -> UXA freezes the machine on start up with wide vertical black and white stripes
 -> XAA goes through a series of video mode switches but failes to start X

KDE style Plastique instead of Oxygen
 -> seemed to lessen the garbage but not a solution, I still see gargabe on the screen

Downgrade Qt to 4.4?
 -> not possible in jaunty

Given that the bug was known before the release of Jaunty I sencerly don't understand
how Jaunty could get released.

Is there any information people with affected machines could still contribute?

Status for KDE Base says "Fix Released" which however concerns only a fix for single line
text edits.

Status for qt4-x11 says "New Undecided", so what can be done to come to a decission?
Anything we could/should try??

Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

There is nothing can be done other than realize that ubuntu sucked bug time,
by letting this happen. If all they do is just make the code into packages
and release with out even testing if this works and with out even attempting
to look what's wrong, then it sucks big time.

On Thu, Apr 30, 2009 at 8:15 AM, Stephan <email address hidden> wrote:

> Comments in this bug offer different workarounds, NONE of which work for me
> having this video card:
> 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4
> Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
>
> XAA / UXA (in case EXA is the culprit)
> -> UXA freezes the machine on start up with wide vertical black and white
> stripes
> -> XAA goes through a series of video mode switches but failes to start X
>
> KDE style Plastique instead of Oxygen
> -> seemed to lessen the garbage but not a solution, I still see gargabe on
> the screen
>
> Downgrade Qt to 4.4?
> -> not possible in jaunty
>
> Given that the bug was known before the release of Jaunty I sencerly don't
> understand
> how Jaunty could get released.
>
> Is there any information people with affected machines could still
> contribute?
>
> Status for KDE Base says "Fix Released" which however concerns only a fix
> for single line
> text edits.
>
> Status for qt4-x11 says "New Undecided", so what can be done to come to a
> decission?
> Anything we could/should try??
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards
Jithin Emmanuel
http://spotm.in
Albert Einstein<http://www.brainyquote.com/quotes/authors/a/albert_einstein.html>
- "Only two things are infinite, the universe and human stupidity, and
I'm
not sure about the f...

Revision history for this message
Grasyop (grasyop) wrote :

Replacing Oxygene theme by Plastique would be a workaround for this bug, but you then encounter another bug, even more annoying, this one:

https://bugs.kde.org/show_bug.cgi?id=178322

I didn't test the other themes. Oxygene is the default theme, so it absolutely has to work. I agree with Jithin Emmanuel and am very angry against Kubuntu team.

Revision history for this message
Stephan (stephan-h) wrote :

> I agree with Jithin Emmanuel and am very angry against Kubuntu team.

OK, I was quite angry too, but let's try not to lose temper but see how we can get out
of this situation (that we should have never gotten into).

(I personally am in the lucky position that I can continue working unaffected from this bug, but
only because I have a second machine - so I can temporarily avoid using the affected machine.)

I'm missing two things here:
(1) help on helping: i.e.: what can all the affected users do to help isolate the root cause of this bug
(2) transparency

Re (2): I think people would be much more comfortable if someone from Canonical acknowledged
that this is a very severe bug with no universal workaround available (I'd really suggest to rank it as a
stop-ship bug, please!). Hints at even more severe bugs (X not starting) don't help people in this bug.
Secondly, this kind of bug damages the trust in Ubuntu releases: can we safely assume that upgrading
to a new Kubuntu release(!) will NOT make that machine unusable for serious work?
Thirdly, is there a discussion, whether including Qt 4.5 was an avoidable risk (with better advice available
from the KDE developers)? If so, where is that discussion? What are we learning from it?

How can a bug with 10 duplicates stay in "undecided" so long?

Revision history for this message
Chris Drost (chris-drostie) wrote :

> I'd really suggest to rank it as a stop-ship bug, please!

Jaunty already shipped, and, to be honest, there's nothing in this bug that suggests to me that it should have stopped the shipment of either Ubuntu or Kubuntu this past month. (I'm affected by it, and while it's a bit of a nuisance in Kate, it's not mission-critical.)

> what can all the affected users do to help isolate the root cause of this bug

Wait for two weeks and live with the graphical nuisance until then. As I understand it, this is a very touchy bug that's been resolved in KDE 4.3, which will have its first beta release on May 12. Kubuntu Karmic will then have its first alpha release on May 14th, so presumably there's going to be some rapid packaging going on at the time.

> How can a bug with 10 duplicates stay in "undecided" so long?

Well, just to recap, this is a bug that doesn't affect most people (and we're not sure why it affects the people it does). It's apparently upstream of KDE, even, much less Kubuntu; but it's also claimed by Intel to be downstream of them; and meanwhile the KDE folks are saying "We said no Qt 4.5 with KDE 4.2 -- Kubuntu didn't listen." We can't narrow down where it goes or where the problem is occurring, because the problem doesn't create crash logs of any sort. And it's already got a fix some time in the near future (KDE 4.3), and it was only discovered shortly before the release date. And it's got a supplemental fix which works if it doesn't introduce further bugs into the system.

I think that all of these contribute to this bug report staying in undecided. We don't know where to start looking for the problem, even, and the problem will hopefully be solved soon anyway.

Revision history for this message
Luis Silva (lacsilva) wrote :

I still cannot understand. I submitted this bug against qt4.5 because, to me, that was the most plausible candidate for the cause. How can you say that you cannot narrow down the possible culprits?

> It's apparently upstream of KDE, even, much less Kubuntu; but it's also claimed by Intel to be downstream of them;
The only thing in between Intel (read Xorg) and KDE is Qt. Incidentally, of all the factors only qt changed. So, what else do you need to locate the problem?

> I'm affected by it, and while it's a bit of a nuisance in Kate, it's not mission-critical.
Surely you are not having the same problem I have. Konqueror, akregator and kmail are all STRONGLY affected by this bug. This is not "a bit of a nuisance" in any of those apps. It completely ruins your experience. Most of the time I can only see the bottom half of the page in konqueror.

>Wait for two weeks and live with the graphical nuisance until then. As I
>understand it, this is a very touchy bug that's been resolved in KDE
>4.3, which will have its first beta release on May 12. Kubuntu Karmic
>will then have its first alpha release on May 14th, so presumably
t>here's going to be some rapid packaging going on at the time.
So, waiting for an yet unstable alpha release is the solution? How about proposing KDE 4.2 compiled against qt4.4 (shipped by default) and package qt4.5 as an alternative with a BIG FAT WARNING? I haven't seen anything preventing such a strategy on a release-update.

Revision history for this message
Luis Silva (lacsilva) wrote :

http://www.qtsoftware.com/developer/changes/changes-4.5.1

According to this changelog this bug might have already been solved in qt. Is there anything against packaging qt4.5.1 ? Could this be the solution? Is there any testing going on?

Revision history for this message
Stephan (stephan-h) wrote :

@Chris:
Thanks for your explanations.

> [..] there's nothing in this bug that suggests to me that it should have stopped the shipment of either Ubuntu or
> Kubuntu this past month. (I'm affected by it, and while it's a bit of a nuisance in Kate, it's not mission-critical.)

I disagree, I can't use kate, nor konqueror, nor kmail to do serious work on the affected machine, because
every other action would be to apply some trickery to get the window repainted, which makes it impossible
to concentrate on the work being done. Thus I insist on this being a very severe bug, if not for most users,
obviously for more than just me.

> As I understand it, this is a very touchy bug that's been resolved in KDE 4.3

Which KDE bug are you referring to?

> and it was only discovered shortly before the release date

to me this doesn't sound like a good reason (for whatever conclusion) ;-)

> And it's got a supplemental fix which works if it doesn't introduce further bugs into the system.

Are you referring to the KDE 4.3 fix? What if the bug is really in Qt 4.5?
After an upgrade broke my machine I, too, would prefer a more conservative solution
as suggested by Luis: using a "better" version of Qt within Jaunty
(perhaps using an optional repository?),
rather than hoping that hoping the next release will be more stable
with no alternative to go if it doesn't.

OTOH, once packaging KDE 4.3 starts, could you post pre-liminary packages
that we could try within the Jaunty install, so we have an option to revert if the
bug didn't get fixed that way or if the fix breaks other things?

Thanks

Revision history for this message
Chris Drost (chris-drostie) wrote :
Download full text (3.2 KiB)

> How can you say that you cannot narrow down the possible culprits?

Because the .tar.gz of the qt4.5 source is 100 MB in size. If we had a crash report saying "there was a segmentation fault right here," we could maybe figure out where in that beast of a source code it was -- but just asking "what line in the KDE 4.2 source is calling the wrong function in the Qt 4.5 source which is also misusing EXA when it repaints the screen" is a question that can't be answered without much more information than the problem itself provides.

> So, waiting for an yet unstable alpha release is the solution?

I'm not saying that you should jump on the Karmic alpha -- once people have solid Karmic-4.3 integration, there will almost surely be a .deb posted to the jaunty-backports repository.

> How about proposing KDE 4.2 compiled against qt4.4 (shipped by default) and package qt4.5 as an alternative with a BIG FAT WARNING? I haven't seen anything preventing such a strategy on a release-update.

You can get KDE 4.2 + Qt 4.4 + Kubuntu! However, you will have to use Intrepid to do it. As jaunty-backports will probably eventually contain KDE 4.3, so too the intrepid-backports repository contains, right now, KDE 4.2. And Intrepid has not been retrofitted to use Qt 4.5 -- 4.5 is strictly Jaunty and up.

> According to this changelog this bug might have already been solved in qt.

I don't see anything in that changelog to suggest a fix for anything EXA-specific, much less rendering artifacts. What line are you referring to, specifically? (I'm not really a Kubuntu dev, so don't take my word as gospel here. The Debian unstable repository (sid) contains a .deb for Qt 4.5.1, and ScottK on IRC says that the current plan is to merge this into Karmic, but keep it out of Jaunty. It might get backported later; I don't know.)

> Which KDE bug are you referring to?

I was referring to this comment (comment #21) by Aaron J. Seigo:

https://bugs.kde.org/show_bug.cgi?id=187356#c21

> Are you referring to the KDE 4.3 fix? What if the bug is really in Qt 4.5?

I was referring to using UXA. (More specifically, since it looks like nobody has placed these instructions explicitly here, adding the line [ Option "AccelMethod" "UXA"] to the "Device" section in /etc/X11/xorg.conf .) So far UXA has been working for me, but the problem was much less prevalent for me than it apparently is for you.

>using a "better" version of Qt within Jaunty (perhaps using an optional repository?)

Jaunty has already shipped with Qt 4.5, and my amateurish attempts to simulate a downgrade to Qt 4.4 with aptitude and the Intrepid repositories have not looked promising. I don't think anyone can provide you with a PPA (an optional repository) that would solve the multitude of dependencies. Everything (?) in Kubuntu Jaunty was built with the idea, "okay, we're releasing a Qt 4.5 operating system this April." Much of it breaks when you try to pull the tablecloth out from under it.

If you want KDE 4.2 + Kubuntu, and you cannot enable UXA for some reason or another (or if UXA doesn't solve the problem), then it looks like your only option is Intrepid at the moment. Karmic may offer a backport of KDE ...

Read more...

Revision history for this message
Jithin Emmanuel (jithin1987) wrote :
Download full text (3.9 KiB)

Guys in short words, Jaunty is screwed please downgrade to intrepid or use
another distro like Fedora 11 which is due release in a short time.

On Tue, May 5, 2009 at 2:15 AM, Chris Drost <email address hidden> wrote:

> > How can you say that you cannot narrow down the possible culprits?
>
> Because the .tar.gz of the qt4.5 source is 100 MB in size. If we had a
> crash report saying "there was a segmentation fault right here," we
> could maybe figure out where in that beast of a source code it was --
> but just asking "what line in the KDE 4.2 source is calling the wrong
> function in the Qt 4.5 source which is also misusing EXA when it
> repaints the screen" is a question that can't be answered without much
> more information than the problem itself provides.
>
> > So, waiting for an yet unstable alpha release is the solution?
>
> I'm not saying that you should jump on the Karmic alpha -- once people
> have solid Karmic-4.3 integration, there will almost surely be a .deb
> posted to the jaunty-backports repository.
>
> > How about proposing KDE 4.2 compiled against qt4.4 (shipped by
> default) and package qt4.5 as an alternative with a BIG FAT WARNING? I
> haven't seen anything preventing such a strategy on a release-update.
>
> You can get KDE 4.2 + Qt 4.4 + Kubuntu! However, you will have to use
> Intrepid to do it. As jaunty-backports will probably eventually contain
> KDE 4.3, so too the intrepid-backports repository contains, right now,
> KDE 4.2. And Intrepid has not been retrofitted to use Qt 4.5 -- 4.5 is
> strictly Jaunty and up.
>
> > According to this changelog this bug might have already been solved in
> qt.
>
> I don't see anything in that changelog to suggest a fix for anything
> EXA-specific, much less rendering artifacts. What line are you referring
> to, specifically? (I'm not really a Kubuntu dev, so don't take my word
> as gospel here. The Debian unstable repository (sid) contains a .deb for
> Qt 4.5.1, and ScottK on IRC says that the current plan is to merge this
> into Karmic, but keep it out of Jaunty. It might get backported later; I
> don't know.)
>
> > Which KDE bug are you referring to?
>
> I was referring to this comment (comment #21) by Aaron J. Seigo:
>
> https://bugs.kde.org/show_bug.cgi?id=187356#c21
>
> > Are you referring to the KDE 4.3 fix? What if the bug is really in Qt
> 4.5?
>
> I was referring to using UXA. (More specifically, since it looks like
> nobody has placed these instructions explicitly here, adding the line [
> Option "AccelMethod" "UXA"] to the "Device" section in
> /etc/X11/xorg.conf .) So far UXA has been working for me, but the
> problem was much less prevalent for me than it apparently is for you.
>
> >using a "better" version of Qt within Jaunty (perhaps using an optional
> repository?)
>
> Jaunty has already shipped with Qt 4.5, and my amateurish attempts to
> simulate a downgrade to Qt 4.4 with aptitude and the Intrepid
> repositories have not looked promising. I don't think anyone can provide
> you with a PPA (an optional repository) that would solve the multitude
> of dependencies. Everything (?) in Kubuntu Jaunty was built with the
> idea, "okay, we're releasing a Qt 4.5 o...

Read more...

Revision history for this message
naught101 (naught101) wrote :

Is the any chance that KDE 4.3beta one will be backported to jaunty, or will
only the final release be backported? Beta 1 comes out in a week, and Aaron
Siego seemed to think that 4.3 might not have the bug.

Chris: I think you and I have similar symptoms: visual damage only in text
areas. Others seem to be reporting much more damage all over the UI.

Revision history for this message
naught101 (naught101) wrote :

In particular, Rick's screen shot in comment 4 has damage in firefox - Rick,
does that occur regularly does it occur when firefox is in the foreground??
I've never seen it on my firefox...

Revision history for this message
Andrew Mason (slackmase2) wrote :

@Jithin Emmanuel It's only broken for those who cannot use UXA and who are experiencing this bug.

@naught101 the RC will probably not be backported. There is nothing to stop you from compiling it yourself on your machine. It's fairly easy to do but obviously takes a while.

Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

@Andrew. You must understand that there is not one or two user who cannot
use UXA. Ubuntu X team recommends not to use UXA because of stability
issues, unless you are talking about some other distro.UXA is unstable if
you want proof read this twiki.
https://wiki.ubuntu.com/X/UxaTesting
Unless of course you want to state that ubuntu/ kubuntu will never work for
all, if it works its a miracle if it dont you are screwed look for another
distro.

On Wed, May 6, 2009 at 6:14 AM, Andrew Mason <email address hidden> wrote:

> @Jithin Emmanuel It's only broken for those who cannot use UXA and who
> are experiencing this bug.
>
> @naught101 the RC will probably not be backported. There is nothing to
> stop you from compiling it yourself on your machine. It's fairly easy to
> do but obviously takes a while.
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards
Jithin Emmanuel
http://spotm.in
Fred Allen <http://www.brainyquote.com/quotes/authors/f/fred_allen.html> -
"The last time I saw him he was walking down lover's lane holding his own
hand."

Revision history for this message
Stephan (stephan-h) wrote :

Little update: after re-installing intrepid on a free partition
(and sharing /home between installs) I ran into bug 372487
(just reporting here to emphasize that downgrading the OS
is usually not a good idea).

The good news: with KDE 4.2 from intrepid backports the system
is back to a usable state.
(Just took some ours of downloading both for the install and to repair
the damage of bug 372487).

Also, if anyone provides packages for KDE 4.3 in jaunty I can
immediately test the effect on an affected machine, kind of in
a sandbox, i.e., without the risk of making the machine unusable again.
Perhaps, using two bootable partitions and upgrading only one at a time
is a fair strategy to reduce risks... some redundancy of that kind seems
necessary these days ...

Revision history for this message
Giovanni Masucci (gio-grifis) wrote :

mmm...anyone tried with qt 4.5.1? don't seem to have it anymore since I've updated to it.
:)

Revision history for this message
Jithin Emmanuel (jithin1987) wrote :

Can you tell how to upgrade to qt 4.5.1 is there a PPA for it?

On Fri, May 8, 2009 at 6:13 AM, Giovanni Masucci
<email address hidden>wrote:

> mmm...anyone tried with qt 4.5.1? don't seem to have it anymore since I've
> updated to it.
> :)
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards
Jithin Emmanuel
http://spotm.in
Ogden Nash <http://www.brainyquote.com/quotes/authors/o/ogden_nash.html> -
"The trouble with a kitten is that when it grows up, it's always a cat."

Revision history for this message
strav (strav) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

There are more official packages cooking here (but they're not done being built yet): https://launchpad.net/~kubuntu-experimental/+archive/ppa/

Revision history for this message
strav (strav) wrote :

Tried qt4-x11 - 4.5.1-0ubuntu1~ppa1 from the Ghersi's ppa and nope,
still getting artifacts all over the place.

No cheers.

Revision history for this message
Jithin Emmanuel (jithin1987) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

Has anyone tried kde 4.2.3. Does it look any better?
Will it be available via jaunty updates. Or is the PPA
http://ppa.launchpad.net/kubuntu-members-kde4/ppa/ubuntu/
going to be the only place where its available.

On Fri, May 8, 2009 at 7:36 PM, strav <email address hidden> wrote:

> Tried qt4-x11 - 4.5.1-0ubuntu1~ppa1 from the Ghersi's ppa and nope,
> still getting artifacts all over the place.
>
> No cheers.
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards
Jithin Emmanuel
http://spotm.in
Ogden Nash <http://www.brainyquote.com/quotes/authors/o/ogden_nash.html> -
"The trouble with a kitten is that when it grows up, it's always a cat."

Revision history for this message
Andreas Wenning (andreas-wenning) wrote :

Remember to clear the cache after installing the new qt4-x11:
rm -r ~/.kde/cache-$HOSTNAME/kpc/*
and either log out/in or disable/re-enable desktop effects to see the effect of the update.

@Jithin
KDE 4.2.3 is available from another PPA than the one you mention: see http://www.kubuntu.org/news/kde-4.2.3

Revision history for this message
Wesley Velroij (velroy1) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

Yes i have 4.3 running on jaunty, doesnt chabge anything, and still
needs uxa.

Verstuurd vanaf mijn iPhone

Op 8 mei 2009 om 16:40 heeft Jithin Emmanuel <email address hidden>
het volgende geschreven:\

> Has anyone tried kde 4.2.3. Does it look any better?
> Will it be available via jaunty updates. Or is the PPA
> http://ppa.launchpad.net/kubuntu-members-kde4/ppa/ubuntu/
> going to be the only place where its available.
>
>
> On Fri, May 8, 2009 at 7:36 PM, strav <email address hidden>
> wrote:
>
>> Tried qt4-x11 - 4.5.1-0ubuntu1~ppa1 from the Ghersi's ppa and nope,
>> still getting artifacts all over the place.
>>
>> No cheers.
>>
>> --
>> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
>> https://bugs.launchpad.net/bugs/338669
>> You received this bug notification because you are a direct
>> subscriber
>> of the bug.
>>
>
>
> --
> Regards
> Jithin Emmanuel
> http://spotm.in
> Ogden Nash <http://www.brainyquote.com/quotes/authors/o/ogden_nash.html
> > -
> "The trouble with a kitten is that when it grows up, it's always a
> cat."
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

Revision history for this message
strav (strav) wrote :

anyone still care about this bug?

Revision history for this message
Grasyop (grasyop) wrote :

Changing the style to QtCurve is a workaround of this bug for me.

But I just tried Oxygen again, and the bug is still there (under KDE 4.2.2).

My graphics card is :
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Revision history for this message
Gustavo Narea (gnarea) wrote :

Just to confirm that UXA fixed this issue over here (VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)).

Revision history for this message
Gustavo Narea (gnarea) wrote :

Forgot to add that UXA works flawlessly, it doesn't introduce another bug. It just works like a charm (I've been using it for one week, played 3D games, used 3D effects, etc).

Revision history for this message
Stephan (stephan-h) wrote :

> anyone still care about this bug?

On my machine KDE in Jaunty still isn't usable:

 * UXA hard-freezes the machine
 * QtCurve is no improvement
 * KDE 4.2.3 is no improvement

Qt 4.5.1 seems to no longer be available from ppa, so I couldn't try.

=> No workaround available, this installation still not usable.

I'm still worried about this being a full show stopper in some setups with
not a bit of convincing explaination, of what causes the bug and how it
will be fixed.

Revision history for this message
Stephan (stephan-h) wrote :

Yet more update:

Successfully installed Qt 4.5.1 from https://launchpad.net/~kubuntu-experimental/+archive/ppa/
but still no break through.

At a closer look after all those updates, the issue seems to be reduced:
 + previously kmail was affected (view and composer), looks good now
 + konqueror:
 * scrolling only broken an certain web pages
 * some artifacts disappear after a short delay
 - kate: forward scroll OK, backward scroll fails to repaint: areas remain white.

re konqueror: problems are reproducable mostly on pages that combine fixed
positions with scrollable content. A funny effect is reproducable on this page:
www.opodo.co.uk (no advertizing intended): some part of the form consistently
fails to repaint during scrolling (the part containing line edits).
Also when searching within a page, repaint frequently fails.

My current belief is: this bug is actually a mixture of several bugs, some of which
might have been fixed in Qt 4.5.1 or KDE 4.2.3. Remaining bugs could actually
be bugs of konqueror and kate respectively.

Revision history for this message
Grasyop (grasyop) wrote :

I must correct what I said yesterday: I just got the bug in KWrite, despite using QtCurve style.

Revision history for this message
Tom Metro (tmetro+ubuntu) wrote : apport-collect data

Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: qt4-x11
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/tcsh
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-12-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin mythtv plugdev sambashare users

Revision history for this message
Tom Metro (tmetro+ubuntu) wrote :

Sorry, apport-collect data sent to wrong ticket.

I just filed Bug #381969 which covers symptoms similar to what is described in this bug, except I'm using GNOME instead of KDE and have an Nvidia video card (nvidia-glx-180 180.44-0ubuntu1).

Revision history for this message
Stephan (stephan-h) wrote :

Wow, today I upgraded to KDE 4.2.90 with Qt 4.5.1 and what a relief:
KDE works again, I can scroll in kate, konqueror et al and really see
the content (rocket science).

What a relief after "I" had to spend so many weeks on an emergency
partition with provisionally re-installed intrepid.

Today jaunty started to be usable on my machine.

I learned from this: the fact that Kubuntu releases a new version
is in no way an indication that it is wise to actually migrate to that version.
Sadly.

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

wow, I'm going to try that.
I have been struggling with this bug for months. And in a working environment where I usually try to convince my colleages that linux is better, I have to say it was so embarassing that these artifacts appear all the time that
I would only hide my kubuntu... Not even to mention the fact that I often need to make video presentations... what a shame.
I have tried all combinations of intel driver options and versions, none would work.

Revision history for this message
Grasyop (grasyop) wrote :

I'd like to try it too, because this bug upsets me. But I read about KDE 4.3 RC 1:

"Note that these packages have a bug which causes X to die during the upgrade. The upgrade will continue and you can reboot when it is done."

So, how do you know when the upgrade is done? What time would you wait before rebooting?

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

Ok so I've installed everything from

deb http://ppa.launchpad.net/kubuntu-ppa/experimental/ubuntu jaunty main
deb-src http://ppa.launchpad.net/kubuntu-ppa/experimental/ubuntu jaunty main

(had to do several sudo apt-get install dist-upgrade before installation succeeded - but X did not crash)

It is now much better: for instance just moving the mouse over the messages list in kmail used to make Xorg use 70% CPU, and now it is about 30%.

However the painting artifacts are NOT gone: see screenshot (top right of kmail window)

Too bad!

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

another, bigger one :(

Revision history for this message
Jithin Emmanuel (jithin1987) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

On Friday 03 Jul 2009 4:10:20 pm Vu Ngoc San wrote:
> another, bigger one :(
>
>
> ** Attachment added: "kmail_paint_problem2.png"
> http://launchpadlibrarian.net/28652973/kmail_paint_problem2.png

Only solution I found to fix this is to use UXA acceleration in xorg.
--
Thanks
Jithin Emmanuel

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

but UXA is not a good solution for me as it freezes when I logout from the kde session, and after suspend/resume.

Revision history for this message
strav (strav) wrote :

As a workaround for this bug, I managed to get stable UXA under kernel
2.6.30 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30/
combined with the latest intel driver from:

deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty
main

A cheap fix, yes.

Revision history for this message
Jithin Emmanuel (jithin1987) wrote : Re: [Bug 338669] Re: (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset

I tried using packages from x-swat but xorg-edgers PPA provides the latest
ones which has lot of fixes for intel driver.

On Fri, Jul 3, 2009 at 9:41 PM, strav <email address hidden> wrote:

> As a workaround for this bug, I managed to get stable UXA under kernel
> 2.6.30 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30/<http://kernel.ubuntu.com/%7Ekernel-ppa/mainline/v2.6.30/>
> combined with the latest intel driver from:
>
> deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
> deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty
> main
>
> A cheap fix, yes.
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Thanks
Jithin Emmanuel

Rita Rudner <http://www.brainyquote.com/quotes/authors/r/rita_rudner.html>
- "I was a vegetarian until I started leaning toward the sunlight."

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

I've tried both without success.

Just an idea: does the same problem occur with amd64 version as well ?

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

answer: yes the same problem can occur in 64bit version... :(
(I've just tried the livecd)

Revision history for this message
Vladimir Kondratyev (vladimirkondratyev) wrote :

I see a mess instead of text in all text fields in Skype on my Asus EeePC 1000H. I'm running Ubuntu 9.04 (with all upgrades installed). Everything worked fine in Ubuntu 8. Is there any chance to get it fixed?

Revision history for this message
Andrew Mason (slackmase2) wrote :

is this only in skype ? if so are you using the static version or the
dynamic version of skype ?

On Sat, Jul 4, 2009 at 8:21 PM, Vladimir
Kondratyev<email address hidden> wrote:
> I see a mess instead of text in all text fields in Skype on my Asus
> EeePC 1000H. I'm running Ubuntu 9.04 (with all upgrades installed).
> Everything worked fine in Ubuntu 8. Is there any chance to get it fixed?
>
> --
> (Needs UXA) painting artifacts after qt4.5 upgrade on intel chipset
> https://bugs.launchpad.net/bugs/338669
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
naught101 (naught101) wrote :

https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/371114

It's not only in skype, and it's the same problem.

Revision history for this message
naught101 (naught101) wrote :

https://bugs.kde.org/show_bug.cgi?id=187356#c46 says bugfixed in xorg 1.6.2. Karmic is stil on 1.6.1 is there any chance that that will be upgraded soon? I might be convinced to go bleeding edge again for a while if it is...

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Just got updated a few days to a prerelease of 1.6.3: https://edge.launchpad.net/ubuntu/+source/xorg-server/2:1.6.2.901-1ubuntu1
It's having a bit of trouble building at the moment, though. Once they fix the build issues we will have a fixed Xserver in Karmic.

Changed in qt4-x11 (Ubuntu):
status: New → Invalid
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Bryce Harrington (bryce)
tags: added: jaunty
Revision history for this message
Vladimir Kondratyev (vladimirkondratyev) wrote :

I've just upgraded to latest Karmic Koala and confirm that the problem is gone.

Revision history for this message
Nicolas Dumoulin (nicolas-dumoulin) wrote :

Yes, the problem seems also fixed for me (Kubuntu Karmic).

Revision history for this message
Vu Ngoc San (san-vu-ngoc) wrote :

I'm using 9.04, but with KDE 4.3.1, via
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu jaunty main

and the problem seems to be fixed for me too.

thanks!!

Changed in xorg-server (Ubuntu):
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
Revision history for this message
VF (fviktor) wrote :

Something similar also happens to me since I installed Ubuntu 9.04 amd64 (clean installation).

OS: Ubuntu 9.04 amd64, up to date
CPU: Intel Q6600 CPU
System RAM: 8G
Graphics card: 06:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8600 GT [10de:0402] (rev a1)
Video RAM: 256M RAM

I'm using the proprietary nVidia drivers (v180), but it does not seem to be the cause.
Reverting to the older v173 drivers does not change the situation.

I'm using GNOME, but have to use KMail as well, since I've been using that for years and can't live without those filters and accounts. KMail is badly affected by repaint artifacts, unfortunately. I've also observed the same problem in SkyPE 2.1.0.47 and in the menus/context menus of Mozilla Firefox 3.0.14.

I'm going to attach a screenshot of broken KMail mail list view.

The bug is listed as "Fix Released" here, but updating my system does not solve the problem.

Is there a way to get it fixed without completely upgrading to Karmic Koala?

Revision history for this message
VF (fviktor) wrote :
Revision history for this message
auspex (auspex) wrote :

Viktor: See the subject line of the bug report "painting artifacts ... on intel chipset".

You're reporting a completely different problem, because you aren't _using_ an intel chipset.

ime, _this_ bug is fixed.

Revision history for this message
Vojtech Vitek (V-Teq) (v-teq) wrote :

I'm using up-to-date KDE 4.3.1 (2009-09-22) from these repos:

deb http://ppa.launchpad.net/kubuntu-ppa/experimental/ubuntu jaunty main
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu jaunty main
deb http://ppa.launchpad.net/kubuntu-ppa/staging/ubuntu jaunty main

and the bug still persists!

My today's report with screenshots etc:
https://bugs.launchpad.net/bugs/434602
(It's a duplicate of this bug, because I didn't find this bug due to "fixed" status.)

Screenshots of artifacts (see the link above) are from KDevelop 3.9.91 (KDE 4.3.1).

V-Teq

Changed in kdebase:
status: Fix Released → Won't Fix
Changed in kdebase:
importance: Unknown → Medium
Revision history for this message
Masiosare (luis-zaldivar) wrote :

I'm on maverick and the UXA fix works as expected

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)

Just creating a file called /etc/X11/xorg.conf with this content

$ cat /etc/X11/xorg.conf
Section "Device"
        Identifier "Configured Video Device"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
EndSection
Section "Device"
        Identifier "Configured Video Device"
        Option "AccelMethod" "UXA"
        Option "Tiling" "No"
EndSection

fixes all the issues.

To post a comment you must log in.