[RV350] xserver-xorg-video-ati driver with compiz has glitches with Google Earth

Bug #336135 reported by Rocko on 2009-03-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

When I run Google Earth on a PC running Intrepid with an ATI Radeon Mobility 9600 card, I have to disable compiz, otherwise sub-windows (eg when you click on a point that brings up a sub-window containing a photo) are not drawn correctly - eg text and graphics are missing from the sub-window, or half the sub-window is obscured by the map.

It runs fine with compiz disabled. Google Earth is also fine on another PC with an nvidia card when compiz is enabled.

Version info:
Ubuntu 8.10, kernel 2.6.28-8-generic
xserver-xorg-video-ati 1:6.9.0+git20081003.f9826a56-0ubuntu2.1
compiz 1:0.7.8-0ubuntu4.1
Google Earth 5.0 beta

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82855PM Processor to I/O Controller [8086:3340] (rev 03)
     Subsystem: Dell Device [1028:016a]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] [1002:4e50]
     Subsystem: Dell Device [1028:2001]

Bryce Harrington (bryce) wrote :

Not enough information to troubleshoot. See http://wiki.ubuntu.com/X/Reporting for instructions on reporting X issues.

Changed in xserver-xorg-video-ati:
status: New → Invalid
RPHegde (rphegde) wrote :
RPHegde (rphegde) wrote :

Screenshot of google earth - with a sub window containing a photo. This is blank

Rocko (rockorequin) wrote :

That's exactly the kind of thing I get as well. Here's my Xorg.0.log file from the last reboot.

Rocko (rockorequin) wrote :

Let us know if any other information is required.

Changed in xserver-xorg-video-ati:
status: Invalid → Confirmed
Bryce Harrington (bryce) wrote :

Rocko, you need to attach the output of 'lspci -vvnn' as well.

description: updated
summary: - xserver-xorg-video-ati driver with compiz has glitches with Google Earth
+ [RV350] xserver-xorg-video-ati driver with compiz has glitches with
+ Google Earth
Rocko (rockorequin) wrote :

Here it is.

Bryce Harrington (bryce) on 2009-05-15
tags: added: compiz
Bryce Harrington (bryce) on 2009-05-17
description: updated
RPHegde (rphegde) wrote :

I think this relted to DRI2 not supported for radeon drivers in Ubuntu. I looked at Fedora 11 preview where DRI2 is implemented and did not see this issue at all. I am not sure when Ubuntu will have DRI2 for ATI drivers.

Rocko (rockorequin) wrote :

FYI, I still get the bug in the latest Jaunty with compiz 1:0.8.2-0ubuntu8.1 and xserver-xorg-video-ati 1:6.12.1-0ubuntu2.

I can confirm that the driver doesn't support DRI2 on my card (Xorg.0.log says (II) Loading extension DRI2 / (II) AIGLX: Screen 0 is not DRI2 capable).

If it is a DRI2 issue, is this bug related to bug #96991? Oddly, that bug says xserver-xorg-video-ati 6.12.2 was uploaded to main on May 12th but apt-get only offers 6.12.1 (and I've got proposed and everything enabled).

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
Bryce Harrington (bryce) on 2009-08-14
tags: added: jaunty
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new version of the -ati driver is now available in Karmic.

This is a significant update to -ati which brings in kernel mode-setting
(currently disabled) and scores of fixes for DRI2, EXA, etc.

I've posted the new version of this driver to the following PPA,
would you mind testing it and seeing if it resolves the bug you
reported?

  https://edge.launchpad.net/~bryceharrington/+archive/ppa/+sourcepub/709908/+listing-archive-extra

If you're not running this release of Ubuntu, you can try booting the Karmic
LiveCD and loading the PPA onto it, and then log out/in to restart X.
ISOs are available at http://cdimages.ubuntu.com/releases/

After testing Karmic, report back here whether it's still an issue or not,
and if it is please post a fresh Xorg.0.log and 'dmesg' output.

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug xorg'.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
Rocko (rockorequin) wrote :

I upgraded the xserver-xorg-video-radeon driver to Karmic's version in my Jaunty installation, and the glitches mentioned in the original bug report are gone, so it does appear if they are fixed.

There is a new glitch - the Earth has a ring of white around it (eg when it starts up and you can see the whole planet on the screen). It's still quite usable, though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers