[RV380] [X300 M22] Kubuntu: Hangs on boot at "* Checking battery state..." on ATI graphics

Bug #335560 reported by Hans Heinrich Bergfeld
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Jaunty Alpha 5 Live CD
Boot runs smoothly until the graphic startup hangs with the following screen content:

---8<---8<---

Starting K Desktop Manager: kdm
* Starting network connection manager NetworkManager [OK]
[139.151285] hci__cmd_task:hci0 command tx timeout
* Starting deferred execution scheduler atd [OK]
* Checking Battery State...
/dev/sda setting Advanced Power Management Level to 0xfe (254)

/dev/sda setting Advanced Power Management Level to 0xfe (254)

---8<---8<---

[Ctrl][Alt][Del] results in clean reboot (Splash-screen + "take your cd out of the drive")

Following reboot with Acpi disabled, the system hangs at a similar point

---8<---8<---

* Checking Battery State...
/dev/sda setting Advanced Power Management Level to 0xfe (254)

/dev/sda setting Advanced Power Management Level to 0xfe (254)

---8<---8<---

Switching to the console and running

init 1
xfix
resume boot

results in a working graphical desktop

Hardware: IBM Thinkpad R52 with ATI X300 graphics

(This bug has similarities ot 277587 and 288614, but a new bug report was requested)

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xorg 1:7.4~5ubuntu12
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-8-generic (buildd@rothera) (gcc version 4.3.3 (Ubuntu 4.3.3-3hostname5) ) #26-Ubuntu SMP Wed Feb 25 04:28:54 UTC 2009
SourcePackage: xorg
Uname: Linux 2.6.28-8-generic i686

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 03)
     Subsystem: IBM Device [1014:0575]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M22 [Mobility Radeon X300] [1002:5460]
     Subsystem: IBM Device [1014:056e]

Revision history for this message
Hans Heinrich Bergfeld (hans-heinrich-bergfeld) wrote :
Revision history for this message
Hans Heinrich Bergfeld (hans-heinrich-bergfeld) wrote :

The following may also be useful

Revision history for this message
Hans Heinrich Bergfeld (hans-heinrich-bergfeld) wrote :

And this one

Bryce Harrington (bryce)
Changed in xorg:
status: New → Confirmed
Bryce Harrington (bryce)
description: updated
Revision history for this message
GL (info-gerardolombardo) wrote :

I have the same problem on my laptop with Jaunty Final release when wired network cable is plugged.
VGA is Intel GMA950, boot is ok only when the wired network cable is unplugged.

Revision history for this message
JasonBurns (47-m450n-47) wrote :

I have this problem on Ubuntu 8.10. It started last week. I got into the terminal and am running a dist-upgrade right now to see if that might fix the problem.

Revision history for this message
rpierri (rpierri) wrote :

I had this problem too in AMD 64bits...

/dev/sda setting Advanced Power Management Level to 0xfe (254)

/dev/sda setting Advanced Power Management Level to 0xfe (254)

Switching to the console and running...

init 1
xfix
resume boot

did not work to me...than I ran both commands shown below.

sudo apt-get install xserver-xorg
sudo apt-get install ubuntu-desktop

and I got that problem solved.

Revision history for this message
JasonBurns (47-m450n-47) wrote :

After upgrading from 8.10 to 9.04 my issues have stopped. My laptop is working fine since the upgrade.

Revision history for this message
JasonBurns (47-m450n-47) wrote :

Oh and my graphics card is an Nvidia GeForce FX Go5200

Bryce Harrington (bryce)
summary: - Hangs on boot at "* Checking battery state..." on ATI graphics
+ [Mobility X300] Hangs on boot at "* Checking battery state..." on ATI
+ graphics
Bryce Harrington (bryce)
summary: - [Mobility X300] Hangs on boot at "* Checking battery state..." on ATI
- graphics
+ [Mobility X300] Kubuntu: Hangs on boot at "* Checking battery state..."
+ on ATI graphics
Bryce Harrington (bryce)
summary: - [Mobility X300] Kubuntu: Hangs on boot at "* Checking battery state..."
- on ATI graphics
+ [X300] Kubuntu: Hangs on boot at "* Checking battery state..." on ATI
+ graphics
Bryce Harrington (bryce)
tags: added: freeze
Bryce Harrington (bryce)
summary: - [X300] Kubuntu: Hangs on boot at "* Checking battery state..." on ATI
- graphics
+ [M22] [X300] Kubuntu: Hangs on boot at "* Checking battery state..." on
+ ATI graphics
Bryce Harrington (bryce)
summary: - [M22] [X300] Kubuntu: Hangs on boot at "* Checking battery state..." on
+ [X300 M22] Kubuntu: Hangs on boot at "* Checking battery state..." on
ATI graphics
Bryce Harrington (bryce)
tags: added: kubuntu
Robert Hooker (sarvatt)
summary: - [X300 M22] Kubuntu: Hangs on boot at "* Checking battery state..." on
- ATI graphics
+ [RV380] [X300 M22] Kubuntu: Hangs on boot at "* Checking battery
+ state..." on ATI graphics
Revision history for this message
Tank (digitalrelay) wrote :

Can't load Jaunty or Lynx on any Dell Latitudes at work. Intel integrated controllers .... same error as above.

/dev/sda setting Advanced Power Management Level to 0xfe (254)

Someone please fix this .... we are all so sick of each release being abandoned while Shuttleworth goes off on the next release.

bugbot (bugbot)
tags: added: jaunty
Revision history for this message
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Revision history for this message
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers