FFe: Xv and EXA not supported on R6xx/R7xx chipsets

Bug #334101 reported by Bryce Harrington on 2009-02-24
70
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Jaunty
High
Tim Gardner
update-manager (Ubuntu)
Undecided
Michael Vogt
Jaunty
Undecided
Michael Vogt
xserver-xorg-video-ati (Ubuntu)
High
Bryce Harrington
Jaunty
High
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-ati

[Proposed Change]
When released, review the code changes and, if acceptable, merge the -ati 6.12.0 driver into main, along with its required kernel changes.

[Explanation]
The 6.11.0 -ati driver in Jaunty supports Xv for video acceleration up to R5xx chips, but newer chips (R6xx/R7xx) lack support, so videos in mplayer, totem, et al only work with the x11 driver, which means that the movie cannot be played at full-screen size, and other assorted problems.

In addition, the 6.11.0 -ati driver does not provide 2D acceleration via EXA. This causes problems scrolling in firefox and other applications, makes window movement sluggish, and various other related problems.

The upcoming 6.12.0 driver promises to correct both of these issues, and bring bug fixes related to supporting 6xx/7xx in general.

[Rationale for Exception]
With EXA and Xv for 6xx/7xx in -ati, we gain full basic 2D support with Ubuntu's main default drivers for the latest ATI hardware currently on the market.

Since we still do not have a version of the proprietary -fglrx driver for Jaunty yet, having 6xx/7xx support in -ati also provides us with a contingency solution in case that driver is not delivered in time for beta freeze.

We are carrying a handful of high priority bugs related to 6xx/7xx support in -ati (ex. bug #206075, bug #243365, bug #267185, bug #272406, bug #273510, bug #319930, bug #325394). I anticipate that 6.12.0 will solve the bulk of these bugs (we'll need to have the reporters re-test to be sure).

[Testing]
I've posted a git snapshot of the 6xx/7xx support branch of the 2D driver from upstream to my ppa:

https://edge.launchpad.net/~bryceharrington/+archive/ppa

You'll also need the kernel bits, which are pending availability.

Bryce Harrington (bryce) on 2009-02-25
description: updated
Bryce Harrington (bryce) on 2009-02-25
description: updated
Martin Pitt (pitti) wrote :

Does 6.12 drop support for any models which 6.11 supports?

With my release hat on, it seems we need to bite that bullet, even if new versions of drivers become more risky at that point; we should get that in before jaunty beta, even if it means to temporarily ship an upstream snapshot instead of the final 0.6.12 release.

Changed in xserver-xorg-video-ati:
assignee: nobody → bryceharrington
importance: Undecided → High
Bryce Harrington (bryce) wrote :

6.12.0 will not drop support for any hardware. Anecdotally, each of the 3-4 persons who have tested it on pre-6xx hardware so far (because they were experiencing various problems with the current version) reported that things improved (fewer glitches, better performance, etc.) and none have reported regressions so far. That's not enough testers to really draw any conclusions yet, but so far so good.

Changed in xserver-xorg-video-ati:
status: New → Triaged
Steve Langasek (vorlon) wrote :

FFe approved assuming this is landing pre-beta. If it's not going to land until after beta, we would need to discuss in more detail. (But please get it in before beta so we don't have to. :)

Luke Plant (spookylukey) wrote :

I've tried your 6.12 packages, my results are:

 - moving top level windows is worse than ever (you can see the update as it goes down the screen). Strangely, moving plasma windows on the KDE4 desktop is OK.
 - no other changes (i.e. video still very poor frame rate etc).

However:
 - Maybe I need to enable stuff in my xorg.conf? Currently I have no xorg.conf at all
 - Maybe I need some kernel updates? (but what? no details have been given about what kernel is needed).

Currently $ cat /proc/version_signature
Ubuntu 2.6.28-8.27-generic

I'm using
- Dell Studio 17,
- ATI Technologies Inc Mobility Radeon HD 3650

Luke Plant (spookylukey) wrote :

In addition to my previous comment, its not just moving windows, it's also scrolling in Firefox -- it's now unbearably bad. Thankfully I use Konqueror most of the time, but I will be forced to downgrade to 6.11 for the sake of the times I need Firefox, unless there is some way of fixing this.

Tormod Volden (tormodvolden) wrote :

After Bryce made those packages, the R6xx/7xx branch was merged to master and received a bunch of updates. Maybe you can try the -ati/-radeon packages in my PPA, https://launchpad.net/~tormodvolden/+archive/ppa

Luke Plant (spookylukey) wrote :

Cheers Tormod. I've installed these packages

xserver-xorg-video-ati_6.11.0.99+git20090305.5dc4b69f-0ubuntu0tormod_i386.deb
xserver-xorg-video-radeon_6.11.0.99+git20090305.5dc4b69f-0ubuntu0tormod_i386.deb

While I don't have the problems I had with Bryce's packages, I still don't have accelerated video i,e, I'm just where I was with the most recent Jaunty packages.

Thanks.

Luke Plant [2009-03-06 0:53 -0000]:
> While I don't have the problems I had with Bryce's packages, I still
> don't have accelerated video i,e, I'm just where I was with the most
> recent Jaunty packages.

Might that be because our kernel doesn't yet have the DRI bits for
those chips?

Installing:
xserver-xorg-video-radeonhd_1.2.4+git20090302.9c8ab2df-0ubuntu0tormod_amd64.deb
xserver-xorg-video-radeonhd-dbg_1.2.4+git20090302.9c8ab2df-0ubuntu0tormod_amd64.deb

and overwriting drm.ko and radeon.ko as explained in:
http://wiki.x.org/wiki/radeonhd%3Ar6xx_r7xx_branch

Makes Xv and EXA work for me on Jaunty.

Using:
xserver-xorg-video-radeon_6.11.0.99+git20090305.5dc4b69f-0ubuntu0tormod_amd64.deb
xserver-xorg-video-radeon-dbg_6.11.0.99+git20090305.5dc4b69f-0ubuntu0tormod_amd64.deb

The colours are screwed, for instance everything which should be black is green.

Luke Plant (spookylukey) wrote :

Thanks Andreas, that worked for me, I now have Xv acceleration, and I can even get reasonable desktop effects (KDE) using XRender (but not OpenGL).

It even has mitigated KDE bug https://bugs.kde.org/show_bug.cgi?id=119281 (sluggishness in KMail composer, which seems to be graphics driver related).

So thanks for all the work on this, it looks good from here.

To sum up additional external changes required:

 - Jaunty kernel does need upgrade/patch to support this
 - xorg.conf needs to be present and have certain non-default options enabled - as per the link Andreas posted.

Luke Plant (spookylukey) wrote :

Hmm, I'm actually seeing screen corruption issues, as described by other people, such as on this page:

http://www.phoronix.com/forums/showthread.php?t=15227&page=8

I'm sometimes seeing garbage on screen like in this screen shot: http://www.stud.tu-ilmenau.de/~johi-in/Bildschirmfoto7.jpg

(that's not mine, but mine is very similar).

Hmm, maybe I'm just lucky or maybe it's because I only use metacity, anyway I have not seen any screen corruption with the radeonhd driver. Btw. I forgot to mention I also made a xorg.conf file:

Section "Device"
    Identifier "Configured Video Device"
    Driver "radeonhd"
    Option "AccelMethod" "exa"
    Option "DRI" "on"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Tormod Volden (tormodvolden) wrote :

I should point out that the -ati/-radeon drivers in my PPA do not have the EXA-by-default patch that Bryce's and the drivers in main have, so they will need the AccelMethod EXA option. This might explain some of the differences Luke experienced in comment 7, unless he used this option.

Luke Plant (spookylukey) wrote :

@Tormod: when I tried Bryce's packages, I was using an empy xorg.conf.

With my current setup, as well as the screen corruption issue, I also cannot hibernate or suspend at all. Has anyone else tried this? I'm wondering if it is to do with manually patching the drm,ko and radeon.ko modules.

Bryce Harrington (bryce) wrote :

Current status - I've merged a git snapshot of -ati, which is available in my ppa. Also, I've been consulting with the kernel team in getting the 6xx/7xx support integrated into the kernel; it is currently anticipated this will go in once the Alpha6 freeze has lifted, perhaps as early as Friday.

Martin Pitt (pitti) on 2009-03-12
Changed in linux:
assignee: nobody → canonical-kernel-team

I'm running Bryce's packages, but without acceleration (I'm guessing it's the missing kernel bits that prevent it). There don't seem to be any particular issues except the (expected) slowness from lack of acceleration. These drivers work whereas the original 6.11.0 did not (I've been using radeonhd drivers in the meantime.)

Will report back once those kernel bits (hopefully) make it into the main repos.

Bryce Harrington (bryce) wrote :

Thanks for testing the git version. So far everyone's test results of this snapshot have been positive.

I've gone ahead and uploaded it to jaunty, to get some more widespread testing before we hit beta freeze.

I see in the upstream git log that there's been some additional fixes to R600 since this git snapshot was made, however I anticipate we'll see 6.12.0 out in time to pull in before beta so will wait for now. If for some reason that doesn't come, I'll either pull a newer snapshot or cherrypick those patches, since they look quite relevant.

Oibaf (oibaf) on 2009-03-13
description: updated
Sam Liddicott (sam-liddicott) wrote :

Building drm.ko and radeon.ko according to:
 http://wiki.x.org/wiki/radeonhd%3Ar6xx_r7xx_branch

and depmod -a (and rmmod fglrx) before modprobe drm && modprobe radeon

and having xorg.conf
Section "Screen"
        Identifier "Configured Screen Device"
        Device "Configured Video Device"
        SubSection "Display"
                Virtual 5040 1050
        EndSubSection
EndSection

Section "Device"
        Identifier "Configured Video Device"

    Driver "radeonhd"
    Option "AccelMethod" "exa"
    Option "DRI" "on"
EndSection

and using either Tormod Volden's or Bryce Harrington's latest ppa still gives me very slow screen updates with sound cutting out when I drag a window around.

Am I missing something or do I just need to be patient for another week or so?

My graphics reports as: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] rev 0, Mem @ 0xc0000000/268435456, 0xd6400000/65536, 0xd6300000/1048576, I/O @ 0x00005000/256

6.12.0 is released; works great with bleeding edge kernel

Tiago Sousa (tiagoboldt) wrote :

Please upload 6.12 to jaunty!

Niels Slot (nielsslot) wrote :

I've been using Tormod's -ati git20090305.5dc4b69f packages on RV670 for the last few days with kernel modules compiled according to the instructions from the RadeonHD wiki. I switched to the -ati package in main yesterday, so far no difference.

KDE4's desktop effects work when using XRender, they are a bit slow though, but usable. Xv acceleration works great and is a huge improvement in comparison to Fglrx and older open source drivers because it gives me tear free video playback.

It would be great to get the kernel bits into Jaunty and to have out-of-the-box 2D and video acceleration on all ATI Radeon chips.

BTW, I also tried installing the latest drivers on my Hardy installation. The drivers installed fine, but I got really slow scrolling, especially in Firefox and Yakuake (KDE3 Konsole). I blamed my Fglrx and old X.org installation, a clean Jaunty installation gave no problems at all.

floid (jkanowitz) wrote :

A "thank you" to everyone working on this; I have a 780G and literally couldn't wait, so built the new DRM and have it working nicely with the 6.11 drivers. The improvement (even without giving 6.12 a shot) is quite dramatic for the basics of Firefox scrolling and window dragging.

For those who aren't having luck, this falls under "theoretically terribly obvious" but might deserve mention: Are you sure you've placed the modules in the right paths? The X.org instructions assume a hierarchy of drivers/char/drm/ while Ubuntu's 2.6.28-9 is using drivers/gpu/drm/ (and drivers/gpu/drm/radeon/). Following the instructions blindly and then relying on modprobe or a reboot to take care of things will probably result in loading the "old" versions.

Sam Liddicott (sam-liddicott) wrote :

Still no joy for me - last Friday my laptop kept hanging - beyond the power of ctrl-alt-sysreq-b

I had copied my modules to the right place.

Today I have the latest Tormod and git update and build radeon.ko and drm.ko; I rmmod fglrx and modprobe these, but things are still slow.

$ lsmod | grep radeon
radeon 357408 0
drm 203296 1 radeon

Should "radeon" have a reference count of 0 when X is running?

I've tried driver "radeon" "radeonhd" and "ati" but it makes no difference.

Firefox paints slowly if I do page-down, but even slower if I do line-down and it has to copy part of the screen.

my xorg.conf is as my post above

Sam Liddicott (sam-liddicott) wrote :

Taking a top from Niels Slot, I purged packages with "fglrx" in the name and now I find:
$ lsmod | grep radeon
radeon 357408 2
drm 203296 3 radeon

which is what I expect.

I also find much improvement. Page-down in firefox is faster - almost instant, but arrow-down is still slow.
Painting of the wallpaper is also nearly instant, and when I log in I can see five shades of wall-paper as it fades in from grey instead of two shades painting very slowly.

So - I think I now have the improvements that are to be expected at this stage.

I'll report on crashes if i get any more.

Thanks to Andreas, Tormod, Niels and others...

Tiago Sousa (tiagoboldt) wrote :

Same thing here, I've replaced drm.ko and radeon.ko as said on X.org wiki and I'm using the drivers from tormod (6.11+git from march 14). I had to purge all fglrx packages, and I now have Xv video acceleration ;)
I'll report on any issues I find.

Yves Glodt (yglodt) wrote :

Can someone briefly explain why in intrepid the driver worked well, and accelerated?

Sam Liddicott (sam-liddicott) wrote :

I'm guessing that by "the driver" you mean "an ati driver" which was probably the closed source fglrx.

The answer is; It still works just as well, except that Jaunty is using a later release of Xorg, and ATI haven't released a build of their driver that matches; and so it doesn't work on the current Xorg in Jaunty.

THIS driver is new-ish and has always been poor on newer hardware AFAIK, it's just that more people are having to use it sooner than they thought because ATI are taking their time releasing their closed source driver.

Some people are using the old intrepid Xorg server so they can keep using the closed source drivers.

Yves Glodt (yglodt) wrote :

Hmm :-) Until 3 days ago I used intrepid on my Vaio FW21E, with the radeon driver, and it did not feel sluggish at all.

Although I could not enable KDE's desktop effects, overall drawing performance seemed very good.

In jaunty, X uses more CPU and painting is much slower, in comparison. I stopped using the fglrx driver a while ago since it causes too many wakeups, and KDE 2D drawing performance was awful.

Tormod Volden (tormodvolden) wrote :

Yves, a difference between Intrepid and Jaunty for the radeon driver is that it now uses EXA by default. Try
 Option "AccelMethod" "XXA"
or "EXA" to compare.

Jarkko Lietolahti (jarkko-jab) wrote :

Using xserver-xorg-video-ati 6.12.0-0ubuntu1
and drm.ko and radeon.ko patches using instructions http://wiki.x.org/wiki/radeonhd%3Ar6xx_r7xx_branch

Gives RADEON(0): Acceleration enabled, with ATI Technologies Inc Mobilitiy Radeon HD 3650

Thanks!

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: drmOpenMinor returns 10
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[ 0.198492] (II) RADEON(0): [dri] Found DRI library version 1.3.0 and kernel module version 1.29.0
[ 0.198536] (==) RADEON(0): Page Flipping disabled on r5xx and newer chips.

[ 0.198542] (II) RADEON(0): Will try to use DMA for Xv image transfers
....
[ 0.943226] (II) RADEON(0): Direct rendering enabled
[ 0.943238] (II) RADEON(0): Setting EXA maxPitchBytes
[ 0.943258] (II) EXA(0): Offscreen pixmap area of 249987072 bytes
[ 0.943268] (II) EXA(0): Driver registered support for the following operations:
[ 0.943273] (II) Solid
[ 0.943276] (II) Copy
[ 0.943280] (II) Composite (RENDER acceleration)
[ 0.943284] (II) UploadToScreen
[ 0.943288] (II) DownloadFromScreen

jarkko@gandalf:~$ uname -a
Linux gandalf 2.6.28-10-generic #32-Ubuntu SMP Mon Mar 16 02:48:55 UTC 2009 x86_64 GNU/Linux

Yves Glodt (yglodt) wrote :

OK tried XAA and it feels better.

But now I got the shiny 6.12 driver and expected EXA to work, but it does not look like it works... Some data:

uname -a
Linux viking 2.6.28-10-generic #32-Ubuntu SMP Mon Mar 16 02:48:55 UTC 2009 x86_64 GNU/Linux

Excerpts from Xorg.0.log:

[ 0.514602] (--) PCI:*(0@1:0:0) ATI Technologies Inc Mobility Radeon HD 3400 Series rev 0, Mem @ 0xc0000000/268435456, 0xd0020000/65536, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
...
[ 0.515178] (II) "extmod" will be loaded by default.
[ 0.515194] (II) "dbe" will be loaded by default.
[ 0.515207] (II) "glx" will be loaded by default.
[ 0.515220] (II) "record" will be loaded by default.
[ 0.515234] (II) "dri" will be loaded by default.
[ 0.515247] (II) "dri2" will be loaded by default.
...
[ 0.621783] (II) LoadModule: "radeon"
[ 0.622137] (II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
[ 0.719498] (II) Module radeon: vendor="X.Org Foundation"
 compiled for 1.6.0, module version = 6.12.0
 Module class: X.Org Video Driver
 ABI class: X.Org Video Driver, version 5.0
...
[ 1.204269] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM [dri] Disabling DRI.
...
[ 2.221159] (EE) RADEON(0): Acceleration initialization failed
...
[ 2.457331] (II) AIGLX: Screen 0 is not DRI2 capable
[ 2.457389] (II) AIGLX: Screen 0 is not DRI capable

Yves Glodt (yglodt) wrote :

...since the kernel from jaunty seems to be not new enough regarding drm and radeon, and as my pre-poster already wrote, I built drm.ko and radeon.ko modules using instructions http://wiki.x.org/wiki/radeonhd%3Ar6xx_r7xx_branch, and now it works.

[ 1.425733] (II) RADEON(0): [dri] Found DRI library version 1.3.0 and kernel module version 1.29.0
...
[ 2.364626] (II) RADEON(0): Acceleration enabled

Performance seems much better now. Will jaunty's kernel be updated to ship these bits? :-)

Bryce Harrington (bryce) wrote :

Tim has the kernel patch from upstream and will be applying it soon.

Changed in linux (Ubuntu Jaunty):
assignee: canonical-kernel-team → timg-tpi
importance: Undecided → High
status: New → Triaged
Bryce Harrington (bryce) wrote :

I've merged and uploaded the 6.12.0 driver this morning, so the X side of this bug is done now; just need the kernel side.

Changed in xserver-xorg-video-ati (Ubuntu Jaunty):
status: Triaged → Fix Released
Bryce Harrington (bryce) wrote :

FTR, I tested -ati on an x1650 and an hd2600 both of which worked well, and on a hd4850 which did not (white screen). Maybe the 4850 will work better once the kernel stuff is in.

Yves, you ought to file a separate bug report on your XAA/EXA performance issue. Probably you should also run the phoronix test suite for both driver options so you can get a quantitative performance measurement for upstream.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Jaunty):
milestone: none → ubuntu-9.04-beta
status: Triaged → Fix Committed
Bryce Harrington (bryce) wrote :

Tim reports this fix is in process of being uploaded with kernel 2.6.28-11. Should be uploaded later today.

Changed in linux (Ubuntu Jaunty):
assignee: timg-tpi → nobody
milestone: ubuntu-9.04-beta → none
status: Fix Committed → Fix Released
Yves Glodt (yglodt) wrote :

Bryce, thanks for the info and the pointers.

Don't know whether it's in the scope of this report, but I noticed this today (check the first and the last line of this excerpt):

[ 0.331623] (II) AIGLX: Screen 0 is not DRI2 capable
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: drmOpenMinor returns 11
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[ 0.423166] (EE) AIGLX error: Calling driver entry point failed[ 0.424817] (EE) AIGLX: reverting to software rendering

Probably it is related to the "There is no 3D support yet."-part of the kernel-commit message... Any timeframe of when AIGLX will run with this driver?

Tim Gardner (timg-tpi) on 2009-03-17
Changed in linux (Ubuntu Jaunty):
assignee: nobody → timg-tpi
milestone: none → ubuntu-9.04-beta
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.6 KiB)

This bug was fixed in the package linux - 2.6.28-11.34

---------------
linux (2.6.28-11.34) jaunty; urgency=low

  [ Alex Deucher ]

  * SAUCE: (drop after 2.6.28) radeon: add support for RS600, R6xx, and
    R7xx GPUs
    - LP: #334101

  [ Aristeu Sergio Rozanski Filho ]

  * SAUCE: (drop after 2.6.28) ALSA: hda: add quirk for Lenovo X200 laptop
    dock

  [ Shane Huang ]

  * SAUCE: (drop after 2.6.28) i2c-piix4: Add support to SB800 SMBus
    changes
    - LP: #338108

  [ Upstream Kernel Changes ]

  * net: amend the fix for SO_BSDCOMPAT gsopt infoleak
  * net: Kill skb_truesize_check(), it only catches false-positives.
  * sparc64: Fix crashes in jbusmc_print_dimm()
  * sparc64: Fix DAX handling via userspace access from kernel.
  * vfs: separate FMODE_PREAD/FMODE_PWRITE into separate flags
  * seq_file: properly cope with pread
  * vt: Declare PIO_CMAP/GIO_CMAP as compatbile ioctls.
  * timerfd: add flags check
  * aoe: ignore vendor extension AoE responses
  * mm: clean up for early_pfn_to_nid()
  * mm: fix memmap init for handling memory hole
  * Fix oops in cifs_strfromUCS_le mounting to servers which do not specify
    their OS
  * mm: fix lazy vmap purging (use-after-free error)
  * mm: vmap fix overflow
  * PCI quirk: enable MSI on 8132
  * SCSI: hptiop: Add new PCI device ID
  * JFFS2: fix mount crash caused by removed nodes
  * SCSI: sd: revive sd_index_lock
  * USB: usb_get_string should check the descriptor type
  * USB: usb-storage: add IGNORE_RESIDUE flag for Genesys Logic adapters
  * USB: cdc-acm: add usb id for motomagx phones
  * rtl8187: New USB ID's for RTL8187L
  * WATCHDOG: ks8695_wdt.c: 'CLOCK_TICK_RATE' undeclared
  * WATCHDOG: rc32434_wdt: fix watchdog driver
  * WATCHDOG: rc32434_wdt: fix sections
  * RDMA/nes: Don't allow userspace QPs to use STag zero
  * USB: option: add BenQ 3g modem information
  * md: avoid races when stopping resync.
  * md/raid10: Don't call bitmap_cond_end_sync when we are doing recovery.
  * md/raid10: Don't skip more than 1 bitmap-chunk at a time during
    recovery.
  * sound: virtuoso: revert "do not overwrite EEPROM on Xonar D2/D2X"
  * ALSA: usb-audio - Fix non-continuous rate detection
  * ALSA: usb-audio - Workaround for misdetected sample rate with CM6207
  * sound: usb-audio: fix uninitialized variable with M-Audio MIDI
    interfaces
  * ALSA: fix excessive background noise introduced by OSS emulation rate
    shrink
  * ALSA: hda - Fix digital mic on dell-m4-1 and dell-m4-3
  * ALSA: aw2: do not grab every saa7146 based device
  * acer-wmi: fix regression in backlight detection
  * vmalloc: call flush_cache_vunmap() from unmap_kernel_range()
  * Fix fixpoint divide exception in acct_update_integrals
  * 8250: fix boot hang with serial console when using with Serial Over Lan
    port
  * x86, vmi: TSC going backwards check in vmi clocksource
  * HID: fix bus endianity in file2alias
  * inotify: fix GFP_KERNEL related deadlock
  * sdhci: fix led naming
  * x86: oprofile: don't set counter width from cpuid on Core2
  * intel-agp: fix a panic with 1M of shared memory, no GTT entries
  * mtd_dataflash: fix probing of AT45DB321C chips.
  * proc: fix kflags to uflags copying in /...

Read more...

Changed in linux:
status: Fix Committed → Fix Released
Oibaf (oibaf) wrote :

Bryce, Tim, what about the updates to upstream drm-next? There is at least one fix after the backport to Ubuntu kernel:
http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=shortlog;h=drm-next

Will they be backported?

Tim Gardner (timg-tpi) wrote :

Fabio - since the backport is a composite of several upstream commits, perhaps you could point out to me which commit in drm-next you believe to be missing. I'm not familiar enough with the code to be able to easily identify what's important.

Martin Pitt (pitti) wrote :

What's still left here is the transition of fglrx users on pre-5xx (Bryce, please confirm) chips to ati. Michael, I assume we can reuse the code we already used in intrepid. What kind of information do you need for this? I can help with providing a vendor/product ID list of affected cards, or something similar.

Changed in update-manager (Ubuntu Jaunty):
assignee: nobody → mvo
milestone: none → ubuntu-9.04-beta
Oibaf (oibaf) wrote :

Citando Tim Gardner <email address hidden>:

> Fabio - since the backport is a composite of several upstream commits,
> perhaps you could point out to me which commit in drm-next you believe
> to be missing. I'm not familiar enough with the code to be able to
> easily identify what's important.

This commit:
http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=41f13fe81dd1b08723ab9f3fc3c7f29cfa81f1a5
was committed to upstream drm-next after the backport to Ubuntu.

Tormod Volden (tormodvolden) wrote :

Martin, wrong bug? This one is about r6xx and r7xx cards, which do not need any transition. Also, the transition concerns "pre-6xx", since the new fglrx does not support 5xx AFAIK.

Tim and Fabio, I think we can deal with additional commits on a per-case basis. Anyway, Fabio's link concerns only RS600 cards, and to me it seems safe enough to add without waiting for a bug report.

Michael Vogt (mvo) wrote :

update-manager has this code enabled. It automatically gets the latest fglrx-modules.alias.override from fglrx-modaliases and checks against that. If fglrx is in use and no longer supported it shows:

_("Upgrading may reduce desktop "
                                         "effects, and performance in games "
                                         "and other graphically intensive "
                                         "programs."),
_("This computer is currently using "
                                         "the AMD 'fglrx' graphics driver. "
                                         "No version of this driver is "
                                         "available that works with your "
                                         "hardware in Ubuntu "
                                         "9.04.\n\nDo you want to continue?"))
and if the user accepts it will remove fglrx and rewrite xorg.conf to use "ati" instead.

Changed in update-manager (Ubuntu Jaunty):
status: New → Fix Released
Luke Plant (spookylukey) wrote :

For reference, regarding my previous problems (screen corruption and hibernate/suspend etc), these seem now to be fixed, using latest Jaunty packages.

(some minor visual glitches remain, the worst is that the 'blank screen' screensaver doesn't actually work if desktop effects are enabled using XRender - you can see the fading in and out transitions, but the screen reverts to normal when it should be black).

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Jaunty):
milestone: ubuntu-9.04-beta → ubuntu-9.04
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-11.37

---------------
linux (2.6.28-11.37) jaunty; urgency=low

  [ Alex Deucher ]

  * SAUCE: radeon: add some new pci ids
    - LP: #334101

  [ Amit Kucheria ]

  * Updating configs - rip out orion5x and mv78xx0 flavours

  [ Andy Whitcroft ]

  * SAUCE: tone down the synaptics warning to avoid triggering kerneloops
    - LP: #330606

  [ Upstream Kernel Changes ]

  * ext4: fix header check in ext4_ext_search_right() for deep extent
    trees.
    - LP: #346194
  * eCryptfs: NULL crypt_stat dereference during lookup
    - LP: #345766
  * eCryptfs: Allocate a variable number of pages for file headers
    (CVE-2009-0787)
    - LP: #345544

 -- Tim Gardner <email address hidden> Mon, 23 Mar 2009 09:24:32 -0600

Changed in linux:
status: Fix Committed → Fix Released
zika (4zika4) wrote :

with kernel 2.6.28-11.37-generic on amd_64 with ATI HD 3650 I still get:

[code]X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-15-server x86_64 Ubuntu
Current Operating System: Linux zika-desktop 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:00 UTC 2009 x86_64
Build Date: 20 March 2009 02:02:41PM
xorg-server 2:1.6.0-0ubuntu4 (<email address hidden>)[/code]
...
[code][ 0.516051] (II) AIGLX: Screen 0 is not DRI2 capable
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: drmOpenMinor returns 11
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[ 0.524201] (EE) AIGLX error: Calling driver entry point failed
[ 0.525959] (EE) AIGLX: reverting to software rendering
[ 0.535116] (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
[ 0.535130] (II) GLX: Initialized DRISWRAST GL provider for screen 0[/code]

any news?

Jarkko Lietolahti (jarkko-jab) wrote :

Btw, for future, the commit 85568da345d4348f33c69043c9bc4e78ad819706 ( http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-jaunty.git;a=commit;h=85568da345d4348f33c69043c9bc4e78ad819706 ) is not included in 2.6.29.

Here's the current 2.6.29 head which also doesn't include r600 drm stuff; http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=tree;f=drivers/gpu/drm/radeon;hb=c31f403de62415c738ddc9e673cf8e722c82f861

So dropping this after 2.6.28 will cause (currently) r600 exa to fail.

Anakin Starkiller (sunrider) wrote :

Can anyone here can confirm that EXA 2D acceleration works with multiple opened X sessions ?
When I login with user A, everything is ok (moving windows is fast) but then when I login with user B, moving windows is terribly sluggish... If I switch back to user A, it works again...
I'm using Intrepid (kernel 2.6.27) with drivers from https://launchpad.net/~tormodvolden/+archive/ppa so I was wondering whether this issue was solved with Jaunty and latest kernel.

Anakin Starkiller (sunrider) wrote :

Well actually my problem was caused by DRI "on" in xorg.conf, and DRI does not work on multiple X sessions....

Rune K. Svendsen (runeks) wrote :

I would just like to report my success on installing the radeon-drivers and getting smooth video rendering and a working xvideo.
For me, however, radeonhd doesn't work very well so I have to use the radeon driver and modify my xorg.conf in order for it to use the radeon driver instead of the radeonhd driver by default.

Using the radeonhd driver makes the refresh rate of my monitor too low, and I am unable to change it under Preferences->Display (the only refresh rate present there is "0 Hz"). And changing the resolution causes the colors on the screen to get very odd (light green, purple etc.)

But, fortunately, with the radeon driver everything works perfectly. Refresh rate is 85 Hz as usual, and under Preferences->Display I can see this refresh rate and not just "0 Hz".

So, in short, this is what worked for me:

Installing the following packages from Tormod's PPA (https://launchpad.net/~tormodvolden/+archive/ppa):

(I had to remove the old version of xserver-xorg-video-radeon first)
xserver-xorg-video-ati_6.12.99+git20090710.43db263d-0ubuntu0tormod_i386.deb (197.1 KiB)
xserver-xorg-video-ati-dbg_6.12.99+git20090710.43db263d-0ubuntu0tormod_i386.deb (201.5 KiB)
xserver-xorg-video-radeon_6.12.99+git20090710.43db263d-0ubuntu0tormod_i386.deb (507.7 KiB)
xserver-xorg-video-radeon-dbg_6.12.99+git20090710.43db263d-0ubuntu0tormod_i386.deb (1.5 MiB)

Follow instructions on http://wiki.x.org/wiki/radeonhd%3Ar6xx_r7xx_branch for building new versions of radeon.ko and drm.ko. Copying drm.ko and radeon.ko to "/lib/modules/$(uname -r)/kernel/drivers/gpu/drm/" and "/lib/modules/$(uname -r)/kernel/drivers/gpu/drm/radeon" respectively.

Modifying my xorg.conf according to the instructions on the X.Org Wiki and adding the following to the "Device" section so the "radeon" driver is used instead of the default "radeonhd" driver:

Driver "radeon"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.