[RV770 HD 4850] ATI Radeon HD 4850 not supported - white screen and system freeze

Bug #325394 reported by Patrice Vetsel on 2009-02-04
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
High
xserver-xorg-video-ati (Ubuntu)
High
Bryce Harrington
Nominated for Jaunty by Patrice Vetsel

Bug Description

Binary package hint: xserver-xorg-video-ati

xserver-xorg-video-radeon 1:6.10.0-1ubuntu1 claim to support "RV770 Radeon HD 4850/4870" (from man radeon) but in fact, when xorg come up screen go white and system freeze.

kagou@agape:~$ lspci | grep VGA
02:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
kagou@agape:~$ lspci -n | grep 0300
02:00.0 0300: 1002:9442
kagou@agape:~$

I'v reported this bug on Ubuntu Jaunty (9.04) :
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/325394

xserver-xorg-video-radeon 1:6.10.0-1ubuntu1 claim to support "RV770 Radeon HD 4850/4870" (from man radeon) but in fact, when xorg come up screen go white and system freeze.

kagou@agape:~$ lspci | grep VGA
02:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
kagou@agape:~$ lspci -n | grep 0300
02:00.0 0300: 1002:9442
kagou@agape:~$

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed

I have set driver to "ati" in xorg.conf -> system freeze
so I'v set it to "radeonhd" -> but i'v discovered that xorg radeonhd is not installed ?! -> should be confirmed
after installation of xserver-xorg-video-radeonhd (1.2.4-1), if driver is set to "ati" -> system freeze
Now if I set it to "radeonhd" xorg launch with good screen resolution.

Please attach your xorg.conf and xorg log.

the xorg.conf is empty -> Xorg detection
or the xorg.conf is a failsafe xorg.conf with just driver set to "ati"

please attach your xorg log. It should be in /var/log/Xorg.*.log

Created an attachment (id=22811)
Xorg.log

(In reply to comment #4)
> Created an attachment (id=22811) [details]
> Xorg.log
>

This is the log from vesa. If ubuntu safe mode kicks in, it will run vesa. The ati log should be one of the other Xorg logs in /var/log.

Nothing is wrote on Xorg.log.
I'v set it empty.
modified xorg.conf -> set driver=ati
reboot
when xorg launch->white screen...3 seconds later system reboot.
I boot under another linux system, access Xorg.log and is always empty

Bug is not resolved in newer xserver-xorg-video-ati (1:6.10.99.0-1ubuntu1)

-ati 6.10.99.0 has been uploaded, try again it may support it better now.

Changed in xserver-xorg-video-ati:
status: New → Fix Released

Bug is not resolved in xserver-xorg-video-ati (1:6.10.99.0-1ubuntu1)

Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: Fix Released → Confirmed

As said in https://bugs.freedesktop.org/show_bug.cgi?id=19984 Xorg.log is not useful because xorg don't write in it when driver is set to ATI.

Xorg try to launch, immediately white screen and after 3 seconds -> reboot

Bryce Harrington (bryce) wrote :

I've ordered a 4850 and will troubleshoot this more directly once it arrives (probably next week).

Meanwhile, maybe see if you have an Xorg.0.log.old with details about your boot attempt.

Changed in xserver-xorg-video-ati:
assignee: nobody → bryceharrington
status: Confirmed → Triaged

please try ati git master. I think commit 42492c70c481c88911337eefb97ba9d030adf7b6
should fix it.

This seems to only affect 1 GB cards.

Bryce Harrington have made a package with this patch but this is not solving the bug for me :(

Confirmed on 1:6.11.0-1ubuntu1

@Bryce Harrington : Alex Deucher in upstream bug suggest to test :
http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=42492c70c481c88911337eefb97ba9d030adf7b6

Can you provide a package including this patch ?

fixed in master:
cadae2a8d9979b2d61eae7d1f7a9ab8f5eb28e83

Bryce Harrington (bryce) wrote :

Uploaded to my ppa. If it solves the issue let me know and I'll put it into jaunty.

Changed in xserver-xorg-video-ati:
status: Triaged → In Progress

this package don't solve the bug for me :(

Bryce Harrington (bryce) on 2009-02-19
Changed in xserver-xorg-video-ati:
status: In Progress → Triaged
Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released

Hey Bryce,

I'm not very familiar with how your efforts relate to what ends up on
the daily live CDs. Do you know when the daily live CD is likely to
contain this fix? I'm eager to try it out.

Thanks,
Christian

On Thu, Feb 19, 2009 at 3:45 PM, Bryce Harrington
<email address hidden> wrote:
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: In Progress => Triaged
>
> --
> [RV770 HD 4850] ATI Radeon HD 4850 not supported - white screen and system freeze
> https://bugs.launchpad.net/bugs/325394
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

@Christian : bug is not yet fixed and we are in freeze so it can be a few days.

I confirm that this patch solve the bug for me :)

Thanks !

I'm building a package to test http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=cadae2a8d9979b2d61eae7d1f7a9ab8f5eb28e83

I will report if this is solving this bug

I can confirm that this patch solve the bug for me :)
"Fix MC setup on systems with more than 512 MB of VRAM"

There is a package on my personal ppa

@Bryce : can you commit the patch for alpha5 (there are also other patches for r6xx/r7xx on git) ?

Changed in xserver-xorg-video-ati:
milestone: none → jaunty-alpha-6

My 4850 works just fine with vesa.

Just a suggestion for a temporary solution for users waiting on a fix.

I just tried the 9.04 alpha5 live environment, with my HD 8450 card. I still get the white screen of death, but now I can switch virtual terminals, so at least I can now access a shell.

Thanks to that new-found ability, I was able to access various files of interest. I'm attaching them to this report.

This bug is still present in today's (4 March 2009) 32-bit live CD build. (I haven't tested other versions of today's build.)

Please fix the package (it's fixed upstream) for Jaunty alpha 6

Still present in 11 March 2009 32-bit live CD build.

Are you working on adding the fixed package to the repos or not?

Sincerely Yours
Nicholas Ipsen

On Wed, Mar 11, 2009 at 7:27 PM, Christian Convey <
<email address hidden>> wrote:

> Still present in 11 March 2009 32-bit live CD build.
>
> --
> [RV770 HD 4850] ATI Radeon HD 4850 not supported - white screen and system
> freeze
> https://bugs.launchpad.net/bugs/325394
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org XServer - ATI gfx chipset driver: Fix Released
> Status in “xserver-xorg-video-ati” source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-ati
>
> xserver-xorg-video-radeon 1:6.10.0-1ubuntu1 claim to support "RV770 Radeon
> HD 4850/4870" (from man radeon) but in fact, when xorg come up screen go
> white and system freeze.
>
> kagou@agape:~$ lspci | grep VGA
> 02:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD
> 4850]
> kagou@agape:~$ lspci -n | grep 0300
> 02:00.0 0300: 1002:9442
> kagou@agape:~$
>

@Nicholas: To whom are you addressing your question?

If it's to me, then the answer is no, because I'm not the package maintainer.

- Christian

Still present in 20090312 daily live 32-bit.

Since alpha-6 is due for release today, does that mean this bug's milestone release needs updating?

Bryce have uploaded 1:6.11.0+git20090310.945ccbbd-0ubuntu1 Snapshot from git taken 2009-03-10
 waiting for a new daily iso to confirm bug fixed. Thanks Bryce

Wonderful! Which daily should contain the fix: 13 March, or 14 March?

On Fri, Mar 13, 2009 at 1:21 AM, Patrice Vetsel <email address hidden> wrote:
> Bryce have uploaded 1:6.11.0+git20090310.945ccbbd-0ubuntu1 Snapshot from git taken 2009-03-10
>  waiting for a new daily iso to confirm bug fixed. Thanks Bryce
>
> --
> [RV770 HD 4850] ATI Radeon HD 4850 not supported - white screen and system freeze
> https://bugs.launchpad.net/bugs/325394
> You received this bug notification because you are a direct subscriber
> of the bug.
>

@Christian : it's in 13 March daily iso ;)

@Patrice: Okay, thanks. Then I'm sad to report that this has not fixed my bug.

The system isn't truly frozen: When I ran today's (13 March's) live CD, I still get the white screen of death. However, I can switch VTs to get a console.

Should I supply a new batch of lcpci and log files to this bug report?

I confirm that the last version 1:6.11.0+git20090310.945ccbbd-0ubuntu1 fix my bug.

Changed in xserver-xorg-video-ati:
status: Triaged → Fix Released

Sounds like we have two bugs that have the same presentation bug different pathologies.

How should we handle this? Un-mark my original bug report as a duplicate of this one?

@Christian : Un-mark my original bug report as a duplicate of this one?

Sound to be a good idea.

Okay. So if someone wants to either direct me to a different bug # for my version of this problem, or have me open a new bug, just let me know.

I guess in the worst-case scenario I can wait for the proprietary Catalyst driver to be ready, which I'm guessing will be mid-April. I was just really hoping to help with the alpha/beta testing of 9.04.

My problem is fixed in 20090314. I have no graphics problems whatsoever at this point. Thanks to everyone who helped fix it.

Bryce Harrington (bryce) wrote :

Glad to hear my git snapshots fixed the issue.

Fwiw, I've uploaded the final 6.12.0 today. I re-tested this on an hd4850 but did not find the whitescreen issue gone.

Can you two please update to today's latest (with -ati 6.12.0) and verify the white issue is still gone? If it has regressed please re-open this bug so I can explore further.

I also have a new -fglrx 8.60 which I've tested on the same card, and found it works great.

> Fwiw, I've uploaded the final 6.12.0 today.  I re-tested this on an
> hd4850 but did not find the whitescreen issue gone.
>
> Can you two please update to today's latest (with -ati 6.12.0) and
> verify the white issue is still gone?  If it has regressed please re-
> open this bug so I can explore further.

I've just updated, and the issue remains fixed for me.

>
> I also have a new -fglrx 8.60 which I've tested on the same card, and
> found it works great.

Isn't fglrx our packaging of the ATI Catalyst driver? If so, how can
that work? I thought that hadn't yet released a Catalyst that's
compatible with Xserver 1.6?

> Isn't fglrx our packaging of the ATI Catalyst driver? If so, how can
> that work? I thought that hadn't yet released a Catalyst that's
> compatible with Xserver 1.6?

Indeed...

And what's the difference between fglrx 8.60 and official ATI catalyst 9.2 (difference of version numbers) ?

Bryce Harrington (bryce) wrote :

You can assume I get testing stuff before the general public.

Show off ;)

So are you saying that if I install the fglrx package, using just
Feisty's default repositories, I'll get a testing version driver to
which you're referring?

On Tue, Mar 17, 2009 at 2:25 PM, Bryce Harrington
<email address hidden> wrote:
> You can assume I get testing stuff before the general public.
>
> --
> [RV770 HD 4850] ATI Radeon HD 4850 not supported - white screen and system freeze
> https://bugs.launchpad.net/bugs/325394
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Please pretend that I'm not an idiot in the previous post, and that I said "Jaunty's repositories", not "Feisty's repositories".

Bryce Harrington (bryce) wrote :

> So are you saying that if I install the fglrx package, using just
> Jaunty's default repositories, I'll get a testing version driver to
> which you're referring?

Yes. Unless you are comfortable manually configuring -nvidia in xorg.conf, you may want to wait until the driver appears in Hardware Drivers, since that takes care of configuring it for your hw. Otherwise you need to know about setting DefaultDepth to 24, yada yada...

Thanks. I just installed it, ran aticonfig, and it ran great for me.
Thanks for sharing it.

- C

On Thu, Mar 19, 2009 at 2:24 PM, Bryce Harrington
<email address hidden> wrote:
>> So are you saying that if I install the fglrx package, using just
>> Jaunty's default repositories, I'll get a testing version driver to
>> which you're referring?
>
> Yes.  Unless you are comfortable manually configuring -nvidia in
> xorg.conf, you may want to wait until the driver appears in Hardware
> Drivers, since that takes care of configuring it for your hw.  Otherwise
> you need to know about setting DefaultDepth to 24, yada yada...
>
> --
> [RV770 HD 4850] ATI Radeon HD 4850 not supported - white screen and system freeze
> https://bugs.launchpad.net/bugs/325394
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Luiz (luiz-stormwalker) wrote :

I had this probleman with my Radeon 4850.. I tried everything to fix it ... I got thsi out of range thing .. now I found this "fix packege"
BUt I'm new on linux.....
can someone explain to me how to install this pack??
where do I put this "man" "SRC" folder ??? and the files ???

tags: added: iso-testing
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Changed in xserver-xorg-driver-ati:
importance: High → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.