Ubuntu

[HD3470 + HD3200] Dual cards prevents X from starting / black screen

Reported by Evertjan Garretsen on 2008-12-27
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
High
Unassigned
xserver-xorg-video-radeonhd (Ubuntu)
Undecided
Unassigned

Bug Description

[Problem]
X gets confused by the presence of two primary graphics devices, resulting in "no screens found" and X exiting.

[Original Report]
The specs:
Asus x56tr Notebook
AMD TURION X2 64
ATI 3200 & ATI HD3470
RAM 4GB

I can install Intrepid Ibex, but my graphics cards don't work in Intrepid.

Installing Ubuntu only works with the extra boot options acpi=off or MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server tried to start but failed. I also cannot switch to terminal using crtl-alt F1, because X keeps trying. sometimes i get the errormessage: no screens found. I tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers. Nothing worked, then after hours of mindbreaking i installed Hardy Heron, IT worked! Installed the restricted drivers and the screen looks nice. No sound though and no wireless.

How can i get Intrepid Ibex to work? I read somewhere that xorg 7.4 could be the problem or the 4GB of RAM. Don't know how to fix this though. Latest versions of Mandriva and OpenSuse also do not run from livecd or install and suse complains about the graphic card.
[lspci]
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
     Subsystem: ASUSTeK Computer Inc. Device [1043:11e7]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612]
     Subsystem: ASUSTeK Computer Inc. Device [1043:1062]
02:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
     Subsystem: ASUSTeK Computer Inc. Device [1043:1875]

I've noticed that on x86 things seem to work just fine:

http://launchpadlibrarian.net/18858927/XorgLog.txt

and all the non-working logs are from x86_64-systems.

So, is this another example of 64bit-unsafeness?

bah, no.. this is a log from a normal i686 installation:

http://launchpadlibrarian.net/18813910/Xorg.0.log

 Asus x56tr

The specs:
AMD TURION X2 64
ATI 3200 & ATI HD3470
RAM 4GB

I can install Intrepid Ibes, but my graphics cards don't work in Intrepid.

Installing Ubuntu only works with the extra boot options acpi=off or MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server tried to start but failed. I also cannot switch to terminal using crtl-alt F1, because X keeps trying. I tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers. Nothing worked, then after hours of mindbreaking i installed Hardy Heron, IT worked! Installed the restricted drivers and the screen looks nice. No sound though and no wireless.

How can i get Intrepid Ibex to work? I read somewhere that xorg 7.4 could be the problem or the 4GB of RAM. Don't know how to fix this thoud. Latest versions of Mandriva and OpenSuse also do not run from livecd or install and suse complains about the graphic card.

description: updated
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Please decide for a driver and file a this bug against it (e.g. radeonhd). Then attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? Please also attach the /var/log/Xorg.0.log from this attempt. Thanks in advance.

Evertjan Garretsen (egarretsen) wrote :

This is the xorg.0.log from the first boot afther installation.

Evertjan Garretsen (egarretsen) wrote :

The previous xorg.0.log is from the first boot after intallation (empty xorg.conf).
This one is from after configuration of the xorg.conf using settings i got from mandriva. Mandriva 2009 has an text-based problem solver when x doesn't start up, i used this to get Mandriva running. Mandriva 2009 downloaded some drivers for my card and after this i was able to use madriva. The only thing i changed in the xorg.conf file is the first device entry. This was set to fglrx in Mandriva, for ubuntu i changed this to Radeonhd. see my xorg.conf and xorg.0.log

Evertjan Garretsen (egarretsen) wrote :

It would be nice if ubuntu also would have an text-based troubleshoot program in case X won't start. This is much more user-friendly then just a console-promt. :-) I hope this info helps the developers.

goto (gotolaunchpad) wrote :

Setting to 'Confirmed' because I cannot set it to 'Triaged'. A developer can look at this now. Thanks for helping to make Ubuntu better.

Changed in xorg:
status: Incomplete → Confirmed

*** Bug 18839 has been marked as a duplicate of this bug. ***

One request though:
I suspect that the problem is, that more than one graphics chip is available.
Could you please attach the file to this report, which gets created if you run the following command:
sudo lspci -vvnn > lspci-vvnn.log (those are 2 v's not a w)

Thanks!

i've attached 5 files:

- Mandriva 2009 xorg.conf
- Mandriva 2009 xorg.0.log
- Ubuntu Jaunty xorg.conf
- Ubuntu Jaunty xorg.0.conf
- Ubuntu Jaunty lspci -vvnn

Mandriva is up and running nicely, i can't get Intrepid or Jaunty to work, hardy worked, but wireless was troublesome.
In both Mandriva and Jaunty sound is not working, only when a headphone is plugged in, but the internal speakers of my laptop are not producing any sound, but i guess it's better to wait for a sollution to this bug and then report the sound problems, or?

Just one more comment, sometimes i get the gnome environment with jaunty and intrepid using the radeon driver, but no mouse function, and no keyboard function. Also i takes a very very long time for the gnome menu to come about 2 minutes, first i get a black screen with blinking cursor, then after 1 minute i see the screen i get immediately after bootup (the manufacturer bios screen), disrupted though, then it get black again and then after some time slowly the gnome menu comes, but only when i start x from the console (using startx). on a fresh startup it always fails.

Hope this will give you more insight.

goto (gotolaunchpad) wrote :

Thanks for providing these files. Could you disable the second card in your BIOS and report if it works then?
Thanks again.

Changed in xorg:
status: Confirmed → Incomplete
goto (gotolaunchpad) wrote :

Mandriva works, because you use there fglrx (the closed source driver from amd/ati).
I think it is a good idea to report this bug upstream, but I don't know exactly where.

Timo Aaltonen (tjaalton) on 2009-01-02
Changed in xorg:
importance: Undecided → High

I'm sorry there is no option to disable graphic-cards in my bios (which is the latest version V207), it's a very compact bios. I tried to install the closed source driver from AMD/ATI on ubuntu but couldn't get it to work. The first time i booted mandrive from harddisk, it said that X couldn't be started, Mandriva then comes with a tool to install drivers, Mandriva downloaded some driver and then i could change some settings about my hardware configuration and press test. After some configuration it succeeded. It would be nice if Ubuntu came with a utility like this, so you never end up with a blinking cursor in the shell.

Like mlindeboom said in his bug report Bug #312924 My laptop came with 4GB of RAM, i physically removed 2GB, because i read so on a forum. Before this i wasn't even able to install Mandriva on my laptop. After this (using only 2GB) i could. In my case the VESA driver doesn't work, also the VGA driver fails. Only radeon sometimes worked but after waiting for 2 minutes, no mouse support / touchpad support.

! There is also a bug in the grub menu, ubuntu doesn't register my windows partition correctly. It places an entry with windows Vista / Longhorn with partition (0,0), this should be (0,1). Mandriva's grub boot loader install this correctly. (0,0) is my recovery partition.

Timo Aaltonen (tjaalton) wrote :

there's a new driver version in the archive, please test it.

Please tell me how to find it and if complex how to install it.

Hoi Timo,

ik neem aan dat je nederlands spreekt. Kun je me vertellen, waar ik die
driver kan vinden? Ik weet niet wat je met archief bedoelt, is het
lastig om te installeren?

MVG,

Evertjan
On Fri, 2009-01-02 at 13:19 +0000, Timo Aaltonen wrote:
> there's a new driver version in the archive, please test it.
>

It's in jaunty, so the next daily livecd should have it, or if you have jaunty installed just upgrade the packages.

i've updated and upgraded the packages, but there were only 2 files available. After that i did an apt-get dist-upgrade so i know have the development branche installed, problem still exists in development branch, tried the radeon driver and ati. In fact it's even worse, i only get a blink cursor forever. I've attachted the xorg.0.log from the development branche.

Bryce Harrington (bryce) wrote :

Does it make a difference if you remove the secondary video card? Doing so could prove or disprove the hypothesis in comment #7.

Fwiw, I've a system with an ATI card and onboard Intel graphics, and also am seeing X fail to start up in Jaunty, and screen corruption when vt switching. However, this configuration worked properly in Intrepid, so it may be a separate bug. (Also, I don't see the same warning about multiple primary devices in the log file.)

Regarding the other bugs, please take care to limit one bug report per issue.

Changed in xserver-xorg-video-ati:
status: Incomplete → Triaged
Timo Aaltonen (tjaalton) wrote :

Evertjan: looks like you don't have the latest driver installed. What does 'apt-cache policy xserver-xorg-video-ati' show?

Hi Bryce,

i cannot remove one of my video-cards, because by doing this i would void my warranty, for i had to dismantle my whole laptop. The BIOS doesn't have a disable function. I only know that it should be possible even with two video-cards, i was able to run hardy using the restricted drivers manager. Mandriva downloaded some sort of a driver, i don't know which one. is there a way to see or can you see iti from the xorg file from mandriva?

@ Timo: I've included the results for the command apt-cache policy xserver-xorg-video-ati.

Timo Aaltonen (tjaalton) wrote :

Could you try building the driver without patch 104 (comment it out from debian/patches/series, then run 'dpkg-buildpackage -b', and if needed, 'apt-get build-dep xserver-xorg-video-ati' before that)?

Timo Aaltonen (tjaalton) wrote :

actually, there was a new package uploaded without that patch, so try it once it's available.

Bryce Harrington (bryce) wrote :

Timo, he's using Intrepid so probably doesn't have patch 104.

Btw, the problem I reported in comment #23 ended up being an unrelated bug.

What should i do next? I haven't got any experience with patches in Ubuntu, how to build a driver without path 104. I am using Jaunty now, i updated the system to the developers branch. Please link to instructions on how to build driver and which driver should i build. xserver-xorg-video-ati i assume? I have some terminal knowledge but not so much knowledge of the structure of ubuntu, i don't know wher to find debian/patches/series for example. Thank you.

Timo Aaltonen (tjaalton) wrote :

Like I said, just make sure you have the latest version (6.9.0.91-1ubuntu4) installed, no need to build it yourself.

.I don't get it anymore, i tried to download the driver 6.9.0.91-1ubuntu4 it is only available as a source package, i had to search google for it to find it on the site of Bryce Harrington. I get errors when i make this file after a succesfull ./configure.
I've attahed the errors i get.

I'm not (yet) an expert in linux please tell me how to make sure i use the 6.9.0.91-1ubuntu4 driver?

Bryce Harrington (bryce) wrote :

You can get debs of 6.9.0.91-1ubuntu4 from http://archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-ati/

However like Timo says, if you're running Jaunty you ought to be able to just do a regular update to get it. System -> Admin -> Update Manager; Check; Install Updates. Verify your version by running 'dpkg -l xserver-xorg-video-ati'.

Changed in xserver-xorg-video-ati:
status: Triaged → Incomplete

..@ Bryce, i've checked the version of xserver-xorg-video-ati and it's 6.0.0.91-1ubuntu4. When i use the ati driver in xorg.conf i just get a blinking cursor. I've attached the current xorg.0.log and xorg.conf (made using X -configure).

mlindeblom (lindeblm) wrote :

I have success with the current radeon driver in jaunty alpha 2 provided I manually add BusID and the HPD option to xorg.conf. I am currently using 4GB memory.

 mur@ubuntu2:~$ xrandr -q
Screen 0: minimum 320 x 200, current 2304 x 1024, maximum 2704 x 1050
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 228mm
   1024x768 60.0*+ 75.0 70.1 60.0*
   800x600 72.2 75.0 60.3
   640x480 75.0 72.8 59.9
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1280x1024+1024+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x1024 59.9*+ 60.0
   1600x1024 60.2
   1440x900 59.9
   1280x960 60.0
   1360x768 59.8
   1152x864 60.0
   1024x768 60.0 59.9
   800x600 60.3
   640x480 59.9

goto (gotolaunchpad) wrote :

Thanks, that's interesting! I think this is a bug "in the graphics card".The drivers have to work around this. Could you please open an upsteam bug report, in order to go sure that it gets fixed in the driver?

Unfortunately there are two drivers for your graphics chip.
On driver is called radeon, the other one is called "radeonhd". Please test also with that driver, which of the options is needed, as described here:
http://www.x.org/wiki/radeonhd
(in section "10.5. My monitor isn't detected").

Here you can create a new bug report upstream (You have to register there first, though) :
https://bugs.freedesktop.org/enter_bug.cgi?product=xorg

Select "Component" : "Driver/Radeon"

And in a second bug : "Driver/radonhd"

Describe the bug and the option, you had to choose. You can also link to this page.

If you have any questions, fell free to ask.

Thanks for making Ubuntu (and linux in general) better!

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Changed in xserver-xorg-video-radeonhd:
status: New → Confirmed
goto (gotolaunchpad) wrote :

Evertjan Garretsen: For you grub problem, please open another bug report.

Could you please test, if setting HDP as described by mlindeblom works for you, too? Also for both drivers, please!

Thanks so much in advance!

I've tried to use Option "HPD" "swap" and Option "HPD" "off", with both the radeon and radeonhd drivers for both devices. When using radeon with this option i get an endless blinking cursor. When i use radeonHD i get the message "no screens found
ddxSigGiveUp: closing log
xinit: No such file or directory (errno 2):
xinit: No such process (errno 3): server error

I will report an bug upstream (don't know what this means though :-) )

Thank you for your information.

For your information: I've also tried to see if the screen output goes to the HDMI port, but when i connect a HD TV to HDMI the screen stays black on the HD TV and a blinking cursor on my laptop display. ISo Jaunty's xserver wont start, I ha've tried Mandriva too and using Mandriva both the laptop-display and the TV screen work.

goto (gotolaunchpad) wrote :

Okay, thanks for testing. Reporting the bug upsteam is a very good idea, please let us know the link to the bug here.

Unfortunately it seems that it is not a simple broken connector table thing, which could be worked around with the HDP option.

The bug-id is: 19513 and can be found by clicking:

https://bugs.freedesktop.org/show_bug.cgi?id=19513

I hope they are able to solve my problem, thanks sofar.

I'm seeing the same "(EE) No device detected" error on an x86_64 with 2 NVIDIA cards -- one on mobo, one on pci.

I'm using a source-built 'nvidia' driver (v180.22).

In my case, setting the BusID, apparently, DOES NOT work.

I've previously posted the details, including logs, on nvnews (nvidia) forum @

 http://www.nvnews.net/vbulletin/showpost.php?p=1900659&postcount=1

@goto I've added the attachments they need. Thank you for your interest in this bug.

goto (gotolaunchpad) wrote :

Yes, thanks. I saw that. I took a look at the log file, you uploaded there:

(WW) Warning, couldn't open module fgl.renamed.libdri
(II) UnloadModule: "fgl.renamed.libdri"
(EE) Failed to load module "fgl.renamed.libdri" (module does not exist, 0)
(II) LoadModule: "radeonhd"
(WW) Warning, couldn't open module radeonhd
(II) UnloadModule: "radeonhd"
(EE) Failed to load module "radeonhd" (module does not exist, 0)
(EE) No drivers available.

Sure that the radeonhd driver is installed in that case? If not install it with a 'sudo apt-get install xserver-xorg-video-radeonhd'. If you want to compile from the source this link is helpful: https://help.ubuntu.com/community/RadeonHD
You could also try a minimal xorg.conf, which only contains the following:

Section "Device"
 Identifier "Configured Video Device"
 Driver "radeonhd"
EndSection

@goto: When trying to install xserver-xorg-video-radeonhd i get the following error message:
xserver-xorg-video-radenhd: Depends: xserver-xorg-core (>= 2:1.4.99.906-2ubuntu2) but is not going to be installed E: Broken packages

i tried sudo apt-get install xserver-xorg-core, but it said it was already the latest version. Will try update upgrade now and then again will try to install. Will also try sudo apt-cache policy xserver-xorg-core.

I've updated and upgraded jaunty developer branch.
xserver-xorg-core is newer than requested, but i still get the same error mentioned in my previous comment.

sudo apt-cache policy xserver-xorg-core:
xserver-xorg-core:
  Installed: 2:1.5.99.3-0ubuntu4
  Candidate: 2:1.5.99.3-0ubuntu4
  Version table:
 *** 2:1.5.99.3-0ubuntu4 0
        500 http://nl.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Tormod Volden (tormodvolden) wrote :

fgl.renamed.libdri? This sounds like some fglrx (the proprietary driver from ATI) cruft. Make sure you uninstall it correctly before running radeon or radeonhd (the open-source drivers).

Bryce Harrington (bryce) on 2009-01-17
description: updated
goto (gotolaunchpad) wrote :

Evertjan Garretsen:
I suggest you to install a stable distribution like Ubuntu Intrepid. With that you can go sure, that the problem is in the radeonhd driver. Be sure that you do not install fglrx/catalyst. Now please install the radeonhd driver, create the minimal xorg.conf, select the radeonhd driver and start x with logverbose 7 and provide the log. :)

mlindeblom (lindeblm) wrote :

I just installed a fresh copy of Jaunty Alpha 3 using ext4.

All install attempts stopped with "PANIC:early exception ... " until I removed the HD3450.

After getting the system built from scratch without the HD3450, I re-installed the HD3450 and my previous xorg.conf.

System works OK as before.

goto (gotolaunchpad) wrote :

mlindeblom:
Could you install the radeonhd driver and try to use that one? Does this work, too?
Thanks!

Download full text (3.4 KiB)

> mlindeblom:
> Could you install the radeonhd driver and try to use that one? Does this work, too?
> Thanks!
>

mur@ubuntu2:~$ uname -a
Linux ubuntu2 2.6.28-4-generic #11-Ubuntu SMP Fri Jan 16 21:50:52 UTC 2009 x86_64 GNU/Linux

mur@ubuntu2:~$ xrandr --output DVI-I_2/analog --right-of VGA_1

mur@ubuntu2:~$ xrandr -q

Screen 0: minimum 320 x 200, current 2304 x 864, maximum 2704 x 1050
VGA_1 connected 1152x864+0+0 0mm x 0mm
   1152x864 75.0*+ 75.0 70.0 60.0
   1680x1050 60.0
   1600x1024 60.2
   1400x1050 60.0
   1280x1024 60.0
   1440x900 59.9
   1280x960 60.0
   1360x768 59.8
   1024x768 85.0 75.0 70.1 60.0 43.5
   832x624 74.6
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1
DVI-D_1 connected 1152x864+1152+0 0mm x 0mm
   1152x864 60.0*+
   1360x768 59.8
   1024x768 60.0
   800x600 60.3
   640x480 59.9
DVI-I_2/digital disconnected
DVI-I_2/analog connected 1152x864+1152+0 0mm x 0mm
   1152x864 60.0*+
   1360x768 59.8
   1024x768 60.0
   800x600 60.3
   640x480 59.9

>
> From: goto <email address hidden>
> Date: 2009/01/17 Sat PM 03:56:56 CST
> To: <email address hidden>
> Subject: [Bug 311748] Re: [HD3470 + HD3200] Dual cards prevents X from
> starting / black screen
>
> --
> [HD3470 + HD3200] Dual cards prevents X from starting / black screen
> https://bugs.launchpad.net/bugs/311748
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in X.org XServer - ATI gfx chipset driver: Unknown
> Status in ?xserver-xorg-video-ati? source package in Ubuntu: Confirmed
> Status in ?xserver-xorg-video-radeonhd? source package in Ubuntu: Confirmed
>
> Bug description:
> The specs:
> Asus x56tr Notebook
> AMD TURION X2 64
> ATI 3200 & ATI HD3470
> RAM 4GB
>
> I can install Intrepid Ibex, but my graphics cards don't work in Intrepid.
>
> Installing Ubuntu only works with the extra boot options acpi=off or MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server tried to start but failed. I also cannot switch to terminal using crtl-alt F1, because X keeps trying. sometimes i get the errormessage: no screens found. I tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers. Nothing worked, then after hours of mindbreaking i installed Hardy Heron, IT worked! Installed the restricted drivers and the screen looks nice. No sound though and no wireless.
>
> How can i get Intrepid Ibex to work? I read somewhere that xorg 7.4 could be the problem or the 4GB of RAM. Don't know how to fix this though. Latest versions of Mandriva and OpenSuse also do not run from livecd or install and suse complains about the graphic card.
> [lspci]
> 00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
> Subsystem: ASUSTeK Computer Inc. Device [1043:11e7]
> 01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/R...

Read more...

goto (gotolaunchpad) wrote :

mlindeblom:
Thanks for the testing. So radeonhd works with two cards (And the card, which should be used set manually by pci id).
I saw in your xorg.conf, that you used the option "HPD" "off". Is this necessary? If yes, does an Option "HPD" "swap" work also? You know that this should only be a temporal workaround, until the table in the driver gets updated and you don't need this option any more [1]. Please report the bug upstream, as I described above, if the option is necessary. Also I can do that for you, if you don't want to do that.

Thanks!

[1] http://www.x.org/wiki/radeonhd
     Section "10.5. My monitor isn't detected"

Download full text (3.5 KiB)

>I saw in your xorg.conf, that you used the option "HPD" "off". Is this
>necessary?

No - It is only required to control the second monitor. The options vary with
radeon versus radeonhd.

A secondary problem is sound card configuration. In my case, the motherboard
ALC883 is not configured.

Based on my research, I think this will be solved by udev rules. I say this
because different alsa options result in different video setups for the
secondary monitor. In one configuration I used xrandr --auto --- worked
perfectly. Now I have to use specific xrandr commands to get the desired
results. The radeon or radeonhd driver produce the same results.

I believe the only common link is the udev rules.

> From: goto <email address hidden>
> Date: 2009/01/18 Sun PM 01:35:22 CST
> To: <email address hidden>
> Subject: [Bug 311748] Re: [HD3470 + HD3200] Dual cards prevents X from
> starting / black screen
>
> mlindeblom:
> Thanks for the testing. So radeonhd works with two cards (And the card, which
should be used set manually by pci id).
> I saw in your xorg.conf, that you used the option "HPD" "off". Is this
necessary? If yes, does an Option "HPD" "swap" work also? You know that this
should only be a temporal workaround, until the table in the driver gets
updated and you don't need this option any more [1]. Please report the bug
upstream, as I described above, if the option is necessary. Also I can do that
for you, if you don't want to do that.
>
> Thanks!
>
> [1] http://www.x.org/wiki/radeonhd
> Section "10.5. My monitor isn't detected"
>
> --
> [HD3470 + HD3200] Dual cards prevents X from starting / black screen
> https://bugs.launchpad.net/bugs/311748
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in X.org XServer - ATI gfx chipset driver: Unknown
> Status in ?xserver-xorg-video-ati? source package in Ubuntu: Confirmed
> Status in ?xserver-xorg-video-radeonhd? source package in Ubuntu: Confirmed
>
> Bug description:
> The specs:
> Asus x56tr Notebook
> AMD TURION X2 64
> ATI 3200 & ATI HD3470
> RAM 4GB
>
> I can install Intrepid Ibex, but my graphics cards don't work in Intrepid.
>
> Installing Ubuntu only works with the extra boot options acpi=off or
MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server
tried to start but failed. I also cannot switch to terminal using crtl-alt F1,
because X keeps trying. sometimes i get the errormessage: no screens found. I
tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers.
Nothing worked, then after hours of mindbreaking i installed Hardy Heron, IT
worked! Installed the restricted drivers and the screen looks nice. No sound
though and no wireless.
>
> How can i get Intrepid Ibex to work? I read somewhere that xorg 7.4 could be
the problem or the 4GB of RAM. Don't know how to fix this though. Latest
versions of Mandriva and OpenSuse also do not run from livecd or install and
suse complains about the graphic card.
> [lspci]
> 00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge
[1022:9600]
> Subsystem: ASUSTeK Computer Inc. Device [10...

Read more...

I've tried installing Intrepid Ibex, using two methods:
live-cd boot => first i get the boot screen, stops with blinking cursor and then a prompt (Xserver-xorg-video-radeonhd was not available in prompt)
install option: first i get the boot screen then the blinking cursor, then a prompt. (xserver-xorg-video-radeonhd was not available in prompt)

I also have sound problems, but i will focus on my screen problems first.

Both methods require me to set acpi =off. Otherwise they will stop immedeately.

I'm now downloading the alternate installer. Hopes this will work. This is a big bug, not being able to install at all imho.
In hardy i was able to use live-cd with acpi=off settings, and could do a graphic install. Intrepid must be installed in text mode. Or using hardy install and then update.

goto (gotolaunchpad) wrote :

Evertjan: This seems to be the kernel bug report regarding your acpi problem:
http://bugzilla.kernel.org/show_bug.cgi?id=11541
Sorry, that you have so many linux problems at once. :(

I'm really interested in the radeonhd log :D

Hi Goto,

I've installed ubuntu Intrepid on a formatted partition with alternate cd. The system doesn't the xserver, i get a command prompt. After the clean install i only installed the radeonhd driver, which was not installed automatically. After this i used the minimal xorg.conf. Result: no screens found. I've attached the xorg.conf and the Xorg.0.log.

Yes goto i have some linux problems, screen, audio, asus keys not working. I don't know if the acpi problem is the same as in http://bugzilla.kernel.org/show_bug.cgi?id=11541. In my case, after making the selection in the install menu, the installation wants to start, but it immediately stopt with a blinking cursor. Hope these new files will help. Should i post a new message on freedesktop? Please tell me when to do so.

goto (gotolaunchpad) wrote :

Yeah, now we get a right xorg.0.log, very good. :)
Now just start the xserver with
startx -- -logverbose 7
when you get to the command prompt. And then upload the new xorg.0.log in the bugzilla bugtracker (and you can mark to old ones as obsolete, if this is possible). This log file will contain the necessary information. Thanks! :)

I've marked the previous attachments as obsolete And added the new files to freedesktop. Now we have to wait and see. Thank you.

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

radeontool in Jaunty* can be used to assist in debugging this issue. After installing it, you run it like this:

    radeontool regmatch '*' > regdump_good.txt
    radeontool regmatch '*' > regdump_broke.txt

Run it two times. Once when you have a working screen (for any driver), and once in the broken case (either from the tty console or logged into the sick box remotely). Attach both of those to this bug report, and we can then forward this issue upstream. Thanks ahead of time!

For more info see https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen

[* Note: radeontool is available in earlier versions of Ubuntu but is too old; if you need to run it on an older version of Ubuntu, you can obtain and build it from the upstream git tree at http://cgit.freedesktop.org/~airlied/radeontool/]

Bryce Harrington (bryce) wrote :

Let's focus on the -ati aspect of this bug.

Actually I suspect this to be an xserver bug (maybe #139990). It is also possible that with GEM/DRI2/etc. this will be resolved. But certainly worth tracking for now.

Changed in xserver-xorg-video-radeonhd:
status: Confirmed → Invalid
Changed in xserver-xorg-video-ati:
status: Confirmed → Triaged
Download full text (3.5 KiB)

Using days update of Jaunty Alpha 3, I commented out Driver, BusID & Option HPD "off from /etc/X11/xorg.conf, then rebooted.
Radeon driver loaded and 2nd monitor not seen

mur@ubuntu2:~$ xrandr
Screen 0: minimum 320 x 200, current 1152 x 864, maximum 2704 x 1050
VGA-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1152x864 75.0*+ 75.0 70.0 60.0 60.0
   1680x1050 60.0
   1600x1024 60.2
   1400x1050 60.0
   1280x1024 60.0
   1440x900 59.9
   1280x960 60.0
   1360x768 59.8
   1024x768 85.0 75.0 70.1 60.0 59.9
   832x624 74.6
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)

Progress !!!
>
> From: Bryce Harrington <email address hidden>
> Date: 2009/01/30 Fri PM 06:38:21 CST
> To: <email address hidden>
> Subject: [Bug 311748] Re: [HD3470 + HD3200] Dual cards prevents X from
> starting / black screen
>
> Let's focus on the -ati aspect of this bug.
>
> Actually I suspect this to be an xserver bug (maybe #139990). It is
> also possible that with GEM/DRI2/etc. this will be resolved. But
> certainly worth tracking for now.
>
> ** Changed in: xserver-xorg-video-radeonhd (Ubuntu)
> Status: Confirmed => Invalid
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: Confirmed => Triaged
>
> --
> [HD3470 + HD3200] Dual cards prevents X from starting / black screen
> https://bugs.launchpad.net/bugs/311748
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in X.org XServer - ATI gfx chipset driver: Confirmed
> Status in ?xserver-xorg-video-ati? source package in Ubuntu: Triaged
> Status in ?xserver-xorg-video-radeonhd? source package in Ubuntu: Invalid
>
> Bug description:
> The specs:
> Asus x56tr Notebook
> AMD TURION X2 64
> ATI 3200 & ATI HD3470
> RAM 4GB
>
> I can install Intrepid Ibex, but my graphics cards don't work in Intrepid.
>
> Installing Ubuntu only works with the extra boot options acpi=off or MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server tried to start but failed. I also cannot switch to terminal using crtl-alt F1, because X keeps trying. sometimes i get the errormessage: no screens found. I tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers. Nothing worked, then after hours of mindbreaking i installed Hardy Heron, IT worked! Installed the restricted drivers and the screen looks nice. No sound though and no wireless.
>
> How can i get Intrepid Ibex to work? I read somewhere that xorg 7.4 could be the problem or the 4GB of RAM. Don't know how to fix this though. Latest versions of Mandriva and OpenSuse also do not run from livecd or install and suse complains about the graphic card.
> [lspci]
> 00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
> Subsystem: A...

Read more...

@ Bryce:
i've tried using radeon driver and use:
 radeontool regmatch '*' > regdump_good.txt
    radeontool regmatch '*' > regdump_broke.txt

When using the radeon driver i get no screens found in both cases.

I have exactly the same with jaunty i386

mlindeblom (lindeblm) wrote :
Download full text (4.0 KiB)

Just did fresh install using Jaunty Alpha 4 using ext4.
It tried to use 1152x864 on my 1024x768 screen. I went back to live cd mode and reduced resolution. Every thing went fine from there. First boot was in 1152x864 using radeon. Edited xorg.conf to get virtual size up for second screen.

mur@ubuntu2:~$ xrandr --output VGA-0 --mode 1024x768
mur@ubuntu2:~$ xrandr --output DVI-0 --mode 1152x864
mur@ubuntu2:~$ xrandr --output DVI-0 --right-of VGA-0
mur@ubuntu2:~$ xrandr -q
Screen 0: minimum 320 x 200, current 2176 x 864, maximum 2704 x 1050
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1152x864 60.0 + 60.0
   1360x768 59.8
   1024x768 60.0* 59.9
   800x600 60.3
   640x480 59.9
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1152x864+1024+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1152x864 60.0*+ 60.0
   1360x768 59.8
   1024x768 60.0 59.9
   800x600 60.3
   640x480 59.9

Success!!!!!
>
> From: Bryce Harrington <email address hidden>
> Date: 2009/01/29 Thu AM 05:07:48 CST
> To: <email address hidden>
> Subject: [Bug 311748] Re: [HD3470 + HD3200] Dual cards prevents X from
> starting / black screen
>
> radeontool in Jaunty* can be used to assist in debugging this issue.
> After installing it, you run it like this:
>
> radeontool regmatch '*' > regdump_good.txt
> radeontool regmatch '*' > regdump_broke.txt
>
> Run it two times. Once when you have a working screen (for any driver),
> and once in the broken case (either from the tty console or logged into
> the sick box remotely). Attach both of those to this bug report, and we
> can then forward this issue upstream. Thanks ahead of time!
>
> For more info see https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen
>
> [* Note: radeontool is available in earlier versions of Ubuntu but is
> too old; if you need to run it on an older version of Ubuntu, you can
> obtain and build it from the upstream git tree at
> http://cgit.freedesktop.org/~airlied/radeontool/]
>
> --
> [HD3470 + HD3200] Dual cards prevents X from starting / black screen
> https://bugs.launchpad.net/bugs/311748
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in X.org XServer - ATI gfx chipset driver: Confirmed
> Status in ?xserver-xorg-video-ati? source package in Ubuntu: Confirmed
> Status in ?xserver-xorg-video-radeonhd? source package in Ubuntu: Confirmed
>
> Bug description:
> The specs:
> Asus x56tr Notebook
> AMD TURION X2 64
> ATI 3200 & ATI HD3470
> RAM 4GB
>
> I can install Intrepid Ibex, but my graphics cards don't work in Intrepid.
>
> Installing Ubuntu only works with the extra boot options acpi=off or MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server tried to start but failed. I also cannot switch to terminal using crtl-alt F1, because X keeps trying. sometimes i get the errormessage: no screens found. I tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers. Nothing worked, then after hours of mindbreaking i...

Read more...

Jaunty alpha 4 is not working for me. I can't even start the live-CD. I don't get it. In Hardy my screen worked, so something changed afterwards that stoppen the screen from working. If there's something is hould try, please let me know.

Bryce Harrington (bryce) on 2009-02-19
description: updated
Bryce Harrington (bryce) wrote :

Since the bug upstreamed to radeonhd seems not to be getting attention, and since we care more about the -ati aspects of this bug, I've re-upstreamed the bug to -ati as https://bugs.freedesktop.org/show_bug.cgi?id=20225

Changed in xserver-xorg-driver-ati:
status: Confirmed → Unknown
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed

*** Bug 20225 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) on 2009-02-24
Changed in xserver-xorg-driver-ati:
status: Confirmed → Unknown
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

This is definitely a dupe of 267241. I've proposed a possible patch to that bug report, so will dupe this bug to that one.

Fedora has a patch which might help here.

When I suggested the Fedora patch to our PCI/driver guys, they responded that
they'd tried similar things before in the kernel and found that they didn't work
on some platforms. The code they ended up with instead is:

http://src.opensolaris.org/source/xref/onnv/onnv-gate/usr/src/uts/i86pc/io/gfx_private/gfxp_vgatext.c#gfxp_check_for_console

let's also mention Dave's patches:
http://lkml.org/lkml/2009/3/4/6
http://lists.x.org/pipermail/xorg-devel/2009-March/000400.html

then i suppose X can use pci_device_is_boot_vga() to look for its "primary" device?

*** Bug 20878 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) wrote :

267241 has been solved via an xserver patch.

The only thing that may not be dupe-ish is that some RS780 chips need their pci id's added to the driver. I'll close this bug once that part of the issue is also solved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:6.12.1-0ubuntu2

---------------
xserver-xorg-video-ati (1:6.12.1-0ubuntu2) jaunty; urgency=low

  [Bryce Harrington]
  * Add 109_pciids_rs780.patch, 110_pciids_rs880.patch: Support for rs780
    and rs880 cards. Cherrypick from upstream.
    (LP: #311748)

  [Tormod Volden]
  * Add 105_fix_dvi_on_macmini.patch: Fix DVI output on MacMini
    Cherrypick from upstream.
    (LP: #351245)

 -- Bryce Harrington <email address hidden> Tue, 31 Mar 2009 16:27:44 -0700

Changed in xserver-xorg-video-ati:
status: Triaged → Fix Released

I confirm that all graphics work now using the cards i mentioned above, i installed the daily realease (07/02/2009). I also could install the restricted driver. So everything seems to be working just fine. Bug can be closed.

correction: i installed the daily release 07/04/2009 (not 07/02/2009) and my graphics worked. Sorry for the confusion.

This is now also fixed in Ubuntu 9.04 (using the redhat/fedora patch) and working for me on x86_64 (xserver-xorg-core: 1.6.0-0ubuntu14) with 2 x nVidia NV43 [GeForce 6600 GT].

I just tested in in Ubuntu 9.04 with the latest patched installed and it is still not working. I have two cards (AGP and PCI)

00:08.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)

and I am using NVidia card. The system fails to start with with the output in the log that no primary card found until I went to xorg.conf and manually added to the device section

BusID "PCI:0:8:0"

I have just installed Ubuntu 9.04 with the latest updates and this is still broken on my system with NVidia proprietary driver.
I have two cards

00:08.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200]
(rev b2)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200]
(rev b2)

and after I have installed the restricted driver, X doesnt start until I go to the xorg.conf and add BusID line to the device section.

dave, this all got merged to master, yeah? if so, can we close it at least for 1.7?

yup should all be in master now + libpciaccess 0.10.8 for Linux.

if this keep happening with a 1.7 server please re-open.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.