Ubuntu

All SDL apps crash in DirectFB on PPC

Reported by Leslie Viljoen on 2008-11-23
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Debian)
Fix Released
Unknown
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

This problem's first symptom is that you are completely logged out of your X session as soon as you try to run something like Tuxpaint on PPC. I have seen it on Fedora, Debian Lenny and Intrepid. Etch worked fine, probably because directfb was version 0.9.

I have stepped though Tuxpaint until an SDL init:

SDL_Init(1048625)
(Those flags are: SDL_INIT_VIDEO | SDL_INIT_TIMER | SDL_INIT_AUDO | SDL_INIT_NOPARACHUTE)

I then stepped through the SDL code until here:
DirectFB_CreateDevice (devindex=<value optimized out>) at ../../src/video/directfb/SDL_DirectFB_video.c:123

DirectFB_CreateDevice crashes. It sometimes prints the error below, but mostly
it doesn't print anything, it just terminates the session. Since it looks permissions related I have
run everything as root but that doesn't help.

---------8x-------------8x-----------8x-----------------8x---------------8x--------------------

     =======================| DirectFB 1.0.1 |=======================
          (c) 2001-2007 The DirectFB Organization (directfb.org)
          (c) 2000-2004 Convergence (integrated media) GmbH
        ------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2008-09-12 20:02)
(*) Direct/Memcpy: Using ppcasm_memcpy()
(!) DirectFB/Core: Could not initialize 'system' core!
    --> Access denied!

     =======================| DirectFB 1.0.1 |=======================
          (c) 2001-2007 The DirectFB Organization (directfb.org)
          (c) 2000-2004 Convergence (integrated media) GmbH
        ------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2008-09-12 20:02)
(*) Direct/Memcpy: Using libc memcpy()
(!) DirectFB/Core: Could not initialize 'system' core!
    --> Access denied!

Error: I could not initialize video and/or the timer!
The Simple DirectMedia Layer error that occurred was:
DirectFBCreate: Access denied!

Caroline Ford (secretlondon) wrote :

This is a bug in upstream SDL?

Leslie Viljoen (leslieviljoen) wrote :

I think the problem is lower than SDL, but I could not determine where with any certainty.
You can follow more of the discussion at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506666

Logan Rosen (logan) on 2012-09-03
affects: directfb (Debian) → xserver-xorg-video-ati (Debian)
affects: directfb (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Debian):
status: Unknown → Incomplete
bugbot (bugbot) on 2012-09-13
tags: added: crash
Changed in xserver-xorg-video-ati (Debian):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.