Ubuntu

[RV530 x1650] Black screen after updating

Reported by Francisco Blas Izquierdo Riera (klondike) on 2008-11-02
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
xserver-xorg-video-ati (Ubuntu)
High
Unassigned

Bug Description

After updating to 8.10 the Xserver wasn't unable to display anything (putting my monitor into sleep mode).

The Xorg logs don't show anything strange.
[lspci]
00:00.0 Host bridge: Intel Corporation 82975X Memory Controller Hub (rev c0)
05:00.0 VGA compatible controller: ATI Technologies Inc RV530LE [Radeon X1600/X1650 PRO]

Misteriously after probing fglrx an then falling back to radeon, the thing seemed to work. Maybe it has something to do with the PCI device identification done on this Xorg config or to a bad card initialization. I'll keep trying.

Tormod Volden (tormodvolden) wrote :

Thanks for your report. Can you please attach the log from when it works?

I have not seen all these "CailReadATIRegister" lines in a log file before.

Changed in xserver-xorg-driver-ati:
assignee: nobody → tormodvolden
status: New → Incomplete

This is the log after using fglrx then restarting the xserver (as t also fails) and then using the radeon module.

I tried not putting the BUSID option to see the problem wasn't there. Right now I think it can be an incorrect card intialization problem (as when using fglrx I see what seems a core dump when restarting kdm which makes me think the original card values aren't restored).

Changed in xserver-xorg-video-ati:
status: Incomplete → New

In case it helps, this is my Xorg.conf although when using the default conf the behavior is still the same.

Bryce Harrington (bryce) on 2008-11-04
Changed in xserver-xorg-video-ati:
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

Well, when it "works", DRI is disabled because you still have the evil fglrx module loaded. I guess you get the same success if you use radeon from the start, but with
 Option "DRI" "off"
in your Device section of xorg.conf. Can you please try it?

Tried but to no avail.

Right now I have modified my kdm so it starts the X with fglrx waits a bit for it to crash then starts with radeon, But it shouldn't be this way :(

Tormod Volden (tormodvolden) wrote :

Please attach your log from running with DRI off.

This is the log

I have noted the following differences when it not works:
Output 68 disable success
Blank CRTC 0 success
Disable CRTC 0 success
Blank CRTC 1 success
Disable CRTC 1 success
(II) RADEON(0): RADEONRestoreMemMapRegisters() :
(II) RADEON(0): MC_FB_LOCATION : 0xdfffd000 0xdfffd000
(II) RADEON(0): MC_AGP_LOCATION : 0x00000000
(II) RADEON(0): avivo_restore !
Enable CRTC 1 success
Unblank CRTC 1 success
Enable CRTC 0 success
Unblank CRTC 0 success

May it be that the Enable and Unblanl don't work properly on the driver thus making that nothing can be seen on the screen?

Tormod Volden (tormodvolden) wrote :

Can you please attach a log with "DRI" "off" like in comment #10, but after running fglrx, so that it works? I would like to see the difference between when it works and when it doesn't, without the distractions of DRI-related messages.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

Of course, here it is.

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed

And the diff betwen the logs just in case.
To the left the log when it works and to the right the log when it doesn't

Socapex_2K (philippe-groarke) wrote :

Hello, I am experiencing the same Black Screen of death problem when I install the Official ATI X1650 Pro drivers. But I was experiencing the same with 8.04. I couldn't post any logs, since I am not an advanced user, and thus I have to reboot when getting the black screen (I don't know how to access the terminal or what-not). I have read many posts on various forums of people experiencing this problem, way back to version 6 I think. I was thinking of reinstalling ubuntu, so I wouldn't mind installing the ATI drivers to help fix the bug, if I just knew how to access information you guys need, and also, how to disable/uninstall the drivers afterwards.

I am having the same problem with gOS, which is an ubuntu based distro...

Regards,
Socapex_2K

Hi,

I suppose you're using the fglrx drivers. If so, you should try using the non proprietary, radeon drivers, and opening another bug.

To get a terminal you can try pressing ctrl+alt+f1

Bryce Harrington (bryce) on 2009-01-17
description: updated
Bryce Harrington (bryce) wrote :

radeontool in Jaunty* can be used to assist in debugging this issue. After installing it, you run it like this:

    radeontool regmatch '*' > regdump_good.txt
    radeontool regmatch '*' > regdump_broke.txt

Run it two times. Once when you have a working screen (for any driver), and once in the broken case (either from the tty console or logged into the sick box remotely). Attach both of those to this bug report, and we can then forward this issue upstream. Thanks ahead of time!

For more info see https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen

[* Note: radeontool is available in earlier versions of Ubuntu but is too old; if you need to run it on an older version of Ubuntu, you can obtain and build it from the upstream git tree at http://cgit.freedesktop.org/~airlied/radeontool/]

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

Well bryce, here you have a tar.gz with the outputs. Those are the contents:

regdump_vesa.txt (using vesa which is what I'm using now and seems to work fine)
regdump_bad.txt (using radeon after vesa, fails)
regdump_good.txt (using fglrx, killing the Xserver then using radeon, seems to work fine)

All those calls to radeontool have been made using the latest git version on Intrepid. I hope you can solve it for Jaunty.

I'm sorry for taking so much time, I had tests since January.

Updated info

Changed in xserver-xorg-video-ati:
status: Incomplete → New
Bryce Harrington (bryce) on 2009-02-18
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: New → Triaged
Bryce Harrington (bryce) wrote :

Hmm, I think the whole issue here is that you still have some leftover fglrx bits that are causing conflicts.

Please see https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver and if the problem still exists after that, feel free to reopen.

Changed in xserver-xorg-video-ati:
status: Triaged → Invalid

After following the steps on the wiki and ensuring fglrx was fully uninstalled the issue remains.

Changed in xserver-xorg-video-ati:
status: Invalid → New
Bryce Harrington (bryce) on 2009-02-20
Changed in xserver-xorg-video-ati:
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Hmm, next I'd like to forward this issue upstream, but first it must be retested on latest Jaunty to make sure the issue still happens there with the latest code. ISO images are available at http://cdimages.ubuntu.com/releases/jaunty/. If you can reproduce it in the LiveCD environment, you shouldn't need to modify your installed system. Also please attach a fresh Xorg.0.log from this testing.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete

Ok I'll try to do so this weekend.

Bryce Harrington (bryce) on 2009-02-26
Changed in xserver-xorg-video-ati:
status: Incomplete → New
status: New → Incomplete

Here is the info you requested and a bit more just in case:
*Xorg.0.log the X log file
*good2.txt the output of radeontool when using vesa (works)
*bad2.txt the output of radeontool when using the radeon driver (doesn't work).

Feel free to link the bug upstream so I subscribe.

Still happens with Jaunty

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed

Created an attachment (id=23546)
Xorg.1.log from booting 8.10 (-ati 6.9.x) - failed

Forwarding this bug from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/292421

[Problem]
Black screen on X boot.

Problem is a regression that first started in Intrepid with the 6.9.x driver, and is still seen on 6.10.0 and 6.11.0.

At times, attempting an fglrx boot (which fails), and then booting -ati will make it work (log attached), but just for one boot. Included will be logs and register dumps from this case, to compare with the plain vanilla boot.

Also attempted clean boots with no fglrx bits installed, but same behavior was seen.

[lspci]
00:00.0 Host bridge: Intel Corporation 82975X Memory Controller Hub (rev c0)
05:00.0 VGA compatible controller: ATI Technologies Inc RV530LE [Radeon X1600/X1650 PRO]

[Original Report]
After updating to 8.10 the Xserver wasn't unable to display anything (putting my monitor into sleep mode).

The Xorg logs don't show anything strange.

I have noted the following differences when it not works:
Output 68 disable success
Blank CRTC 0 success
Disable CRTC 0 success
Blank CRTC 1 success
Disable CRTC 1 success
(II) RADEON(0): RADEONRestoreMemMapRegisters() :
(II) RADEON(0): MC_FB_LOCATION : 0xdfffd000 0xdfffd000
(II) RADEON(0): MC_AGP_LOCATION : 0x00000000
(II) RADEON(0): avivo_restore !
Enable CRTC 1 success
Unblank CRTC 1 success
Enable CRTC 0 success
Unblank CRTC 0 success

May it be that the Enable and Unblanl don't work properly on the driver thus making that nothing can be seen on the screen?

Created an attachment (id=23547)
Xorg.0.log - functioning, 8.10

This is the log after using fglrx then restarting the xserver (as t also fails) and then using the radeon module.

Created an attachment (id=23548)
Xorg.log.nodri

Log from attempting a boot with DRI turned off - this didn't seem to make a difference.

Created an attachment (id=23549)
Xorg.0.log - working case, nodri

And for comparison, here is the same configuration as previously, but after doing the fglrx-crash trick.

Here's the diff between the two files:

15c15
< (==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 9 15:41:12 2008
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 8 17:44:54 2008
505c505
< (II) RADEON(0): MC_FB_LOCATION : 0xdfffd000 0xcfffc000
---
> (II) RADEON(0): MC_FB_LOCATION : 0xdfffd000 0xdfffd000
634,661c634,646
< (II) RADEON(0): I2C device "VGA-0:ddc2" registered at address 0xA0.
< (II) RADEON(0): I2C device "VGA-0:ddc2" removed.
< (II) RADEON(0): Output: VGA-0, Detected Monitor Type: 0
< Dac detection success
< in RADEONProbeOutputModes
< (II) RADEON(0): Adding Screen mode: 1280x1024
< (II) RADEON(0): Adding Screen mode: 1024x768
< (II) RADEON(0): Adding Screen mode: 800x600
< (II) RADEON(0): Adding Screen mode: 640x480
< (II) RADEON(0): Total number of valid Screen mode(s) added: 4
< (II) RADEON(0): I2C device "DVI-0:ddc2" registered at address 0xA0.
< (II) RADEON(0): I2C device "DVI-0:ddc2" removed.
< (II) RADEON(0): Output: DVI-0, Detected Monitor Type: 0
< Dac detection success
< (II) RADEON(0): I2C device "VGA-0:ddc2" registered at address 0xA0.
< (II) RADEON(0): I2C device "VGA-0:ddc2" removed.
< (II) RADEON(0): Output: VGA-0, Detected Monitor Type: 0
< Dac detection success
< in RADEONProbeOutputModes
< (II) RADEON(0): Adding Screen mode: 1280x1024
< (II) RADEON(0): Adding Screen mode: 1024x768
< (II) RADEON(0): Adding Screen mode: 800x600
< (II) RADEON(0): Adding Screen mode: 640x480
< (II) RADEON(0): Total number of valid Screen mode(s) added: 4
< (II) RADEON(0): I2C device "DVI-0:ddc2" registered at address 0xA0.
< (II) RADEON(0): I2C device "DVI-0:ddc2" removed.
< (II) RADEON(0): Output: DVI-0, Detected Monitor Type: 0
< Dac detection success
---
> Output 68 disable success
> Blank CRTC 0 success
> Disable CRTC 0 success
> Blank CRTC 1 success
> Disable CRTC 1 success
> (II) RADEON(0): RADEONRestoreMemMapRegisters() :
> (II) RADEON(0): MC_FB_LOCATION : 0xdfffd000 0xdfffd000
> (II) RADEON(0): MC_AGP_LOCATION : 0x00000000
> (II) RADEON(0): avivo_restore !
> Enable CRTC 1 success
> Unblank CRTC 1 success
> Enable CRTC 0 success
> Unblank CRTC 0 success

Created an attachment (id=23550)
register dumps

regdump_vesa.txt (using vesa which is what I'm using now and seems to work fine)
regdump_bad.txt (using radeon after vesa, fails)
regdump_good.txt (using fglrx, killing the Xserver then using radeon, seems to work fine)

Created an attachment (id=23551)
Xorg.0.log - jaunty

Updated log after confirming issue is still present on Jaunty.

Created an attachment (id=23552)
register dumps with 6.11.0 - Failure case

Created an attachment (id=23553)
register dumps with 6.11.0 - Working case

Unfortunately, these dumps are from radeontool (rather than avivotool) so they aren't much use on this chip. for r1xx-r4xx use radeontool, for everything else, use avivotool. Any chance you could update the dumps?

Bryce Harrington (bryce) on 2009-03-05
Changed in xserver-xorg-video-ati:
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

klondike, ok thanks for collecting all these files, I've forwarded everything upstream (whew!) here:
https://bugs.freedesktop.org/show_bug.cgi?id=20476

Please subscribe to that bug report in case upstream has further questions or needs you to test something.

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

klondike, upstream would like to get register dumps using a different command, 'avivotool', which you should already have installed (it's part of the radeontool package). You run it like this:

    avivotool regs all > regdump_good.txt

    avivotool regs all > regdump_broke.txt

If you could, please attach the output to the upstream bug report.

I'm the original reporter. Thanks Bryce for all :)

The following are the results when executing on Intrepid with the following X.org version:
X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux KDK 2.6.27-13-generic #1 SMP Thu Feb 26 07:26:43 UTC 2009 i686
Build Date: 09 March 2009 10:48:54AM
xorg-server 2:1.5.2-2ubuntu3.1 (<email address hidden>)
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present

According to aptitude the radeon module version is 6.9.0

I can try it on jaunty or on another live distro if needed.

Those are the avivotool reports :)
avivo_bad.txt Report when using the radeon driver, screen gets blank.
avivo_good.txt Report when using the vesa driver all is ok.

Created an attachment (id=23837)
Results of sudo ./avivotool regmatch '*' with the latest git version

Created an attachment (id=23838)
Results of sudo ./avivotool regmatch '*' with the latest git version when using radeon driver

(In reply to comment #9)
>
> According to aptitude the radeon module version is 6.9.0

Is this still happening with 6.11.0 or newer?

I'm sorry bryce I was really busy this weeks with various assignments, I'm subscribing right now and sending the data :)

(In reply to comment #12)
> (In reply to comment #9)
> >
> > According to aptitude the radeon module version is 6.9.0
>
> Is this still happening with 6.11.0 or newer?

I could say yes as it happened too with jaunty, though those reports aren't from that version. I can boot into jaunty later if necessary and make new reports-

Just a side comment. Using xorg-server-1.5.3 and xf86-video-ati-6.12.1-r1 from gentoo seems to solve the issue. But I don't know if it will work with xorg-server-1.6. I'll try and report later.

Created an attachment (id=25239)
xorg.log on gentoo when it began failing again

It's odd it began failing again (on gentoo) without touching anything.

I got the following (strange) errors at dmesg:
mtrr: no MTRR for d0000000,10000000 found
mtrr: no MTRR for d0000000,1000000 found

Also I go the following xorg.log

mtrrs are enabled on kernel.

Bryce Harrington (bryce) on 2009-05-15
tags: added: black-screen

Does xf86-video-ati git master work for you?

(In reply to comment #16)
> Does xf86-video-ati git master work for you?
>

I have the same issue (Asus EAX1650XT video card, Ubuntu 9.04). I tried installing the latest version of the driver (following the instructions at http://www.x.org/wiki/radeon). The result is still the same.

When I start X, I get a blank screen, sometimes with some garbage near the top. Sometimes, I also have garbage where the mouse pointer is supposed to be. gdm plays its welcome sound, so the system is not completely locked up, but they keyboard doesn't seem to do anything anymore.

I am experiencing similar symptoms that are described in this bug. I have recently installed Fedora 11 on a machine with an X1650 XT video card.
When I try to start X with the radeon driver, I get a blank screen with only a
bit of garbage at the top. The keyboard and mouse are unresponsive, and I
have to power off the machine. I have tried disabling DRI, which results in an
equally useless display, but I get a mouse pointer, and I can kill the X
server and return to a console. I've also tried disabling kernel mode
setting, and that didn't help.

Driver version = 6.12.2-14
X Server version = 1.6.1.901-1
kernel version = 2.6.29.4-167.fc11.i686.PAE

Relevant lspci output:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon X1650 XT
(Primary) (PCIE) (rev 9a)
01:00.1 Display controller: ATI Technologies Inc Radeon X1650 XT (Secondary)
(PCIE) (rev 9a)

Please let me know if I can provide any additional information.

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid

On Ubuntu 9.10 I still have blank video (monitor off).

I tried to setup Ubuntu 9.10 in safe graphics mode and then edited xorg.conf to set ati driver in place of vesa.
It works. I only found AGP 4x mode in use in place of 8x even if I set explicitly 8x mode in xorg.conf.

After updating the driver and enabling ATOMTvOut the screens began working again.

Now the question is, why isn't it enabled when the screen is analogical and the chip requires it?

(In reply to comment #19)
> After updating the driver and enabling ATOMTvOut the screens began working
> again.
>
> Now the question is, why isn't it enabled when the screen is analogical and the
> chip requires it?
>

What are you asking? The ATOMTvOut option is only required for using tv-out. Other outputs (DVI, VGA, etc.) should work just fine without the ATOMTvOut option, if they don't then that's a bug. Or was this whole bug about tv-out not working? It's not clear from the description.

(In reply to comment #20)
> What are you asking? The ATOMTvOut option is only required for using tv-out.
> Other outputs (DVI, VGA, etc.) should work just fine without the ATOMTvOut
> option, if they don't then that's a bug.
Then it's a bug, the screen not working was a VGA monitor attached to the VGA port of the card.
> Or was this whole bug about tv-out
> not working? It's not clear from the description.
Well I have a TV attached to the S-Video output but I don't use it. The problem was the VGA monitor.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi klondike,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 292421

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 292421 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/292421

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june
Pastor (sinel1980) wrote :

I have exactly the same problem with my ATI Radeon 9000 (rv250) in Ubuntu 10.04 (default configuration).
Every time during boot up monitor gets black and turns in power save mode so i can't see anything (but system is responding - when for example i press ctrl+alt+delete and enter goes to power off).
I can only use this distribution in "recovery mode" "safe graphic vesa".
In 9.04 i have'nt this problem.

You can try this xorg.conf.

Simply backup the one at /etc/X11/xorg.conf and copy it there. If it works then post a new bug asking for a hal rule being added to solve this on your card.

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium

Is this still an issue with KMS or a newer version of the driver?

Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Bryce Harrington (bryce) on 2012-02-04
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed

I think this was fixed at some point of time but I forgot to close this bug. Even if it wasn't fixed I don't have access to the hardware anyway.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
Mörgæs (moergaes) on 2013-03-19
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.