[HD 3650] white screen before login screen

Bug #267185 reported by Martin Gerdzhev on 2008-09-06
20
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
High
Unassigned
Nominated for Hardy by logan stiner
Declined for Intrepid by Bryce Harrington

Bug Description

I just updated to Intrepid and was greeted with a completely white screen when gdm was supposed to show. The computer is still responsive and i can even log in even though i can't see anything, but the screen remains white. I can switch to console and checked the Xorg.0.log - no errors. I have an asus f8va-b1 with a Radeon Mobility HD 3650 video card. the fglrx driver doesn't work and neither does the vesa. Let me know what you need to get this fixed. Thanks.
[lspci]
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
01:00.0 VGA compatible controller: ATI Technologies Inc Mobilitiy Radeon HD 3650

I am having the same problem, with an ati hd 3200 video card.

Changed in xserver-xorg-video-ati:
status: New → Confirmed

Although for me the vesa driver does work.

Victor Van Hee (vvanhee) wrote :

I'm having the same problem with ATI Radeon HD 3650 on ASUS F8Sp notebook, except I get a white screen with intermittent horizontal dark stripes. 64 bit Intrepid, Alpha 5. Driver identified as radeon. Ctrl-Alt-F1 lets me go to command line.

Vesa 'safe mode' just crashes to command line without starting the gdm, but no white screen. Vesa seems to identify no valid resolution / frequency combos for this laptop screen.

Hardy works just fine on this computer / configuration (fglrx or vesa).

islevegan (islevegan) wrote :

I have tried Ubuntu 8.04 for 32 bit and AMD64, and every few days try the latest alpha or daily build of 8.10 for AMD64 and 32 bit...nothing has worked yet.

This is a an ASUS M51 Series M51TA-X2 NoteBook with AMD Turion X2 Ultra ZM-82(2.20GHz) 15.4" Wide XGA+ 4GB Memory 250GB HDD 5400rpm DVD Super Multi ATI Mobility Radeon HD 3650

Here is where it was purchased, with some specifications available:

http://www.newegg.com/Product/Product.aspx?Item=N82E16834220349

Here are some threads on ubuntuforums that relate to this machine:

http://ubuntuforums.org/showthread.php?t=899327

http://ubuntuforums.org/showthread.php?t=909820

http://ubuntuforums.org/showthread.php?t=897843

The display will go blank shortly after choosing to "try ubuntu without changing my computer" or trying to go into the install process from the CD or DVD (I've tried both).

I understand that this machine has *both* integrated graphics with an ATI 3200 and another graphics system based on the ATI 3650 for higher performance, when desired.

I do not know if the problem is with video drivers or support of some other elements, or a combination thereof.

We were able to do an install using virtualbox on top of Windows Vista on this very same machine. It works, but that is not an ideal setup...if anything, I would prefer the opposite or no Windows at all.

After reenabling the ati driver, I cannot longer reproduce this problem on an up-to-date intrepid system (login does seem to be very slow compared to when using the vesa driver). Martin can you try again with all the latest updates? And if you still experience this problem, can you please attach your xorg.conf, Xorg.0.log and the output of lspci here? Thanks!

Martin Gerdzhev (mgerdjev) wrote :

Yeah i just tried again with the latest intrepid updates and still no luck. Same white screen. Here are the xorg.conf, Xorg.0.log and lspci.

Martin Gerdzhev (mgerdjev) wrote :
Martin Gerdzhev (mgerdjev) wrote :
Colin Watson (cjwatson) wrote :

Bryce, you declined this for Intrepid - I was just wondering why, as you didn't leave a comment? (I'm sure it's perfectly reasonable, but it suggests you've done some analysis of this bug.)

islevegan (islevegan) wrote :

What does "Declined for Intrepid" mean, exactly?

Bryce Harrington (bryce) wrote :

Colin, given that it occurs with -vesa and -fglrx as well, it's sounding like not an -ati bug particularly, but without some deeper debug work it's uncertain what is failing. xserver maybe?

unmaugeois (unmaugeois) wrote :

I have the same problem with that configuration : ATI HD3650, intreprid ibex
I tried all drivers that exist (catalyst 8.10, 8.11, 8.12) and always the same problem, when GDM should appers, the screen stay black. I noticed that after usplash, the screen turn off (at the moment of showing GDM).
I switch to TTY1 console with crtl+alt+F1, login, and enter "exit", then the screen turn on and I can see the GDM screen, log in and everything is working properly (X server, compiz fusion, ..) I have tried to change the xorg.conf with a lot of option in all section, but nothing solved my problem

Steve Beattie (sbeattie) wrote :

This bug was reported in the Intrepid development cycle; removing regression-potential and marking as regression-release.

Bryce Harrington (bryce) on 2009-01-17
description: updated
Bryce Harrington (bryce) wrote :

I suspect this may just be a dupe of bug 272406, but the symptoms are different, so I think it should be forwarded upstream and let them make the determination.

Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Before I forward this upstream, one thing to check. You mentioned having tried with -fglrx; there is a known issue where leftover bits of fglrx can interfere with -ati and cause it to fail, with symptoms not unlike what's described in this bug report.

Can you please follow the steps at https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver, see if the issue still exists, and report your findings here?

Changed in xserver-xorg-video-ati:
status: Triaged → Incomplete
shelvingguy (shelvingguy) wrote :

I know I am jumping into the middle, but I am new to linux and I have been trying to resolve this issue for weeks on my laptop. I have tried everything I can find. I have the ATI Mobility Radeon HD 3650. No matter what driver (restricted / open / fglrx / radeon / radeonhd / radeon / ati) I try, the result is a reboot to unresponsive black screen.

If I can provide any data that would help to resolve this, please let me know. From everything I have learned, this particular card has been an unresolved problem across the board. I have seen only a couple posts where people have claimed to have it working, but I could not replicate the results.

I have a lot of time on this, and it would be great to get it running.

Thanks.

sOLARiZ (mg-solariz) wrote :

Same here,

tried to update to intrepid on the weekend and instead of gdm I only get a white screen. System is responding.

ATI 4870 very sad ;(

Bryce Harrington (bryce) wrote :

I've just uploaded the new 6.12.0 -ati to jaunty, which should fix this issue. Please test and verify.

shelvingguy (shelvingguy) wrote :

Where would I find the new driver? Is it the same version I downloaded yesterday from Tormod's PPA? If so, it did not resolve the issue. I tested it late yesterday.

So far, the only thing that has worked is removing 2GB of my RAM, which was suggested in one of the other bugs related to this issue.

If there is something new I could test, please let me know.

sOLARiZ (mg-solariz) wrote :

@shelvingguy: You can obtain it from the daily JJ builds: http://cdimage.ubuntu.com/daily/current/

@Bryce: Thanks I will confirm as soon as I got a USB stick to put the oversized image on.

sOLARiZ - I'm confused. I have been upgrading through the Upgrade Manager.
Are the JJ builds different? Do I need to reinstall the whole deal?

For a while, there seemed to be a lot of activity on this, and related,
bugs. It's died down a bit. Do you know what's up?

Thank you.

On Fri, Mar 20, 2009 at 2:59 PM, sOLARiZ <email address hidden> wrote:

> @shelvingguy: You can obtain it from the daily JJ builds:
> http://cdimage.ubuntu.com/daily/current/
>
> @Bryce: Thanks I will confirm as soon as I got a USB stick to put the
> oversized image on.
>
> --
> [HD 3650] white screen before login screen
> https://bugs.launchpad.net/bugs/267185
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-ati” source package in Ubuntu: Incomplete
>
> Bug description:
> I just updated to Intrepid and was greeted with a completely white screen
> when gdm was supposed to show. The computer is still responsive and i can
> even log in even though i can't see anything, but the screen remains white.
> I can switch to console and checked the Xorg.0.log - no errors. I have an
> asus f8va-b1 with a Radeon Mobility HD 3650 video card. the fglrx driver
> doesn't work and neither does the vesa. Let me know what you need to get
> this fixed. Thanks.
> [lspci]
> 00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory
> Controller Hub (rev 07)
> 01:00.0 VGA compatible controller: ATI Technologies Inc Mobilitiy Radeon HD
> 3650
>
>

sOLARiZ (mg-solariz) wrote :

@Bryce: I can confirm it's working. "Ubuntu jaunty (development branch), 2.6.28-11-generic, 20090319" with default ATI driver and the "white screen of death" is gone. Will now try the closed prop. driver.

thanks.

@shelvingguy: I guess the best place to get more information is the ubuntu community forums. Jaunty is still under heavy development and not marked as stable yet.

Bryce Harrington (bryce) wrote :

Thanks for confirming it's fixed. Martin, I'd love to hear confirmation from you, but if you update and find the issue still exists for some reason, you can reopen the bug report.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Fix Released
shelvingguy (shelvingguy) wrote :

I just tested it again with the full 4GB of RAM. It still boots to a black screen.

With 2GB of the RAM removed, I can boot to native resolution (1366x768) with the ati driver.

I'll attach the Xorg.0.log.

Thanks.

New shopping new life!

What are u doing these days?Yesterday I found a web of a large trading
company from china,which is an agent of all the well-known digital product
factories,and facing to both wholesalers,retailsalers,and personal customer
all over the world. They export all kinds of digital products and offer
realy competitive and reasonable price and high quality goods for our
clients,so i think you make a big profit if do business with them.And they
promise they will provide the best after-sales-service.In my opinion we can
make a trial order to test that.

Look forward to your early reply!

The Web address: www(dot)easylifeing(dot)com
loreto!

I have the same problem here as shelvingguy on a Toshiba Satellite A350-12D. I tried the open source radeon driver from the ubuntu 9.04 repositories, fglrx from the repositories and Catalyst 9.4 from ati's homepage. None of them works.
I attached my Xorg.0.logs for "ati" flag in xorg.conf plus xorg.0.log for fglrx via envyng.

It seems, this problem is common to this model of notebook, see https://wiki.edubuntu.org/LaptopTestingTeam/ToshibaSatelliteA350.

I have to add, "vesa"-driver is working at a wrong resolution. If you have a look at the log-files, you will see, that the monitor seems to be recognized correctly, as there are the right numbers (1366x768) to be found.

Sarven Capadisli (csarven) wrote :

I have a Lenovo W500 with HD 3650 and 3GB of Memory, running Ubuntu Jaunty Jackalope 9.04 Linux version 2.6.28-11-generic.

I had previously installed xorg-driver-fglrx. I got everything back to normal speed (e.g., no lag when dragging windows) when I rebooted (simply logging out and back in doesn't do it it) after the second set of steps (Problem: Need to fully remove -fglrx and reinstall -ati from scratch) at https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver mentioned by Bryce Harrington ( https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/267185/comments/15 ).

However, I still can't use the Visual Effects -> Extra. It gives me "Desktop effects could not be enabled".

Hi Sarven Capadisli

Even I face this problem with Lenovo W500 laptop. My lspci output is below

lspci | grep adeo
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650

When I try to enable desktop effects, it says Desktop effects could not be enabled. Did you get any solution for your issue? If yes, plz share with me

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers