[RV 6xx HD 3870] Driver fails to load on 2 Sep daily

Bug #264462 reported by rbmorse on 2008-09-03
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
High
xserver-xorg-video-ati (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

The xserver-xorg-video-ati driver version that is part of the 02 Sep daily build (Ubuntu i386) fails to start the display during the boot sequence for either the live desktop or direct install modes, resulting in a blank "X" display. The text terminals are accessible, and if I edit xorg.conf to load either the "vesa" driver or the "radeonhd" driver and restart the X terminal, the display works normally.

If one then continues to install to hard drive the same behavior manifests on that installation...the radeon (ati) driver fails to start, but either the VESA or radeonhd drivers work as expected.

I am not sufficiently knowledgeable to be able to determine if the problem lies with the ati driver, xrandr or the "X" subsystem. If it is any help, the display and video adapter are properly detected, but when using the "ATI" driver xrandr -q returns inappropriate mode data. Xrandr returns appropriate mode data when using both the "vesa" and "radeonhd" drivers.

The display is an Apple Cinema HD 23 Inch and the video adapter is an ATI HD3870.

Interpid Alpha-3 and earlier did not exhibit this problem. The 02 Sep daily was the first of the Alpha-4 releases I attempted to use.
[lspci]
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3870

Colin Watson (cjwatson) wrote :

I'm not sure which package this belongs on either, but at any rate it's not ubuntu-cdimage (which is for the software that actually builds the CDs), so moving it over.

Changed in ubuntu-cdimage:
status: New → Invalid
Bryce Harrington (bryce) wrote :

rbmorse, can you try setting:

Section "Device"
   ...
   Option "AGPMode" "2"
EndSection

Also try values 1, 4, and 8 (4 is typically the default). If one of those settings fix it, we may be able to quirk your hardware to use that value instead of the default. In this case please provide the following info so we can quirk it:

  * AGPMode value(s) that work
  * Make/Model of laptop or motherboard
  * Output of lspci -vvnn
  * Is the system all factory hardware, or have any parts been replaced?
  * Is there an AGP Mode in the system BIOS?
    - If so, is it set to the factory default?

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Download full text (15.6 KiB)

Bryce Harrington wrote:
> rbmorse, can you try setting:
>
> Section "Device"
> ...
> Option "AGPMode" "2"
> EndSection
>
> Also try values 1, 4, and 8 (4 is typically the default). If one of
> those settings fix it, we may be able to quirk your hardware to use that
> value instead of the default. In this case please provide the following
> info so we can quirk it:
>
> * AGPMode value(s) that work
> * Make/Model of laptop or motherboard
> * Output of lspci -vvnn
> * Is the system all factory hardware, or have any parts been replaced?
> * Is there an AGP Mode in the system BIOS?
> - If so, is it set to the factory default?
>
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: New => Incomplete
>
Hi Bryce.

The video card is a PCI-e card and there is no AGP slot on
this motherboard. Do you still want me to try
adding/changing the AGPmode parameter in xorg.conf?

Motherboard: Gigabyte GA-EP35-DS3R

Video Card Gigabyte GV-RX387512H (ATI HD3870 - PCI-e)

The system homebrew, but all settings are default.

There is no AGPmode setting in BIOS.

I note that editing xorg.conf to load either the "vesa" or
"radeonhd" driver results in proper operation. The default
video driver is the "radeon" driver, so perhaps something in
the specific build of the xorg-xserver-video-ati driver used
in the daily is the problem.

Please let me know if I can provide any additional information.

Ron Morse

Output of lspci --vvnn:

> 00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 02)
> Subsystem: Giga-byte Technology Device [1458:5000]
> Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
> Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
> Latency: 0
> Capabilities: <access denied>
> Kernel modules: intel-agp
>
> 00:01.0 PCI bridge [0604]: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port [8086:29c1] (rev 02)
> Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
> Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
> Latency: 0, Cache Line Size: 32 bytes
> Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
> I/O behind bridge: 0000b000-0000bfff
> Memory behind bridge: f4000000-f5ffffff
> Prefetchable memory behind bridge: 00000000e0000000-00000000efffffff
> Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
> BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
> PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
> Capabilities: <access denied>
> Kernel driver in use: pcieport-driver
> Kernel modules: shpchp
>
> 00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 02)
> Subsystem: Giga-byte Technology Device [1458:5004]
> Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
> Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >S...

Bryce Harrington wrote:
> Yes, please give it a try.
>
Hi Bryce.

As requested, I added the Option "AGPmode" "X" statement to
the device section of the default /etc/X11/xorg.conf.

No change. All attempted modes (1,2,4) produced the same
result: No display (black, blank). X server running.

Ron Morse

Okay, thanks. Fwiw, I have a dell laptop with a HD3670 and don't see this issue (but there's others I'm seeing like https://bugs.freedesktop.org/show_bug.cgi?id=17094).

The next thing to try would be disabling DRI to isolate if the issue is in the 3D side (which is what I suspect) or something more general:

  Option "DRI" "false"

Bryce Harrington wrote:
> Okay, thanks. Fwiw, I have a dell laptop with a HD3670 and don't see
> this issue (but there's others I'm seeing like
> https://bugs.freedesktop.org/show_bug.cgi?id=17094).
>
> The next thing to try would be disabling DRI to isolate if the issue is
> in the 3D side (which is what I suspect) or something more general:
>
> Option "DRI" "false"
>
No joy.

I'm not surprised as the radeon driver doesn't do 3D on this
chipset (RV-670) yet, but it was worth a shot.

In any case, setting that option in xorg.conf did not change
the system's behavior.

Ron Morse

Okay thanks again. Can you attach your /var/log/Xorg.0.log? Maybe we just need to punt this one upstream and see what they say.

Download full text (36.0 KiB)

Bryce Harrington wrote:
> Okay thanks again. Can you attach your /var/log/Xorg.0.log? Maybe we
> just need to punt this one upstream and see what they say.
>
Sure. See below.

I see that you pushed a newer build of of
xorg.xserver.video.ati earlier today. I'll keep an eye out
for that in updates and see if that makes a difference, too.

Ron Morse

Contents of Xorg.0.log:

(WW) Failed to open protocol names file
/etc/X11/xserver/protocol.txt
This is a pre-release version of the X server from The X.Org
Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at
http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-15-server i686 Ubuntu
Current Operating System: Linux intrepid 2.6.27-2-generic #1
SMP Thu Aug 28 17:20:02 UTC 2008 i686
Build Date: 03 September 2008 01:24:30PM
xorg-server 2:1.4.99.906-2ubuntu5 (<email address hidden>)
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default
setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 5
21:37:29 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section. Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Configured Monitor"
(**) | |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not
exist.
 Entry deleted from font path.
(==) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input
devices.
 If no devices become available, reconfigure HAL or disable
AllowEmptyInput.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81d8a40
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.4
 X.Org Video Driver: 4.1
 X.Org XInput driver : 2.1
 X.Org Server Extension : 1.1
 X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 9

(--) PCI:*(0@1:0:0) ATI Technologies Inc Radeon HD 3870 rev
0, Mem @ 0xe0000000/0, 0xf5000000/0, I/O @ 0x0000b000/0,
BIOS @ 0x????????/131072
(II) System resource ranges:
 [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
 [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
 [2] -1 0 0x000c0000 - 0x000effff (0x3000...

I'm confirming this bug in Kubuntu 8.10 Alpha 5 Live CD.
I'll see the exact same behaviour and I too got an ATI HD3870.

For your information I have also seen the same on Kubuntu 8.04 when trying the latest xserver-xorg-video-ati from https://launchpad.net/~tormodvolden/+archive (xserver-xorg-video-ati - 1:6.9.0+git20080820.1cf7a549-0ubuntu0tormod~hardy)
The latest RadeonHD-driver (xserver-xorg-video-radeonhd - 1.2.1+git20080816.76272c54-0ubuntu0tormod~hardy) from the same place works though.

rbmorse wrote:
> I see that you pushed a newer build of of
> xorg.xserver.video.ati earlier today. I'll keep an eye out
> for that in updates and see if that makes a difference, too.
>
I regret to report the new driver did not change
anything...the X session still presents a blank (black) screen.

Ron Morse

Bryce Harrington (bryce) on 2008-09-14
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: Incomplete → Triaged

I'm having a similar (?same) issue on an ASUS F8Sp laptop with ATI Radeon HD 3650 running Intrepid Alpha 5 64 bit Live CD. On starting the GDM, I get a gray screen with intermittently flashing horizontal lines. Everything seems to be working except the X, because I can hit Shift-Alt-F1 and drop to a fully functional terminal. I'm attaching the xorg log file. The xorg.conf file appears to be completely unconfigured (no drivers or anything in it), although if I try 'X -configure' I get an xorg.conf file that has the radeon driver in it, but it doesn't work either (gray screen etc as above).

CAn you also attach the output of lspci here? Thanks.

Wouter Stomp wrote:
> CAn you also attach the output of lspci here? Thanks.
>

Sure. Attached.

Ron Morse

Here's my lspci file also, for what it's worth.

jjos (jbenjos) wrote :

The bug "xserver-xorg-video-ati/+bug/277361" has been marked as a duplicate of this bug.

Stefan Carslöv (odur) wrote :

I've just tested the Kubuntu 8.10 Beta Live CD (i386) and there is no change. The monitor goes to sleep when the driver loads and only wakes up if I switch to vt1. If I switch back to vt7 the monitor goes blank again.
This happens in both normal and safe graphics mode. I checked the Xorg.0.log and the same driver loads in both modes.

I think this bug should be tagged Critical and be targeted for the final release. It's a potential show stopper for a lot of people out there who got a recent ATI card.

The solution would probably be to load the radeonhd for the R6xx/R7xx cards by default.

Aurélien COUDERC (coucouf) wrote :

Same problem with an HD3850 (same RV670 chip) after upgrading from Hardy to Intrepid beta.
The panel tells me some "refresh rate out of range" message and goes to sleep.

Both vesa and radeonhd work fine.

Aurélien COUDERC (coucouf) wrote :

It still doesn't work with the latest version 6.9.0+git20081003 of the driver that was uploaded today.
I just tried but the issue remains.

tsiros (tsiros) wrote :

i dunno if it got fixed anywhere else
but
i never hoped it would work so easily...

sudo vim /etc/X11/xorg.conf

i changed the usefbdev to false and added a line
driver "radeonhd"

it worked

8|

widget redrawing is kinda slow though :( when are they going to make it fast?

Aurélien COUDERC (coucouf) wrote :

radeonhd is a different driver.
The bug is against radeon/ati driver, which currently supports much more than radeonhd. Depending on the board radeon can support video playback acceleration, 2D and 3D rendering acceleration.

Bryce Harrington (bryce) wrote :

tsiros, out of curiosity, did you do anything special to get radeonhd installed? Afaik, the radeonhd in universe won't work since it requires git versions of libdrm and mesa, but perhaps I'm incorrect. So I'm surprised it worked so easily for you? Also, could you check in your /var/log/Xorg.0.log file to see if you're really using radeonhd or if it's dropped you to VESA? (Look at the last half of the file; lines will be prepended with the driver name.)

Aurélien COUDERC (coucouf) wrote :

Since radeon is broken, I'm also using radeonhd and it works without any problem nor any special trick. Just using xserver-xorg-video-radeonhd from the repos and added Driver "radeonhd" to xorg.conf.

Bryce Harrington (bryce) wrote :

@Victor, your symptoms are quite different from what others have reported, and you have a different chipset, so you probably are not seeing this particular bug but probably something else. You should report it separately, via 'ubuntu-bug xserver-xorg-video-ati'.

Bryce Harrington (bryce) wrote :

rbmorse and others,

I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=17986. rbmorse, Stefan, and Coucouf, could you please subscribe to that bug in case upstream wishes more info or needs you to test something? Thanks ahead of time.

It's good to know (and, frankly, a bit surprising) radeonhd works for some of you, however understand that it is not one of the drivers we actively support at this time.

Done. Thank you.

Ron Morse

On Thu, 2008-10-09 at 02:58 +0000, Bryce Harrington wrote:
> rbmorse and others,
>
> I've forwarded this bug upstream to
> https://bugs.freedesktop.org/show_bug.cgi?id=17986. rbmorse, Stefan,
> and Coucouf, could you please subscribe to that bug in case upstream
> wishes more info or needs you to test something? Thanks ahead of time.
>
> It's good to know (and, frankly, a bit surprising) radeonhd works for
> some of you, however understand that it is not one of the drivers we
> actively support at this time.
>

Bryce Harrington (bryce) on 2008-10-09
Changed in xserver-xorg-driver-ati:
importance: Undecided → Unknown
status: New → Unknown

Done. Thanks.

On Thu, 2008-10-09 at 02:58 +0000, Bryce Harrington wrote:
> rbmorse and others,
>
> I've forwarded this bug upstream to
> https://bugs.freedesktop.org/show_bug.cgi?id=17986. rbmorse, Stefan,
> and Coucouf, could you please subscribe to that bug in case upstream
> wishes more info or needs you to test something? Thanks ahead of time.
>
> It's good to know (and, frankly, a bit surprising) radeonhd works for
> some of you, however understand that it is not one of the drivers we
> actively support at this time.
>

Martin Pitt (pitti) wrote :

Oops, sorry. I tried to remove the "CD image" task from this, and somehow I ended up assigning it to hoary-backports, and now I cannot change it back. Backporters, can you please change it back?

/me grumbles on the inability to remove tasks

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Colin Watson (cjwatson) wrote :

Bryce, do you have a preference regarding these two patches? Can we get something in so that people can test dailies quickly?

Bryce Harrington (bryce) wrote :

Sorry, I started doing some packaging on them but I got sidetracked on other issues.

Basically, the patches need to be modified to apply to our driver and then verified that they solve the issue before they go in.

Bryce Harrington (bryce) wrote :

I've built 3 sets of packages, one for each patch and one with both patches together:

http://bryceharrington.org/ubuntu/AtiBug264462/

prefhighfb
prefhighref
prefhighboth

Please test each of these and see which one(s) solve the issue if any.

The patches themselves look fine to me and low risk, we just need to verify they do solve the issue, and if so what needs committed.

Aurélien COUDERC (coucouf) wrote :

I tested all 3 pairs of packages linked above (I didn't install the -dbg) but none of these solution worked for me.
X started as before with no special error in the log, but then the LCD panel complained about an "out of range" problem and went to sleep.

Bryce Harrington (bryce) wrote :

We're still waiting on a response from upstream, but it's gotten too late for intrepid so I'm closing the intrepid task (an SRU post-release could still be done).

Changed in xserver-xorg-video-ati:
status: Triaged → Won't Fix

Ok. I'll keep an eye on it, too.

Thanks.

On Thu, 2008-10-23 at 14:57 +0000, Bryce Harrington wrote:
> We're still waiting on a response from upstream, but it's gotten too
> late for intrepid so I'm closing the intrepid task (an SRU post-release
> could still be done).
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu Intrepid)
> Status: Triaged => Won't Fix
>

No news on this one ?
This the only bug that make Intrepid unusable to me and it seems to touch all the radeon cards :'(

Aurélien COUDERC (coucouf) wrote :

Since then, AMD released a X Server 1.5-compatible version of the fglrx proprietary driver.
If you can cope with this driver being non free, it can be an alternative.

Besides I think the problem is only for R600+ cards (HD2/3/4xxx). I tested the radeon driver on older 9700 and X1950 cards and it works very well.

Tormod Volden (tormodvolden) wrote :

This bug only affects the cards using RV670 chip, like HD3870 and HD3850.

I've just tried the 64 bits version of Intrepid Ibex, and, big surprise : it works !!!

Does anyone knows why ? Different version of drivers between 32 and 64 bits ?

Tormod Volden (tormodvolden) wrote :

Please attach both your 32 and 64 bits log, so that we can compare them.

Bryce Harrington (bryce) on 2009-01-17
description: updated
Bryce Harrington (bryce) wrote :

radeontool in Jaunty* can be used to assist in debugging this issue. After installing it, you run it like this:
    radeontool regmatch '*' > regdump_good.txt
    radeontool regmatch '*' > regdump_broke.txt

Run it two times. Once when you have a working screen (for any driver), and once in the broken case (either from the tty console or logged into the sick box remotely). Attach both of those to this bug report, and we can then forward this issue upstream. Thanks ahead of time!

For more info see https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen

[* Note: radeontool is available in earlier versions of Ubuntu but is too old; if you need to run it on an older version of Ubuntu, you can obtain and build it from the upstream git tree at http://cgit.freedesktop.org/~airlied/radeontool/]

Changed in xserver-xorg-video-ati:
status: Triaged → Incomplete
Aurélien COUDERC (coucouf) wrote :

It's fixed for me in Jaunty.
The radeon driver works correctly again. So far, support is quite limited (no 3D, glxinfo/glxgears crashing) but it works. I'm using the default xorg as generated by dpkg-reconfigure xserver-xorg.

Martin Pitt (pitti) wrote :

Reportedly fixed. Please reopen/report back here if you still have problems in Jaunty. Thank you!

Changed in xserver-xorg-video-ati:
status: Incomplete → Fix Released

With the live cd daily jaunty build from yesterday 09-Feb-09, I still
get the same grey screen with intermittent flashing black lines. Asus
laptop F8Sp with ATI Radeon HD 3650. Seems like the ati driver still
doesn't work. Haven't tried vesa yet or the proprietary fglrx (which
is the only driver that works well in Intrepid).

On Tue, Feb 10, 2009 at 6:44 AM, Martin Pitt <email address hidden> wrote:
> Reportedly fixed. Please reopen/report back here if you still have
> problems in Jaunty. Thank you!
>
> ** Changed in: xserver-xorg-video-ati (Ubuntu)
> Status: Incomplete => Fix Released
>
> --
> [RV 6xx HD 3870] Driver fails to load on 2 Sep daily
> https://bugs.launchpad.net/bugs/264462
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tormod Volden (tormodvolden) wrote :

Victor, please file a new bug. Your description does not fit this bug report and is probably not related.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
tags: added: iso-testing
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Changed in xserver-xorg-driver-ati:
importance: High → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.